Send mpeg-lib to its grave. This software whasn't been updated in three

years, and the author no longer has any desire to update it.  This port
also installs libraries that directly conflict with KDE.

The only ports which relied on mpeg-lib (gimp1 and gimp-devel) have been
modified to statically use mpeg-lib, and not polute the system with .so's
or .a's.

Submitted by:	maintainer and the KDE project
Not objected by:	ports after three days
Approved by:	maintainer
This commit is contained in:
Joe Marcus Clarke 2002-08-12 18:21:06 +00:00
parent 1732752ddd
commit 106a9f3906
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=64436
9 changed files with 0 additions and 176 deletions

View file

@ -218,7 +218,6 @@
SUBDIR += mmsclient
SUBDIR += morpheus
SUBDIR += mpeg
SUBDIR += mpeg-lib
SUBDIR += mpeg2codec
SUBDIR += mpeg2play
SUBDIR += mpeg4ip

View file

@ -1,26 +0,0 @@
# New ports collection makefile for: mpeg_lib
# Date created: 16 November 1994
# Whom: torstenb
#
# $FreeBSD$
#
PORTNAME= mpeg_lib
PORTVERSION= 1.3.1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.bic.mni.mcgill.ca/pub/mpeg/ \
http://starship.python.net/~gward/mpeglib/
MAINTAINER= ports@geeksrus.net
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= OPTIMIZE="${CFLAGS}"
post-patch:
@(cd ${WRKSRC} ; \
${GREP} -r -l "<malloc.h>" * | \
${XARGS} ${REINPLACE_CMD} -e "s/<malloc.h>/<stdlib.h>/")
.include <bsd.port.mk>

View file

@ -1 +0,0 @@
MD5 (mpeg_lib-1.3.1.tar.gz) = 9d803be0073f42acf87d5fbb339a183b

View file

@ -1,82 +0,0 @@
--- Makefile.in.orig Fri Nov 27 01:03:29 1998
+++ Makefile.in Tue Nov 23 02:51:05 1999
@@ -19,13 +19,14 @@
exec_prefix = @exec_prefix@
INSTALL_INCLUDE = @includedir@
INSTALL_LIBRARY = @libdir@
-INSTALL = @INSTALL@
+INSTALL_DATA = @INSTALL_DATA@
# Other miscellaneous programs
AR = @AR@
ARFLAGS = -ru
RANLIB = @RANLIB@
+.SUFFIXES: .so
# Source for the library itself -- note that we define LIBSRC and
# LIBOBJ this way (instead of just LIBOBJ=$(LIBSRC:.c=.o) because
@@ -37,12 +38,17 @@
mono.c ordered.c ordered2.c mb_ordered.c
LIBSRC = @libsrc@
LIBOBJ = @libobj@
+SHLIBOBJ = @shlibobj@
# Other files of interest
LIBRARY = libmpeg.a
-SHLIB = libmpeg.so
+.if ${PORTOBJFORMAT} == elf
+SHLIB = libmpeg.so.1
+.else
+SHLIB = libmpeg.so.1.3
+.endif
HEADER = mpeg.h
EXTRAS = @extras@
@@ -53,7 +59,7 @@
# Library/cleanup targets:
-all: lib $(EXTRAS)
+all: lib shlib $(EXTRAS)
lib: $(LIBRARY)
@@ -63,14 +69,18 @@
$(AR) $(ARFLAGS) $(LIBRARY) $(LIBOBJ)
$(RANLIB) $(LIBRARY)
-$(SHLIB): $(LIBOBJ)
- $(CC) -shared -o $(SHLIB) $(LIBOBJ)
-
-install: $(LIBRARY)
- $(INSTALL) -d $(INSTALL_INCLUDE) $(INSTALL_LIBRARY)
- $(INSTALL) -m 0644 $(HEADER) $(INSTALL_INCLUDE)/$(HEADER)
- $(INSTALL) -m 0644 $(LIBRARY) $(INSTALL_LIBRARY)/$(LIBRARY)
- @if test -f $(SHLIB) ; then echo "warning: $(SHLIB) *not* installed (installing shared libraries is too system-specific)" ; fi
+$(SHLIB): $(SHLIBOBJ)
+.if ${PORTOBJFORMAT} == elf
+ $(CC) -shared -Wl,-soname,$(SHLIB) -o $(SHLIB) $(SHLIBOBJ)
+.else
+ $(CC) -shared -o $(SHLIB) $(SHLIBOBJ)
+.endif
+ ln -sf $(SHLIB) `echo $(SHLIB) | sed 's/\.so.*$$/\.so/'`
+
+install:
+ $(INSTALL_DATA) $(LIBRARY) $(SHLIB) $(INSTALL_LIBRARY)
+ (cd $(INSTALL_LIBRARY); ln -sf $(SHLIB) `echo $(SHLIB) | sed 's/\.so.*$$/\.so/'`)
+ $(INSTALL_DATA) $(HEADER) $(INSTALL_INCLUDE)
clean:
rm -f $(LIBRARY) $(EXTRAS) $(LIBOBJ) core
@@ -80,6 +90,8 @@
rm -f config.cache config.log config.status Makefile config.h
cd extras && $(MAKE) distclean
+.c.so:
+ $(CC) $(CFLAGS) $(INCLUDE_DIRS) -fpic -DPIC -c $< -o $@
# Executable targets (mpegtest, easympeg [GL platforms only])

View file

@ -1,23 +0,0 @@
--- video.c.orig Sat Jul 24 13:00:51 1999
+++ video.c Tue Aug 31 23:11:56 1999
@@ -49,6 +49,10 @@
#include "proto.h"
#include "my_dmalloc.h"
+#ifdef _HAVE_PARAM_H
+#include <sys/param.h>
+#endif
+
/* Declarations of functions. */
static void ReconIMBlock(VidStream *,int);
static void ReconPMBlock(VidStream *,int,int,int,int);
@@ -445,7 +449,9 @@
static int num_calls = 0;
unsigned int data;
int i, status;
+#if BSD < 199103
long int ftell (FILE *stream);
+#endif
/* If vid_stream is null, create new VidStream structure. */

View file

@ -1,26 +0,0 @@
--- configure.orig Mon Aug 9 09:36:05 1999
+++ configure Tue Aug 31 23:11:56 1999
@@ -1101,6 +1101,7 @@
if test $dither = yes; then
libsrc='$(DECODER_SRC) $(DITHER_SRC)'
libobj='$(DECODER_SRC:.c=.o) $(DITHER_SRC:.c=.o)'
+ shlibobj='$(DECODER_SRC:.c=.so) $(DITHER_SRC:.c=.so)'
cat >> confdefs.h <<\EOF
#define ENABLE_DITHER 1
EOF
@@ -1109,6 +1110,7 @@
else
libsrc='$(DECODER_SRC)'
libobj='$(DECODER_SRC:.c=.o)'
+ shlibobj='$(DECODER_SRC:.c=.so)'
cat >> confdefs.h <<\EOF
#define ENABLE_DITHER 0
EOF
@@ -1818,6 +1820,7 @@
s%@AR@%$AR%g
s%@libsrc@%$libsrc%g
s%@libobj@%$libobj%g
+s%@shlibobj@%$shlibobj%g
s%@CPP@%$CPP%g
CEOF

View file

@ -1 +0,0 @@
A collection of C routines to decode MPEG movies

View file

@ -1,12 +0,0 @@
The MPEG Library is a collection of C routines to decode MPEG movies
and dither them in a variety of colour schemes. Most of the code in
the library comes directly from the Berkely MPEG player, an
X11-specific implementation that works fine, but suffers from minimal
documentation and a lack of modularity. A front end to the Berkeley
decoding engine was developed by Greg Ward at the Montreal
Neurological Institute in May/June 1994 to facilitate the development
of an MPEG player specifically for Silicon Graphics workstations; the
decoding engine together with the MNI front end constitute the MPEG
Library.
WWW: http://starship.python.net/~gward/mpeglib/

View file

@ -1,4 +0,0 @@
include/mpeg.h
lib/libmpeg.a
lib/libmpeg.so
lib/libmpeg.so.1