devel/fifechan: update to 0.1.5

- Update to 0.1.5
- Fix license
- Set default options to correspond upstream settings

Needed for unknown-horizons update

PR:             242454
Submitted by:   amdmi3
Approved by:    fiziologus@gmail.com (maintainer timeout)
This commit is contained in:
Piotr Kubaj 2020-01-14 15:26:21 +00:00
parent 38c54a3f01
commit 107e31ae45
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=523022
4 changed files with 38 additions and 12 deletions

View file

@ -2,21 +2,23 @@
# $FreeBSD$
PORTNAME= fifechan
PORTVERSION= 0.1.4
PORTREVISION= 2
PORTVERSION= 0.1.5
CATEGORIES= devel games
MAINTAINER= fiziologus@gmail.com
COMMENT= Small, efficient C++ GUI library designed for games
LICENSE= LGPL21
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/LICENSE.md
USES= cmake
USES= cmake
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= fifengine
CMAKE_ON= BUILD_FIFECHAN_ALLEGRO_SHARED BUILD_FIFECHAN_IRRLICHT_SHARED
PLIST_SUB= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= ALLEGRO IRRLICHT OPENGL SDL SDL_CONTRIB
@ -26,9 +28,9 @@ OPENGL_DESC= OpenGL extension (need for FIFE)
SDL_DESC= SDL extension (need for FIFE)
SDL_CONTRIB_DESC= SDL contrib extension (need SDL)
OPTIONS_DEFAULT= ALLEGRO IRRLICHT OPENGL SDL
OPTIONS_DEFAULT= OPENGL SDL
OPTIONS_SUB= yes
OPTIONS_SUB= yes
ALLEGRO_CMAKE_BOOL= ENABLE_ALLEGRO
ALLEGRO_LIB_DEPENDS= liballeg.so:devel/allegro
@ -40,9 +42,9 @@ OPENGL_CMAKE_BOOL= ENABLE_OPENGL
OPENGL_USES= gl
OPENGL_USE= gl=gl,glu
SDL_CMAKE_BOOL= ENABLE_SDL
SDL_USES= sdl
SDL_USE= sdl=sdl2,image2
SDL_CMAKE_BOOL= ENABLE_SDL
SDL_USES= sdl
SDL_USE= sdl=sdl2,image2
SDL_CONTRIB_CMAKE_BOOL= ENABLE_SDL_CONTRIB
SDL_CONTRIB_USE= sdl=ttf2

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1487971273
SHA256 (fifengine-fifechan-0.1.4_GH0.tar.gz) = a93b015b5852b8fe2a0a2a6891d3de2cacb196732f670e081d7b7966f9ed1b87
SIZE (fifengine-fifechan-0.1.4_GH0.tar.gz) = 246181
TIMESTAMP = 1575382083
SHA256 (fifengine-fifechan-0.1.5_GH0.tar.gz) = 29be5ff4b379e2fc4f88ef7d8bc172342130dd3e77a3061f64c8a75efe4eba73
SIZE (fifengine-fifechan-0.1.5_GH0.tar.gz) = 272472

View file

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig 2019-01-11 01:31:25 UTC
+++ CMakeLists.txt
@@ -453,7 +453,7 @@ IF(ENABLE_SDL AND SDL2_FOUND AND SDL2_IMAGE_FOUND)
TARGET_LINK_LIBRARIES(${PROJECT_NAME}_sdl ${SDL2_LIBRARY} ${SDL2_IMAGE_LIBRARY} ${SDL_TTF_LIBRARY} ${PROJECT_NAME})
ENDIF(MINGW)
ELSE(WIN32)
- TARGET_LINK_LIBRARIES(${PROJECT_NAME}_sdl ${SDL2_LIBRARY} ${SDL2_IMAGE_LIBRARY} ${PROJECT_NAME})
+ TARGET_LINK_LIBRARIES(${PROJECT_NAME}_sdl ${SDL2_LIBRARY} ${SDL2_IMAGE_LIBRARY} ${SDL_TTF_LIBRARY} ${PROJECT_NAME})
ENDIF(WIN32)
ADD_CUSTOM_TARGET(sdllib DEPENDS ${PROJECT_NAME}_sdl) # Create symlink

View file

@ -49,6 +49,7 @@ include/fifechan/mouselistener.hpp
%%OPENGL%%include/fifechan/opengl/openglimage.hpp
%%OPENGL%%include/fifechan/opengl/openglsdlimageloader.hpp
include/fifechan/platform.hpp
include/fifechan/point.hpp
include/fifechan/rectangle.hpp
%%SDL%%include/fifechan/sdl.hpp
%%SDL%%include/fifechan/sdl/sdlgraphics.hpp
@ -58,29 +59,41 @@ include/fifechan/rectangle.hpp
%%SDL%%include/fifechan/sdl/sdlpixel.hpp
include/fifechan/selectionevent.hpp
include/fifechan/selectionlistener.hpp
include/fifechan/size.hpp
include/fifechan/text.hpp
include/fifechan/utf8stringeditor.hpp
include/fifechan/util/fcn_math.hpp
include/fifechan/version.hpp
include/fifechan/visibilityeventhandler.hpp
include/fifechan/widget.hpp
include/fifechan/widgetlistener.hpp
include/fifechan/widgets/adjustingcontainer.hpp
include/fifechan/widgets/bargraph.hpp
include/fifechan/widgets/button.hpp
include/fifechan/widgets/checkbox.hpp
include/fifechan/widgets/container.hpp
include/fifechan/widgets/curvegraph.hpp
include/fifechan/widgets/dropdown.hpp
include/fifechan/widgets/flowcontainer.hpp
include/fifechan/widgets/icon.hpp
include/fifechan/widgets/iconprogressbar.hpp
include/fifechan/widgets/imagebutton.hpp
include/fifechan/widgets/imageprogressbar.hpp
include/fifechan/widgets/label.hpp
include/fifechan/widgets/linegraph.hpp
include/fifechan/widgets/listbox.hpp
include/fifechan/widgets/passwordfield.hpp
include/fifechan/widgets/piegraph.hpp
include/fifechan/widgets/pointgraph.hpp
include/fifechan/widgets/radiobutton.hpp
include/fifechan/widgets/scrollarea.hpp
include/fifechan/widgets/slider.hpp
include/fifechan/widgets/spacer.hpp
include/fifechan/widgets/tab.hpp
include/fifechan/widgets/tabbedarea.hpp
include/fifechan/widgets/textbox.hpp
include/fifechan/widgets/textfield.hpp
include/fifechan/widgets/togglebutton.hpp
include/fifechan/widgets/window.hpp
lib/libfifechan.so
lib/libfifechan.so.%%PORTVERSION%%