Update to new upstream release 1.42.3.

ChangeLog: http://e2fsprogs.sourceforge.net/e2fsprogs-release.html#1.42.3

Convert to OptionsNG. (e2fsprogs-libss seems to compile fine, too)
This commit is contained in:
Matthias Andree 2012-06-08 13:37:48 +00:00
parent 2b95e5bb14
commit 10cf8a82d8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=298757
6 changed files with 17 additions and 67 deletions

View file

@ -16,7 +16,6 @@ LIB_DEPENDS= uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
CONFIGURE_ARGS= --enable-elf-shlibs
WITHOUT_NLS= yes
MASTERDIR= ${.CURDIR}/../../sysutils/e2fsprogs
MAKE_ARGS= LIB_SUBDIRS=lib/blkid
USE_GMAKE= yes
@ -24,7 +23,7 @@ USE_LDCONFIG= yes
ALL_TARGET= libs
INSTALL_TARGET= install install-shlibs
INSTALL_WRKSRC= ${WRKSRC}/lib/blkid
MAKE_JOBS_UNSAFE= yes
MAKE_JOBS_SAFE= yes
MAN3= libblkid.3

View file

@ -25,6 +25,7 @@ INSTALL_TARGET= install install-shlibs
INSTALL_WRKSRC= ${WRKSRC}/lib/uuid
FILESDIR= ${.CURDIR}/files
USE_RC_SUBR= uuidd
MAKE_JOBS_SAFE= yes
MAN1= uuidgen.1

View file

@ -6,7 +6,7 @@
#
PORTNAME= e2fsprogs
PORTVERSION= 1.42.2
PORTVERSION= 1.42.3
PORTREVISION?= 0
CATEGORIES?= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/v${PORTVERSION}
@ -24,9 +24,11 @@ CONFIGURE_ARGS+=--disable-fsck --disable-e2initrd-helper \
CPPFLAGS+= -I${WRKSRC}/lib -I${LOCALBASE}/include # -D_EXT2_USE_C_VERSIONS
MAKE_ARGS+= LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib'
OPTIONS?= NLS "Enable national language support" on
.if !defined(MASTERDIR)
OPTIONS_DEFINE= DOCS NLS
OPTIONS_DEFAULT= NLS
OPTIONS_EXCLUDE+= EXAMPLES
MAN1= chattr.1 lsattr.1
MAN5= e2fsck.conf.5 mke2fs.conf.5
MAN8= badblocks.8 debugfs.8 dumpe2fs.8 e2fsck.8 e2image.8 e2label.8 \
@ -52,14 +54,14 @@ MAKE_ARGS+= V=1
.include <bsd.port.pre.mk>
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB= NLS="@comment "
libintl=
.else
.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB= NLS=""
libintl= "${LOCALBASE}/lib/libintl.a ${LOCALBASE}/lib/libiconv.a"
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB= NLS="@comment "
libintl=
.endif
post-patch::
@ -70,6 +72,7 @@ post-patch::
@${REINPLACE_CMD} -e 's/ install-doc-libs$$//' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -E -e 's/md5sum ([^ ]*)/printf "%s %s\\n" $$(md5 -q \1) \1/' \
-e "s/ == 0/ = 0/" ${WRKSRC}/tests/[a-t]_*/script
@${REINPLACE_CMD} -e 's/<malloc\.h>/<stdlib.h>/' ${WRKSRC}/*/*.c
# disable f_mmp_garbage, fails on FreeBSD
.for i in f_mmp_garbage m_bigjournal
@${MV} ${WRKSRC}/tests/${i} ${WRKSRC}/tests/disabled_test-${i}
@ -98,7 +101,7 @@ post-build:
if test "x$$a" = "x" ; then echo 'PASS' ; else \
echo 'FAIL' ; echo '===> e2fsck depends on:' ; echo "$$a" ; exit 1 ; fi
# Update translation binary files
.if !defined(WITHOUT_NLS)
.if ${PORT_OPTIONS:MNLS}
cd ${WRKSRC}/po && ${GMAKE} update-gmo
.endif
# Build fsck(8) wrapper
@ -118,7 +121,7 @@ post-build:
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/fsck_ext2fs ${PREFIX}/sbin/
${INSTALL_MAN} ${FILESDIR}/fsck_ext2fs.8 ${PREFIX}/man/man8/
.if !defined(NOPORTDOCS)
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}

View file

@ -1,2 +1,2 @@
SHA256 (e2fsprogs-1.42.2.tar.gz) = 1d36fec5e34ac285f59dff3851d6f4ca9f0b964ddd7e8fe00f1f920b091cb8be
SIZE (e2fsprogs-1.42.2.tar.gz) = 5753009
SHA256 (e2fsprogs-1.42.3.tar.gz) = ad6a41be876fab94c2bd5d10f7a0871a5601bbaf9cd25c551c2af11c1c8d5436
SIZE (e2fsprogs-1.42.3.tar.gz) = 5817248

View file

@ -1,11 +0,0 @@
--- ./debugfs/debugfs.c.orig 2012-03-26 19:36:24.000000000 +0200
+++ ./debugfs/debugfs.c 2012-04-01 17:34:53.000000000 +0200
@@ -1000,7 +1000,7 @@
if (common_args_process(argc, argv, 2, 3, argv[0], "<file> [num]",
CHECK_FS_RW | CHECK_FS_BITMAPS))
- return 1;
+ return;
if (check_fs_read_write(argv[0]))
return;

View file

@ -1,42 +0,0 @@
From 0abb581fe2ab23813ea57efa11fd82fbb3bc8414 Mon Sep 17 00:00:00 2001
From: Matthias Andree <matthias.andree@gmx.de>
Date: Wed, 9 May 2012 19:43:52 +0200
Subject: [PATCH 2/2] Fix parallel (make -j) build.
Add a few dependencies where needed, so that "make -j17 check" now works.
Signed-off-by: Matthias Andree <matthias.andree@gmx.de>
---
Makefile.in | 2 ++
lib/uuid/Makefile.in | 2 +-
2 files changed, 3 insertions(+), 1 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index 7c5d441..544ed02 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -73,6 +73,8 @@ install-libs: install-libs-recursive
uninstall-libs: uninstall-libs-recursive
+check-recursive: all
+
TAGS clean-recursive distclean-recursive depend-recursive check-recursive \
mostlyclean-recursive realclean-recursive:
@for subdir in $(SUBDIRS); do \
diff --git a/lib/uuid/Makefile.in b/lib/uuid/Makefile.in
index b85c720..caa13f7 100644
--- a/lib/uuid/Makefile.in
+++ b/lib/uuid/Makefile.in
@@ -76,7 +76,7 @@ uuid.h: $(srcdir)/uuid.h.in
$(top_builddir)/lib/uuid/uuid_types.h: $(srcdir)/uuid_types.h.in $(top_builddir)/config.status
cd $(top_builddir); CONFIG_FILES=$(my_dir)/uuid_types.h ./config.status
-tst_uuid.o: $(srcdir)/tst_uuid.c
+tst_uuid.o: $(srcdir)/tst_uuid.c uuid.h
$(E) " CC $@"
$(Q) $(CC) $(ALL_CFLAGS) -c $(srcdir)/tst_uuid.c -o tst_uuid.o
--
1.7.4.1