New port: net-im/libaccounts-glib.

From pkg-descr:

  Accounts and SSO (Single Sign-On) framework for Linux and POSIX based
  platforms.
  WWW: https://code.google.com/p/accounts-sso/

Necessary for the upcoming libaccounts-qt5, which is used in newer versions
of KDE Telepathy.

Submitted by:	Tobias Berner <tcberner@gmail.com> via area51
This commit is contained in:
Raphael Kubo da Costa 2015-07-03 20:52:54 +00:00
parent 991db535c9
commit 1116efdafd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=391272
6 changed files with 135 additions and 0 deletions

View file

@ -54,6 +54,7 @@
SUBDIR += ktp-kded-integration-module
SUBDIR += ktp-send-file
SUBDIR += ktp-text-ui
SUBDIR += libaccounts-glib
SUBDIR += libjreen
SUBDIR += libnice
SUBDIR += libnice-gst010

View file

@ -0,0 +1,33 @@
# Created by: Tobias C. Berner <tcberner@gmail.com>
# $FreeBSD$
PORTNAME= libaccounts-glib
PORTVERSION= 1.18
CATEGORIES= net-im
MASTER_SITES= https://drive.google.com/uc?export=download&id=0B8fX9XOwH_g4U1NzNmg0cWoxNGM&dummy= \
LOCAL/rakuco
MAINTAINER= kde@FreeBSD.org
COMMENT= Accounts and SSO framework for Linux and POSIX based platforms
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libsqlite3.so:${PORTSDIR}/databases/sqlite3
FETCH_BEFORE_ARGS= -o ${DISTFILES}
GNU_CONFIGURE= YES
# The line below is a hack required when the port is configure either without
# devel/libcheck installed or with --disable-tests.
# A proper fix has been submitted upstream:
# https://gitlab.com/accounts-sso/libaccounts-glib/merge_requests/1
CONFIGURE_ENV= HAVE_GCOV_FALSE='\#'
CONFIGURE_ARGS= --disable-tests
INSTALL_TARGET= install-strip
USES= gmake libtool pathfix pkgconfig python
USE_GNOME= pygobject3 introspection libxml2
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (libaccounts-glib-1.18.tar.gz) = 7aab9ec2ba3ae2548125f4bb330ed433e8066c672e32101a339cbb7f4657ff56
SIZE (libaccounts-glib-1.18.tar.gz) = 579435

View file

@ -0,0 +1,21 @@
Fixes the following build error with clang:
ag-manager.c:503:16: error: implicit conversion from enumeration type 'AgAccountsError' to different enumeration type 'AgError' [-Werror,-Wenum-conversion]
code = AG_ACCOUNTS_ERROR_DB_LOCKED;
~ ^~~~~~~~~~~~~~~~~~~~~~~~~~~
ag-manager.c:508:16: error: implicit conversion from enumeration type 'AgAccountsError' to different enumeration type 'AgError' [-Werror,-Wenum-conversion]
code = AG_ACCOUNTS_ERROR_DB;
~ ^~~~~~~~~~~~~~~~~~~~
Sent upstream: https://gitlab.com/accounts-sso/libaccounts-glib/merge_requests/3
--- libaccounts-glib/ag-manager.c
+++ libaccounts-glib/ag-manager.c
@@ -490,7 +490,7 @@ static void
set_error_from_db (AgManager *manager)
{
AgManagerPrivate *priv = manager->priv;
- AgError code;
+ AgAccountsError code;
GError *error;
switch (sqlite3_errcode (priv->db))

View file

@ -0,0 +1,3 @@
Accounts and SSO (Single Sign-On) framework for Linux and POSIX based platforms.
WWW: https://code.google.com/p/accounts-sso/

View file

@ -0,0 +1,75 @@
bin/ag-backup
bin/ag-tool
include/libaccounts-glib/accounts-glib.h
include/libaccounts-glib/ag-account-service.h
include/libaccounts-glib/ag-account.h
include/libaccounts-glib/ag-application.h
include/libaccounts-glib/ag-auth-data.h
include/libaccounts-glib/ag-errors.h
include/libaccounts-glib/ag-manager.h
include/libaccounts-glib/ag-provider.h
include/libaccounts-glib/ag-service-type.h
include/libaccounts-glib/ag-service.h
include/libaccounts-glib/ag-types.h
lib/girepository-1.0/Accounts-1.0.typelib
lib/libaccounts-glib.so
lib/libaccounts-glib.so.0
lib/libaccounts-glib.so.0.1.3
libdata/pkgconfig/libaccounts-glib.pc
%%PYTHON_SITELIBDIR%%/gi/overrides/Accounts.py
%%PYTHON_SITELIBDIR%%/gi/overrides/Accounts.pyc
%%PYTHON_SITELIBDIR%%/gi/overrides/Accounts.pyo
share/backup-framework/applications/accounts.conf
share/dbus-1/interfaces/com.google.code.AccountsSSO.Accounts.Manager.xml
share/gir-1.0/Accounts-1.0.gir
share/gtk-doc/html/libaccounts-glib/AgAccount.html
share/gtk-doc/html/libaccounts-glib/AgAccountService.html
share/gtk-doc/html/libaccounts-glib/AgApplication.html
share/gtk-doc/html/libaccounts-glib/AgAuthData.html
share/gtk-doc/html/libaccounts-glib/AgManager.html
share/gtk-doc/html/libaccounts-glib/AgProvider.html
share/gtk-doc/html/libaccounts-glib/AgService.html
share/gtk-doc/html/libaccounts-glib/AgServiceType.html
share/gtk-doc/html/libaccounts-glib/account-management.html
share/gtk-doc/html/libaccounts-glib/ag-backup.html
share/gtk-doc/html/libaccounts-glib/ag-tool.html
share/gtk-doc/html/libaccounts-glib/annotation-glossary.html
share/gtk-doc/html/libaccounts-glib/api-index-1-1.html
share/gtk-doc/html/libaccounts-glib/api-index-1-2.html
share/gtk-doc/html/libaccounts-glib/api-index-1-4.html
share/gtk-doc/html/libaccounts-glib/api-index-1-5.html
share/gtk-doc/html/libaccounts-glib/api-index-deprecated.html
share/gtk-doc/html/libaccounts-glib/api-index-full.html
share/gtk-doc/html/libaccounts-glib/appendices.html
share/gtk-doc/html/libaccounts-glib/gettext-xml-files.html
share/gtk-doc/html/libaccounts-glib/glossary.html
share/gtk-doc/html/libaccounts-glib/home.png
share/gtk-doc/html/libaccounts-glib/index.html
share/gtk-doc/html/libaccounts-glib/index.sgml
share/gtk-doc/html/libaccounts-glib/left-insensitive.png
share/gtk-doc/html/libaccounts-glib/left.png
share/gtk-doc/html/libaccounts-glib/libaccounts-compiling.html
share/gtk-doc/html/libaccounts-glib/libaccounts-glib-objects.html
share/gtk-doc/html/libaccounts-glib/libaccounts-glib-overview.html
share/gtk-doc/html/libaccounts-glib/libaccounts-glib-tools.html
share/gtk-doc/html/libaccounts-glib/libaccounts-glib.devhelp2
share/gtk-doc/html/libaccounts-glib/libaccounts-overview.html
share/gtk-doc/html/libaccounts-glib/libaccounts-running.html
share/gtk-doc/html/libaccounts-glib/object-tree.html
share/gtk-doc/html/libaccounts-glib/provider-file-format.html
share/gtk-doc/html/libaccounts-glib/right-insensitive.png
share/gtk-doc/html/libaccounts-glib/right.png
share/gtk-doc/html/libaccounts-glib/service-file-format.html
share/gtk-doc/html/libaccounts-glib/service-type-file-format.html
share/gtk-doc/html/libaccounts-glib/style.css
share/gtk-doc/html/libaccounts-glib/up-insensitive.png
share/gtk-doc/html/libaccounts-glib/up.png
share/gtk-doc/html/libaccounts-glib/validating-xml-files.html
share/gtk-doc/html/libaccounts-glib/xml-file-formats.html
share/gtk-doc/html/libaccounts-glib/xml-files.html
share/vala/vapi/libaccounts-glib.deps
share/vala/vapi/libaccounts-glib.vapi
share/xml/accounts/schema/dtd/accounts-application.dtd
share/xml/accounts/schema/dtd/accounts-provider.dtd
share/xml/accounts/schema/dtd/accounts-service-type.dtd
share/xml/accounts/schema/dtd/accounts-service.dtd