games/coffeebreak: Correct sed and patch applied twice

Last commit "Move man to share/man" I used patch to set MANDIR and sed
to fix hardcoded PREFIX=/usr/local on wrksrc Makefile.

Simplify and correct changes with use of MAKE_ARGS.
Not bumping port revision as is doesn't change build.

Reported by:	danfe
Approved by:	portmgr (blanket)
Fixes:		021fcd36af Move man pages to share/man
This commit is contained in:
Nuno Teixeira 2024-03-11 10:55:45 +00:00
parent 2d50a3e2e7
commit 1128357fc9
2 changed files with 3 additions and 14 deletions

View File

@ -12,13 +12,13 @@ LICENSE= BSD2CLAUSE
USE_GITHUB= yes
GH_ACCOUNT= 0mp
MAKE_ARGS= MANDIR=${STAGEDIR}${PREFIX}/share/man \
PREFIX=${PREFIX}
NO_ARCH= yes
NO_BUILD= yes
PLIST_FILES= bin/coffeebreak \
share/man/man6/coffeebreak.6.gz
post-patch:
${REINPLACE_CMD} 's|/usr/local|${PREFIX}|g' ${WRKSRC}/Makefile
.include <bsd.port.mk>

View File

@ -1,11 +0,0 @@
--- Makefile.orig 2024-03-09 06:57:33 UTC
+++ Makefile
@@ -27,7 +27,7 @@ BINDIR = $(DESTDIR)$(PREFIX)/bin
PREFIX = /usr/local
BINDIR = $(DESTDIR)$(PREFIX)/bin
-MANDIR = $(DESTDIR)$(PREFIX)/man
+MANDIR = $(DESTDIR)$(PREFIX)/share/man
MAN6DIR = $(MANDIR)/man6
install: