- Replace patch with USES=pathfix and post-patch command
- Remove old libtool patch - Remove post-patch command that isn't needed with staging
This commit is contained in:
parent
a7718b4499
commit
11508622a3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=368437
3 changed files with 5 additions and 48 deletions
|
@ -17,17 +17,16 @@ RUN_DEPENDS= umap:${PORTSDIR}/converters/p5-Unicode-Map8
|
|||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= gmake libtool pkgconfig iconv tar:bzip2
|
||||
GNU_CONFIGURE= yes
|
||||
USES= gmake iconv libtool pathfix pkgconfig tar:bzip2
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-html-dir=${DOCSDIR}
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch::
|
||||
@${REINPLACE_CMD} -e 's/$$(LN_S)/$$(LN_S) -f/' ${WRKSRC}/src/Makefile.in
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} '/SUBDIRS =/s/test//' ${WRKSRC}/src/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
--- Makefile.in.orig 2010-02-09 11:23:03.000000000 +0100
|
||||
+++ Makefile.in 2010-12-30 21:08:30.000000000 +0100
|
||||
@@ -245,6 +245,7 @@
|
||||
infodir = @infodir@
|
||||
install_sh = @install_sh@
|
||||
libdir = @libdir@
|
||||
+libdatadir = $(exec_prefix)/libdata
|
||||
libexecdir = @libexecdir@
|
||||
localedir = @localedir@
|
||||
localstatedir = @localstatedir@
|
||||
@@ -264,10 +265,10 @@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-@MAINTAINER_MODE_FALSE@SUBDIRS = tools script lib src devel-docs test
|
||||
+@MAINTAINER_MODE_FALSE@SUBDIRS = tools script lib src devel-docs
|
||||
|
||||
# @(#) $Id: Makefile.am,v 1.35 2005/11/24 10:21:32 yeti Exp $
|
||||
-@MAINTAINER_MODE_TRUE@SUBDIRS = tools data script lib src devel-docs test
|
||||
+@MAINTAINER_MODE_TRUE@SUBDIRS = tools data script lib src devel-docs
|
||||
man_MANS = man/enca.1
|
||||
DISTCHECK_CONFIGURE_FLAGS = --enable-maintainer-mode
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
@@ -299,7 +300,7 @@
|
||||
man/enca.1 \
|
||||
$(M4TESTS)
|
||||
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfigdir = $(libdatadir)/pkgconfig
|
||||
pkgconfig_DATA = enca.pc
|
||||
all: config.h
|
||||
$(MAKE) $(AM_MAKEFLAGS) all-recursive
|
|
@ -1,10 +0,0 @@
|
|||
--- configure.orig 2010-02-09 11:23:03.000000000 +0100
|
||||
+++ configure 2010-12-30 21:12:31.000000000 +0100
|
||||
@@ -7156,6 +7156,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ltmain"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
Loading…
Reference in a new issue