www/nextcloud: Update to 13.0.0

- Changes permissions as well

PR:             223778
Approved by:    Loic Blot <loic.blot unixexperience fr> maintainer)
This commit is contained in:
Bernard Spil 2018-02-20 09:14:21 +00:00
parent a784d39047
commit 118fcfc527
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=462379
5 changed files with 542 additions and 319 deletions

View file

@ -5,7 +5,27 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20180214:
20180220:
AFFECTS: users of www/nextcloud
AUTHOR: brnrd@FreeBSD.org
The file and directory permissions of Nextcloud have changed. Write
permissions have been removed from all directories except `data' and
`config'. For the updater to work, the app store of your installation
must be disabled. To disable the app-store prior to updating the
package:
# cd /usr/local/www/nextcloud
# su -m www -c "php ./occ config:system:set appstoreenabled --value=false --type=boolean"
If you've already updated your nextcloud package, you must manually edit
the configuration of nextcloud (config/config.php) and add
'appstoreenabled' => false,
to the CONFIG array before the updater will run.
20180214
AFFECTS: users of lang/ruby23
AUTHOR: swills@FreeBSD.org
@ -39,7 +59,6 @@ you update your ports collection, before attempting any port upgrades.
# pkg set -o lang/ruby23:lang/ruby24
# portupgrade -x ruby-2.4.\* -fr lang/ruby24
20180209:
AFFECTS: users of japanese/lookup
AUTHOR: yasu@utahime.org

View file

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= nextcloud
PORTVERSION= 12.0.5
DISTVERSION= 13.0.0
CATEGORIES= www
MASTER_SITES= https://download.nextcloud.com/server/prereleases/
@ -30,6 +30,7 @@ OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE
OPTIONS_DEFAULT= EXIF LDAP MYSQL SMB SSL
DB_DESC= Database backend(s)
EXIF_DESC= Image rotation support
EXIF_USE= PHP=exif
@ -42,12 +43,6 @@ SQLITE_USE= PHP=pdo_sqlite,sqlite3
SMB_RUN_DEPENDS= pecl-smbclient>=0.8.0:net/pecl-smbclient
SSL_USE= PHP=openssl
.include <bsd.port.pre.mk>
.if !empty(PORT_OPTIONS:MPGSQL) && ${PGSQL_VER} >= 10
EXTRA_PATCHES= ${FILESDIR}/extra-patch-PostgreSQL-10
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/var/www/|${WWWDIR}|' ${WRKSRC}/config/config.sample.php
@ -57,4 +52,4 @@ do-install:
@${RM} ${STAGEDIR}${WWWDIR}/updater/updater.phar
@${MKDIR} ${STAGEDIR}${WWWDIR}/data
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1516883682
SHA256 (nextcloud-12.0.5.tar.bz2) = c8be29ace6821079e881818266fe49d28812b5aa0c7d2e76511173d48828ca43
SIZE (nextcloud-12.0.5.tar.bz2) = 43704324
TIMESTAMP = 1517914004
SHA256 (nextcloud-13.0.0.tar.bz2) = 38e6064432a2d1a044f219028d3fd46cb7a943a47e11eef346810bd289705aec
SIZE (nextcloud-13.0.0.tar.bz2) = 43397247

View file

@ -1,20 +0,0 @@
--- 3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Schema/PostgreSqlSchemaManager.php.orig 2017-11-27 09:11:23 UTC
+++ 3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Schema/PostgreSqlSchemaManager.php
@@ -289,7 +289,16 @@ class PostgreSqlSchemaManager extends Ab
$sequenceName = $sequence['relname'];
}
- $data = $this->_conn->fetchAll('SELECT min_value, increment_by FROM ' . $this->_platform->quoteIdentifier($sequenceName));
+ $version = floatval($this->_conn->getWrappedConnection()->getServerVersion());
+
+ if ($version >= 10) {
+ $data = $this->_conn->fetchAll('SELECT min_value, increment_by FROM pg_sequences WHERE schemaname = \'public\' AND sequencename = '.$this->_conn->quote($sequenceName));
+ }
+ else
+ {
+ $data = $this->_conn->fetchAll('SELECT min_value, increment_by FROM ' . $this->_platform->quoteIdentifier($sequenceName));
+ }
+// $data = $this->_conn->fetchAll('SELECT min_value, increment_by FROM ' . $this->_platform->quoteIdentifier($sequenceName));
return new Sequence($sequenceName, $data[0]['increment_by'], $data[0]['min_value']);
}

File diff suppressed because it is too large Load diff