www/davix: Update 0.7.1 -> 0.7.3
Change to tarballs because the previously used github repository is broken: cmake says one function has wrong number of arguments.
This commit is contained in:
parent
9618c8187c
commit
11fc070249
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=501028
4 changed files with 13 additions and 13 deletions
|
@ -1,10 +1,9 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= davix
|
||||
DISTVERSION= 0.7.1
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 0.7.3
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= https://github.com/cern-fts/davix/releases/download/R_${DISTVERSION:S/./_/g}/
|
||||
MASTER_SITES= http://grid-deployment.web.cern.ch/grid-deployment/dms/lcgutil/tar/${PORTNAME}/${DISTVERSION}/
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Make the task of managing files over HTTP-based protocols simple
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1541295884
|
||||
SHA256 (davix-0.7.1.tar.gz) = 0d13c21d5d4ef9194313ae4cfba8095ac5a4272f276993c43103f833514f206b
|
||||
SIZE (davix-0.7.1.tar.gz) = 4336124
|
||||
TIMESTAMP = 1557330227
|
||||
SHA256 (davix-0.7.3.tar.gz) = cd46276e72c6a0da1e2ad30eb66ec509a4c023687767c62a66713fa8c23d328a
|
||||
SIZE (davix-0.7.3.tar.gz) = 4341865
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- test/functional/CMakeLists.txt.orig 2018-10-02 17:09:41 UTC
|
||||
--- test/functional/CMakeLists.txt.orig 2019-05-08 15:50:42 UTC
|
||||
+++ test/functional/CMakeLists.txt
|
||||
@@ -83,7 +83,7 @@ add_library(test_davix_functional_lib ST
|
||||
@@ -81,7 +81,7 @@ add_library(test_davix_functional_lib ST
|
||||
#target_link_libraries(test_mv libdavix test_davix_functional_lib)
|
||||
|
||||
add_executable(tester ${src_tester})
|
||||
-target_link_libraries(tester libdavix test_davix_functional_lib)
|
||||
+target_link_libraries(tester libdavix test_davix_functional_lib uuid)
|
||||
add_executable(davix-tester ${src_tester})
|
||||
-target_link_libraries(davix-tester libdavix test_davix_functional_lib)
|
||||
+target_link_libraries(davix-tester libdavix test_davix_functional_lib uuid)
|
||||
|
||||
function(assert_not_empty var)
|
||||
if("${var}" STREQUAL "")
|
||||
install(TARGETS davix-tester
|
||||
DESTINATION ${BIN_INSTALL_DIR}/)
|
||||
|
|
|
@ -5,6 +5,7 @@ bin/davix-mkdir
|
|||
bin/davix-mv
|
||||
bin/davix-put
|
||||
bin/davix-rm
|
||||
bin/davix-tester
|
||||
bin/davix-unit-tests
|
||||
include/davix/auth/davixauth.hpp
|
||||
include/davix/auth/davixx509cred.hpp
|
||||
|
|
Loading…
Reference in a new issue