www/pydio-cells: Update to 2.2.8
- One patch has been upstreamed, deleted - Fixed unit tests by fixing keyring code Testing: - `portlint -AC` still OK - Smoke-tested in production - Unit tests pass Changelog: https://github.com/pydio/cells/compare/v2.2.7...v2.2.8
This commit is contained in:
parent
250fab975e
commit
12169c9d89
4 changed files with 24 additions and 20 deletions
|
@ -1,7 +1,6 @@
|
|||
PORTNAME= cells
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2.2.7
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 2.2.8
|
||||
CATEGORIES= www
|
||||
PKGNAMEPREFIX= pydio-
|
||||
|
||||
|
@ -37,6 +36,9 @@ ZSH_PLIST_FILES= share/zsh/site-functions/_${PORTNAME}
|
|||
post-patch:
|
||||
${REINPLACE_CMD} -e "s|\$${GOPATH}/bin/packr|${LOCALBASE}/bin/pydio-packr|g" \
|
||||
${WRKSRC}/Makefile
|
||||
# Linux keyring code is compatible with FreeBSD
|
||||
cd ${WRKSRC}/vendor/github.com/zalando/go-keyring && \
|
||||
${LN} -s keyring_linux.go keyring_freebsd.go
|
||||
|
||||
pre-build:
|
||||
@cd ${WRKSRC} && \
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1620685268
|
||||
SHA256 (pydio-cells-v2.2.7_GH0.tar.gz) = a03cb5c58086aa4c5c62bd313ed6c1b7533c14c9d285a546e74dbd74994701e2
|
||||
SIZE (pydio-cells-v2.2.7_GH0.tar.gz) = 99130816
|
||||
TIMESTAMP = 1622664125
|
||||
SHA256 (pydio-cells-v2.2.8_GH0.tar.gz) = 205df5bc051130e7d4fb69b684833e80b29e437c8140aa6a26002b80559d0c4c
|
||||
SIZE (pydio-cells-v2.2.8_GH0.tar.gz) = 99126120
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
--- cmd/start.go.orig 2021-05-06 12:02:02 UTC
|
||||
+++ cmd/start.go
|
||||
@@ -289,7 +289,11 @@ ENVIRONMENT
|
||||
if (process == nil || len(process.Services) == 0) && len(childrenProcesses) == 0 {
|
||||
return nil
|
||||
}
|
||||
- log.Info("Services are still running ", zap.Any("services", process.Services))
|
||||
+ // Already fixed upstream, should be in the next version after 2.2.7:
|
||||
+ // https://github.com/pydio/cells/issues/325
|
||||
+ if (process != nil) {
|
||||
+ log.Info("Services are still running ", zap.Any("services", process.Services))
|
||||
+ }
|
||||
continue
|
||||
case <-timeout:
|
||||
return nil
|
|
@ -0,0 +1,17 @@
|
|||
--- vendor/github.com/godbus/dbus/transport_unixcred_freebsd.go.orig 2021-05-06 12:02:02 UTC
|
||||
+++ vendor/github.com/godbus/dbus/transport_unixcred_freebsd.go
|
||||
@@ -4,12 +4,14 @@
|
||||
// http://code.google.com/p/go/source/browse/unix/sockcmsg_linux.go?repo=sys
|
||||
|
||||
// Local implementation of the UnixCredentials system call for FreeBSD
|
||||
+// Patch added from upstream project: https://github.com/godbus/dbus/commit/efee8394fa9a426004eb24eed1dee80f5efd90af
|
||||
|
||||
package dbus
|
||||
|
||||
/*
|
||||
const int sizeofPtr = sizeof(void*);
|
||||
#define _WANT_UCRED
|
||||
+#include <sys/types.h>
|
||||
#include <sys/ucred.h>
|
||||
*/
|
||||
import "C"
|
Loading…
Reference in a new issue