Rename xxxterm to xombrero
Update xombrero to latest version 1.2.2 Pass maintainership to me PR: ports/169860 Submitted by: HU Dong <itechbear@gmail.com> Approved by: maintainer, kwm (mentor)
This commit is contained in:
parent
c848e5a9f6
commit
121bb62424
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=302803
11 changed files with 152 additions and 68 deletions
1
MOVED
1
MOVED
|
@ -3645,3 +3645,4 @@ www/django-mezzanine-filebrowser|www/py-django-mezzanine-filebrowser|2012-08-19|
|
|||
www/django-mezzanine-grappelli|www/py-django-mezzanine-grappelli|2012-08-19|Rename to consistency with other Python ports
|
||||
misc/gpt31||2012-08-20|Has expired: was a dependency for net/globus4, which was removed 2008-12-07, unmaintained upstream since 2004
|
||||
misc/gpt||2012-08-20|Has expired: was a dependency for net/globus4, which was removed 2008-12-07, unmaintained upstream since 2004
|
||||
www/xxxterm/|www/xombrero|2012-08-20|Project renamed
|
||||
|
|
74
www/xombrero/Makefile
Normal file
74
www/xombrero/Makefile
Normal file
|
@ -0,0 +1,74 @@
|
|||
# New ports collection makefile for: xxxterm
|
||||
# Date created: 2011.01.15
|
||||
# Whom: Aldis Berjoza <aldis@bsdroot.lv>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= xombrero
|
||||
PORTVERSION= 1.2.2
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= https://opensource.conformal.com/snapshots/xombrero/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= zeising@FreeBSD.org
|
||||
COMMENT= Minimalists vi-like web browser based on webkit and GTK+
|
||||
|
||||
LICENCE= ISCL
|
||||
|
||||
LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
|
||||
soup-2.4:${PORTSDIR}/devel/libsoup \
|
||||
webkitgtk-1:${PORTSDIR}/www/webkit-gtk2
|
||||
|
||||
USE_PKGCONFIG= build
|
||||
USE_PERL5_BUILD=yes
|
||||
USE_GNOME= gtk20
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
MAKE_ENV= GTK_VERSION="gtk2" \
|
||||
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
|
||||
PTHREAD_LIBS="${PTHREAD_LIBS}"
|
||||
|
||||
MAN1= xombrero.1
|
||||
PORTEXAMPLES= favorites playflash.sh xombrero.conf
|
||||
|
||||
BUILD_WRKSRC= ${WRKSRC}/freebsd
|
||||
|
||||
OPTIONS_DEFINE= EXAMPLES
|
||||
|
||||
SUB_FILES= xombrero
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 800041
|
||||
BROKEN= does not build due to missing arc4random_buf in libc
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@cd ${WRKSRC}; ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
|
||||
-e 's|# ssl_ca_file|ssl_ca_file|' \
|
||||
-e 's|/etc/ssl/cert.pem|${LOCALBASE}/share/certs/ca-root-nss.crt|' \
|
||||
unix.c xombrero.conf
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/xombrero ${PREFIX}/bin/xombrero
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/freebsd/xombrero ${PREFIX}/bin/xombrero-bin
|
||||
${INSTALL_MAN} ${WRKSRC}/xombrero.1 ${MANPREFIX}/man/man1
|
||||
.for i in 16 32 48 64 128
|
||||
${MKDIR} ${PREFIX}/share/icons/hicolor/${i}x${i}/apps
|
||||
${INSTALL_DATA} ${WRKSRC}/xombreroicon${i}.png ${PREFIX}/share/icons/hicolor/${i}x${i}/apps
|
||||
.endfor
|
||||
${MKDIR} ${DATADIR}
|
||||
.for i in style.css tld-rules
|
||||
${INSTALL_DATA} ${WRKSRC}/${i} ${DATADIR}
|
||||
.endfor
|
||||
${MKDIR} ${PREFIX}/share/applications
|
||||
${INSTALL_DATA} ${WRKSRC}/xombrero.desktop ${PREFIX}/share/applications
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
.for i in favorites xombrero.conf
|
||||
${INSTALL_DATA} ${WRKSRC}/${i} ${EXAMPLESDIR}
|
||||
.endfor
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/playflash.sh ${EXAMPLESDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
www/xombrero/distinfo
Normal file
2
www/xombrero/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (xombrero-1.2.2.tgz) = 7cd2d1174239b5e3f897473ca69efc1fb303491d6ed60bf068263adfb76b164a
|
||||
SIZE (xombrero-1.2.2.tgz) = 242038
|
13
www/xombrero/files/patch-freebsd__Makefile
Normal file
13
www/xombrero/files/patch-freebsd__Makefile
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- ./freebsd/Makefile.orig 2012-07-25 17:37:55.000000000 -0400
|
||||
+++ ./freebsd/Makefile 2012-07-31 08:13:02.000000000 -0400
|
||||
@@ -9,8 +9,8 @@
|
||||
LDADD= -lutil -lgcrypt
|
||||
GTK_CFLAGS!= pkg-config --cflags $(LIBS)
|
||||
GTK_LDFLAGS!= pkg-config --libs $(LIBS)
|
||||
-CFLAGS+= $(GTK_CFLAGS) -O2 -Wall -pthread
|
||||
-LDFLAGS+= $(GTK_LDFLAGS) -pthread
|
||||
+CFLAGS+= $(GTK_CFLAGS) -Wall -D_GCRYPT_IN_LIBGCRYPT=1 -I.. ${PTHREAD_CFLAGS}
|
||||
+LDFLAGS+= $(GTK_LDFLAGS) ${PTHREAD_LIBS}
|
||||
|
||||
PREFIX?= /usr/local
|
||||
BINDIR?= $(PREFIX)/bin
|
11
www/xombrero/files/patch-xombrero.c
Normal file
11
www/xombrero/files/patch-xombrero.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./xombrero.c.orig 2012-07-25 17:37:55.000000000 -0400
|
||||
+++ ./xombrero.c 2012-07-31 08:13:02.000000000 -0400
|
||||
@@ -1423,7 +1423,7 @@
|
||||
{
|
||||
struct passwd *pwd;
|
||||
int i;
|
||||
- char user[LOGIN_NAME_MAX];
|
||||
+ char user[sysconf(_SC_LOGIN_NAME_MAX)];
|
||||
const char *sc = s;
|
||||
|
||||
if (path == NULL || s == NULL)
|
22
www/xombrero/files/xombrero.in
Normal file
22
www/xombrero/files/xombrero.in
Normal file
|
@ -0,0 +1,22 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
# A wrapper script for xombrero
|
||||
# Created by HU Dong <itechbear@gmail.com>
|
||||
|
||||
if [ ! -d "~/.xombrero" ]; then
|
||||
mkdir -p -m 700 ~/.xombrero
|
||||
fi
|
||||
|
||||
if [ ! -f "~/.xombrero.conf" ]; then
|
||||
cp %%EXAMPLESDIR%%/xombrero.conf ~/.xombrero.conf
|
||||
chmod +w ~/.xombrero.conf
|
||||
fi
|
||||
|
||||
if [ ! -f "~/.xombrero/playflash.sh" ]; then
|
||||
cp %%EXAMPLESDIR%%/playflash.sh ~/.xombrero/playflash.sh
|
||||
chmod +x ~/.xombrero/playflash.sh
|
||||
fi
|
||||
|
||||
exec %%PREFIX%%/bin/xombrero-bin
|
5
www/xombrero/pkg-descr
Normal file
5
www/xombrero/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
xombrero, previously known as xxxterm, is a minimalists web browser. It strives
|
||||
to be vi-like for heavy keyboard users while maintaining traditional web browser
|
||||
behaviour. It is ISC licensed. It is based on webkit using GTK+.
|
||||
|
||||
WWW: https://opensource.conformal.com/wiki/xombrero
|
24
www/xombrero/pkg-plist
Normal file
24
www/xombrero/pkg-plist
Normal file
|
@ -0,0 +1,24 @@
|
|||
bin/xombrero
|
||||
bin/xombrero-bin
|
||||
share/applications/xombrero.desktop
|
||||
share/icons/hicolor/128x128/apps/xombreroicon128.png
|
||||
share/icons/hicolor/16x16/apps/xombreroicon16.png
|
||||
share/icons/hicolor/32x32/apps/xombreroicon32.png
|
||||
share/icons/hicolor/48x48/apps/xombreroicon48.png
|
||||
share/icons/hicolor/64x64/apps/xombreroicon64.png
|
||||
%%DATADIR%%/style.css
|
||||
%%DATADIR%%/tld-rules
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrmtry share/icons/hicolor/64x64/apps
|
||||
@dirrmtry share/icons/hicolor/64x64
|
||||
@dirrmtry share/icons/hicolor/48x48/apps
|
||||
@dirrmtry share/icons/hicolor/48x48
|
||||
@dirrmtry share/icons/hicolor/32x32/apps
|
||||
@dirrmtry share/icons/hicolor/32x32
|
||||
@dirrmtry share/icons/hicolor/16x16/apps
|
||||
@dirrmtry share/icons/hicolor/16x16
|
||||
@dirrmtry share/icons/hicolor/128x128/apps
|
||||
@dirrmtry share/icons/hicolor/128x128
|
||||
@dirrmtry share/icons/hicolor
|
||||
@dirrmtry share/icons
|
||||
@dirrmtry share/applications
|
|
@ -1,61 +0,0 @@
|
|||
# New ports collection makefile for: xxxterm
|
||||
# Date created: 2011.01.15
|
||||
# Whom: Aldis Berjoza <aldis@bsdroot.lv>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= xxxterm
|
||||
PORTVERSION= 1.10.0
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= https://opensource.conformal.com/snapshots/xxxterm/ \
|
||||
SF/xxxterm/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= graudeejs@gmail.com
|
||||
COMMENT= Minimalists vi-like web browser based on webkit and GTK+
|
||||
|
||||
LIB_DEPENDS= gnutls.47:${PORTSDIR}/security/gnutls \
|
||||
soup-2.4:${PORTSDIR}/devel/libsoup \
|
||||
webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
|
||||
|
||||
USE_GNOME= gtk20 pkgconfig
|
||||
USE_PERL5_BUILD=YES
|
||||
|
||||
PLIST_FILES= bin/xxxterm
|
||||
MAN1= xxxterm.1
|
||||
PORTEXAMPLES= favorites xxxterm.conf
|
||||
PLIST_DIRS+= share/xxxterm
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 800041
|
||||
BROKEN= does not build due to missing arc4random_buf in libc
|
||||
.endif
|
||||
|
||||
ICONS= 16 32 48 64 128
|
||||
.for i in ${ICONS}
|
||||
PLIST_FILES+= share/xxxterm/xxxtermicon${i}.png
|
||||
.endfor
|
||||
PLIST_FILES+= share/xxxterm/style.css
|
||||
|
||||
do-build:
|
||||
(cd ${WRKSRC}/freebsd && make)
|
||||
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/freebsd/xxxterm ${PREFIX}/bin/
|
||||
${INSTALL_MAN} ${WRKSRC}/xxxterm.1 ${PREFIX}/man/man1/
|
||||
${MKDIR} ${PREFIX}/share/${PORTNAME}
|
||||
.for i in ${ICONS}
|
||||
${INSTALL_DATA} ${WRKSRC}/xxxtermicon${i}.png ${PREFIX}/share/xxxterm/
|
||||
.endfor
|
||||
${INSTALL_DATA} ${WRKSRC}/style.css ${PREFIX}/share/xxxterm/
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/favorites ${EXAMPLESDIR}/
|
||||
${INSTALL_DATA} ${WRKSRC}/xxxterm.conf ${EXAMPLESDIR}/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (xxxterm-1.10.0.tgz) = 70987029223012be5c1c1f2c1d021af604550b8a10dc66abd993b1f315614d25
|
||||
SIZE (xxxterm-1.10.0.tgz) = 187630
|
|
@ -1,5 +0,0 @@
|
|||
xxxterm is a minimalists web browser. It strives to be vi-like for heavy
|
||||
keyboard users while maintaining traditional web browser behaviour. It is ISC
|
||||
licensed. It is based on webkit using GTK+.
|
||||
|
||||
WWW: https://opensource.conformal.com/wiki/XXXTerm
|
Loading…
Reference in a new issue