- Update to version 1.2.3
PR: 61524 Submitted by: Ports Fury
This commit is contained in:
parent
ca2e4f8e65
commit
122d8a5f68
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=98490
4 changed files with 5 additions and 98 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= sdl_image
|
||||
PORTVERSION= 1.2.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.2.3
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
|
||||
DISTNAME= SDL_image-${PORTVERSION}
|
||||
|
@ -20,18 +19,16 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
|||
tiff.4:${PORTSDIR}/graphics/tiff
|
||||
|
||||
USE_SDL= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
|
||||
CONFIGURE_ARGS= --enable-tif --enable-xcf
|
||||
MAKE_ARGS= LT_CURRENT=10 LT_REVISION=0 LT_AGE=0
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
|
||||
${WRKSRC}/libtool
|
||||
post-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/.libs/showimage ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (SDL_image-1.2.2.tar.gz) = d07cb8f3f0e8bbb645ef8369d96eb7db
|
||||
MD5 (SDL_image-1.2.3.tar.gz) = d55826ffbd2bdc48b09cc64a9ed9e59e
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- configure 2000/12/11 14:34:53 1.1
|
||||
+++ configure 2000/12/11 14:35:05
|
||||
@@ -581,7 +581,7 @@
|
||||
|
||||
# libtool versioning
|
||||
LT_RELEASE=$MAJOR_VERSION.$MINOR_VERSION
|
||||
-LT_CURRENT=`expr $MICRO_VERSION - $INTERFACE_AGE`
|
||||
+LT_CURRENT=10
|
||||
LT_REVISION=$INTERFACE_AGE
|
||||
LT_AGE=`expr $BINARY_AGE - $INTERFACE_AGE`
|
||||
|
|
@ -1,79 +0,0 @@
|
|||
--- IMG_xcf.c.orig Mon Apr 29 03:01:48 2002
|
||||
+++ IMG_xcf.c Mon Apr 29 03:17:07 2002
|
||||
@@ -166,6 +166,7 @@
|
||||
|
||||
Uint32 offset_x;
|
||||
Uint32 offset_y;
|
||||
+ int visible : 1;
|
||||
} xcf_layer;
|
||||
|
||||
typedef struct {
|
||||
@@ -179,6 +180,7 @@
|
||||
Uint32 color;
|
||||
Uint32 opacity;
|
||||
int selection : 1;
|
||||
+ int visible : 1;
|
||||
} xcf_channel;
|
||||
|
||||
typedef struct {
|
||||
@@ -245,7 +247,9 @@
|
||||
prop->id = SDL_ReadBE32 (src);
|
||||
prop->length = SDL_ReadBE32 (src);
|
||||
|
||||
+#if 0
|
||||
printf ("%.8X: %s: %d\n", SDL_RWtell (src), prop->id < 25 ? prop_names [prop->id] : "unknown", prop->length);
|
||||
+#endif
|
||||
|
||||
switch (prop->id) {
|
||||
case PROP_COLORMAP:
|
||||
@@ -265,6 +269,9 @@
|
||||
case PROP_COLOR:
|
||||
SDL_RWread (src, &prop->data, prop->length, 1);
|
||||
break;
|
||||
+ case PROP_VISIBLE:
|
||||
+ prop->data.visible = SDL_ReadBE32 (src);
|
||||
+ break;
|
||||
default:
|
||||
// SDL_RWread (src, &prop->data, prop->length, 1);
|
||||
SDL_RWseek (src, prop->length, SEEK_CUR);
|
||||
@@ -332,6 +339,8 @@
|
||||
if (prop.id == PROP_OFFSETS) {
|
||||
l->offset_x = prop.data.offset.x;
|
||||
l->offset_y = prop.data.offset.y;
|
||||
+ } else if (prop.id == PROP_VISIBLE) {
|
||||
+ l->visible = prop.data.visible ? 1 : 0;
|
||||
}
|
||||
} while (prop.id != PROP_END);
|
||||
|
||||
@@ -371,6 +380,9 @@
|
||||
case PROP_SELECTION:
|
||||
l->selection = 1;
|
||||
break;
|
||||
+ case PROP_VISIBLE:
|
||||
+ l->visible = prop.data.visible ? 1 : 0;
|
||||
+ break;
|
||||
default:
|
||||
}
|
||||
} while (prop.id != PROP_END);
|
||||
@@ -724,9 +736,10 @@
|
||||
rd.y = layer->offset_y;
|
||||
rd.w = layer->width;
|
||||
rd.h = layer->height;
|
||||
- free_xcf_layer (layer);
|
||||
|
||||
- SDL_BlitSurface (lays, &rs, surface, &rd);
|
||||
+ if (layer->visible)
|
||||
+ SDL_BlitSurface (lays, &rs, surface, &rd);
|
||||
+ free_xcf_layer (layer);
|
||||
}
|
||||
|
||||
SDL_FreeSurface (lays);
|
||||
@@ -756,7 +769,7 @@
|
||||
}
|
||||
for (i = 0; i < chnls; i++) {
|
||||
// printf ("CNLBLT %i\n", i);
|
||||
- if (!channel [i]->selection) {
|
||||
+ if (!channel [i]->selection && channel [i]->visible) {
|
||||
create_channel_surface (chs, head->image_type, channel [i]->color, channel [i]->opacity);
|
||||
SDL_BlitSurface (chs, NULL, surface, NULL);
|
||||
}
|
Loading…
Reference in a new issue