apg is an automated generator for pronounceable passwords.
This commit is contained in:
parent
6225e192c4
commit
1264b6c7b0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=37355
8 changed files with 78 additions and 0 deletions
|
@ -6,6 +6,7 @@
|
|||
SUBDIR += aescrypt
|
||||
SUBDIR += aide
|
||||
SUBDIR += amavis-perl
|
||||
SUBDIR += apg
|
||||
SUBDIR += bjorb
|
||||
SUBDIR += bro
|
||||
SUBDIR += bugs
|
||||
|
|
20
security/apg/Makefile
Normal file
20
security/apg/Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
# New ports collection makefile for: apg
|
||||
# Date created: 1 September 2000
|
||||
# Whom: roam@orbitel.bg
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= apg
|
||||
PORTVERSION= 1.1.61b
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.adel.nursat.kz/apg/download/
|
||||
|
||||
MAINTAINER= roam@orbitel.bg
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAN1= apg.1
|
||||
MAN8= apgd.8
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/apg/distinfo
Normal file
1
security/apg/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (apg-1.1.61b.tar.gz) = 44301e3c689985a16aceb5ffc1afe245
|
32
security/apg/files/patch-aa
Normal file
32
security/apg/files/patch-aa
Normal file
|
@ -0,0 +1,32 @@
|
|||
--- Makefile 2000/09/30 14:55:17 1.1.1.1
|
||||
+++ Makefile 2001/01/17 14:12:15 1.3
|
||||
@@ -1,12 +1,13 @@
|
||||
# You can modify CC variable if you have compiler other than GCC
|
||||
# But the code was designed and tested with GCC
|
||||
-CC = gcc
|
||||
+CC ?= gcc
|
||||
|
||||
# compilation flags
|
||||
-FLAGS = -Wall
|
||||
+CFLAGS ?= -Wall
|
||||
|
||||
# Install dirs
|
||||
-INSTALL_PREFIX = /usr/local
|
||||
+PREFIX ?= /usr/local
|
||||
+INSTALL_PREFIX = ${PREFIX}
|
||||
APG_BIN_DIR = /bin
|
||||
APG_MAN_DIR = /man/man1
|
||||
APGD_BIN_DIR = /sbin
|
||||
@@ -41,10 +42,10 @@
|
||||
cygwin: standalone
|
||||
|
||||
cliserv: ${SOURCES} ${HEADERS}
|
||||
- ${CC} ${FLAGS} ${CS_LIBS} -DCLISERV -o ${CS_PROGNAME} ${SOURCES}
|
||||
+ ${CC} ${CFLAGS} ${CS_LIBS} -DCLISERV -o ${CS_PROGNAME} ${SOURCES}
|
||||
|
||||
standalone: ${SOURCES} ${HEADERS}
|
||||
- ${CC} ${FLAGS} -o ${PROGNAME} ${SOURCES}
|
||||
+ ${CC} ${CFLAGS} -o ${PROGNAME} ${SOURCES}
|
||||
|
||||
strip:
|
||||
strip ${PROGNAME}
|
15
security/apg/files/patch-ab
Normal file
15
security/apg/files/patch-ab
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- apg.c 2001/01/17 09:01:19 1.1.1.3
|
||||
+++ apg.c 2001/01/15 11:33:01 1.2
|
||||
@@ -342,9 +342,10 @@
|
||||
char * seq;
|
||||
UINT32 prom = 0L;
|
||||
|
||||
- printf ("\nPlease enter some random data (only first 4 are significant)\n");
|
||||
+ printf ("\nPlease enter some random data (only the first %d characters "
|
||||
+ "are significant)\n", sizeof(prom));
|
||||
seq = (char *)getpass("(eg. your old password):>");
|
||||
- if (strlen(seq) < 4)
|
||||
+ if (strlen(seq) < sizeof(prom))
|
||||
bcopy((void *)seq, (void *)&prom, (int)strlen(seq));
|
||||
else
|
||||
bcopy((void *)seq, (void *)&prom, sizeof(prom));
|
1
security/apg/pkg-comment
Normal file
1
security/apg/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
An automated password generator
|
6
security/apg/pkg-descr
Normal file
6
security/apg/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
An automated password generator, using several strong algorithms
|
||||
for random and/or pronounceable password generation, and a built-in
|
||||
pseudo-random number generator.
|
||||
|
||||
WWW: http://www.adel.nursat.kz/apg/
|
||||
Author: Adel I. Mirzazhanov <a-del@iname.com>
|
2
security/apg/pkg-plist
Normal file
2
security/apg/pkg-plist
Normal file
|
@ -0,0 +1,2 @@
|
|||
bin/apg
|
||||
sbin/apgd
|
Loading…
Reference in a new issue