- Update to 0.57
- Take maintainership Changes: http://search.cpan.org/dist/Data-Serializer/Changes
This commit is contained in:
parent
b6cc30ebf1
commit
129a262e77
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=272045
4 changed files with 17 additions and 26 deletions
|
@ -6,13 +6,12 @@
|
|||
#
|
||||
|
||||
PORTNAME= Data-Serializer
|
||||
PORTVERSION= 0.49
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.57
|
||||
CATEGORIES= devel perl5
|
||||
MASTER_SITES= CPAN
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= culot@FreeBSD.org
|
||||
COMMENT= Modules that serialize data structures
|
||||
|
||||
RUN_DEPENDS= ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC \
|
||||
|
@ -21,20 +20,19 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
|
|||
|
||||
PERL_MODBUILD= yes
|
||||
|
||||
MAN3= Data::Serializer.3 Data::Serializer::Config::General.3 \
|
||||
MAN3= Data::Serializer.3 Data::Serializer::Bencode.3 \
|
||||
Data::Serializer::Config::General.3 \
|
||||
Data::Serializer::Convert::Bencode.3 \
|
||||
Data::Serializer::Convert::Bencode_XS.3 \
|
||||
Data::Serializer::Cookbook.3 Data::Serializer::Data::Denter.3 \
|
||||
Data::Serializer::Data::Dumper.3 Data::Serializer::Data::Taxi.3 \
|
||||
Data::Serializer::FreezeThaw.3 Data::Serializer::JSON.3 \
|
||||
Data::Serializer::JSON::Syck.3 \
|
||||
Data::Serializer::Persistent.3 \
|
||||
Data::Serializer::PHP::Serialization.3 \
|
||||
Data::Serializer::Raw.3 \
|
||||
Data::Serializer::Storable.3 Data::Serializer::XML::Dumper.3 \
|
||||
Data::Serializer::XML::Simple.3 Data::Serializer::YAML.3 \
|
||||
Data::Serializer::YAML::Syck.3
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PERL_LEVEL} < 500903
|
||||
RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,2 @@
|
|||
MD5 (Data-Serializer-0.49.tar.gz) = 31a8c3f5ab573a840b4314d327bc534a
|
||||
SHA256 (Data-Serializer-0.49.tar.gz) = 79863107726ab1e01c5de1bc1b81d2e2933c2e0c572391ca0c9ccccf00193e16
|
||||
SIZE (Data-Serializer-0.49.tar.gz) = 28958
|
||||
SHA256 (Data-Serializer-0.57.tar.gz) = 9e13a78a6c39342ceb278b68135548ebb7f71bb8c9345e055fb89d62907f8eca
|
||||
SIZE (Data-Serializer-0.57.tar.gz) = 42401
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- Makefile.PL.orig Tue Jun 10 21:30:54 2003
|
||||
+++ Makefile.PL Tue Jun 10 21:49:49 2003
|
||||
@@ -15,3 +15,9 @@
|
||||
'ZIP'=>'/usr/bin/zip','ZIPFLAGS'=>'-rl'}
|
||||
|
||||
);
|
||||
+
|
||||
+sub MY::manifypods {
|
||||
+ package MY; my $self=shift;
|
||||
+ $self->{MAN3PODS}->{'lib/Data/Serializer/Config/General.pm'}='$(INST_MAN3DIR)/Data::Serializer::Config::General.$(MAN3EXT)';
|
||||
+ $self->SUPER::manifypods(@_);
|
||||
+}
|
|
@ -1,5 +1,8 @@
|
|||
%%SITE_PERL%%/Data/Serializer.pm
|
||||
%%SITE_PERL%%/Data/Serializer/Bencode.pm
|
||||
%%SITE_PERL%%/Data/Serializer/Config/General.pm
|
||||
%%SITE_PERL%%/Data/Serializer/Convert/Bencode.pm
|
||||
%%SITE_PERL%%/Data/Serializer/Convert/Bencode_XS.pm
|
||||
%%SITE_PERL%%/Data/Serializer/Cookbook.pm
|
||||
%%SITE_PERL%%/Data/Serializer/Data/Denter.pm
|
||||
%%SITE_PERL%%/Data/Serializer/Data/Dumper.pm
|
||||
|
@ -7,7 +10,9 @@
|
|||
%%SITE_PERL%%/Data/Serializer/FreezeThaw.pm
|
||||
%%SITE_PERL%%/Data/Serializer/JSON.pm
|
||||
%%SITE_PERL%%/Data/Serializer/JSON/Syck.pm
|
||||
%%SITE_PERL%%/Data/Serializer/Persistent.pm
|
||||
%%SITE_PERL%%/Data/Serializer/PHP/Serialization.pm
|
||||
%%SITE_PERL%%/Data/Serializer/Raw.pm
|
||||
%%SITE_PERL%%/Data/Serializer/Storable.pm
|
||||
%%SITE_PERL%%/Data/Serializer/XML/Dumper.pm
|
||||
%%SITE_PERL%%/Data/Serializer/XML/Simple.pm
|
||||
|
@ -18,6 +23,7 @@
|
|||
@dirrm %%SITE_PERL%%/Data/Serializer/PHP
|
||||
@dirrm %%SITE_PERL%%/Data/Serializer/JSON
|
||||
@dirrm %%SITE_PERL%%/Data/Serializer/Data
|
||||
@dirrm %%SITE_PERL%%/Data/Serializer/Convert
|
||||
@dirrm %%SITE_PERL%%/Data/Serializer/Config
|
||||
@dirrm %%SITE_PERL%%/Data/Serializer
|
||||
@dirrmtry %%SITE_PERL%%/auto/Data
|
||||
|
|
Loading…
Reference in a new issue