- Update boost to 1.41

PR:		ports/141749
Submitted by:	Alexander Churanov <churanov.port.maintainer@gmail.com> (maintainer)
This commit is contained in:
Pav Lucistnik 2009-12-29 13:50:29 +00:00
parent b262319bab
commit 129e62f606
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=246863
31 changed files with 2289 additions and 1280 deletions

View file

@ -118,6 +118,7 @@
SUBDIR += boost-docs
SUBDIR += boost-jam
SUBDIR += boost-libs
SUBDIR += boost-pyste
SUBDIR += boost-python-libs
SUBDIR += boost_build
SUBDIR += bouml

View file

@ -13,9 +13,10 @@ EXTRACT_ONLY= # empty
COMMENT?= The "meta-port" for boost libraries
OPTIONS= JAM "Boost.Jam - boost.org build utility" on \
LIBRARIES "C++ source and shared libraries" on \
OPTIONS= JAM "Boost.Jam - Build tool from the boost.org" on \
LIBRARIES "Free portable C++ libraries" on \
PYTHON "Boost.Python - interfacing Python and C++" off \
PYSTE "Boost.Pyste - Boost.Python code generator" off \
DOCS "Documentation & examples" on
NO_BUILD= yes
@ -24,19 +25,23 @@ NO_BUILD= yes
.include "common.mk"
.if !defined(WITHOUT_LIBRARIES)
RUN_DEPENDS+= ${PREFIX}/lib/libboost_thread.so:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_thread.so:${PORTSDIR}/devel/boost-libs
.endif
.if !defined(WITHOUT_JAM)
RUN_DEPENDS+= ${PREFIX}/bin/bjam:${PORTSDIR}/devel/boost-jam
RUN_DEPENDS+= ${LOCALBASE}/bin/bjam:${PORTSDIR}/devel/boost-jam
.endif
.if !defined(WITHOUT_PYTHON)
RUN_DEPENDS+= ${PREFIX}/lib/libboost_python.so:${PORTSDIR}/devel/boost-python-libs
RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_python.so:${PORTSDIR}/devel/boost-python-libs
.endif
.if !defined(WITHOUT_PYSTE)
RUN_DEPENDS+= ${LOCALBASE}/bin/pyste.py:${PORTSDIR}/devel/boost-pyste
.endif
.if !defined(WITHOUT_DOCS)
RUN_DEPENDS+= ${PREFIX}/share/doc/boost/doc/html/index.html:${PORTSDIR}/devel/boost-docs
RUN_DEPENDS+= ${LOCALBASE}/share/doc/boost/doc/html/index.html:${PORTSDIR}/devel/boost-docs
.endif
do-install:

View file

@ -1,9 +1,10 @@
PORTVERSION= 1.39.0
PORTVERSION= 1.41.0
PORTVERSUFFIX= ${PORTVERSION:C/\.[0-9]+$//}
DISTNAME= boost_${PORTVERSION:S/./_/g}
CATEGORIES= devel
MAINTAINER= churanov.port.maintainer@gmail.com
CONFLICTS= boost-python-1* boost-1*
CONFLICTS+= boost-python-1* boost-1*
MASTER_SITES= SF/boost/boost/${PORTVERSION}

View file

@ -1,4 +0,0 @@
MASTER_SITES= SF/boost/boost/${PORTVERSION}
WRKSRC= ${WRKDIR}/${DISTNAME}

View file

@ -17,7 +17,6 @@ NO_BUILD= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/boost-all/common.mk"
.include "${PORTSDIR}/devel/boost-all/sites.mk"
do-install:
# Documentation & examples

View file

@ -1,3 +1,3 @@
MD5 (boost_1_39_0.tar.bz2) = a17281fd88c48e0d866e1a12deecbcc0
SHA256 (boost_1_39_0.tar.bz2) = 44785eae8c6cce61a29a8a51f9b737e57b34d66baa7c0bcd4af188832b8018fd
SIZE (boost_1_39_0.tar.bz2) = 29408537
MD5 (boost_1_41_0.tar.bz2) = 8bb65e133907db727a2a825c5400d0a6
SHA256 (boost_1_41_0.tar.bz2) = 1ef94e6749eaf13318284b4f629be063544c7015b45e38113b975ac1945cc726
SIZE (boost_1_41_0.tar.bz2) = 33348161

File diff suppressed because it is too large Load diff

View file

@ -11,7 +11,6 @@ USE_BZIP2= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/boost-all/common.mk"
.include "${PORTSDIR}/devel/boost-all/sites.mk"
.if ${ARCH} == alpha
BJAM-SUFFIX= axp
@ -26,7 +25,7 @@ BJAM-SUFFIX= x86
.elif ${ARCH} == amd64
BJAM-SUFFIX= x86_64
.else
BJAM-SUFFIX=
BJAM-SUFFIX= #
.endif
BJAM= ${WRKSRC}/tools/jam/src/bin.freebsd${BJAM-SUFFIX}/bjam

View file

@ -1,3 +1,3 @@
MD5 (boost_1_39_0.tar.bz2) = a17281fd88c48e0d866e1a12deecbcc0
SHA256 (boost_1_39_0.tar.bz2) = 44785eae8c6cce61a29a8a51f9b737e57b34d66baa7c0bcd4af188832b8018fd
SIZE (boost_1_39_0.tar.bz2) = 29408537
MD5 (boost_1_41_0.tar.bz2) = 8bb65e133907db727a2a825c5400d0a6
SHA256 (boost_1_41_0.tar.bz2) = 1ef94e6749eaf13318284b4f629be063544c7015b45e38113b975ac1945cc726
SIZE (boost_1_41_0.tar.bz2) = 33348161

View file

@ -16,15 +16,14 @@ OPTIONS= VERBOSE_BUILD "Show compiler messages" off \
ICU "Boost.Regex with ICU unicode support" on \
OPTIMIZED_CFLAGS "Enable -O3 optimization" off
BOOST_LIBS= date_time filesystem graph iostreams\
math_c99 math_c99f math_tr1 math_tr1f\
prg_exec_monitor program_options regex\
serialization signals system thread unit_test_framework\
wave wserialization
BOOST_LIBS= date_time filesystem graph iostreams\
math_c99 math_c99f math_tr1 math_tr1f\
prg_exec_monitor program_options regex\
serialization signals system thread unit_test_framework\
wave wserialization
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/boost-all/common.mk"
.include "${PORTSDIR}/devel/boost-all/sites.mk"
.include "${PORTSDIR}/devel/boost-all/compiled.mk"
.if defined (WITH_ICU)
@ -33,9 +32,11 @@ BJAM_OPTIONS+= -sICU_PATH=${LOCALBASE}
.endif
post-patch: customize-boost-build
# The following directory is empty and causes issues with pkg_{add,delete}
${RMDIR} ${WRKSRC}/boost/interprocess/containers/detail
# Remove Boost.Python
.if !defined(WITH_PYTHON)
@${RM} -rf ${WRKSRC}/boost/python* ${WRKSRC}/libs/python
${RM} -rf ${WRKSRC}/boost/python* ${WRKSRC}/libs/python
.endif
do-build:

View file

@ -1,3 +1,3 @@
MD5 (boost_1_39_0.tar.bz2) = a17281fd88c48e0d866e1a12deecbcc0
SHA256 (boost_1_39_0.tar.bz2) = 44785eae8c6cce61a29a8a51f9b737e57b34d66baa7c0bcd4af188832b8018fd
SIZE (boost_1_39_0.tar.bz2) = 29408537
MD5 (boost_1_41_0.tar.bz2) = 8bb65e133907db727a2a825c5400d0a6
SHA256 (boost_1_41_0.tar.bz2) = 1ef94e6749eaf13318284b4f629be063544c7015b45e38113b975ac1945cc726
SIZE (boost_1_41_0.tar.bz2) = 33348161

View file

@ -1,20 +1,11 @@
--- Jamroot.orig-orig 2009-07-06 20:50:54.000000000 +0400
+++ Jamroot 2009-07-06 20:52:21.000000000 +0400
@@ -333,7 +333,7 @@
# suffixes either. Pgi compilers can not accept library with version
# suffix.
if $(type) = SHARED_LIB &&
- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
+ ( ! ( [ $(property-set).get <target-os> ] in windows freebsd cygwin darwin aix ) &&
! ( [ $(property-set).get <toolset> ] in pgi ) )
{
result = $(result).$(BOOST_VERSION) ;
@@ -356,7 +356,7 @@
# suffixes either. Pgi compilers can not accept library with version
# suffix.
if $(type) = SHARED_LIB &&
- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
+ ( ! ( [ $(property-set).get <target-os> ] in windows freebsd cygwin darwin aix ) &&
! ( [ $(property-set).get <toolset> ] in pgi ) )
{
result = $(result).$(BOOST_VERSION) ;
--- Jamroot.orig 2009-09-23 16:35:49.000000000 +0400
+++ Jamroot 2009-09-23 16:36:49.000000000 +0400
@@ -384,7 +384,7 @@
# suffixes either. Pgi compilers can not accept library with version
# suffix.
if $(type) = SHARED_LIB &&
- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
+ ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix freebsd ) &&
! ( [ $(property-set).get <toolset> ] in pgi ) )
{
result = $(result).$(BOOST_VERSION) ;

View file

@ -0,0 +1,18 @@
Index: boost/archive/shared_ptr_helper.hpp
===================================================================
--- boost/archive/shared_ptr_helper.hpp (revision 55789)
+++ boost/archive/shared_ptr_helper.hpp (revision 57981)
@@ -109,5 +110,5 @@
static const boost::serialization::extended_type_info *
get_object_identifier(T & t){
- return boost::serialization::singleton<
+ return & boost::serialization::singleton<
BOOST_DEDUCED_TYPENAME
boost::serialization::type_info_implementation<T>::type
@@ -158,5 +159,5 @@
result_type r =
get_od(
- t,
+ static_cast<void *>(t),
true_type,
this_type

View file

@ -1,15 +1,31 @@
--- boost/test/impl/execution_monitor.ipp Mon Oct 13 12:20:26 2008
+++ boost/test/impl/execution_monitor.ipp Sun Nov 9 00:36:42 2008
@@ -289,50 +289,11 @@
--- boost/test/impl/execution_monitor.ipp.orig 2009-09-23 16:44:57.000000000 +0400
+++ boost/test/impl/execution_monitor.ipp 2009-09-23 16:59:44.000000000 +0400
@@ -319,48 +319,7 @@
switch( m_sig_info->si_signo ) {
case SIGILL:
- switch( m_sig_info->si_code ) {
switch( m_sig_info->si_code ) {
-#ifndef BOOST_TEST_LIMITED_SIGNAL_DETAILS
- case ILL_ILLOPC:
- report_error( execution_exception::system_fatal_error,
- "signal: illegal opcode; address of failing instruction: 0x%08lx",
- m_sig_info->si_addr );
- break;
- case ILL_ILLTRP:
- report_error( execution_exception::system_fatal_error,
- "signal: illegal trap; address of failing instruction: 0x%08lx",
- m_sig_info->si_addr );
- break;
- case ILL_PRVREG:
- report_error( execution_exception::system_fatal_error,
- "signal: privileged register; address of failing instruction: 0x%08lx",
- m_sig_info->si_addr );
- break;
- case ILL_BADSTK:
- report_error( execution_exception::system_fatal_error,
- "signal: internal stack error; address of failing instruction: 0x%08lx",
- m_sig_info->si_addr );
- break;
-#endif
- case ILL_ILLOPN:
- report_error( execution_exception::system_fatal_error,
- "signal: illegal operand; address of failing instruction: 0x%08lx",
@ -20,46 +36,25 @@
- "signal: illegal addressing mode; address of failing instruction: 0x%08lx",
- m_sig_info->si_addr );
- break;
- case ILL_ILLTRP:
- report_error( execution_exception::system_fatal_error,
- "signal: illegal trap; address of failing instruction: 0x%08lx",
- m_sig_info->si_addr );
- break;
- case ILL_PRVOPC:
- report_error( execution_exception::system_fatal_error,
- "signal: privileged opcode; address of failing instruction: 0x%08lx",
- m_sig_info->si_addr );
- break;
- case ILL_PRVREG:
- report_error( execution_exception::system_fatal_error,
- "signal: privileged register; address of failing instruction: 0x%08lx",
- m_sig_info->si_addr );
- break;
- case ILL_COPROC:
- report_error( execution_exception::system_fatal_error,
- "signal: co-processor error; address of failing instruction: 0x%08lx",
- m_sig_info->si_addr );
- break;
- case ILL_BADSTK:
- report_error( execution_exception::system_fatal_error,
- "signal: internal stack error; address of failing instruction: 0x%08lx",
- m_sig_info->si_addr );
- break;
- }
+ // FreeBSD 6.2 does not provide details for this signal as required by SUSv3
+ report_error( execution_exception::system_fatal_error,
+ "signal: SIGILL (illegal instruction)" );
break;
-
+
case SIGFPE:
switch( m_sig_info->si_code ) {
case FPE_INTDIV:
@@ -379,73 +340,21 @@
break;
+ // FreeBSD 6.x does not provide details for this signal as required by SUSv3
default:
report_error( execution_exception::system_fatal_error,
"signal: SIGILL, si_code: %d (illegal instruction; address of failing instruction: 0x%08lx)",
@@ -421,18 +380,7 @@
case SIGSEGV:
- switch( m_sig_info->si_code ) {
switch( m_sig_info->si_code ) {
-#ifndef BOOST_TEST_LIMITED_SIGNAL_DETAILS
- case SEGV_MAPERR:
- report_error( execution_exception::system_fatal_error,
- "memory access violation at address: 0x%08lx: no mapping at fault address",
@ -70,14 +65,16 @@
- "memory access violation at address: 0x%08lx: invalid permissions",
- m_sig_info->si_addr );
- break;
- }
+ // FreeBSD 6.2 does not provide details for this signal as required by SUSv3
+ report_error( execution_exception::system_fatal_error,
+ "signal: SIGSEGV (invalid memory reference)" );
break;
-#endif
+ // FreeBSD 6.x does not provide details for this signal as required by SUSv3
default:
report_error( execution_exception::system_fatal_error,
"signal: SIGSEGV, si_code: %d (memory access violation at address: 0x%08lx)",
@@ -443,23 +391,7 @@
case SIGBUS:
- switch( m_sig_info->si_code ) {
switch( m_sig_info->si_code ) {
-#ifndef BOOST_TEST_LIMITED_SIGNAL_DETAILS
- case BUS_ADRALN:
- report_error( execution_exception::system_fatal_error,
- "memory access violation at address: 0x%08lx: invalid address alignment",
@ -93,14 +90,16 @@
- "memory access violation at address: 0x%08lx: object specific hardware error",
- m_sig_info->si_addr );
- break;
- }
+ // FreeBSD 6.2 does not provide details for this signal as required by SUSv3
+ report_error( execution_exception::system_fatal_error,
+ "signal: SIGBUS (access to an undefined portion of a memory object)" );
break;
-#endif
+ // FreeBSD 6.x does not provide details for this signal as required by SUSv3
default:
report_error( execution_exception::system_fatal_error,
"signal: SIGSEGV, si_code: %d (memory access violation at address: 0x%08lx)",
@@ -470,38 +402,7 @@
case SIGCHLD:
- switch( m_sig_info->si_code ) {
switch( m_sig_info->si_code ) {
-#ifndef BOOST_TEST_LIMITED_SIGNAL_DETAILS
- case CLD_EXITED:
- report_error( execution_exception::system_error,
- "child has exited; pid: %d; uid: %d; exit value: %d",
@ -131,20 +130,25 @@
- "stopped child had continued; pid: %d; uid: %d; exit value: %d",
- (int)m_sig_info->si_pid, (int)m_sig_info->si_uid, (int)m_sig_info->si_status );
- break;
- }
+ // FreeBSD 6.2 does not provide details for this signal as required by SUSv3
+ report_error( execution_exception::system_error,
+ "signal: SIGCHLD (child process terminated, stopped, or continued)" );
break;
#if defined(BOOST_TEST_CATCH_SIGPOLL)
@@ -695,7 +604,8 @@
-#endif
+ // FreeBSD 6.x does not provide details for this signal as required by SUSv3
default:
report_error( execution_exception::system_error,
"signal: SIGCHLD, si_code: %d (child process has terminated; pid: %d; uid: %d; exit value: %d)",
@@ -771,15 +672,7 @@
static bool ignore_sigchild( siginfo_t* info )
{
- return info->si_signo == SIGCHLD && info->si_code == CLD_EXITED
+ // for now just use an assumption that children always exit normally
+ return true //info->si_signo == SIGCHLD && info->si_code == CLD_EXITED
#ifdef BOOST_TEST_IGNORE_NON_ZERO_CHILD_CODE
;
#else
- return info->si_signo == SIGCHLD
-#ifndef BOOST_TEST_LIMITED_SIGNAL_DETAILS
- && info->si_code == CLD_EXITED
-#endif
-#ifdef BOOST_TEST_IGNORE_NON_ZERO_CHILD_CODE
- ;
-#else
- && (int)info->si_status == 0;
-#endif
+ return info->si_signo == SIGCHLD && (int)info->si_status == 0;
}
//____________________________________________________________________________//

View file

@ -1,17 +1,17 @@
--- tools/build/v2/tools/common.jam.orig Thu Oct 16 12:42:03 2008
+++ tools/build/v2/tools/common.jam Tue Nov 11 23:43:27 2008
@@ -760,14 +760,6 @@
--- tools/build/v2/tools/common.jam.orig 2009-09-23 16:39:31.000000000 +0400
+++ tools/build/v2/tools/common.jam 2009-09-23 16:39:33.000000000 +0400
@@ -765,14 +765,6 @@
result += [ join-tag $(f:G=) : [ toolset-tag $(name) : $(type) :
$(property-set) ] ] ;
- case <threading> :
$(property-set) ] ] ;
- case <threading> :
- result += [ join-tag $(f:G=) : [ threading-tag $(name) : $(type)
- : $(property-set) ] ] ;
-
- case <runtime> :
- : $(property-set) ] ] ;
-
- case <runtime> :
- result += [ join-tag $(f:G=) : [ runtime-tag $(name) : $(type) :
- $(property-set) ] ] ;
-
case <version:*> :
local key = [ MATCH <version:(.*)> : $(f:G) ] ;
local version = [ $(property-set).get <$(key)> ] ;
- $(property-set) ] ] ;
-
case <qt> :
result += [ join-tag $(f:G=) : [ qt-tag $(name) : $(type) :
$(property-set) ] ] ;

File diff suppressed because it is too large Load diff

View file

@ -0,0 +1,60 @@
# Ports collection makefile for: boost-pyste
# Date Created: 16 Novemeber 2009
# Whom: Alexander Churanov <churanov.port.maintainer@gmail.com>
#
# $FreeBSD$
#
PORTNAME= boost-pyste
COMMENT= Boost.Python code generator
CONFLICTS+= boost-python-libs-1.3* boost-python-libs-1.40
USE_BZIP2= yes
USE_PYTHON= 2.4+
OPTIONS= VERBOSE_BUILD "Show compiler messages" off \
DEBUG "Build debugging symbols" off \
OPTIMIZED_CFLAGS "Enable -O3 optimization" off
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/boost-all/common.mk"
.include "${PORTSDIR}/devel/boost-all/compiled.mk"
MAKE_ENV+= PYTHON_ROOT="${LOCALBASE}"\
PYTHON_VERSION="${PYTHON_VERSION}"\
PYTHON_INCLUDES="${PYTHON_INCLUDEDIR}"\
PYTHON_LIB_PATH="${PYTHON_LIBDIR}"
RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_python.so.${BOOST_SHARED_LIB_VER}:${PORTSDIR}/devel/boost-python-libs
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/ElementTree.py:${PORTSDIR}/devel/py-elementtree
RUN_DEPENDS+= gccxml:${PORTSDIR}/devel/gccxml
BUILD_DEPENDS+= ${BJAM}:${PORTSDIR}/devel/boost-jam
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/ElementTree.py:${PORTSDIR}/devel/py-elementtree
ESCAPED_PREFIX != echo ${PREFIX} | sed 's/\//\\\//g'
RELATIVE_PYTHON_SITELIBDIR != echo ${PYTHON_SITELIBDIR} | sed "s/${ESCAPED_PREFIX}\///"
PLIST_SUB+= PYTHON_SITELIBDIR=${RELATIVE_PYTHON_SITELIBDIR}
PLIST_SUB+= PYTHON_VERSION=${PYTHON_VERSION:C/python//1}
post-patch: customize-boost-build
post-configure:
# Configure pyste, the Boost.Python code generator
@cd ${BUILD_WRKSRC}/libs/python/pyste/install && \
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
config ${PYDISTUTILS_CONFIGUREARGS}
do-build:
# Build pyste, the Boost.Python code generator
cd ${BUILD_WRKSRC}/libs/python/pyste/install && \
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
build ${PYDISTUTILS_BUILDARGS}
do-install:
# Install pyste, the Boost.Python code generator
cd ${WRKSRC}/libs/python/pyste/install && \
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
install ${PYDISTUTILS_INSTALLARGS}
.include <bsd.port.post.mk>

View file

@ -0,0 +1,3 @@
MD5 (boost_1_41_0.tar.bz2) = 8bb65e133907db727a2a825c5400d0a6
SHA256 (boost_1_41_0.tar.bz2) = 1ef94e6749eaf13318284b4f629be063544c7015b45e38113b975ac1945cc726
SIZE (boost_1_41_0.tar.bz2) = 33348161

View file

@ -0,0 +1,11 @@
--- Jamroot.orig 2009-09-23 16:35:49.000000000 +0400
+++ Jamroot 2009-09-23 16:36:49.000000000 +0400
@@ -384,7 +384,7 @@
# suffixes either. Pgi compilers can not accept library with version
# suffix.
if $(type) = SHARED_LIB &&
- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
+ ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix freebsd ) &&
! ( [ $(property-set).get <toolset> ] in pgi ) )
{
result = $(result).$(BOOST_VERSION) ;

View file

@ -0,0 +1,17 @@
--- tools/build/v2/tools/common.jam.orig 2009-09-23 16:39:31.000000000 +0400
+++ tools/build/v2/tools/common.jam 2009-09-23 16:39:33.000000000 +0400
@@ -765,14 +765,6 @@
result += [ join-tag $(f:G=) : [ toolset-tag $(name) : $(type) :
$(property-set) ] ] ;
- case <threading> :
- result += [ join-tag $(f:G=) : [ threading-tag $(name) : $(type)
- : $(property-set) ] ] ;
-
- case <runtime> :
- result += [ join-tag $(f:G=) : [ runtime-tag $(name) : $(type) :
- $(property-set) ] ] ;
-
case <qt> :
result += [ join-tag $(f:G=) : [ qt-tag $(name) : $(type) :
$(property-set) ] ] ;

View file

@ -0,0 +1,29 @@
--- tools/build/v2/tools/gcc.jam.orig Thu Oct 16 12:42:03 2008
+++ tools/build/v2/tools/gcc.jam Tue Nov 11 23:48:37 2008
@@ -88,7 +88,7 @@
{
# Information about the gcc command...
# The command.
- local command = [ common.get-invocation-command gcc : g++ : $(command) ] ;
+ local command = [ common.get-invocation-command gcc : %%CXX%% : $(command) ] ;
# The root directory of the tool install.
local root = [ feature.get-values <root> : $(options) ] ;
# The bin directory where to find the command to execute.
@@ -292,7 +292,7 @@
# Declare flags and action for compilation.
toolset.flags gcc.compile OPTIONS <optimization>off : -O0 ;
-toolset.flags gcc.compile OPTIONS <optimization>speed : -O3 ;
+toolset.flags gcc.compile OPTIONS <optimization>speed : %%CXXFLAGS%% ;
toolset.flags gcc.compile OPTIONS <optimization>space : -Os ;
toolset.flags gcc.compile OPTIONS <inlining>off : -fno-inline ;
@@ -811,7 +811,7 @@
}
case *bsd :
{
- option = -pthread ;
+ option = %%PTHREAD_LIBS%% %%PTHREAD_CFLAGS%% ;
# There is no -lrt on BSD.
}
case sgi :

View file

@ -0,0 +1,11 @@
--- tools/build/v2/tools/python.jam.orig Thu Oct 16 12:42:03 2008
+++ tools/build/v2/tools/python.jam Tue Nov 11 23:50:21 2008
@@ -650,7 +650,7 @@
case windows : return ;
case hpux : return <library>rt ;
- case *bsd : return <library>pthread <toolset>gcc:<library>util ;
+ case *bsd : return <library>%%PTHREAD_LIBS%% <toolset>gcc:<library>util ;
case aix : return <library>pthread <library>dl ;

View file

@ -0,0 +1,11 @@
--- tools/jam/src/build.jam.orig Tue Jul 29 15:43:31 2008
+++ tools/jam/src/build.jam Tue Nov 11 23:52:09 2008
@@ -176,7 +176,7 @@
## GCC 2.x, 3.x, 4.x
toolset gcc gcc : "-o " : -D
: -pedantic -fno-strict-aliasing
- [ opt --release : [ opt --symbols : -g : -s ] -O3 ]
+ [ opt --release : [ opt --symbols : -g : -s ] -O3 -fno-strict-aliasing ]
[ opt --debug : -g -O0 -fno-inline ]
-I$(--python-include) -I$(--extra-include) -Wno-long-long
: -L$(--python-lib[1]) -l$(--python-lib[2]) ;

View file

@ -0,0 +1,7 @@
Pyste is a Boost.Python code generator. The user specifies the classes
and functions to be exported using a simple interface file, which
following the Boost.Python's philosophy, is simple Python code. Pyste
then uses GCCXML to parse all the headers and extract the necessary
information to automatically generate C++ code.
WWW: http://www.boost.org/

View file

@ -0,0 +1,66 @@
bin/pyste.py
%%PYTHON_SITELIBDIR%%/Pyste-0.9.10-py%%PYTHON_VERSION%%.egg-info
%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.py
%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.pyc
%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.pyo
%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.py
%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.pyc
%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.pyo
%%PYTHON_SITELIBDIR%%/Pyste/CppParser.py
%%PYTHON_SITELIBDIR%%/Pyste/CppParser.pyc
%%PYTHON_SITELIBDIR%%/Pyste/CppParser.pyo
%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.py
%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.pyc
%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.pyo
%%PYTHON_SITELIBDIR%%/Pyste/Exporter.py
%%PYTHON_SITELIBDIR%%/Pyste/Exporter.pyc
%%PYTHON_SITELIBDIR%%/Pyste/Exporter.pyo
%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.py
%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.pyc
%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.pyo
%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.py
%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.pyc
%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.pyo
%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.py
%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.pyc
%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.pyo
%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.py
%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.pyc
%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.pyo
%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.py
%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.pyc
%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.pyo
%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.py
%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.pyc
%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.pyo
%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.py
%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.pyc
%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.pyo
%%PYTHON_SITELIBDIR%%/Pyste/__init__.py
%%PYTHON_SITELIBDIR%%/Pyste/__init__.pyc
%%PYTHON_SITELIBDIR%%/Pyste/__init__.pyo
%%PYTHON_SITELIBDIR%%/Pyste/declarations.py
%%PYTHON_SITELIBDIR%%/Pyste/declarations.pyc
%%PYTHON_SITELIBDIR%%/Pyste/declarations.pyo
%%PYTHON_SITELIBDIR%%/Pyste/exporters.py
%%PYTHON_SITELIBDIR%%/Pyste/exporters.pyc
%%PYTHON_SITELIBDIR%%/Pyste/exporters.pyo
%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.py
%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.pyc
%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.pyo
%%PYTHON_SITELIBDIR%%/Pyste/infos.py
%%PYTHON_SITELIBDIR%%/Pyste/infos.pyc
%%PYTHON_SITELIBDIR%%/Pyste/infos.pyo
%%PYTHON_SITELIBDIR%%/Pyste/policies.py
%%PYTHON_SITELIBDIR%%/Pyste/policies.pyc
%%PYTHON_SITELIBDIR%%/Pyste/policies.pyo
%%PYTHON_SITELIBDIR%%/Pyste/pyste.py
%%PYTHON_SITELIBDIR%%/Pyste/pyste.pyc
%%PYTHON_SITELIBDIR%%/Pyste/pyste.pyo
%%PYTHON_SITELIBDIR%%/Pyste/settings.py
%%PYTHON_SITELIBDIR%%/Pyste/settings.pyc
%%PYTHON_SITELIBDIR%%/Pyste/settings.pyo
%%PYTHON_SITELIBDIR%%/Pyste/utils.py
%%PYTHON_SITELIBDIR%%/Pyste/utils.pyc
%%PYTHON_SITELIBDIR%%/Pyste/utils.pyo
@dirrm %%PYTHON_SITELIBDIR%%/Pyste

View file

@ -6,7 +6,6 @@
#
PORTNAME= boost-python-libs
PORTREVISION= 1
COMMENT= Framework for interfacing Python and C++
USE_BZIP2= yes
@ -18,7 +17,6 @@ OPTIONS= VERBOSE_BUILD "Show compiler messages" off \
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/boost-all/common.mk"
.include "${PORTSDIR}/devel/boost-all/sites.mk"
.include "${PORTSDIR}/devel/boost-all/compiled.mk"
MAKE_ENV+= PYTHON_ROOT="${LOCALBASE}"\
@ -28,12 +26,7 @@ MAKE_ENV+= PYTHON_ROOT="${LOCALBASE}"\
RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_thread.so.${BOOST_SHARED_LIB_VER}:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/ElementTree.py:${PORTSDIR}/devel/py-elementtree
.if defined(WITH_PYSTE)
RUN_DEPENDS+= gccxml:${PORTSDIR}/devel/gccxml
PLIST_SUB+= PYSTE=
.else
PLIST_SUB+= PYSTE="@comment "
.endif
BUILD_DEPENDS+= ${BJAM}:${PORTSDIR}/devel/boost-jam
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/ElementTree.py:${PORTSDIR}/devel/py-elementtree
@ -44,25 +37,12 @@ PLIST_SUB+= PYTHON_VERSION=${PYTHON_VERSION:C/python//1}
post-patch: customize-boost-build
.if defined(WITH_PYSTE)
post-configure:
# Configure pyste, the Boost.Python code generator
@cd ${BUILD_WRKSRC}/libs/python/pyste/install && \
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
config ${PYDISTUTILS_CONFIGUREARGS}
.endif
do-build:
# build the library
cd ${WRKSRC} && \
${SETENV} ${MAKE_ENV} ${BJAM} ${BJAM_OPTIONS} --prefix=${PREFIX}\
--toolset=${BOOST_TOOLS} --with-python
# Build pyste, the Boost.Python code generator
cd ${BUILD_WRKSRC}/libs/python/pyste/install && \
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
build ${PYDISTUTILS_BUILDARGS}
# Remove non-python headers
cd ${WRKSRC} && \
${FIND} boost -not -path '*boost/python*' -delete
@ -90,13 +70,6 @@ do-install:
${FIND} boost -type f -a \! -name "*.orig"\
-exec ${INSTALL_DATA} \{\} ${PREFIX}/include/\{\} \;
.if defined(WITH_PYSTE)
# Install pyste, the Boost.Python code generator
cd ${WRKSRC}/libs/python/pyste/install && \
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
install ${PYDISTUTILS_INSTALLARGS}
.endif
post-install:
# display pkg-message
@${TOUCH} ${PKGMESSAGE}

View file

@ -1,3 +1,3 @@
MD5 (boost_1_39_0.tar.bz2) = a17281fd88c48e0d866e1a12deecbcc0
SHA256 (boost_1_39_0.tar.bz2) = 44785eae8c6cce61a29a8a51f9b737e57b34d66baa7c0bcd4af188832b8018fd
SIZE (boost_1_39_0.tar.bz2) = 29408537
MD5 (boost_1_41_0.tar.bz2) = 8bb65e133907db727a2a825c5400d0a6
SHA256 (boost_1_41_0.tar.bz2) = 1ef94e6749eaf13318284b4f629be063544c7015b45e38113b975ac1945cc726
SIZE (boost_1_41_0.tar.bz2) = 33348161

View file

@ -1,20 +1,11 @@
--- Jamroot.orig-orig 2009-07-06 20:50:54.000000000 +0400
+++ Jamroot 2009-07-06 20:52:21.000000000 +0400
@@ -333,7 +333,7 @@
# suffixes either. Pgi compilers can not accept library with version
# suffix.
if $(type) = SHARED_LIB &&
- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
+ ( ! ( [ $(property-set).get <target-os> ] in windows freebsd cygwin darwin aix ) &&
! ( [ $(property-set).get <toolset> ] in pgi ) )
{
result = $(result).$(BOOST_VERSION) ;
@@ -356,7 +356,7 @@
# suffixes either. Pgi compilers can not accept library with version
# suffix.
if $(type) = SHARED_LIB &&
- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
+ ( ! ( [ $(property-set).get <target-os> ] in windows freebsd cygwin darwin aix ) &&
! ( [ $(property-set).get <toolset> ] in pgi ) )
{
result = $(result).$(BOOST_VERSION) ;
--- Jamroot.orig 2009-09-23 16:35:49.000000000 +0400
+++ Jamroot 2009-09-23 16:36:49.000000000 +0400
@@ -384,7 +384,7 @@
# suffixes either. Pgi compilers can not accept library with version
# suffix.
if $(type) = SHARED_LIB &&
- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
+ ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix freebsd ) &&
! ( [ $(property-set).get <toolset> ] in pgi ) )
{
result = $(result).$(BOOST_VERSION) ;

View file

@ -1,17 +1,17 @@
--- tools/build/v2/tools/common.jam.orig Thu Oct 16 12:42:03 2008
+++ tools/build/v2/tools/common.jam Tue Nov 11 23:43:27 2008
@@ -760,14 +760,6 @@
--- tools/build/v2/tools/common.jam.orig 2009-09-23 16:39:31.000000000 +0400
+++ tools/build/v2/tools/common.jam 2009-09-23 16:39:33.000000000 +0400
@@ -765,14 +765,6 @@
result += [ join-tag $(f:G=) : [ toolset-tag $(name) : $(type) :
$(property-set) ] ] ;
- case <threading> :
$(property-set) ] ] ;
- case <threading> :
- result += [ join-tag $(f:G=) : [ threading-tag $(name) : $(type)
- : $(property-set) ] ] ;
-
- case <runtime> :
- : $(property-set) ] ] ;
-
- case <runtime> :
- result += [ join-tag $(f:G=) : [ runtime-tag $(name) : $(type) :
- $(property-set) ] ] ;
-
case <version:*> :
local key = [ MATCH <version:(.*)> : $(f:G) ] ;
local version = [ $(property-set).get <$(key)> ] ;
- $(property-set) ] ] ;
-
case <qt> :
result += [ join-tag $(f:G=) : [ qt-tag $(name) : $(type) :
$(property-set) ] ] ;

View file

@ -3,4 +3,6 @@ C++. It allows you to quickly and seamlessly expose C++ classes
functions and objects to Python, and vice-versa, using no special
tools -- just your C++ compiler.
The Boost.Pyste code generator resides in a separate port: devel/boost-pyste
WWW: http://www.boost.org/

View file

@ -1,4 +1,3 @@
%%PYSTE%%bin/pyste.py
include/boost/python.hpp
include/boost/python/arg_from_python.hpp
include/boost/python/args.hpp
@ -213,71 +212,6 @@ include/boost/python/wrapper.hpp
lib/libboost_python.a
lib/libboost_python.so
lib/libboost_python.so.%%BOOST_SHARED_LIB_VER%%
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste-0.9.10-py%%PYTHON_VERSION%%.egg-info
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/CppParser.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/CppParser.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/CppParser.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/Exporter.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/Exporter.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/Exporter.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/__init__.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/__init__.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/__init__.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/declarations.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/declarations.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/declarations.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/exporters.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/exporters.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/exporters.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/infos.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/infos.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/infos.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/policies.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/policies.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/policies.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/pyste.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/pyste.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/pyste.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/settings.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/settings.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/settings.pyo
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/utils.py
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/utils.pyc
%%PYSTE%%%%PYTHON_SITELIBDIR%%/Pyste/utils.pyo
%%PYSTE%%@dirrm %%PYTHON_SITELIBDIR%%/Pyste
@dirrm include/boost/python/suite/indexing/detail
@dirrm include/boost/python/suite/indexing
@dirrm include/boost/python/suite