- add patch based on OS versions.
- add USE_GCC=3.3 and unbreak this port on 4.x - backout arch-related settings in previous commit. Noticed by: kris Reviewed by: Florent Thoumie <flz@xbsd.org> Approved by: Florent Thoumie <flz@xbsd.org>
This commit is contained in:
parent
d709fa8022
commit
12c05f36a2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=107602
4 changed files with 18 additions and 6 deletions
|
@ -20,12 +20,14 @@ LIB_DEPENDS= uuid.1:${PORTSDIR}/sysutils/e2fsprogs \
|
|||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
USE_GCC= 3.3
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
.if ${ARCH} == "alpha"
|
||||
BROKEN= "Does not compile on alpha"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|depend||' ${WRKSRC}/Makefile.in
|
||||
|
|
|
@ -1,10 +1,14 @@
|
|||
--- src/peer.c Wed Apr 7 06:14:44 2004
|
||||
+++ src/peer.c.new Tue Apr 13 19:29:01 2004
|
||||
@@ -20,6 +20,7 @@
|
||||
@@ -20,6 +20,11 @@
|
||||
# endif
|
||||
#endif
|
||||
#include <sys/types.h>
|
||||
+#if __FreeBSD__ >= 5
|
||||
+#include <sys/limits.h>
|
||||
+#else
|
||||
+#include <machine/limits.h>
|
||||
+#endif
|
||||
#include <string.h>
|
||||
#ifdef HAVE_STRINGS_H
|
||||
# include <strings.h>
|
||||
|
|
|
@ -20,12 +20,14 @@ LIB_DEPENDS= uuid.1:${PORTSDIR}/sysutils/e2fsprogs \
|
|||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
USE_GCC= 3.3
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
.if ${ARCH} == "alpha"
|
||||
BROKEN= "Does not compile on alpha"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|depend||' ${WRKSRC}/Makefile.in
|
||||
|
|
|
@ -1,10 +1,14 @@
|
|||
--- src/peer.c Wed Apr 7 06:14:44 2004
|
||||
+++ src/peer.c.new Tue Apr 13 19:29:01 2004
|
||||
@@ -20,6 +20,7 @@
|
||||
@@ -20,6 +20,11 @@
|
||||
# endif
|
||||
#endif
|
||||
#include <sys/types.h>
|
||||
+#if __FreeBSD__ >= 5
|
||||
+#include <sys/limits.h>
|
||||
+#else
|
||||
+#include <machine/limits.h>
|
||||
+#endif
|
||||
#include <string.h>
|
||||
#ifdef HAVE_STRINGS_H
|
||||
# include <strings.h>
|
||||
|
|
Loading…
Reference in a new issue