o Bump PORTREVISION
o Prefer mplayer internal DVD access routines rather than libdvdread due to problem reports from users. Prefer libdvdread if WITH_LIBDVDREAD o Change iconv interaction since users have been complaining since iconv was updated to 1.7 Submitted by: maintainer
This commit is contained in:
parent
296624e8f0
commit
12c8a1eae2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60631
9 changed files with 174 additions and 9 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= mplayer
|
||||
PORTVERSION= 0.90.0.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
|
||||
http://www.mplayerhq.hu/MPlayer/releases/ \
|
||||
|
@ -46,7 +47,7 @@ DOCFILES= DVB bugreports.html cd-dvd.html codecs-in.html \
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libdvdread.so.2)
|
||||
.if exists(${LOCALBASE}/lib/libdvdcss.so.2)
|
||||
WITH_DVD= yes
|
||||
.endif
|
||||
|
||||
|
@ -80,8 +81,12 @@ CONFIGURE_ARGS+= --enable-gui
|
|||
.endif
|
||||
|
||||
.if defined(WITH_DVD)
|
||||
.if !defined(WITH_LIBDVDREAD)
|
||||
LIB_DEPENDS+= dvdcss.2:${PORTSDIR}/graphics/libdvdcss
|
||||
.else
|
||||
LIB_DEPENDS+= dvdread.2:${PORTSDIR}/graphics/libdvdread
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SVGALIB)
|
||||
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
|
||||
|
@ -156,6 +161,10 @@ pre-everything::
|
|||
.if !defined(WITH_DVD)
|
||||
@${ECHO_MSG} "You can enable DVD support by defining WITH_DVD."
|
||||
.endif
|
||||
.if defined(WITH_DVD) && !defined(WITH_LIBDVDREAD)
|
||||
@${ECHO_MSG} "You can replace mplayer internal DVD routines with libdvdread"
|
||||
@${ECHO_MSG} "support by defining WITH_LIBDVDREAD."
|
||||
.endif
|
||||
.if !defined(WITH_SVGALIB)
|
||||
@${ECHO_MSG} "You can enable SVGALIB support by defining WITH_SVGALIB."
|
||||
.endif
|
||||
|
@ -195,7 +204,9 @@ pre-everything::
|
|||
.endif # ARCH == i386
|
||||
|
||||
pre-configure:
|
||||
.if defined(WITH_LIBDVDREAD)
|
||||
@${RM} -Rf ${WRKSRC}/libmpdvdkit/
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${DATADIR}
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- configure.orig Mon May 13 22:52:10 2002
|
||||
+++ configure Tue May 21 08:56:42 2002
|
||||
+++ configure Tue Jun 4 23:08:36 2002
|
||||
@@ -450,19 +450,10 @@
|
||||
|
||||
# Try to find the available options for the current CPU
|
||||
|
@ -67,7 +67,37 @@
|
|||
echores "yes (using $_ld_pthread)"
|
||||
|
||||
|
||||
@@ -3570,7 +3531,7 @@
|
||||
@@ -3064,11 +3025,7 @@
|
||||
|
||||
echocheck "iconv"
|
||||
if test "$_iconv" = auto ; then
|
||||
- if freebsd ; then
|
||||
- _iconv_tmp='#include <giconv.h>'
|
||||
- else
|
||||
_iconv_tmp='#include <iconv.h>'
|
||||
- fi
|
||||
cat > $TMPC << EOF
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
@@ -3102,7 +3059,7 @@
|
||||
EOF
|
||||
_iconv=no
|
||||
if freebsd ; then
|
||||
- cc_check -lm -lgiconv && _iconv=yes
|
||||
+ cc_check -lm -liconv && _iconv=yes
|
||||
elif bsdos ; then
|
||||
cc_check -lm -liconv && _iconv=yes
|
||||
else
|
||||
@@ -3111,7 +3068,7 @@
|
||||
fi
|
||||
if test "$_iconv" = yes ; then
|
||||
_def_iconv='#define USE_ICONV 1'
|
||||
- freebsd && _ld_iconv='-lgiconv'
|
||||
+ freebsd && _ld_iconv='-liconv'
|
||||
bsdos && _ld_iconv='-liconv'
|
||||
else
|
||||
_def_iconv='#undef USE_ICONV'
|
||||
@@ -3570,7 +3527,7 @@
|
||||
CFLAGS="$CFLAGS -D_REENTRANT"
|
||||
elif bsd ; then
|
||||
# FIXME bsd needs this so maybe other OS'es
|
||||
|
|
14
graphics/mplayer/files/patch-mplayer:subreader.c
Normal file
14
graphics/mplayer/files/patch-mplayer:subreader.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- subreader.c.orig Mon May 13 22:41:20 2002
|
||||
+++ subreader.c Tue Jun 4 22:54:33 2002
|
||||
@@ -18,11 +18,7 @@
|
||||
#define ERR ((void *) -1)
|
||||
|
||||
#ifdef USE_ICONV
|
||||
-#ifdef __FreeBSD__
|
||||
-#include <giconv.h>
|
||||
-#else
|
||||
#include <iconv.h>
|
||||
-#endif
|
||||
char *sub_cp=NULL;
|
||||
#endif
|
||||
|
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= mplayer
|
||||
PORTVERSION= 0.90.0.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
|
||||
http://www.mplayerhq.hu/MPlayer/releases/ \
|
||||
|
@ -46,7 +47,7 @@ DOCFILES= DVB bugreports.html cd-dvd.html codecs-in.html \
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libdvdread.so.2)
|
||||
.if exists(${LOCALBASE}/lib/libdvdcss.so.2)
|
||||
WITH_DVD= yes
|
||||
.endif
|
||||
|
||||
|
@ -80,8 +81,12 @@ CONFIGURE_ARGS+= --enable-gui
|
|||
.endif
|
||||
|
||||
.if defined(WITH_DVD)
|
||||
.if !defined(WITH_LIBDVDREAD)
|
||||
LIB_DEPENDS+= dvdcss.2:${PORTSDIR}/graphics/libdvdcss
|
||||
.else
|
||||
LIB_DEPENDS+= dvdread.2:${PORTSDIR}/graphics/libdvdread
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SVGALIB)
|
||||
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
|
||||
|
@ -156,6 +161,10 @@ pre-everything::
|
|||
.if !defined(WITH_DVD)
|
||||
@${ECHO_MSG} "You can enable DVD support by defining WITH_DVD."
|
||||
.endif
|
||||
.if defined(WITH_DVD) && !defined(WITH_LIBDVDREAD)
|
||||
@${ECHO_MSG} "You can replace mplayer internal DVD routines with libdvdread"
|
||||
@${ECHO_MSG} "support by defining WITH_LIBDVDREAD."
|
||||
.endif
|
||||
.if !defined(WITH_SVGALIB)
|
||||
@${ECHO_MSG} "You can enable SVGALIB support by defining WITH_SVGALIB."
|
||||
.endif
|
||||
|
@ -195,7 +204,9 @@ pre-everything::
|
|||
.endif # ARCH == i386
|
||||
|
||||
pre-configure:
|
||||
.if defined(WITH_LIBDVDREAD)
|
||||
@${RM} -Rf ${WRKSRC}/libmpdvdkit/
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${DATADIR}
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- configure.orig Mon May 13 22:52:10 2002
|
||||
+++ configure Tue May 21 08:56:42 2002
|
||||
+++ configure Tue Jun 4 23:08:36 2002
|
||||
@@ -450,19 +450,10 @@
|
||||
|
||||
# Try to find the available options for the current CPU
|
||||
|
@ -67,7 +67,37 @@
|
|||
echores "yes (using $_ld_pthread)"
|
||||
|
||||
|
||||
@@ -3570,7 +3531,7 @@
|
||||
@@ -3064,11 +3025,7 @@
|
||||
|
||||
echocheck "iconv"
|
||||
if test "$_iconv" = auto ; then
|
||||
- if freebsd ; then
|
||||
- _iconv_tmp='#include <giconv.h>'
|
||||
- else
|
||||
_iconv_tmp='#include <iconv.h>'
|
||||
- fi
|
||||
cat > $TMPC << EOF
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
@@ -3102,7 +3059,7 @@
|
||||
EOF
|
||||
_iconv=no
|
||||
if freebsd ; then
|
||||
- cc_check -lm -lgiconv && _iconv=yes
|
||||
+ cc_check -lm -liconv && _iconv=yes
|
||||
elif bsdos ; then
|
||||
cc_check -lm -liconv && _iconv=yes
|
||||
else
|
||||
@@ -3111,7 +3068,7 @@
|
||||
fi
|
||||
if test "$_iconv" = yes ; then
|
||||
_def_iconv='#define USE_ICONV 1'
|
||||
- freebsd && _ld_iconv='-lgiconv'
|
||||
+ freebsd && _ld_iconv='-liconv'
|
||||
bsdos && _ld_iconv='-liconv'
|
||||
else
|
||||
_def_iconv='#undef USE_ICONV'
|
||||
@@ -3570,7 +3527,7 @@
|
||||
CFLAGS="$CFLAGS -D_REENTRANT"
|
||||
elif bsd ; then
|
||||
# FIXME bsd needs this so maybe other OS'es
|
||||
|
|
14
multimedia/mplayer/files/patch-mplayer:subreader.c
Normal file
14
multimedia/mplayer/files/patch-mplayer:subreader.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- subreader.c.orig Mon May 13 22:41:20 2002
|
||||
+++ subreader.c Tue Jun 4 22:54:33 2002
|
||||
@@ -18,11 +18,7 @@
|
||||
#define ERR ((void *) -1)
|
||||
|
||||
#ifdef USE_ICONV
|
||||
-#ifdef __FreeBSD__
|
||||
-#include <giconv.h>
|
||||
-#else
|
||||
#include <iconv.h>
|
||||
-#endif
|
||||
char *sub_cp=NULL;
|
||||
#endif
|
||||
|
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= mplayer
|
||||
PORTVERSION= 0.90.0.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://ftp.mplayerhq.hu/MPlayer/releases/ \
|
||||
http://www.mplayerhq.hu/MPlayer/releases/ \
|
||||
|
@ -46,7 +47,7 @@ DOCFILES= DVB bugreports.html cd-dvd.html codecs-in.html \
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if exists(${LOCALBASE}/lib/libdvdread.so.2)
|
||||
.if exists(${LOCALBASE}/lib/libdvdcss.so.2)
|
||||
WITH_DVD= yes
|
||||
.endif
|
||||
|
||||
|
@ -80,8 +81,12 @@ CONFIGURE_ARGS+= --enable-gui
|
|||
.endif
|
||||
|
||||
.if defined(WITH_DVD)
|
||||
.if !defined(WITH_LIBDVDREAD)
|
||||
LIB_DEPENDS+= dvdcss.2:${PORTSDIR}/graphics/libdvdcss
|
||||
.else
|
||||
LIB_DEPENDS+= dvdread.2:${PORTSDIR}/graphics/libdvdread
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SVGALIB)
|
||||
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
|
||||
|
@ -156,6 +161,10 @@ pre-everything::
|
|||
.if !defined(WITH_DVD)
|
||||
@${ECHO_MSG} "You can enable DVD support by defining WITH_DVD."
|
||||
.endif
|
||||
.if defined(WITH_DVD) && !defined(WITH_LIBDVDREAD)
|
||||
@${ECHO_MSG} "You can replace mplayer internal DVD routines with libdvdread"
|
||||
@${ECHO_MSG} "support by defining WITH_LIBDVDREAD."
|
||||
.endif
|
||||
.if !defined(WITH_SVGALIB)
|
||||
@${ECHO_MSG} "You can enable SVGALIB support by defining WITH_SVGALIB."
|
||||
.endif
|
||||
|
@ -195,7 +204,9 @@ pre-everything::
|
|||
.endif # ARCH == i386
|
||||
|
||||
pre-configure:
|
||||
.if defined(WITH_LIBDVDREAD)
|
||||
@${RM} -Rf ${WRKSRC}/libmpdvdkit/
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${DATADIR}
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- configure.orig Mon May 13 22:52:10 2002
|
||||
+++ configure Tue May 21 08:56:42 2002
|
||||
+++ configure Tue Jun 4 23:08:36 2002
|
||||
@@ -450,19 +450,10 @@
|
||||
|
||||
# Try to find the available options for the current CPU
|
||||
|
@ -67,7 +67,37 @@
|
|||
echores "yes (using $_ld_pthread)"
|
||||
|
||||
|
||||
@@ -3570,7 +3531,7 @@
|
||||
@@ -3064,11 +3025,7 @@
|
||||
|
||||
echocheck "iconv"
|
||||
if test "$_iconv" = auto ; then
|
||||
- if freebsd ; then
|
||||
- _iconv_tmp='#include <giconv.h>'
|
||||
- else
|
||||
_iconv_tmp='#include <iconv.h>'
|
||||
- fi
|
||||
cat > $TMPC << EOF
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
@@ -3102,7 +3059,7 @@
|
||||
EOF
|
||||
_iconv=no
|
||||
if freebsd ; then
|
||||
- cc_check -lm -lgiconv && _iconv=yes
|
||||
+ cc_check -lm -liconv && _iconv=yes
|
||||
elif bsdos ; then
|
||||
cc_check -lm -liconv && _iconv=yes
|
||||
else
|
||||
@@ -3111,7 +3068,7 @@
|
||||
fi
|
||||
if test "$_iconv" = yes ; then
|
||||
_def_iconv='#define USE_ICONV 1'
|
||||
- freebsd && _ld_iconv='-lgiconv'
|
||||
+ freebsd && _ld_iconv='-liconv'
|
||||
bsdos && _ld_iconv='-liconv'
|
||||
else
|
||||
_def_iconv='#undef USE_ICONV'
|
||||
@@ -3570,7 +3527,7 @@
|
||||
CFLAGS="$CFLAGS -D_REENTRANT"
|
||||
elif bsd ; then
|
||||
# FIXME bsd needs this so maybe other OS'es
|
||||
|
|
14
multimedia/mplayerxp/files/patch-mplayer:subreader.c
Normal file
14
multimedia/mplayerxp/files/patch-mplayer:subreader.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- subreader.c.orig Mon May 13 22:41:20 2002
|
||||
+++ subreader.c Tue Jun 4 22:54:33 2002
|
||||
@@ -18,11 +18,7 @@
|
||||
#define ERR ((void *) -1)
|
||||
|
||||
#ifdef USE_ICONV
|
||||
-#ifdef __FreeBSD__
|
||||
-#include <giconv.h>
|
||||
-#else
|
||||
#include <iconv.h>
|
||||
-#endif
|
||||
char *sub_cp=NULL;
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue