add p5-Shout

Perl glue for libshout MP3 streaming source library

PR:		26677
Submitted by:	Leo Kim <leo@florida.sarang.net>
This commit is contained in:
Ying-Chieh Liao 2001-05-24 12:24:51 +00:00
parent c53060edcd
commit 1303808006
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=43008
7 changed files with 67 additions and 0 deletions

26
audio/p5-Shout/Makefile Normal file
View file

@ -0,0 +1,26 @@
# New ports collection makefile for: Shout
# Date created: 18 April 2001
# Whom: leo
#
# $FreeBSD$
#
PORTNAME= Shout
PORTVERSION= 0.99
CATEGORIES= audio perl5
MASTER_SITES= http://developer.icecast.org/libshout/releases/
PKGNAMEPREFIX= p5-
MAINTAINER= leo@florida.sarang.net
LIB_DEPENDS= shout.1:${PORTSDIR}/audio/libshout
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Shout.3
pre-configure:
@(cd ${WRKSRC} && ${RM} example.pl example2.pl)
.include <bsd.port.mk>

1
audio/p5-Shout/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (Shout-0.99.tar.gz) = a4cbf46d1107a54fff61d457ac46dd35

View file

@ -0,0 +1,13 @@
--- Makefile.PL.orig Wed Apr 18 13:29:39 2001
+++ Makefile.PL Wed Apr 18 13:31:05 2001
@@ -4,8 +4,8 @@
WriteMakefile(
'NAME' => 'Shout',
'VERSION_FROM' => 'Shout.pm', # finds $VERSION
- 'LIBS' => ['-lshout'], # e.g., '-lm'
+ 'LIBS' => ['-L/usr/local/lib -lshout'], # e.g., '-lm'
'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
- 'INC' => '', # e.g., '-I/usr/include/other'
+ 'INC' => '-I/usr/local/include', # e.g., '-I/usr/include/other'
'MYEXTLIB' => ''
);

View file

@ -0,0 +1,10 @@
--- MANIFEST.orig Wed Apr 18 13:58:36 2001
+++ MANIFEST Wed Apr 18 13:58:43 2001
@@ -3,7 +3,5 @@
Makefile.PL
Shout.pm
Shout.xs
-example.pl
-example2.pl
test.pl
typemap

View file

@ -0,0 +1 @@
Perl glue for libshout MP3 streaming source library

10
audio/p5-Shout/pkg-descr Normal file
View file

@ -0,0 +1,10 @@
This module is an object-oriented interface to libshout, an MP3 streaming
library that allows applications to easily communicate and broadcast to an
Icecast streaming media server. It handles the socket connections, metadata
communication, and data streaming for the calling application, and lets
developers focus on feature sets instead of implementation details.
WWW: http://developer.icecast.org/libshout/
- Leo
leo@florida.sarang.net

6
audio/p5-Shout/pkg-plist Normal file
View file

@ -0,0 +1,6 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Shout.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shout/.packlist
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shout/Shout.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shout/Shout.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shout/autosplit.ix
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shout