Argh. So, the update notifier was wrong, and 0.2 is not a new release

(of course), but I was fooled because there's a separate project called
libssh which *did* just have a new release. 1.0 is the real update.

Pointed out by: J. Johnston
This commit is contained in:
David Thiel 2009-02-02 01:34:45 +00:00
parent a760ac7bca
commit 1319a93963
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=227415
3 changed files with 43 additions and 17 deletions

View file

@ -6,8 +6,8 @@
#
PORTNAME= libssh2
PORTVERSION= 0.2
PORTEPOCH= 1
PORTVERSION= 1.0
PORTEPOCH= 2
CATEGORIES= security devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -20,7 +20,44 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
PLIST_FILES= include/libssh2.h \
lib/libssh2.so.0
include/libssh2_publickey.h \
include/libssh2_sftp.h \
lib/libssh2.so \
lib/libssh2.so.1 \
lib/libssh2.la \
lib/libssh2.a
MAN3= libssh2_banner_set.3 libssh2_channel_close.3 \
libssh2_channel_direct_tcpip_ex.3 libssh2_channel_eof.3 \
libssh2_channel_flush_ex.3 libssh2_channel_forward_accept.3 \
libssh2_channel_forward_cancel.3 libssh2_channel_forward_listen_ex.3 \
libssh2_channel_free.3 libssh2_channel_get_exit_status.3 \
libssh2_channel_handle_extended_data.3 \
libssh2_channel_handle_extended_data2.3 libssh2_channel_open_ex.3 \
libssh2_channel_process_startup.3 libssh2_channel_read_ex.3 \
libssh2_channel_request_pty_ex.3 libssh2_channel_send_eof.3 \
libssh2_channel_set_blocking.3 libssh2_channel_setenv_ex.3 \
libssh2_channel_wait_eof.3 libssh2_channel_x11_req_ex.3 \
libssh2_hostkey_hash.3 libssh2_scp_recv.3 libssh2_scp_send_ex.3 \
libssh2_session_abstract.3 libssh2_session_free.3 \
libssh2_session_callback_set.3 libssh2_session_disconnect_ex.3 \
libssh2_session_init.3 libssh2_session_last_errno.3 \
libssh2_session_last_error.3 libssh2_session_method_pref.3 \
libssh2_session_methods.3 libssh2_session_set_blocking.3 \
libssh2_session_startup.3 libssh2_poll.3 libssh2_poll_channel_read.3 \
libssh2_sftp_close_handle.3 libssh2_sftp_fstat_ex.3 \
libssh2_sftp_last_error.3 libssh2_sftp_init.3 libssh2_sftp_open_ex.3 \
libssh2_sftp_mkdir_ex.3 libssh2_sftp_read.3 libssh2_sftp_readdir.3 \
libssh2_sftp_rename_ex.3 libssh2_sftp_rmdir_ex.3 libssh2_sftp_seek.3 \
libssh2_sftp_shutdown.3 libssh2_sftp_stat_ex.3 \
libssh2_sftp_symlink_ex.3 libssh2_sftp_tell.3 \
libssh2_sftp_unlink_ex.3 libssh2_sftp_write.3 \
libssh2_userauth_authenticated.3 libssh2_userauth_list.3 \
libssh2_userauth_password_ex.3 libssh2_userauth_publickey_fromfile.3 \
libssh2_channel_wait_closed.3 libssh2_channel_write_ex.3 \
libssh2_session_block_directions.3 libssh2_trace.3 \
libssh2_sftp_tell64.3 libssh2_userauth_keyboard_interactive_ex.3 \
libssh2_base64_decode.3
post-patch:
@${REINPLACE_CMD} -e '/ssh2_sample\.o/d' ${WRKSRC}/Makefile.in

View file

@ -1,3 +1,3 @@
MD5 (libssh2-0.2.tar.gz) = 4ea730be18efcbff79265c68f976dca2
SHA256 (libssh2-0.2.tar.gz) = 07d1408b863a1d4db68bafc39c725c22c8229b9ddba6a92fa579b44841267939
SIZE (libssh2-0.2.tar.gz) = 78016
MD5 (libssh2-1.0.tar.gz) = c3602adae912702ba9cbefbe813b7b5b
SHA256 (libssh2-1.0.tar.gz) = 2601c58bee8126b0a2adf1596010fc042abe0f2a8f446c6f7cfedf71e3d90e62
SIZE (libssh2-1.0.tar.gz) = 565414

View file

@ -1,11 +0,0 @@
--- include/libssh2_priv.h.orig 2009-01-31 11:23:49.000000000 -0800
+++ include/libssh2_priv.h 2009-01-31 11:24:00.000000000 -0800
@@ -44,6 +44,8 @@
#include <sys/socket.h>
#include <openssl/evp.h>
+#include <openssl/md5.h>
+#include <openssl/sha.h>
#define LIBSSH2_ALLOC(session, count) session->alloc((count), &(session)->abstract)
#define LIBSSH2_REALLOC(session, ptr, count) session->realloc((ptr), (count), &(session)->abstract)