Add gnugadu 2.0 pre5 after repocopy from polish/gnugadu.

This is Gtk2 version of gnugadu.

PR:		ports/61242
Submitted by:	Piotr Smyrak <piotr.smyrak@heron.pl>
This commit is contained in:
Pav Lucistnik 2004-01-15 23:48:07 +00:00
parent e04c5951e1
commit 132dd06182
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=98239
10 changed files with 488 additions and 159 deletions

View file

@ -5,6 +5,7 @@
SUBDIR += aspell
SUBDIR += ekg
SUBDIR += gnugadu
SUBDIR += gnugadu2
SUBDIR += ispell
SUBDIR += kadu
SUBDIR += kde3-i18n

View file

@ -1,57 +1,150 @@
# Ports collection makefile for: gnugadu
# Date created: 23 dec 2001
# Whom: doc@lublin.t1.pl
# Ports collection makefile for: gnugadu2
# Date created: 12 january 2004
# Whom: smyru@heron.pl
#
# $FreeBSD$
#
PORTNAME= gnugadu
PORTVERSION= 1.0.0
PORTNAME= gnugadu2
PORTVERSION= 2.0.p5
CATEGORIES= polish net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ggadu
DISTNAME= gg-${PORTVERSION}
DISTNAME= gg2-${PORTVERSION:S/.p5/pre5/}
MAINTAINER= dotz@irc.pl
COMMENT= A GaduGadu client for X11/GTK
MAINTAINER= smyru@heron.pl
COMMENT= GTK2 based Gadu-Gadu client for X11
LIB_DEPENDS= gadu.3:${PORTSDIR}/polish/ekg
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= gtk12
USE_GNOME= gtk20
USE_LIBTOOL= yes
USE_REINPLACE= yes
USE_SUBMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
WANT_GNOME= yes
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
IS_INTERACTIVE= yes
CONFIGURE_ARGS= --with-gui \
--with-gadu \
--with-sms \
--with-external \
--with-update
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
.if (${HAVE_GNOME:Mesound}!="")
WITH_ESOUND= yes
.endif
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
MKDIR="${MKDIR}" \
CAT="${CAT}" \
GNUGADU_OPTIONS="${GNUGADU_OPTIONS}" \
REALCURDIR="${.CURDIR}"
.if defined(WITH_DOCKLET)
CONFIGURE_ARGS+= --with-docklet_system_tray
PLIST_SUB+= DOCKLET:=""
.else
CONFIGURE_ARGS+= --without-docklet_system_tray
PLIST_SUB+= DOCKLET:="@comment "
.endif
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.gg
.if defined(WITH_DOCKAPP)
CONFIGURE_ARGS+= --with-docklet_dockapp
PLIST_SUB+= DOCKAPP:=""
.else
CONFIGURE_ARGS+= --without-docklet_dockapp
PLIST_SUB+= DOCKAPP:="@comment "
.endif
.if defined(WITH_TLEN)
CONFIGURE_ARGS+= --with-tlen
LIB_DEPENDS+= tlen.1:${PORTSDIR}/polish/libtlen
PLIST_SUB+= TLEN:=""
.else
CONFIGURE_ARGS+= --without-tlen
PLIST_SUB+= TLEN:="@comment "
.endif
.if defined(WITH_JABBER)
CONFIGURE_ARGS+= --with-jabber
LIB_DEPENDS+= loudmouth.0:${PORTSDIR}/net/loudmouth
PLIST_SUB+= JABBER:=""
.else
CONFIGURE_ARGS+= --without-jabber
PLIST_SUB+= JABBER:="@comment "
.endif
.if defined(WITH_ESOUND)
CONFIGURE_ARGS+= --with-esd
PKGNAMESUFFIX= -esound
USE_GNOME+= esound
PLIST_SUB+= ESOUND:=""
.else
CONFIGURE_ARGS+= --without-esd
PLIST_SUB+= ESOUND:="@comment "
.endif
.if defined(WITH_ARTS)
CONFIGURE_ARGS+= --with-arts
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
PLIST_SUB+= ARTS:=""
.else
CONFIGURE_ARGS+= --without-arts
PLIST_SUB+= ARTS:="@comment "
.endif
.if defined(WITH_OSS)
CONFIGURE_ARGS+= --with-oss
PLIST_SUB+= OSS:=""
.else
PLIST_SUB+= OSS:="@comment "
.endif
.if defined(WITH_XOSD)
CONFIGURE_ARGS+= --with-xosd
LIB_DEPENDS+= xosd.4:${PORTSDIR}/misc/xosd
PLIST_SUB+= XOSD:=""
.else
CONFIGURE_ARGS+= --without-xosd
PLIST_SUB+= XOSD:="@comment "
.endif
.if (${HAVE_GNOME:Mgnomehier}!="")
PLIST_SUB+= GNOME:=""
.else
PLIST_SUB+= GNOME:="@comment "
.endif
.if exists(${LOCALBASE}/lib/libkdecore.so)
PLIST_SUB+= KDE:=""
.else
PLIST_SUB+= KDE:="@comment "
.endif
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} " You can define following build options:"
@${ECHO_MSG}
@${ECHO_MSG} " WITH_TLEN to enable Tlen.pl network plugin"
@${ECHO_MSG} " WITH_JABBER to enable Jabber loudmouth plugin"
@${ECHO_MSG} " WITH_XOSD to enable On-Screen-Display messages"
@${ECHO_MSG} " WITH_DOCKLET to enable freedesktop.org docklet plugin"
@${ECHO_MSG} " WITH_DOCKAPP to enable WindowMaker dockapp plugin"
@${ECHO_MSG} " WITH_OSS to build with sound via OSS"
@${ECHO_MSG} " WITH_ARTS to build with aRts sound server"
@${ECHO_MSG} " WITH_ESOUND to build with esound sound server"
@${ECHO_MSG}
post-patch:
@${REINPLACE_CMD} -e 's,GTK_ CFLAGS,GTK_CFLAGS,' \
-e 's,CFLAGS =, CFLAGS += @GTK_CFLAGS@ ${PTHREAD_CFLAGS},' \
-e 's,@GTK_LIBS@,@GTK_LIBS@ ${PTHREAD_LIBS},'\
${WRKSRC}/Makefile.in \
${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e 's,-O2,,' -e 's,gtk-config,${GTK_CONFIG},' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/gg2.desktop
post-install:
${STRIP_CMD} ${PREFIX}/bin/gg
post-clean:
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.if (${HAVE_GNOME:Mgnomehier}!="")
${INSTALL_DATA} ${WRKSRC}/gg2.desktop ${X11BASE}/share/gnome/apps/Internet
.endif
.if exists(${LOCALBASE}/lib/libkdecore.so)
${INSTALL_DATA} ${WRKSRC}/gg2.desktop ${LOCALBASE}/share/applnk/Internet
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1 +1 @@
MD5 (gg-1.0.0.tar.gz) = 7b32d4c866ef59dfe22373a83b1a9a2a
MD5 (gg2-2.0pre5.tar.bz2) = 0e24e1420d3b85822b871af953e12df6

View file

@ -0,0 +1,19 @@
--- configure.orig Sun Dec 14 21:35:41 2003
+++ configure Sun Dec 14 21:39:11 2003
@@ -19127,6 +19127,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -24937,7 +24938,7 @@
fi
else
cat >>confdefs.h <<_ACEOF
-#define PACKAGE_LOCALE_DIR "${datadir}/locale"
+#define PACKAGE_LOCALE_DIR "${prefix}/share/locale"
_ACEOF
fi

View file

@ -0,0 +1,16 @@
--- gg2.desktop.orig Sat Dec 13 15:43:17 2003
+++ gg2.desktop Mon Jan 12 13:01:30 2004
@@ -3,10 +3,10 @@
Encoding=UTF-8
Name=GNU Gadu
Comment=Instant Messanger Client
-Comment[pl]=Wolne Gadanie
+Comment[pl]=Free-wolne Gadanie
Exec=gg2
-Icon=gg2.png
+Icon=/usr/X11R6/share/gg2/pixmaps/icon.png
Terminal=false
Type=Application
-Categories=GTK;Application;Network;InstantMessaging;
+Categories=Application;Network;
# vi: encoding=utf-8

View file

@ -0,0 +1,11 @@
--- lib/Makefile.in.orig Sun Dec 14 21:27:52 2003
+++ lib/Makefile.in Sun Dec 14 21:28:26 2003
@@ -252,7 +252,7 @@
libgg2_core_la_HEADERS = gg2_core.h
-libgg2_core_la_LIBADD = $(PERL_OPTION_LDFLAGS) -ldl
+libgg2_core_la_LIBADD = $(PERL_OPTION_LDFLAGS)
libgg2_core_la_LDFLAGS = -version-info 2:0:0
pkgconfigdir = $(libdir)/pkgconfig

View file

@ -0,0 +1,11 @@
--- po/Makefile.in.in.orig Sun Dec 14 21:44:41 2003
+++ po/Makefile.in.in Sun Dec 14 21:45:44 2003
@@ -27,7 +27,7 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
datadir = $(prefix)/@DATADIRNAME@
-localedir = $(datadir)/locale
+localedir = $(prefix)/share/locale
gnulocaledir = $(prefix)/share/locale
gettextsrcdir = $(prefix)/share/glib-2.0/gettext/po
subdir = po

View file

@ -1,4 +1,9 @@
A GaduGadu client for X11/GTK. GaduGadu is an ICQ-like messenger for the
Polish language.
Development GTK2 based version of GaduGadu client for X11/GTK.
GaduGadu is an ICQ-like messenger network for the Polish language.
WWW: http://ggadu.sourceforge.net/
GnuGadu2 is a complete rewrite featuring a plugin extensible
architecture, that opens it to the multiprotocol world. Transport
plugins exist for Jabber, Tlen.pl, there are sound servers and
others.
WWW: http://gadu.gnu.pl

View file

@ -1,42 +1,292 @@
bin/gg
share/gg/pixmaps/arrow.xpm
share/gg/pixmaps/away-descr.xpm
share/gg/pixmaps/away-mobile-descr.xpm
share/gg/pixmaps/away-mobile.xpm
share/gg/pixmaps/away.xpm
share/gg/pixmaps/cell.xpm
share/gg/pixmaps/cellphone.xpm
share/gg/pixmaps/chat.xpm
share/gg/pixmaps/config.xpm
share/gg/pixmaps/empty.xpm
share/gg/pixmaps/gg-logo.xpm
share/gg/pixmaps/gg.xpm
share/gg/pixmaps/go-chat.xpm
share/gg/pixmaps/go-msg.xpm
share/gg/pixmaps/ignored.xpm
share/gg/pixmaps/invisible-descr.xpm
share/gg/pixmaps/invisible.xpm
share/gg/pixmaps/malehead.xpm
share/gg/pixmaps/mobile.xpm
share/gg/pixmaps/msg.xpm
share/gg/pixmaps/new-msg.xpm
share/gg/pixmaps/offline-descr.xpm
share/gg/pixmaps/offline-mobile-descr.xpm
share/gg/pixmaps/offline-mobile.xpm
share/gg/pixmaps/offline.xpm
share/gg/pixmaps/online-descr.xpm
share/gg/pixmaps/online-mobile-descr.xpm
share/gg/pixmaps/online-mobile.xpm
share/gg/pixmaps/online.xpm
share/gg/pixmaps/online_connecting.xpm
share/gg/pixmaps/pubdir_info.xpm
share/gg/pixmaps/search.xpm
share/gg/pixmaps/search_unknown.xpm
share/gg/pixmaps/wmexit.xpm
share/gg/pixmaps/wmmsg.xpm
share/gg/sounds/msg.wav
share/gg/sounds/usr.wav
share/gg/sounds/yahoo.wav
@dirrm share/gg/sounds
@dirrm share/gg/pixmaps
@dirrm share/gg
bin/gg2
include/gg2_core.h
lib/gg2/libGUI_plugin.so
%%DOCKAPP:%%lib/gg2/libdocklet_dockapp_plugin.so
%%DOCKLET:%%lib/gg2/libdocklet_system_tray_plugin.so
lib/gg2/libgadu_gadu_plugin.so
%%JABBER:%%lib/gg2/libjabber_plugin.so
lib/gg2/libsms_plugin.so
%%ARTS:%%lib/gg2/libsound_arts_plugin.so
%%ESOUND:%%lib/gg2/libsound_esd_plugin.so
lib/gg2/libsound_external_plugin.so
%%OSS:%%lib/gg2/libsound_oss_plugin.so
%%TLEN:%%lib/gg2/libtlen_plugin.so
lib/gg2/libupdate_plugin.so
%%XOSD:%%lib/gg2/libxosd_plugin.so
lib/libgg2_core.a
lib/libgg2_core.so
lib/libgg2_core.so.2
lib/pkgconfig/gg2_core.pc
%%KDE:%%%%LOCALBASE%%share/applnk/Internet/gg2.desktop
share/gg2/pixmaps/arrow.png
share/gg2/pixmaps/away.png
share/gg2/pixmaps/emoticon.gif
share/gg2/pixmaps/emoticons/3m_sie.gif
share/gg2/pixmaps/emoticons/8P.gif
share/gg2/pixmaps/emoticons/aniolek.gif
share/gg2/pixmaps/emoticons/beksa.gif
share/gg2/pixmaps/emoticons/bije.gif
share/gg2/pixmaps/emoticons/boje_sie.gif
share/gg2/pixmaps/emoticons/boks.gif
share/gg2/pixmaps/emoticons/brawa.gif
share/gg2/pixmaps/emoticons/buja_w_oblokach.gif
share/gg2/pixmaps/emoticons/bukiet.gif
share/gg2/pixmaps/emoticons/calus.gif
share/gg2/pixmaps/emoticons/cfaniak.gif
share/gg2/pixmaps/emoticons/chatownik.gif
share/gg2/pixmaps/emoticons/chytry.gif
share/gg2/pixmaps/emoticons/cisza.gif
share/gg2/pixmaps/emoticons/cmok.gif
share/gg2/pixmaps/emoticons/co.gif
share/gg2/pixmaps/emoticons/co_jest.gif
share/gg2/pixmaps/emoticons/czarodziej.gif
share/gg2/pixmaps/emoticons/czas.gif
share/gg2/pixmaps/emoticons/czytaj.gif
share/gg2/pixmaps/emoticons/diabelek.gif
share/gg2/pixmaps/emoticons/dobani.gif
share/gg2/pixmaps/emoticons/dostal.gif
share/gg2/pixmaps/emoticons/dresiarz.gif
share/gg2/pixmaps/emoticons/drink.gif
share/gg2/pixmaps/emoticons/dupa.gif
share/gg2/pixmaps/emoticons/emoticons.def
share/gg2/pixmaps/emoticons/faja.gif
share/gg2/pixmaps/emoticons/fuck.gif
share/gg2/pixmaps/emoticons/gafa.gif
share/gg2/pixmaps/emoticons/ganja.gif
share/gg2/pixmaps/emoticons/gazeta.gif
share/gg2/pixmaps/emoticons/glaszcze.gif
share/gg2/pixmaps/emoticons/glupek.gif
share/gg2/pixmaps/emoticons/glupek2.gif
share/gg2/pixmaps/emoticons/gool.gif
share/gg2/pixmaps/emoticons/gra.gif
share/gg2/pixmaps/emoticons/hahaha.gif
share/gg2/pixmaps/emoticons/heej.gif
share/gg2/pixmaps/emoticons/hmmm.gif
share/gg2/pixmaps/emoticons/jablko.gif
share/gg2/pixmaps/emoticons/je_pizze.gif
share/gg2/pixmaps/emoticons/jem.gif
share/gg2/pixmaps/emoticons/jezyk1.gif
share/gg2/pixmaps/emoticons/jezyk2.gif
share/gg2/pixmaps/emoticons/jupi.gif
share/gg2/pixmaps/emoticons/kawa.gif
share/gg2/pixmaps/emoticons/killer.gif
share/gg2/pixmaps/emoticons/klotnia.gif
share/gg2/pixmaps/emoticons/krecka_dostal.gif
share/gg2/pixmaps/emoticons/krzywy.gif
share/gg2/pixmaps/emoticons/kwasny.gif
share/gg2/pixmaps/emoticons/kwiatek.gif
share/gg2/pixmaps/emoticons/list.gif
share/gg2/pixmaps/emoticons/lol.gif
share/gg2/pixmaps/emoticons/menu.gif
share/gg2/pixmaps/emoticons/milosc.gif
share/gg2/pixmaps/emoticons/mruga.gif
share/gg2/pixmaps/emoticons/mutny.gif
share/gg2/pixmaps/emoticons/nauka.gif
share/gg2/pixmaps/emoticons/nie.gif
share/gg2/pixmaps/emoticons/nie_powiem.gif
share/gg2/pixmaps/emoticons/niee.gif
share/gg2/pixmaps/emoticons/nonono.gif
share/gg2/pixmaps/emoticons/obiad.gif
share/gg2/pixmaps/emoticons/oczko.gif
share/gg2/pixmaps/emoticons/oczko2.gif
share/gg2/pixmaps/emoticons/oczy.gif
share/gg2/pixmaps/emoticons/ok.gif
share/gg2/pixmaps/emoticons/ok2.gif
share/gg2/pixmaps/emoticons/okularnik.gif
share/gg2/pixmaps/emoticons/olaboga.gif
share/gg2/pixmaps/emoticons/onajego.gif
share/gg2/pixmaps/emoticons/pada.gif
share/gg2/pixmaps/emoticons/paker.gif
share/gg2/pixmaps/emoticons/palacz.gif
share/gg2/pixmaps/emoticons/papa.gif
share/gg2/pixmaps/emoticons/peace.gif
share/gg2/pixmaps/emoticons/pisze.gif
share/gg2/pixmaps/emoticons/piwko2.gif
share/gg2/pixmaps/emoticons/piwo.gif
share/gg2/pixmaps/emoticons/placze.gif
share/gg2/pixmaps/emoticons/pomocy.gif
share/gg2/pixmaps/emoticons/prezent.gif
share/gg2/pixmaps/emoticons/prysznic.gif
share/gg2/pixmaps/emoticons/przytul.gif
share/gg2/pixmaps/emoticons/puknijsie.gif
share/gg2/pixmaps/emoticons/pytajnik.gif
share/gg2/pixmaps/emoticons/rotfl.gif
share/gg2/pixmaps/emoticons/roza.gif
share/gg2/pixmaps/emoticons/sciana.gif
share/gg2/pixmaps/emoticons/serce.gif
share/gg2/pixmaps/emoticons/serducho.gif
share/gg2/pixmaps/emoticons/serduszka.gif
share/gg2/pixmaps/emoticons/serduszka2.gif
share/gg2/pixmaps/emoticons/sex.gif
share/gg2/pixmaps/emoticons/slonko.gif
share/gg2/pixmaps/emoticons/smutny.gif
share/gg2/pixmaps/emoticons/snieg.gif
share/gg2/pixmaps/emoticons/soczek.gif
share/gg2/pixmaps/emoticons/spie.gif
share/gg2/pixmaps/emoticons/spioch.gif
share/gg2/pixmaps/emoticons/spoko.gif
share/gg2/pixmaps/emoticons/stop.gif
share/gg2/pixmaps/emoticons/szampan.gif
share/gg2/pixmaps/emoticons/tancze.gif
share/gg2/pixmaps/emoticons/telefon.gif
share/gg2/pixmaps/emoticons/tiaaa.gif
share/gg2/pixmaps/emoticons/tort.gif
share/gg2/pixmaps/emoticons/tuptup.gif
share/gg2/pixmaps/emoticons/uczen.gif
share/gg2/pixmaps/emoticons/uscisk.gif
share/gg2/pixmaps/emoticons/usmiech.gif
share/gg2/pixmaps/emoticons/usmiech2.gif
share/gg2/pixmaps/emoticons/usta.gif
share/gg2/pixmaps/emoticons/wanna.gif
share/gg2/pixmaps/emoticons/wc.gif
share/gg2/pixmaps/emoticons/wesoly.gif
share/gg2/pixmaps/emoticons/winko.gif
share/gg2/pixmaps/emoticons/wow.gif
share/gg2/pixmaps/emoticons/wow_na.gif
share/gg2/pixmaps/emoticons/wsciekly.gif
share/gg2/pixmaps/emoticons/wstydnis.gif
share/gg2/pixmaps/emoticons/wykrzyknik.gif
share/gg2/pixmaps/emoticons/ysz.gif
share/gg2/pixmaps/emoticons/z_jezorem.gif
share/gg2/pixmaps/emoticons/zab.gif
share/gg2/pixmaps/emoticons/zakochany.gif
share/gg2/pixmaps/emoticons/zawstydzony.gif
share/gg2/pixmaps/emoticons/zdziwko.gif
share/gg2/pixmaps/emoticons/zeby.gif
share/gg2/pixmaps/emoticons/zegar.gif
share/gg2/pixmaps/emoticons/ziew.gif
share/gg2/pixmaps/emoticons/zly.gif
share/gg2/pixmaps/emoticons/zniesmaczony.gif
share/gg2/pixmaps/emoticons/zygi.gif
share/gg2/pixmaps/gadu-gadu-away-descr.png
share/gg2/pixmaps/gadu-gadu-away.png
share/gg2/pixmaps/gadu-gadu-invisible-descr.png
share/gg2/pixmaps/gadu-gadu-invisible.png
share/gg2/pixmaps/gadu-gadu-offline-descr.png
share/gg2/pixmaps/gadu-gadu-offline.png
share/gg2/pixmaps/gadu-gadu-online-descr.png
share/gg2/pixmaps/gadu-gadu-online.png
share/gg2/pixmaps/gadu-gadu.png
share/gg2/pixmaps/gg-about.png
share/gg2/pixmaps/icon.png
share/gg2/pixmaps/icons/bubble/README
share/gg2/pixmaps/icons/bubble/gadu-gadu-away-descr.png
share/gg2/pixmaps/icons/bubble/gadu-gadu-away.png
share/gg2/pixmaps/icons/bubble/gadu-gadu-invisible-descr.png
share/gg2/pixmaps/icons/bubble/gadu-gadu-invisible.png
share/gg2/pixmaps/icons/bubble/gadu-gadu-offline-descr.png
share/gg2/pixmaps/icons/bubble/gadu-gadu-offline.png
share/gg2/pixmaps/icons/bubble/gadu-gadu-online-descr.png
share/gg2/pixmaps/icons/bubble/gadu-gadu-online.png
share/gg2/pixmaps/icons/bubble/icon.png
share/gg2/pixmaps/icons/classic/README
share/gg2/pixmaps/icons/classic/gadu-gadu-away-descr.png
share/gg2/pixmaps/icons/classic/gadu-gadu-away.png
share/gg2/pixmaps/icons/classic/gadu-gadu-invisible-descr.png
share/gg2/pixmaps/icons/classic/gadu-gadu-invisible.png
share/gg2/pixmaps/icons/classic/gadu-gadu-offline-descr.png
share/gg2/pixmaps/icons/classic/gadu-gadu-offline.png
share/gg2/pixmaps/icons/classic/gadu-gadu-online-descr.png
share/gg2/pixmaps/icons/classic/gadu-gadu-online.png
share/gg2/pixmaps/icons/classic/icon.png
share/gg2/pixmaps/icons/ghosts/README
share/gg2/pixmaps/icons/ghosts/gadu-gadu-away-descr.png
share/gg2/pixmaps/icons/ghosts/gadu-gadu-away.png
share/gg2/pixmaps/icons/ghosts/gadu-gadu-invisible-descr.png
share/gg2/pixmaps/icons/ghosts/gadu-gadu-invisible.png
share/gg2/pixmaps/icons/ghosts/gadu-gadu-offline-descr.png
share/gg2/pixmaps/icons/ghosts/gadu-gadu-offline.png
share/gg2/pixmaps/icons/ghosts/gadu-gadu-online-descr.png
share/gg2/pixmaps/icons/ghosts/gadu-gadu-online.png
share/gg2/pixmaps/icons/ghosts/icon.png
share/gg2/pixmaps/icons/modern/README
share/gg2/pixmaps/icons/modern/gadu-gadu-away-descr.png
share/gg2/pixmaps/icons/modern/gadu-gadu-away.png
share/gg2/pixmaps/icons/modern/gadu-gadu-invisible-descr.png
share/gg2/pixmaps/icons/modern/gadu-gadu-invisible.png
share/gg2/pixmaps/icons/modern/gadu-gadu-offline-descr.png
share/gg2/pixmaps/icons/modern/gadu-gadu-offline.png
share/gg2/pixmaps/icons/modern/gadu-gadu-online-descr.png
share/gg2/pixmaps/icons/modern/gadu-gadu-online.png
share/gg2/pixmaps/icons/modern/icon.png
share/gg2/pixmaps/icons/modern/tlen-away.png
share/gg2/pixmaps/icons/modern/tlen-beback.png
share/gg2/pixmaps/icons/modern/tlen-chat.png
share/gg2/pixmaps/icons/modern/tlen-invisible.png
share/gg2/pixmaps/icons/modern/tlen-occupied.png
share/gg2/pixmaps/icons/modern/tlen-offline.png
share/gg2/pixmaps/icons/modern/tlen-online.png
share/gg2/pixmaps/icons/rozgwiazda/gadu-gadu-away-descr.png
share/gg2/pixmaps/icons/rozgwiazda/gadu-gadu-away.png
share/gg2/pixmaps/icons/rozgwiazda/gadu-gadu-invisible-descr.png
share/gg2/pixmaps/icons/rozgwiazda/gadu-gadu-invisible.png
share/gg2/pixmaps/icons/rozgwiazda/gadu-gadu-offline-descr.png
share/gg2/pixmaps/icons/rozgwiazda/gadu-gadu-offline.png
share/gg2/pixmaps/icons/rozgwiazda/gadu-gadu-online-descr.png
share/gg2/pixmaps/icons/rozgwiazda/gadu-gadu-online.png
share/gg2/pixmaps/icons/rozgwiazda/gadu-gadu.png
share/gg2/pixmaps/icons/rozgwiazda/icon.png
share/gg2/pixmaps/icons/rozgwiazda/jabber.png
share/gg2/pixmaps/icons/rozgwiazda/license.txt
share/gg2/pixmaps/icons/rozgwiazda/sms.png
share/gg2/pixmaps/icons/rozgwiazda/tlen.png
share/gg2/pixmaps/icons/tlen-3d/README
share/gg2/pixmaps/icons/tlen-3d/tlen-away.png
share/gg2/pixmaps/icons/tlen-3d/tlen-beback.png
share/gg2/pixmaps/icons/tlen-3d/tlen-chat.png
share/gg2/pixmaps/icons/tlen-3d/tlen-invisible.png
share/gg2/pixmaps/icons/tlen-3d/tlen-occupied.png
share/gg2/pixmaps/icons/tlen-3d/tlen-offline.png
share/gg2/pixmaps/icons/tlen-3d/tlen-online.png
share/gg2/pixmaps/jabber-away.png
share/gg2/pixmaps/jabber-dnd.png
share/gg2/pixmaps/jabber-error.png
share/gg2/pixmaps/jabber-offline.png
share/gg2/pixmaps/jabber-online.png
share/gg2/pixmaps/jabber-xa.png
share/gg2/pixmaps/jabber.png
share/gg2/pixmaps/new-msg.png
share/gg2/pixmaps/offline.png
share/gg2/pixmaps/online.png
share/gg2/pixmaps/show-hide-inactive.png
share/gg2/pixmaps/sms.png
share/gg2/pixmaps/sms_i.png
share/gg2/pixmaps/tlen-away.png
share/gg2/pixmaps/tlen-beback.png
share/gg2/pixmaps/tlen-chat.png
share/gg2/pixmaps/tlen-desc.png
share/gg2/pixmaps/tlen-invisible.png
share/gg2/pixmaps/tlen-occupied.png
share/gg2/pixmaps/tlen-offline.png
share/gg2/pixmaps/tlen-online.png
share/gg2/pixmaps/tlen.png
share/gg2/sounds/msg.wav
share/gg2/sounds/usr.wav
share/gg2/sounds/yahoo.wav
share/gg2/themes/blue2.theme
share/gg2/themes/darkblue.theme
share/gg2/themes/default.theme
share/gg2/themes/gray2.theme
share/gg2/themes/green2.theme
share/gg2/themes/lightblue.theme
share/gg2/themes/red2.theme
share/gg2/themes/thinice.theme
share/gg2/themes/vblue2.theme
share/gg2/themes/vgreen2.theme
share/gg2/themes/vred2.theme
share/gg2/themes/white2.theme
%%GNOME:%%share/gnome/apps/Internet/gg2.desktop
share/locale/pl/LC_MESSAGES/gg2.mo
@dirrm share/gg2/themes
@dirrm share/gg2/sounds
@dirrm share/gg2/pixmaps/icons/tlen-3d
@dirrm share/gg2/pixmaps/icons/rozgwiazda
@dirrm share/gg2/pixmaps/icons/modern
@dirrm share/gg2/pixmaps/icons/ghosts
@dirrm share/gg2/pixmaps/icons/classic
@dirrm share/gg2/pixmaps/icons/bubble
@dirrm share/gg2/pixmaps/icons
@dirrm share/gg2/pixmaps/emoticons
@dirrm share/gg2/pixmaps
@dirrm share/gg2
@dirrm lib/gg2

View file

@ -1,77 +0,0 @@
#!/bin/sh
# $FreeBSD$
if [ -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc ]; then
exit
fi
tempfile=`/usr/bin/mktemp -t checklist`
if [ "${BATCH}" ]; then
if [ "${GNUGADU_OPTIONS}" ]; then
set ${GNUGADU_OPTIONS}
else
set \"esd\"
fi
else
/usr/bin/dialog --title "gnugadu configuration options" --clear \
--checklist "\n\
Please select desired options:" -1 -1 16 \
esd "esd support" ON \
arts "arts support" OFF \
gnome "GNOME support" OFF \
panel "GNOME applet support" OFF \
2> $tempfile
retval=$?
if [ -s $tempfile ]; then
set `cat $tempfile`
fi
rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then
echo "Nothing selected"
fi
;;
1) echo "Cancel pressed."
exit 1
;;
esac
fi
${MKDIR} ${WRKDIRPREFIX}${REALCURDIR}
exec > ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
while [ "$1" ]; do
case $1 in
\"esd\")
echo "USE_GNOME+= esound"
echo "CONFIGURE_ARGS+= --enable-esd"
esd="yes"
;;
\"arts\")
echo "CONFIGURE_ARGS+= --enable-arts"
echo "LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts"
;;
\"gnome\")
echo "USE_GNOME+= gnomelibs"
echo "CONFIGURE_ARGS+= --enable-gnome"
;;
\"panel\")
echo "USE_GNOME+= gnomepanel"
echo "CONFIGURE_ARGS+= --enable-panel"
;;
*)
echo "Invalid option(s): $1" >&2
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
exit 1
;;
esac
shift
done
if [ -z "${esd}" ]; then
echo "CONFIGURE_ARGS+= --disable-esd --without-esd"
fi