Fix build on -CURRENT.

This commit is contained in:
Joe Marcus Clarke 2002-06-16 19:03:10 +00:00
parent b6e54fb48a
commit 1350c19569
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61387
4 changed files with 40 additions and 2 deletions

View file

@ -41,6 +41,14 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= galeon.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500000
# Galeon does not build correctly in -CURRENT if -Werror is passed
# to the compiler.
CONFIGURE_ARGS+= --disable-werror
.endif
post-extract:
.if !defined(WITH_FULL_MOZILLA)
@${ECHO_MSG}
@ -69,4 +77,4 @@ post-configure:
pre-install:
@-${X11BASE}/bin/gconftool --shutdown
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -0,0 +1,11 @@
--- src/mozilla/TOCProtocolHandler.cpp.orig Sun Jun 16 14:02:36 2002
+++ src/mozilla/TOCProtocolHandler.cpp Sun Jun 16 14:11:48 2002
@@ -400,7 +400,7 @@
nsresult rv;
struct dirent **namelist;
- int n = scandir (SHARE_DIR"/../gnome/help", &namelist, select,
+ int n = scandir (SHARE_DIR"/../gnome/help", &namelist, ((int(*)(struct dirent *))select),
alphasort);
if (n<0) return NS_ERROR_FAILURE;

View file

@ -41,6 +41,14 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= galeon.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500000
# Galeon does not build correctly in -CURRENT if -Werror is passed
# to the compiler.
CONFIGURE_ARGS+= --disable-werror
.endif
post-extract:
.if !defined(WITH_FULL_MOZILLA)
@${ECHO_MSG}
@ -69,4 +77,4 @@ post-configure:
pre-install:
@-${X11BASE}/bin/gconftool --shutdown
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -0,0 +1,11 @@
--- src/mozilla/TOCProtocolHandler.cpp.orig Sun Jun 16 14:02:36 2002
+++ src/mozilla/TOCProtocolHandler.cpp Sun Jun 16 14:11:48 2002
@@ -400,7 +400,7 @@
nsresult rv;
struct dirent **namelist;
- int n = scandir (SHARE_DIR"/../gnome/help", &namelist, select,
+ int n = scandir (SHARE_DIR"/../gnome/help", &namelist, ((int(*)(struct dirent *))select),
alphasort);
if (n<0) return NS_ERROR_FAILURE;