Port for licq 1.1.0 devel 2002-01-28 snapshot (repo-copied from `licq' port).
Most important new feature is ICQv8 support (works for me). `licq-qt-gui' and `licq-console' ports will be altered soon to add ability to build with this port instead of `licq'.
This commit is contained in:
parent
027909387b
commit
13518aacca
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=54313
7 changed files with 65 additions and 43 deletions
|
@ -216,6 +216,7 @@
|
|||
SUBDIR += libunpipc
|
||||
SUBDIR += licq
|
||||
SUBDIR += licq-console
|
||||
SUBDIR += licq-devel
|
||||
SUBDIR += licq-qt-gui
|
||||
SUBDIR += linpopup
|
||||
SUBDIR += lla
|
||||
|
|
|
@ -12,7 +12,7 @@ CATEGORIES= net
|
|||
PKGNAMESUFFIX= -socks
|
||||
.endif
|
||||
|
||||
MAINTAINER= dinoex@FreeBSD.org
|
||||
MAINTAINER= fjoe@FreeBSD.org
|
||||
|
||||
.if defined(WITH_SOCKS)
|
||||
.if defined(WITH_DANTE)
|
||||
|
@ -23,7 +23,12 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
|
|||
.endif
|
||||
|
||||
USE_OPENSSL= yes
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
.if defined(USE_CVS)
|
||||
WRKSRC= ${WRKDIR}/licq
|
||||
CVS_MODULE= licq
|
||||
.else
|
||||
WRKSRC= ${WRKDIR}/licq-${TIMESTAMP}
|
||||
.endif
|
||||
.if defined(WITH_SOCKS)
|
||||
CONFIGURE_ARGS+=--enable-socks5
|
||||
.if defined(WITH_DANTE)
|
||||
|
@ -41,5 +46,6 @@ post-patch:
|
|||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include "${.CURDIR}/Makefile.inc"
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -2,28 +2,49 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PKGNAMEPREFIX= licq-
|
||||
LICQ_VER= 1.0.4
|
||||
TIMESTAMP= 20020128
|
||||
LICQ_VER= 1.1.0-${TIMESTAMP}
|
||||
QT_LICQ_VER= ${LICQ_VER}
|
||||
RMS_LICQ_VER= 0.23
|
||||
CONSOLE_LICQ_VER= 1.0.4
|
||||
CONSOLE_LICQ_VER= ${LICQ_VER}
|
||||
AUTO_REPLY_LICQ_VER= 1.0.2
|
||||
FORWARDER_LICQ_VER= 1.0.1
|
||||
.if ${PORTNAME} != "base"
|
||||
RUN_DEPENDS+= licq:${PORTSDIR}/net/licq
|
||||
.endif
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
ftp://ftp.wibble.net/pub/licq/srcs/ \
|
||||
ftp://licq.darkorb.net/srcs/ \
|
||||
ftp://ftp.fanfic.org/pub/licq/srcs/ \
|
||||
ftp://ftp.inter-i.uni-mainz.de/pub/licq/srcs/
|
||||
MASTER_SITE_SUBDIR= licq
|
||||
DISTNAME= ${PKGNAMEPREFIX}${LICQ_VER}
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= fjoe
|
||||
#MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
# ftp://ftp.wibble.net/pub/licq/srcs/ \
|
||||
# ftp://licq.darkorb.net/srcs/ \
|
||||
# ftp://ftp.fanfic.org/pub/licq/srcs/ \
|
||||
# ftp://ftp.inter-i.uni-mainz.de/pub/licq/srcs/
|
||||
#MASTER_SITE_SUBDIR= licq
|
||||
DISTNAME= ${PKGNAMEPREFIX}daily-${TIMESTAMP}
|
||||
DISTFILES= ${DISTNAME}.tar.bz2
|
||||
GNU_CONFIGURE= yes
|
||||
MD5_FILE= ${PORTSDIR}/net/licq/distinfo
|
||||
MD5_FILE= ${PORTSDIR}/net/licq-devel/distinfo
|
||||
# USE_LIBTOOL doesn't work for these ports
|
||||
#USE_LIBTOOL= yes
|
||||
USE_GMAKE= yes
|
||||
USE_NEWGCC= yes
|
||||
USE_BZIP2= yes
|
||||
WRKSRC?= ${WRKDIR}/${DISTNAME}/plugins/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
.if defined(USE_CVS)
|
||||
WRKSRC?= ${WRKDIR}/licq-plugins/${PORTNAME}
|
||||
DISTFILES=
|
||||
CVS_MODULE?= licq-plugins
|
||||
IS_INTERACTIVE= yes
|
||||
|
||||
do-fetch:
|
||||
|
||||
do-extract:
|
||||
${MKDIR} ${WRKDIR}
|
||||
cvs -d :pserver:anonymous@cvs.licq.sourceforge.net:/cvsroot/licq login
|
||||
(cd ${WRKDIR} && cvs -z9 -d :pserver:anonymous@cvs.licq.sourceforge.net:/cvsroot/licq co ${CVS_MODULE})
|
||||
|
||||
pre-patch:
|
||||
(cd ${WRKSRC} && ${GMAKE} -f Makefile.cvs)
|
||||
.else
|
||||
WRKSRC?= ${WRKDIR}/licq-${TIMESTAMP}/plugins/${PORTNAME}
|
||||
.endif
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (licq-1.0.4.tar.bz2) = df3e50c1b03aa0cf2ecd1c27af3588e7
|
||||
MD5 (licq-daily-20020128.tar.bz2) = a99d2f76c7f5bfb499e560f21b56e3d5
|
||||
|
|
|
@ -1,27 +1,23 @@
|
|||
--- src/socket.cpp.orig Tue Jul 4 20:51:50 2000
|
||||
+++ src/socket.cpp Mon Jul 24 03:32:56 2000
|
||||
@@ -12,6 +12,7 @@
|
||||
--- src/socket.cpp.orig Fri Jan 4 16:25:00 2002
|
||||
+++ src/socket.cpp Mon Jan 28 15:15:22 2002
|
||||
@@ -13,6 +13,7 @@
|
||||
#include <netdb.h>
|
||||
#include <fcntl.h>
|
||||
#include <unistd.h>
|
||||
+#include <osreldate.h>
|
||||
|
||||
#ifndef MSG_DONTWAIT
|
||||
#define MSG_DONTWAIT 0
|
||||
@@ -288,7 +289,12 @@
|
||||
bool INetSocket::SetLocalAddress(bool bIp)
|
||||
{
|
||||
#ifdef HAVE_INET_ATON
|
||||
#include <arpa/inet.h>
|
||||
@@ -294,6 +295,8 @@
|
||||
// Setup the local structure
|
||||
+
|
||||
+#if __FreeBSD_version < 400013
|
||||
#ifdef USE_SOCKS5
|
||||
int sizeofSockaddr = sizeof(struct sockaddr_in);
|
||||
+#elif __FreeBSD_version < 400013
|
||||
+ int sizeofSockaddr = sizeof(struct sockaddr_in);
|
||||
+#else
|
||||
#else
|
||||
socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
|
||||
+#endif
|
||||
if (getsockname(m_nDescriptor, (struct sockaddr *)&m_sLocalAddr, &sizeofSockaddr) < 0)
|
||||
{
|
||||
m_nErrorType = SOCK_ERROR_errno;
|
||||
@@ -372,7 +378,11 @@
|
||||
#endif
|
||||
@@ -380,7 +383,11 @@
|
||||
m_sRemoteAddr.sin_family = AF_INET;
|
||||
|
||||
// if connect fails then call CloseConnection to clean up before returning
|
||||
|
@ -33,16 +29,12 @@
|
|||
if (connect(m_nDescriptor, (struct sockaddr *)&m_sRemoteAddr, sizeofSockaddr) < 0)
|
||||
{
|
||||
// errno has been set
|
||||
@@ -504,7 +514,11 @@
|
||||
*---------------------------------------------------------------------------*/
|
||||
@@ -640,6 +647,8 @@
|
||||
void TCPSocket::RecvConnection(TCPSocket &newSocket)
|
||||
{
|
||||
- socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
|
||||
+#if __FreeBSD_version < 400013
|
||||
+ int sizeofSockaddr = sizeof(struct sockaddr_in);
|
||||
+#else
|
||||
+ socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
|
||||
+#endif
|
||||
newSocket.m_nDescriptor = accept(m_nDescriptor, (struct sockaddr *)&newSocket.m_sRemoteAddr, &sizeofSockaddr);
|
||||
newSocket.SetLocalAddress();
|
||||
}
|
||||
#ifdef USE_SOCKS5
|
||||
+ int sizeofSockaddr = sizeof(struct sockaddr_in);
|
||||
+#elif __FreeBSD_version < 400013
|
||||
int sizeofSockaddr = sizeof(struct sockaddr_in);
|
||||
#else
|
||||
socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
|
||||
|
|
|
@ -1,3 +1,4 @@
|
|||
In order to actually use licq, at least one plugin port needs to be installed.
|
||||
Currently they include: licq-qt-gui, gtk+licq, licq-console, and several others.
|
||||
Currently they include licq-qt-gui and licq-console.
|
||||
Check the net category to find them.
|
||||
You should use -DWITH_LICQ_DEVEL to build them using licq-devel port.
|
||||
|
|
|
@ -78,6 +78,7 @@ share/licq/translations/SWEDISH
|
|||
share/licq/translations/SWEDISH_NAMES
|
||||
share/licq/translations/SWEDISH_NAMES_COM
|
||||
share/licq/translations/SWISS
|
||||
share/licq/translations/UKRAINIAN_WIN
|
||||
share/licq/translations/UNITED_KINGDOM
|
||||
share/licq/translations/UNITED_KINGDOM_COM
|
||||
share/licq/utilities/BackOrifice.utility
|
||||
|
|
Loading…
Reference in a new issue