Ming with Japanese charachter enhancement.
This commit is contained in:
parent
9170fe5b9e
commit
1352cda2c6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=64102
8 changed files with 263 additions and 0 deletions
|
@ -225,6 +225,7 @@
|
|||
SUBDIR += migemo-emacs21
|
||||
SUBDIR += migemo-xemacs21-mule
|
||||
SUBDIR += mimekit
|
||||
SUBDIR += ming
|
||||
SUBDIR += mnews
|
||||
SUBDIR += mnews-gnspool
|
||||
SUBDIR += mnews-im
|
||||
|
|
85
japanese/ming/Makefile
Normal file
85
japanese/ming/Makefile
Normal file
|
@ -0,0 +1,85 @@
|
|||
# New ports collection makefile for: ja-Ming
|
||||
# Date created: Aug 6 2002
|
||||
# Whom: kuriyama
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ming
|
||||
PORTVERSION= 0.1.5
|
||||
CATEGORIES= japanese graphics
|
||||
MASTER_SITES= http://blue.ribbon.to/~harpy/ming/jaming/
|
||||
DISTFILES= jaming-${PORTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= kuriyama@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
|
||||
ungif.5:${PORTSDIR}/graphics/libungif
|
||||
|
||||
WRKSRC= ${WRKDIR}/jaming-${PORTVERSION}/src
|
||||
MAKE_ARGS= NOPROFILE=true
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
UTILS= gif2dbl \
|
||||
gif2mask \
|
||||
listfdb \
|
||||
listjpeg \
|
||||
listswf \
|
||||
makefdb \
|
||||
png2dbl \
|
||||
swftophp
|
||||
DOCS= CHANGES \
|
||||
CREDITS \
|
||||
README \
|
||||
TODO
|
||||
DOCS_UTIL= README \
|
||||
TODO
|
||||
|
||||
post-extract:
|
||||
${SED} -e 's:"\.\./\.\./ming\.h":<ming.h>:g' \
|
||||
${WRKSRC}/ming.h > ${WRKSRC}/mingpp.h
|
||||
cd ${WRKSRC}/../util && \
|
||||
${RM} bindump.c decompile5.c hexdump.c listmp3.c
|
||||
|
||||
pre-build:
|
||||
${CP} ${FILESDIR}/Makefile ${WRKSRC}/
|
||||
cd ${WRKSRC}/actioncompiler; ${MAKE} lex.swf4.c lex.swf5.c swf4compiler.tab.c swf5compiler.tab.c
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC}/../util && \
|
||||
${CC} ${CFLAGS} -I${PREFIX}/include -I${PREFIX}/include/ming -c *.c
|
||||
cd ${WRKSRC}/../util && \
|
||||
${CC} ${CFLAGS} -L${PREFIX}/lib -o gif2dbl gif2dbl.o -lm -lz -lungif
|
||||
cd ${WRKSRC}/../util && \
|
||||
${CC} ${CFLAGS} -L${PREFIX}/lib -o gif2mask gif2mask.o -lm -lz -lungif
|
||||
cd ${WRKSRC}/../util && \
|
||||
${CC} ${CFLAGS} -L${PREFIX}/lib -o listfdb listfdb.o blocktypes.o
|
||||
cd ${WRKSRC}/../util && \
|
||||
${CC} ${CFLAGS} -L${PREFIX}/lib -o listjpeg listjpeg.o
|
||||
cd ${WRKSRC}/../util && \
|
||||
${CC} ${CFLAGS} -L${PREFIX}/lib -o listswf listswf.o blocktypes.o decompile.o read.o -lz
|
||||
cd ${WRKSRC}/../util && \
|
||||
${CC} ${CFLAGS} -L${PREFIX}/lib -o makefdb makefdb.o blocktypes.o read.o
|
||||
cd ${WRKSRC}/../util && \
|
||||
${CC} ${CFLAGS} -L${PREFIX}/lib -o png2dbl png2dbl.o -lm -lz -lpng
|
||||
cd ${WRKSRC}/../util && \
|
||||
${CC} ${CFLAGS} -L${PREFIX}/lib -o swftophp swftophp.o blocktypes.o decompile.o read.o -lm
|
||||
|
||||
pre-install:
|
||||
${MKDIR} ${PREFIX}/include/ming/blocks
|
||||
|
||||
post-install:
|
||||
.for f in ${UTILS}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/../util/${f} ${PREFIX}/bin/
|
||||
.endfor
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/ming/utils
|
||||
.for f in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/../${f} ${PREFIX}/share/doc/ming/
|
||||
.endfor
|
||||
.for f in ${DOCS_UTIL}
|
||||
${INSTALL_DATA} ${WRKSRC}/../util/${f} ${PREFIX}/share/doc/ming/utils/
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
japanese/ming/distinfo
Normal file
1
japanese/ming/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (jaming-0.1.5.tar.gz) = ec50ba0947a571cdbae3a947f37c0a5b
|
107
japanese/ming/files/Makefile
Normal file
107
japanese/ming/files/Makefile
Normal file
|
@ -0,0 +1,107 @@
|
|||
# $FreeBSD$
|
||||
|
||||
LIB= ming
|
||||
SHLIB_MAJOR?= 3
|
||||
SHLIB_MINOR?= 0
|
||||
CFLAGS+= -I${.CURDIR}/actioncompiler -I${.CURDIR}/blocks -I${LOCALBASE}/include
|
||||
LDADD= -lm
|
||||
SRCS= blocklist.c \
|
||||
displaylist.c \
|
||||
fill.c \
|
||||
ming.c \
|
||||
movie.c \
|
||||
movieclip.c \
|
||||
position.c \
|
||||
shape_cubic.c \
|
||||
shape_util.c \
|
||||
text_util.c \
|
||||
actioncompiler/assembler.c \
|
||||
actioncompiler/compile.c \
|
||||
actioncompiler/compileaction.c \
|
||||
actioncompiler/lex.swf4.c \
|
||||
actioncompiler/lex.swf5.c \
|
||||
actioncompiler/swf4compiler.tab.c \
|
||||
actioncompiler/swf5compiler.tab.c \
|
||||
blocks/action.c \
|
||||
blocks/bitmap.c \
|
||||
blocks/block.c \
|
||||
blocks/browserfont.c \
|
||||
blocks/button.c \
|
||||
blocks/character.c \
|
||||
blocks/cxform.c \
|
||||
blocks/dbl.c \
|
||||
blocks/error.c \
|
||||
blocks/fillstyle.c \
|
||||
blocks/font.c \
|
||||
blocks/fontinfo.c \
|
||||
blocks/gradient.c \
|
||||
blocks/input.c \
|
||||
blocks/jpeg.c \
|
||||
blocks/linestyle.c \
|
||||
blocks/loadfont.c \
|
||||
blocks/matrix.c \
|
||||
blocks/method.c \
|
||||
blocks/morph.c \
|
||||
blocks/mp3.c \
|
||||
blocks/output.c \
|
||||
blocks/outputblock.c \
|
||||
blocks/placeobject.c \
|
||||
blocks/rect.c \
|
||||
blocks/shape.c \
|
||||
blocks/soundstream.c \
|
||||
blocks/sprite.c \
|
||||
blocks/text.c \
|
||||
blocks/textfield.c
|
||||
INCSGROUPS= INCS BLKS
|
||||
INCS= blocklist.h \
|
||||
blocktypes.h \
|
||||
displaylist.h \
|
||||
fill.h \
|
||||
libming.h \
|
||||
../ming.h \
|
||||
../mingpp.h \
|
||||
movie.h \
|
||||
movieclip.h \
|
||||
position.h \
|
||||
shape_cubic.h \
|
||||
shape_util.h \
|
||||
text_util.h
|
||||
|
||||
NOMAN= YES
|
||||
LIBDIR= ${LOCALBASE}/lib
|
||||
INCSDIR= ${LOCALBASE}/include/ming
|
||||
|
||||
BLKS= block.h cxform.h \
|
||||
error.h exports.h \
|
||||
input.h matrix.h \
|
||||
outputblock.h placeobject.h \
|
||||
sound.h sprite.h \
|
||||
swf.h blocktypes.h \
|
||||
character.h libswf.h \
|
||||
method.h output.h \
|
||||
rect.h
|
||||
BLKS:= ${BLKS:S;^;${.CURDIR}/blocks/;}
|
||||
BLKSDIR= ${INCSDIR}/blocks
|
||||
|
||||
.include <bsd.lib.mk>
|
||||
|
||||
# For pre-bsd.incs.mk API
|
||||
.if defined(INCOWN)
|
||||
INCDIR= ${INCSDIR}
|
||||
beforeinstall:
|
||||
${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
|
||||
${.CURDIR}/blocks/block.h ${.CURDIR}/blocks/cxform.h \
|
||||
${.CURDIR}/blocks/error.h ${.CURDIR}/blocks/exports.h \
|
||||
${.CURDIR}/blocks/input.h ${.CURDIR}/blocks/matrix.h \
|
||||
${.CURDIR}/blocks/outputblock.h ${.CURDIR}/blocks/placeobject.h \
|
||||
${.CURDIR}/blocks/sound.h ${.CURDIR}/blocks/sprite.h \
|
||||
${.CURDIR}/blocks/swf.h ${.CURDIR}/blocks/blocktypes.h \
|
||||
${.CURDIR}/blocks/character.h ${.CURDIR}/blocks/libswf.h \
|
||||
${.CURDIR}/blocks/method.h ${.CURDIR}/blocks/output.h \
|
||||
${.CURDIR}/blocks/rect.h ${INCDIR}/blocks/
|
||||
.endif
|
||||
|
||||
dynamic: lib${LIB}.so
|
||||
|
||||
static: lib${LIB}.a
|
||||
|
11
japanese/ming/files/patch-mingpp.h
Normal file
11
japanese/ming/files/patch-mingpp.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ../mingpp.h Thu Mar 7 18:28:27 2002
|
||||
+++ ../mingpp.h Thu Mar 7 18:28:41 2002
|
||||
@@ -627,7 +627,7 @@
|
||||
void setColor(unsigned char r, unsigned char g, unsigned char b, int a=0xff)
|
||||
{ SWFText_setColor(this->text, r, g, b, a); }
|
||||
|
||||
- void addString(const char *string, float *advance=NULL)
|
||||
+ void addString(const char *string, int *advance=NULL)
|
||||
{ SWFText_addString(this->text, string, advance); }
|
||||
|
||||
void setSpacing(float spacing)
|
1
japanese/ming/pkg-comment
Normal file
1
japanese/ming/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
LGPL'ed Flash 4/5 movie output library with Japanese languages support
|
6
japanese/ming/pkg-descr
Normal file
6
japanese/ming/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
Ming is an LGPL'ed Flash 4/5 (TM) movie (SWF) output library with PHP,
|
||||
Python, Ruby, Perl5, C and C++ interfaces.
|
||||
|
||||
This port includes Japanese character enhancement.
|
||||
|
||||
WWW: http://blue.ribbon.to/~harpy/ming/jaming/index.html
|
51
japanese/ming/pkg-plist
Normal file
51
japanese/ming/pkg-plist
Normal file
|
@ -0,0 +1,51 @@
|
|||
bin/gif2dbl
|
||||
bin/gif2mask
|
||||
bin/listfdb
|
||||
bin/listjpeg
|
||||
bin/listswf
|
||||
bin/makefdb
|
||||
bin/png2dbl
|
||||
bin/swftophp
|
||||
include/ming/blocklist.h
|
||||
include/ming/blocktypes.h
|
||||
include/ming/displaylist.h
|
||||
include/ming/fill.h
|
||||
include/ming/libming.h
|
||||
include/ming/ming.h
|
||||
include/ming/movie.h
|
||||
include/ming/movieclip.h
|
||||
include/ming/position.h
|
||||
include/ming/shape_cubic.h
|
||||
include/ming/shape_util.h
|
||||
include/ming/text_util.h
|
||||
include/ming/blocks/block.h
|
||||
include/ming/blocks/blocktypes.h
|
||||
include/ming/blocks/character.h
|
||||
include/ming/blocks/cxform.h
|
||||
include/ming/blocks/error.h
|
||||
include/ming/blocks/exports.h
|
||||
include/ming/blocks/input.h
|
||||
include/ming/blocks/libswf.h
|
||||
include/ming/blocks/matrix.h
|
||||
include/ming/blocks/method.h
|
||||
include/ming/blocks/output.h
|
||||
include/ming/blocks/outputblock.h
|
||||
include/ming/blocks/placeobject.h
|
||||
include/ming/blocks/rect.h
|
||||
include/ming/blocks/sound.h
|
||||
include/ming/blocks/sprite.h
|
||||
include/ming/blocks/swf.h
|
||||
include/ming/mingpp.h
|
||||
@dirrm include/ming/blocks
|
||||
@dirrm include/ming
|
||||
lib/libming.a
|
||||
lib/libming.so
|
||||
lib/libming.so.3
|
||||
%%PORTDOCS%%share/doc/ming/CHANGES
|
||||
%%PORTDOCS%%share/doc/ming/CREDITS
|
||||
%%PORTDOCS%%share/doc/ming/README
|
||||
%%PORTDOCS%%share/doc/ming/TODO
|
||||
%%PORTDOCS%%share/doc/ming/utils/README
|
||||
%%PORTDOCS%%share/doc/ming/utils/TODO
|
||||
%%PORTDOCS%%@dirrm share/doc/ming/utils
|
||||
%%PORTDOCS%%@dirrm share/doc/ming
|
Loading…
Reference in a new issue