Update to 2.0.0 release to add php 5.4 support.

PR:		ports/167994
Submitted by:	Gea-Suan Lin <gslin@gslin.org>
This commit is contained in:
Alex Dupre 2012-05-17 10:52:29 +00:00
parent e748e69581
commit 13787d844f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=296821
10 changed files with 6 additions and 256 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= intl
PORTVERSION= 1.1.2
PORTREVISION= 3
PORTVERSION= 2.0.0
CATEGORIES= devel pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@ -17,12 +16,12 @@ DIST_SUBDIR= PECL
MAINTAINER= miwi@FreeBSD.org
COMMENT= A PECL extension to support Internationalization(ICU)
LIB_DEPENDS= icui18n.48:${PORTSDIR}/devel/icu
LICENSE= PHP301
LIB_DEPENDS= icui18n.48:${PORTSDIR}/devel/icu
USE_PHP= yes
USE_PHPEXT= yes
IGNORE_WITH_PHP=4 52
IGNORE_WITH_PHP=52
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (PECL/intl-1.1.2.tgz) = 5737698b16489e7fec4376520a20db960b64295d53bceabd16b8e59a5b2b90eb
SIZE (PECL/intl-1.1.2.tgz) = 142511
SHA256 (PECL/intl-2.0.0.tgz) = 03a197e1ed9537594e829936c9b95eb234f49ed05d81c3d177f5a4a7a7728feb
SIZE (PECL/intl-2.0.0.tgz) = 145979

View file

@ -1,25 +0,0 @@
--- ./collator/collator_class.c.orig 2010-03-15 18:03:30.000000000 -0400
+++ ./collator/collator_class.c 2010-04-13 10:31:54.000000000 -0400
@@ -88,22 +88,18 @@
modify approptiate 'collator_XX_args' for
the procedural API.
*/
-static
ZEND_BEGIN_ARG_INFO_EX( collator_0_args, 0, 0, 0 )
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX( collator_1_arg, 0, 0, 1 )
ZEND_ARG_INFO( 0, arg1 )
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX( collator_2_args, 0, 0, 2 )
ZEND_ARG_INFO( 0, arg1 )
ZEND_ARG_INFO( 0, arg2 )
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX( collator_sort_args, 0, 0, 1 )
ZEND_ARG_ARRAY_INFO( 1, arr, 0 )
ZEND_ARG_INFO( 0, flags )

View file

@ -1,46 +0,0 @@
--- ./dateformat/dateformat_class.c.orig 2010-04-13 10:34:55.000000000 -0400
+++ ./dateformat/dateformat_class.c 2010-04-13 10:35:14.000000000 -0400
@@ -84,42 +84,35 @@
*/
/* {{{ arginfo */
-static ZEND_BEGIN_ARG_INFO_EX(datefmt_parse_args, 0, 0, 1)
+ZEND_BEGIN_ARG_INFO_EX(datefmt_parse_args, 0, 0, 1)
ZEND_ARG_INFO(0, string)
ZEND_ARG_INFO(1, position)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_intldateformatter_format, 0, 0, 0)
ZEND_ARG_INFO(0, args)
ZEND_ARG_INFO(0, array)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO(arginfo_intldateformatter_getdatetype, 0)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_intldateformatter_settimezoneid, 0, 0, 1)
ZEND_ARG_INFO(0, zone)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_intldateformatter_setpattern, 0, 0, 1)
ZEND_ARG_INFO(0, pattern)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_intldateformatter_setlenient, 0, 0, 1)
ZEND_ARG_INFO(0, lenient)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_intldateformatter_setcalendar, 0, 0, 1)
ZEND_ARG_INFO(0, which)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_intldateformatter___construct, 0, 0, 3)
ZEND_ARG_INFO(0, locale)
ZEND_ARG_INFO(0, datetype)

View file

@ -1,68 +0,0 @@
--- ./formatter/formatter_class.c.orig 2010-03-15 18:03:30.000000000 -0400
+++ ./formatter/formatter_class.c 2010-04-13 10:31:54.000000000 -0400
@@ -80,63 +80,54 @@
*/
/* {{{ arginfo */
-static ZEND_BEGIN_ARG_INFO_EX(number_parse_arginfo, 0, 0, 1)
+ZEND_BEGIN_ARG_INFO_EX(number_parse_arginfo, 0, 0, 1)
ZEND_ARG_INFO(0, string)
ZEND_ARG_INFO(0, type)
ZEND_ARG_INFO(1, position)
ZEND_END_ARG_INFO()
-static ZEND_BEGIN_ARG_INFO_EX(number_parse_currency_arginfo, 0, 0, 2)
+ZEND_BEGIN_ARG_INFO_EX(number_parse_currency_arginfo, 0, 0, 2)
ZEND_ARG_INFO(0, string)
ZEND_ARG_INFO(1, currency)
ZEND_ARG_INFO(1, position)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_numberformatter_getattribute, 0, 0, 1)
ZEND_ARG_INFO(0, attr)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_numberformatter_setattribute, 0, 0, 2)
ZEND_ARG_INFO(0, attr)
ZEND_ARG_INFO(0, value)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_numberformatter_setsymbol, 0, 0, 2)
ZEND_ARG_INFO(0, attr)
ZEND_ARG_INFO(0, symbol)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO(arginfo_numberformatter_getpattern, 0)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_numberformatter_setpattern, 0, 0, 1)
ZEND_ARG_INFO(0, pattern)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_numberformatter_getlocale, 0, 0, 0)
ZEND_ARG_INFO(0, type)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_numberformatter___construct, 0, 0, 2)
ZEND_ARG_INFO(0, locale)
ZEND_ARG_INFO(0, style)
ZEND_ARG_INFO(0, pattern)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_numberformatter_formatcurrency, 0, 0, 2)
ZEND_ARG_INFO(0, num)
ZEND_ARG_INFO(0, currency)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_numberformatter_format, 0, 0, 1)
ZEND_ARG_INFO(0, num)
ZEND_ARG_INFO(0, type)

View file

@ -1,32 +0,0 @@
--- ./locale/locale_class.c.orig 2010-04-13 10:34:14.000000000 -0400
+++ ./locale/locale_class.c 2010-04-13 10:34:27.000000000 -0400
@@ -35,29 +35,24 @@
* approptiate 'locale_XX_args' for the procedural API!
*/
-static
ZEND_BEGIN_ARG_INFO_EX( locale_0_args, 0, 0, 0 )
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX( locale_1_arg, 0, 0, 1 )
ZEND_ARG_INFO( 0, arg1 )
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX( locale_2_args, 0, 0, 2 )
ZEND_ARG_INFO( 0, arg1 )
ZEND_ARG_INFO( 0, arg2 )
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX( locale_3_args, 0, 0, 3 )
ZEND_ARG_INFO( 0, arg1 )
ZEND_ARG_INFO( 0, arg2 )
ZEND_ARG_INFO( 0, arg3 )
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX( locale_4_args, 0, 0, 4 )
ZEND_ARG_INFO( 0, arg1 )
ZEND_ARG_INFO( 0, arg2 )

View file

@ -1,37 +0,0 @@
--- ./msgformat/msgformat_class.c.orig 2010-04-13 10:35:58.000000000 -0400
+++ ./msgformat/msgformat_class.c 2010-04-13 10:36:15.000000000 -0400
@@ -77,34 +77,28 @@
*/
/* {{{ arginfo */
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_messageformatter___construct, 0, 0, 2)
ZEND_ARG_INFO(0, locale)
ZEND_ARG_INFO(0, pattern)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO(arginfo_messageformatter_geterrormessage, 0)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_messageformatter_formatmessage, 0, 0, 3)
ZEND_ARG_INFO(0, locale)
ZEND_ARG_INFO(0, pattern)
ZEND_ARG_INFO(0, args)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_messageformatter_format, 0, 0, 1)
ZEND_ARG_INFO(0, args)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_messageformatter_setpattern, 0, 0, 1)
ZEND_ARG_INFO(0, pattern)
ZEND_END_ARG_INFO()
-static
ZEND_BEGIN_ARG_INFO_EX(arginfo_messageformatter_parse, 0, 0, 1)
ZEND_ARG_INFO(0, source)
ZEND_END_ARG_INFO()

View file

@ -1,10 +0,0 @@
--- ./normalizer/normalizer_class.c.orig 2010-04-13 10:33:36.000000000 -0400
+++ ./normalizer/normalizer_class.c 2010-04-13 10:33:47.000000000 -0400
@@ -29,7 +29,6 @@
/* {{{ Normalizer methods arguments info */
-static
ZEND_BEGIN_ARG_INFO_EX( normalizer_3_args, 0, 0, 3 )
ZEND_ARG_INFO( 0, arg1 )
ZEND_ARG_INFO( 0, arg2 )

View file

@ -1,11 +0,0 @@
--- ./resourcebundle/resourcebundle_class.c.orig 2010-04-13 10:38:08.000000000 -0400
+++ ./resourcebundle/resourcebundle_class.c 2010-04-13 10:38:25.000000000 -0400
@@ -212,7 +212,7 @@
MAKE_STD_ZVAL(retval);
resourcebundle_array_fetch(object, offset, retval, 1 TSRMLS_CC);
- retval->refcount--;
+ Z_DELREF_P(retval);
return retval;
}
/* }}} */

View file

@ -1,20 +0,0 @@
--- ./resourcebundle/resourcebundle_iterator.c.orig 2010-04-13 10:38:51.000000000 -0400
+++ ./resourcebundle/resourcebundle_iterator.c 2010-04-13 10:39:13.000000000 -0400
@@ -75,7 +75,7 @@
resourcebundle_iterator_invalidate( iter TSRMLS_CC );
- object->refcount--;
+ Z_DELREF_P(object);
efree(iterator);
}
@@ -162,7 +162,7 @@
php_error( E_ERROR, "ResourceBundle does not support writable iterators" );
}
- object->refcount++;
+ Z_ADDREF_P(object);
iterator->intern.data = (void *) object;
iterator->intern.funcs = &resourcebundle_iterator_funcs;