Adding jesred version 1.2pl1.

A redirector for Squid.

PR:		14869
Submitted by:	Denis Shaposhnikov <dsh@wizard.vlink.ru>
This commit is contained in:
Steve Price 1999-12-27 02:15:15 +00:00
parent 17a34ce292
commit 1381d53ba1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24140
8 changed files with 106 additions and 0 deletions

View file

@ -46,6 +46,7 @@
SUBDIR += httperf
SUBDIR += hypermail
SUBDIR += ijb
SUBDIR += jesred
SUBDIR += libghttp
SUBDIR += libwww
SUBDIR += libxpg4-ns

31
www/jesred/Makefile Normal file
View file

@ -0,0 +1,31 @@
# New ports collection makefile for: jesred
# Version required: 1.2.pl1
# Date created: Mon Nov 8 17:42:20 MSK 1999
# Whom: dsh@vlink.ru
#
# $FreeBSD$
#
DISTNAME= jesred-1.2pl1
PKGNAME= jesred-1.2.1
CATEGORIES= www
MASTER_SITES= http://ivs.cs.uni-magdeburg.de/~elkner/webtools/src/
MAINTAINER= dsh@vlink.ru
RUN_DEPENDS= squid:${PORTSDIR}/www/squid22
do-install:
${INSTALL_PROGRAM} ${COPY} ${WRKSRC}/jesred ${PREFIX}/libexec
${SED} "s!%%PREFIX%%!${PREFIX}!" < ${WRKSRC}/etc/jesred.conf \
> ${WRKSRC}/etc/jesred.conf.sample
${INSTALL_DATA} ${WRKSRC}/etc/jesred.conf.sample ${PREFIX}/etc/squid
${INSTALL_DATA} ${COPY} ${WRKSRC}/etc/redirect.acl \
${PREFIX}/etc/squid/redirect.acl.sample
${INSTALL_DATA} ${COPY} ${WRKSRC}/etc/redirect.rules \
${PREFIX}/etc/squid/redirect.rules.sample
@[ -f ${PREFIX}/etc/squid/jesred.conf ] || \
${CP} ${PREFIX}/etc/squid/jesred.conf.sample \
${PREFIX}/etc/squid/jesred.conf
.include <bsd.port.mk>

1
www/jesred/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (jesred-1.2pl1.tar.gz) = 8d7009e0700996dbc28540d1a8f7c36d

46
www/jesred/files/patch-aa Normal file
View file

@ -0,0 +1,46 @@
--- Makefile.orig Sat Jul 25 07:19:50 1998
+++ Makefile Mon Nov 8 18:22:45 1999
@@ -2,20 +2,20 @@
# HINT: If you want to run the program on an UltraSPARC driven machine,
# I recommend to use Sun C-Compiler >= 4.0 or gcc >= 2.8.0 with
# optimization level >= 4 for best performance.
-CC=cc
+#CC=cc
-INCLUDE = -I.
-LDFLAGS =
+#INCLUDE = -I.
+#LDFLAGS =
# Compiler Options
-AC_CFLAGS = -xO5 -mr -s -xcrossfile #-g -xsb # SUN cc >= 4.0
+#AC_CFLAGS = -xO5 -mr -s -xcrossfile #-g -xsb # SUN cc >= 4.0
#AC_CFLAGS = -O3 -s # SGI cc, AIX cc
#AC_CFLAGS = -O5 -s # GNU cc
# extra Libraries ( we need this for inet_addr(char *) only )
-XTRA_LIBS = -lnsl # Solaris 2.x
+#XTRA_LIBS = -lnsl # Solaris 2.x
#XTRA_LIBS = # AIX 4.2, Linux 2.x.x, IRIX 5.x, 6.x
# if you want to have the option, to enable debug message logging,
@@ -49,7 +49,7 @@
# If jesred is compiled without -DUSE_ACCEL the ACCEL strings in the
# redirect rules are ignored, if there are some.
#
-# DEFS = -DUSE_ACCEL
+DEFS = -DUSE_ACCEL -DDEFAULT_PATH=\"${PREFIX}/etc/squid\"
# That's it - no further changes should be necessary ;-)
# ===========================================================================
@@ -66,7 +66,7 @@
CFILES = $(patsubst %.o,%.c,$(OBJS))
PROGS = jesred
-CFLAGS = $(AC_CFLAGS) $(INCLUDE)
+CFLAGS += $(AC_CFLAGS) $(INCLUDE)
LIBS = -L. $(XTRA_LIBS)
.SUFFIXES: .o

11
www/jesred/files/patch-ab Normal file
View file

@ -0,0 +1,11 @@
--- path.h.orig Sat Jul 25 03:03:13 1998
+++ path.h Mon Nov 8 18:15:30 1999
@@ -7,6 +7,8 @@
/* change this to the path, which contains your jesred.conf */
+#ifndef DEFAULT_PATH
#define DEFAULT_PATH "/local/squid/etc"
+#endif
#endif

1
www/jesred/pkg-comment Normal file
View file

@ -0,0 +1 @@
A redirector for Squid

10
www/jesred/pkg-descr Normal file
View file

@ -0,0 +1,10 @@
Jesred is a very fast and highly configurable redirector for the Squid
Internet Object Cache. It was derived from Chris Foote's and Wayne
Piekarski's Squirm 1.0 betaB and some code from Squid itself, but is
about 2-3x faster than the original version and has some additional
features.
WWW: http://ivs.cs.uni-magdeburg.de/~elkner/webtools/jesred/
-- Denis Shaposhnikov
dsh@vlink.ru

5
www/jesred/pkg-plist Normal file
View file

@ -0,0 +1,5 @@
etc/squid/jesred.conf.sample
@exec [ -f %B/jesred.conf ] || /bin/cp %B/%f %B/jesred.conf
etc/squid/redirect.acl.sample
etc/squid/redirect.rules.sample
libexec/jesred