1: rename php5-snappy to pecl-snappy.
2: it's php7 compatible now. 3: switch to GITHUB.
This commit is contained in:
parent
732d3c5fcd
commit
139d2d284d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=422191
5 changed files with 8 additions and 55 deletions
|
@ -2,27 +2,23 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= php5-snappy
|
||||
PORTVERSION= 0.0.2
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.1.5
|
||||
CATEGORIES= archivers
|
||||
MASTER_SITES= GOOGLE_CODE
|
||||
PROJECTHOST= php-snappy
|
||||
DISTNAME= ${PROJECTHOST}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= PHP extension for the snappy compression algorithm
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
|
||||
BROKEN= Unfetchable (google code has gone away)
|
||||
|
||||
LIB_DEPENDS= libsnappy.so:archivers/snappy
|
||||
|
||||
USES= php:ext
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= kjdev
|
||||
GH_PROJECT= php-ext-snappy
|
||||
PHP_MODNAME= snappy
|
||||
CONFIGURE_ARGS= --with-snappy-includedir=${LOCALBASE}/include
|
||||
WRKSRC= ${WRKDIR}/${PROJECTHOST}
|
||||
IGNORE_WITH_PHP= 70
|
||||
WRKSRC= ${WRKDIR}/php-ext-snappy-${PORTVERSION}
|
||||
|
||||
do-test:
|
||||
(cd ${WRKSRC} && ${DO_MAKE_BUILD} NO_INTERACTION=yes test < /dev/null)
|
3
archivers/pecl-snappy/distinfo
Normal file
3
archivers/pecl-snappy/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1473896952
|
||||
SHA256 (kjdev-php-ext-snappy-0.1.5_GH0.tar.gz) = 78d407290ca7d75eed5127642d8dcb5c08a71ec611efa5f197980e48b3623dab
|
||||
SIZE (kjdev-php-ext-snappy-0.1.5_GH0.tar.gz) = 9516
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (php-snappy-0.0.2.tar.gz) = 7aa6be88e09985fc0f9054b3e3d06612383aaacbbc6db705913ad7d047dc9cd9
|
||||
SIZE (php-snappy-0.0.2.tar.gz) = 6801
|
|
@ -1,44 +0,0 @@
|
|||
--- config.m4.orig 2011-09-07 08:27:21 UTC
|
||||
+++ config.m4
|
||||
@@ -53,7 +53,7 @@ if test "$PHP_SNAPPY" != "no"; then
|
||||
|
||||
if test "$PHP_SNAPPY_INCLUDEDIR" != "no" && test "$PHP_SNAPPY_INCLUDEDIR" != "yes"; then
|
||||
if test -r "$PHP_SNAPPY_INCLUDEDIR/snappy.h"; then
|
||||
- SNAPPY_DIR="$PHP_SNAPPY_INCLUDEDIR"
|
||||
+ SNAPPY_DIR="$(dirname $PHP_SNAPPY_INCLUDEDIR)"
|
||||
else
|
||||
AC_MSG_ERROR([Can't find snappy headers under "$PHP_SNAPPY_INCLUDEDIR"])
|
||||
fi
|
||||
@@ -61,12 +61,12 @@ if test "$PHP_SNAPPY" != "no"; then
|
||||
SEARCH_PATH="/usr/local /usr" # you might want to change this
|
||||
SEARCH_FOR="/include/snappy-c.h" # you most likely want to change this
|
||||
if test -r $PHP_SNAPPY/$SEARCH_FOR; then # path given as parameter
|
||||
- SNAPPY_DIR="$PHP_SNAPPY/include"
|
||||
+ SNAPPY_DIR="$PHP_SNAPPY"
|
||||
else # search default path list
|
||||
AC_MSG_CHECKING([for snappy files in default path])
|
||||
for i in $SEARCH_PATH ; do
|
||||
if test -r $i/$SEARCH_FOR; then
|
||||
- SNAPPY_DIR="$i/include"
|
||||
+ SNAPPY_DIR="$i"
|
||||
AC_MSG_RESULT(found in $i)
|
||||
fi
|
||||
done
|
||||
@@ -80,7 +80,7 @@ if test "$PHP_SNAPPY" != "no"; then
|
||||
|
||||
dnl # add include path
|
||||
|
||||
- PHP_ADD_INCLUDE($SNAPPY_DIR)
|
||||
+ PHP_ADD_INCLUDE([$SNAPPY_DIR/include])
|
||||
|
||||
dnl # check for lib
|
||||
|
||||
@@ -90,7 +90,7 @@ if test "$PHP_SNAPPY" != "no"; then
|
||||
AC_LANG_CPLUSPLUS
|
||||
AC_TRY_COMPILE(
|
||||
[
|
||||
- #include "$SNAPPY_DIR/snappy-c.h"
|
||||
+ #include "$SNAPPY_DIR/include/snappy-c.h"
|
||||
],[
|
||||
snappy_max_compressed_length(1);
|
||||
],[
|
Loading…
Reference in a new issue