Correct typos plus cosmetic chenges in Makefile.
PR: 107901 Submitted by: Ying-Chieh Chen <yinjieh@csie.nctu.edu.tw>
This commit is contained in:
parent
830072bb8e
commit
13afc99a99
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=183858
2 changed files with 19 additions and 10 deletions
|
@ -7,15 +7,10 @@
|
|||
|
||||
PORTNAME= fltk
|
||||
PORTVERSION= ${VERSION}
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= http://ftp.easysw.com/pub/fltk/%SUBDIR%/ \
|
||||
ftp://ftp.easysw.com/pub/fltk/%SUBDIR%/ \
|
||||
ftp://ftp3.easysw.com/pub/fltk/%SUBDIR%/ \
|
||||
http://mirror.nu6.org/ftp.easysw.com/pub/fltk/%SUBDIR%/ \
|
||||
http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/fltk/%SUBDIR%/ \
|
||||
http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/%SUBDIR%/
|
||||
MASTER_SITE_SUBDIR= ${VERSION}
|
||||
MASTER_SITES= ${MASTER_SITE_EASYSW}
|
||||
MASTER_SITE_SUBDIR= fltk/${VERSION}
|
||||
.ifdef WITH_THREADS
|
||||
PKGNAMESUFFIX= -threads
|
||||
.endif
|
||||
|
@ -39,7 +34,7 @@ CONFLICTS= fltk-threads-1*
|
|||
|
||||
VERSION= 1.1.7
|
||||
USE_BZIP2= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS+=--enable-shared --enable-xft
|
||||
|
@ -56,7 +51,7 @@ MAN3= fltk.3
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000 && defined(WITH_THREADS)
|
||||
IGNORE= "does not work on FreeBSD 4.x, because threading is not activated"
|
||||
IGNORE= does not work on FreeBSD 4.x, because threading is not activated
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
|
|
14
x11-toolkits/fltk/files/patch-FL-Fl_Spinner.H
Normal file
14
x11-toolkits/fltk/files/patch-FL-Fl_Spinner.H
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- FL/Fl_Spinner.H.orig Sun Jan 14 12:57:46 2007
|
||||
+++ FL/Fl_Spinner.H Sun Jan 14 12:58:41 2007
|
||||
@@ -127,9 +127,9 @@
|
||||
|
||||
const char *format() { return (format_); }
|
||||
void format(const char *f) { format_ = f; update(); }
|
||||
- double maxinum() const { return (maximum_); }
|
||||
+ double maximum() const { return (maximum_); }
|
||||
void maximum(double m) { maximum_ = m; }
|
||||
- double mininum() const { return (minimum_); }
|
||||
+ double minimum() const { return (minimum_); }
|
||||
void minimum(double m) { minimum_ = m; }
|
||||
void range(double a, double b) { minimum_ = a; maximum_ = b; }
|
||||
void resize(int X, int Y, int W, int H) {
|
Loading…
Reference in a new issue