www/domoticz: Update to 3.8153

PR:		221118
Submitted by:	kiwi@oav.net (maintainer)
This commit is contained in:
Steve Wills 2017-08-18 03:14:03 +00:00
parent ae38b304b3
commit 13fd861fed
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=448203
6 changed files with 343 additions and 45 deletions

View file

@ -2,7 +2,6 @@
PORTNAME= domoticz
PORTVERSION= 3.${DOMOTICZ_REL}
PORTREVISION= 2
CATEGORIES= www
MAINTAINER= kiwi@oav.net
@ -12,27 +11,25 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/License.txt
LIB_DEPENDS= libcurl.so:ftp/curl \
libexpat.so:textproc/expat2 \
libtelldus-core.so:comms/telldus-core
libexpat.so:textproc/expat2
BROKEN_armv6= fails to compile: HarmonyHub.cpp: ordered comparison between pointer and zero
CONFLICTS_INSTALL?= domoticz-[23]*
CONFLICTS_INSTALL?= domoticz-[23]* domoticz-devel-*
OPTIONS_SUB= YES
OPTIONS_DEFINE= SBOOST SLUA SMQTT SSQLITE PYTHON
OPTIONS_DEFINE= SBOOST SLUA SMQTT SSQLITE PYTHON TELLDUS
SBOOST_DESC= Use static Boost instead of dynamic linking
SLUA_DESC= Use domoticz provided LUA instead of ports one
SMQTT_DESC= Use domoticz mosquitto instead of ports one
SSQLITE_DESC= Use domoticz SQLLite instead of ports one
PYTHON_DESC= Enable support for Python in EventSystem
PYTHON_DESC= Enable support for Python Plugins
TELLDUS_DESC= Enable support for Telldus
.include <bsd.port.options.mk>
# This hack is to get rid of dependency of git while building
# the package.
DOMOTICZ_REL= 5877
DOMOTICZ_TS= 1478792673
DOMOTICZ_REL= 8153
DOMOTICZ_TS= 1501416191
USE_GITHUB= yes
GH_ACCOUNT= domoticz
GH_PROJECT= domoticz
@ -46,17 +43,14 @@ GROUPS= domoticz
CMAKE_ARGS+= -DCMAKE_INSTALL_PREFIX=${PREFIX}/domoticz \
-DUSE_BUILTIN_ZLIB="NO" \
-DUSE_PYTHON="YES" \
-DUSE_STATIC_OPENZWAVE="NO"
.if ${PORT_OPTIONS:MSBOOST}
CMAKE_ARGS+= -DUSE_STATIC_BOOST="YES"
BUILD_DEPENDS+= boost-libs>=0:devel/boost-libs \
boost-python-libs>=0:devel/boost-python-libs
BUILD_DEPENDS+= boost-libs>=0:devel/boost-libs
.else
CMAKE_ARGS+= -DUSE_STATIC_BOOST="NO"
LIB_DEPENDS+= libboost_system.so:devel/boost-libs \
libboost_python.so:devel/boost-python-libs
LIB_DEPENDS+= libboost_system.so:devel/boost-libs
.endif
.if ${PORT_OPTIONS:MSLUA}
@ -81,10 +75,14 @@ USES+= sqlite
.endif
.if ${PORT_OPTIONS:MPYTHON}
CMAKE_ARGS+= -DUSE_PYTHON="NO"
.else
CMAKE_ARGS+= -DUSE_PYTHON="YES"
USES+= python
USES+= python:3.4
.else
CMAKE_ARGS+= -DUSE_PYTHON="NO"
.endif
.if ${PORT_OPTIONS:MTELLDUS}
LIB_DEPENDS+= libtelldus-core.so:comms/telldus-core
.endif
post-patch:

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1482855396
SHA256 (domoticz-domoticz-3.5877_GH0.tar.gz) = fb88edbe428851a7a337a85faa93f6da00713b3ad086ff6957031dc9b3b58bba
SIZE (domoticz-domoticz-3.5877_GH0.tar.gz) = 38524442
TIMESTAMP = 1501437831
SHA256 (domoticz-domoticz-3.8153_GH0.tar.gz) = 5ea8f37f2ef900e9bd17b1b5375e75bfdec4f09001e3e2e0b647a260989d014c
SIZE (domoticz-domoticz-3.8153_GH0.tar.gz) = 39659793

View file

@ -1,6 +1,6 @@
--- CMakeLists.txt.orig 2016-11-10 15:44:33 UTC
+++ CMakeLists.txt
@@ -163,7 +163,7 @@ MACRO(ADD_PRECOMPILED_HEADER _targetName
--- CMakeLists.txt.orig 2017-06-07 08:41:02.000000000 +0200
+++ CMakeLists.txt 2017-06-08 09:55:44.434914000 +0200
@@ -241,7 +241,7 @@
ENDIF(CMAKE_COMPILER_IS_GNUCXX)
ENDMACRO()
@ -8,9 +8,22 @@
+FIND_PROGRAM(GIT_EXECUTABLE NOgitNO
DOC "git command line client")
MACRO(Gitversion_GET_REVISION dir variable)
@@ -653,14 +653,13 @@ IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_D
set(CMAKE_INSTALL_PREFIX "/opt/${CPACK_PACKAGE_NAME}" CACHE PATH "Install path prefix, prepended onto install directories." FORCE)
@@ -680,7 +680,7 @@
SET(CPACK_SOURCE_PACKAGE_FILE_NAME "${domoticz}-dev")
SET(CPACK_PACKAGING_INSTALL_PREFIX "/")
-SET(CPACK_PACKAGE_DEFAULT_LOCATION "/opt/${CPACK_PACKAGE_NAME}")
+SET(CPACK_PACKAGE_DEFAULT_LOCATION "/usr/local/${CPACK_PACKAGE_NAME}")
SET(CPACK_PACKAGE_EXECUTABLES "domoticz;Home Automation System (Domotica).")
#set(CPACK_DEB_COMPONENT_INSTALL TRUE)
@@ -689,18 +689,17 @@
INCLUDE(CPack)
IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
- set(CMAKE_INSTALL_PREFIX "/opt/${CPACK_PACKAGE_NAME}" CACHE PATH "Install path prefix, prepended onto install directories." FORCE)
+ set(CMAKE_INSTALL_PREFIX "/usr/local/${CPACK_PACKAGE_NAME}" CACHE PATH "Install path prefix, prepended onto install directories." FORCE)
ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
-install(TARGETS domoticz DESTINATION ${CMAKE_INSTALL_PREFIX})
@ -19,15 +32,17 @@
-install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/History.txt DESTINATION ${CMAKE_INSTALL_PREFIX})
-install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/server_cert.pem DESTINATION ${CMAKE_INSTALL_PREFIX})
-install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/scripts DESTINATION ${CMAKE_INSTALL_PREFIX} USE_SOURCE_PERMISSIONS)
-install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/plugins DESTINATION ${CMAKE_INSTALL_PREFIX})
-install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/Config DESTINATION ${CMAKE_INSTALL_PREFIX})
-install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/updatedomo DESTINATION ${CMAKE_INSTALL_PREFIX} PERMISSIONS OWNER_EXECUTE OWNER_WRITE OWNER_READ GROUP_EXECUTE GROUP_READ)
+install(TARGETS domoticz DESTINATION "XXXPREFIXXXX")
+install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/www DESTINATION "XXXPREFIXXXX")
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/License.txt DESTINATION "XXXPREFIXXXX")
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/History.txt DESTINATION "XXXPREFIXXXX")
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/server_cert.pem DESTINATION "XXXPREFIXXXX")
+install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/scripts DESTINATION "XXXPREFIXXXX" USE_SOURCE_PERMISSIONS)
+install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/Config DESTINATION "XXXPREFIXXXX")
+install(TARGETS domoticz DESTINATION "/usr/local/domoticz")
+install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/www DESTINATION "/usr/local/domoticz")
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/License.txt DESTINATION "/usr/local/domoticz")
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/History.txt DESTINATION "/usr/local/domoticz")
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/server_cert.pem DESTINATION "/usr/local/domoticz")
+install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/scripts DESTINATION "/usr/local/domoticz" USE_SOURCE_PERMISSIONS)
+install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/plugins DESTINATION "/usr/local/domoticz")
+install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/Config DESTINATION "/usr/local/domoticz")
INCLUDE(TestBigEndian)

View file

@ -1,9 +1,9 @@
--- appversion.default.orig 2016-11-10 15:44:33 UTC
+++ appversion.default
--- appversion.default.orig 2016-03-09 17:30:00.000000000 +0100
+++ appversion.default 2016-03-09 19:10:01.169567000 +0100
@@ -1,3 +1,3 @@
-#define APPVERSION 5876
-#define APPHASH "b97777b"
-#define APPDATE 1478691222
-#define APPVERSION 4834
-#define APPHASH "2bd98a1"
-#define APPDATE 1456904172
+#define APPVERSION XXXDOMOTICZXXX
+#define APPHASH "XXXHASHXXX"
+#define APPDATE XXXTIMEXXX

View file

@ -1,5 +1,5 @@
--- getgit.cmake.orig 2016-11-10 15:44:33 UTC
+++ getgit.cmake
--- getgit.cmake.orig 2016-04-01 15:27:18.517929000 +0200
+++ getgit.cmake 2016-04-01 15:27:52.572836000 +0200
@@ -1,66 +1,7 @@
# this macro gets called as a custom build step by running make
# please take into account, that the variable 'SOURCE_DIR' has been defined by the caller

View file

@ -10,11 +10,13 @@ domoticz/Config/BeNext/DoorSensor.xml
domoticz/Config/BeNext/EnergySwitch.xml
domoticz/Config/BeNext/HeatingControl.xml
domoticz/Config/BeNext/Molite.xml
domoticz/Config/BeNext/P1dongle.xml
domoticz/Config/BeNext/PanicButton.xml
domoticz/Config/BeNext/PanicWatch.xml
domoticz/Config/BeNext/PluginDimmer.xml
domoticz/Config/BeNext/SceneController.xml
domoticz/Config/BeNext/TagReader.xml
domoticz/Config/BeNext/TagReader500.xml
domoticz/Config/act/lfm20.xml
domoticz/Config/act/zdm230.xml
domoticz/Config/act/zdw103.xml
@ -61,41 +63,77 @@ domoticz/Config/aeotec/zw097.xml
domoticz/Config/aeotec/zw098.xml
domoticz/Config/aeotec/zw099.xml
domoticz/Config/aeotec/zw100.xml
domoticz/Config/aeotec/zw111.xml
domoticz/Config/aeotec/zw112.xml
domoticz/Config/aeotec/zw116.xml
domoticz/Config/aeotec/zw117.xml
domoticz/Config/aeotec/zw120.xml
domoticz/Config/aeotec/zw121.xml
domoticz/Config/aeotec/zw122.xml
domoticz/Config/aeotec/zw129.xml
domoticz/Config/aeotec/zw130.xml
domoticz/Config/aeotec/zw132.xml
domoticz/Config/aeotec/zw139.xml
domoticz/Config/aeotec/zw140.xml
domoticz/Config/assa_abloy/KeyfreeConnected.xml
domoticz/Config/assa_abloy/RealLivingCapTouch.xml
domoticz/Config/assa_abloy/PushButtonDeadbolt.xml
domoticz/Config/assa_abloy/PushButtonLever.xml
domoticz/Config/assa_abloy/TouchDeadbolt.xml
domoticz/Config/assa_abloy/TouchLever.xml
domoticz/Config/assa_abloy/nexTouch.xml
domoticz/Config/cooper/RF9501.xml
domoticz/Config/cooper/RF9505-T.xml
domoticz/Config/cooper/RF9517.xml
domoticz/Config/cooper/RF9540-N.xml
domoticz/Config/cooper/RF9542-Z.xml
domoticz/Config/danfoss/living.xml
domoticz/Config/danfoss/rsroom.xml
domoticz/Config/danfoss/z.xml
domoticz/Config/device_classes.xml
domoticz/Config/device_classes.xsd
domoticz/Config/device_configuration.xsd
domoticz/Config/devolo/connectz.xml
domoticz/Config/devolo/mt02648.xml
domoticz/Config/devolo/mt02755.xml
domoticz/Config/devolo/mt02758.xml
domoticz/Config/devolo/mt02792.xml
domoticz/Config/devolo/mt2646.xml
domoticz/Config/devolo/mt2647.xml
domoticz/Config/devolo/mt2652.xml
domoticz/Config/devolo/mt2653.xml
domoticz/Config/devolo/mt2756.xml
domoticz/Config/devolo/rs014G0159.xml
domoticz/Config/dlink/dch-z110.xml
domoticz/Config/dlink/dch-z120.xml
domoticz/Config/dlink/dch-z510.xml
domoticz/Config/domitech/zb22uk.xml
domoticz/Config/domitech/ze27eu.xml
domoticz/Config/domux/DX1CA-Z.xml
domoticz/Config/domux/DX1CG-Z.xml
domoticz/Config/domux/DX1DS-Z.xml
domoticz/Config/domux/DX1HT-Z.xml
domoticz/Config/domux/DX1MS-Z.xml
domoticz/Config/domux/DX1SA-Z.xml
domoticz/Config/domux/DX1WL-Z.xml
domoticz/Config/domux/DX2SK-Z.xml
domoticz/Config/dragontech/wd-100.xml
domoticz/Config/duwi/05458.xml
domoticz/Config/duwi/ZWES1000.xml
domoticz/Config/duwi/ZWESJ300.xml
domoticz/Config/duwi/zwfb.xml
domoticz/Config/ecolink/doorwindow.xml
domoticz/Config/ecolink/firefighter.xml
domoticz/Config/ecolink/motion.xml
domoticz/Config/ecolink/sensor.xml
domoticz/Config/electronicsolutions/dbmz.xml
domoticz/Config/enerwave/zw15rmplus.xml
domoticz/Config/enerwave/zw15s.xml
domoticz/Config/enerwave/zw20r.xml
domoticz/Config/enerwave/zw20rm.xml
domoticz/Config/enerwave/zw500d.xml
domoticz/Config/enerwave/zwn-bpc.xml
domoticz/Config/enerwave/zwn-sc7.xml
domoticz/Config/enerwave/zwnrsm1plus.xml
domoticz/Config/eurotronic/eur_cometz.xml
domoticz/Config/eurotronic/eur_stellaz.xml
domoticz/Config/everspring/ad146.xml
@ -120,20 +158,25 @@ domoticz/Config/everspringct/hsm02.xml
domoticz/Config/evolve/lrm-as.xml
domoticz/Config/evolve/lsm-15.xml
domoticz/Config/evolve/ltm-5.xml
domoticz/Config/fakro/zwp10.xml
domoticz/Config/fakro/zwrs.xml
domoticz/Config/fakro/zws12.xml
domoticz/Config/fakro/zws230.xml
domoticz/Config/fibaro/fgbs001.xml
domoticz/Config/fibaro/fgcd001.xml
domoticz/Config/fibaro/fgd211.xml
domoticz/Config/fibaro/fgd212.xml
domoticz/Config/fibaro/fgdw2.xml
domoticz/Config/fibaro/fgfs101.xml
domoticz/Config/fibaro/fgfs101zw5.xml
domoticz/Config/fibaro/fggc001.xml
domoticz/Config/fibaro/fgk001.xml
domoticz/Config/fibaro/fgk10x.xml
domoticz/Config/fibaro/fgkf601.xml
domoticz/Config/fibaro/fgms.xml
domoticz/Config/fibaro/fgmszw5.xml
domoticz/Config/fibaro/fgpb101.xml
domoticz/Config/fibaro/fgr221.xml
domoticz/Config/fibaro/fgr222.xml
domoticz/Config/fibaro/fgrgbwm441.xml
domoticz/Config/fibaro/fgrm222.xml
domoticz/Config/fibaro/fgs211.xml
@ -145,6 +188,7 @@ domoticz/Config/fibaro/fgs223.xml
domoticz/Config/fibaro/fgsd002.xml
domoticz/Config/fibaro/fgss101.xml
domoticz/Config/fibaro/fgwpe.xml
domoticz/Config/fibaro/fgwpfzw5.xml
domoticz/Config/firstalert/zcombo.xml
domoticz/Config/fortrezz/mimolite.xml
domoticz/Config/fortrezz/ssa2.xml
@ -153,16 +197,38 @@ domoticz/Config/fortrezz/wv01.xml
domoticz/Config/fortrezz/wwa02.xml
domoticz/Config/frostdale/fdn2nxx.xml
domoticz/Config/ge/12724-dimmer.xml
domoticz/Config/ge/14282-plugin-switch.xml
domoticz/Config/ge/14291-switch.xml
domoticz/Config/ge/14294-dimmer.xml
domoticz/Config/ge/26931-motion-switch.xml
domoticz/Config/ge/26933-motion-dimmer.xml
domoticz/Config/ge/dimmer.xml
domoticz/Config/ge/dimmer_module.xml
domoticz/Config/ge/hinge-pin.xml
domoticz/Config/ge/receptacle.xml
domoticz/Config/ge/relay.xml
domoticz/Config/gocontrol/GC-TBZ48L.xml
domoticz/Config/gr/gr105.xml
domoticz/Config/gr/gr105n.xml
domoticz/Config/greenwave/powernode1.xml
domoticz/Config/greenwave/powernode6.xml
domoticz/Config/hank/hkzw-dws01.xml
domoticz/Config/hank/hkzw-ms01.xml
domoticz/Config/hank/hkzw-so01-smartplug.xml
domoticz/Config/hank/hkzw-so05-smartplug.xml
domoticz/Config/hank/scenecontroller1.xml
domoticz/Config/hank/scenecontroller4.xml
domoticz/Config/heiman/HS1CA-Z.xml
domoticz/Config/heiman/HS1CG-Z.xml
domoticz/Config/heiman/HS1DS-Z.xml
domoticz/Config/heiman/HS1HT-Z.xml
domoticz/Config/heiman/HS1MS-Z.xml
domoticz/Config/heiman/HS1SA-Z.xml
domoticz/Config/heiman/HS1WL-Z.xml
domoticz/Config/heiman/HS2SK-Z.xml
domoticz/Config/homeseer/ezmotionplus.xml
domoticz/Config/homeseer/hs-wd100plus.xml
domoticz/Config/homeseer/hs-ws100plus.xml
domoticz/Config/homeseer/hsm100.xml
domoticz/Config/homeseer/hsm200.xml
domoticz/Config/homeseer/ztroller.xml
@ -174,21 +240,36 @@ domoticz/Config/horstmann/ses302.xml
domoticz/Config/horstmann/ses303.xml
domoticz/Config/horstmann/sir321.xml
domoticz/Config/horstmann/srt323.xml
domoticz/Config/horstmann/ssr302.xml
domoticz/Config/idlock/idlock101.xml
domoticz/Config/ingersoll/dwzwave1.xml
domoticz/Config/intermatic/ca8900.xml
domoticz/Config/iris/rangeextender.xml
domoticz/Config/kaipule/im20.xml
domoticz/Config/kwikset/smartcode.xml
domoticz/Config/leviton/dz15s.xml
domoticz/Config/leviton/dz6hd.xml
domoticz/Config/leviton/dzpd3.xml
domoticz/Config/leviton/rzi10.xml
domoticz/Config/leviton/vrcpg.xml
domoticz/Config/leviton/vrf01.xml
domoticz/Config/leviton/vri06.xml
domoticz/Config/leviton/vri10.xml
domoticz/Config/linear/GC-TBZ48.xml
domoticz/Config/linear/LB60Z-1.xml
domoticz/Config/linear/PD300Z-2.xml
domoticz/Config/linear/WA00Z-1.xml
domoticz/Config/linear/WA105DBZ-1.xml
domoticz/Config/linear/WADWAZ-1.xml
domoticz/Config/linear/WAPIRZ-1.xml
domoticz/Config/linear/WD500Z-1.xml
domoticz/Config/linear/WS15Z-1.xml
domoticz/Config/linear/WT00Z-1.xml
domoticz/Config/logicsoft/ZHC5010.xml
domoticz/Config/manufacturer_specific.xml
domoticz/Config/manufacturer_specific.xsd
domoticz/Config/mcohome/mh8fceu.xml
domoticz/Config/mcohome/mh9co2.xml
domoticz/Config/mcohome/mhp210.xml
domoticz/Config/mcohome/mhs311.xml
domoticz/Config/mcohome/mhs312.xml
@ -211,12 +292,16 @@ domoticz/Config/options.xml
domoticz/Config/options.xsd
domoticz/Config/philio/pan03.xml
domoticz/Config/philio/pan04.xml
domoticz/Config/philio/pan07.xml
domoticz/Config/philio/pan08.xml
domoticz/Config/philio/pan11.xml
domoticz/Config/philio/pan16.xml
domoticz/Config/philio/phpab01.xml
domoticz/Config/philio/phpat02.xml
domoticz/Config/philio/phpsg01.xml
domoticz/Config/philio/pse02.xml
domoticz/Config/philio/psm02.xml
domoticz/Config/philio/psp05.xml
domoticz/Config/philio/psr04.xml
domoticz/Config/philio/pst02-1c.xml
domoticz/Config/philio/pst02-b.xml
@ -224,11 +309,15 @@ domoticz/Config/philio/pst02.xml
domoticz/Config/polycontrol/doorlock.xml
domoticz/Config/polycontrol/keypad.xml
domoticz/Config/polycontrol/polylock.xml
domoticz/Config/popp/004407.xml
domoticz/Config/popp/009105.xml
domoticz/Config/popp/009303.xml
domoticz/Config/popp/009402.xml
domoticz/Config/popp/012501.xml
domoticz/Config/popp/123580.xml
domoticz/Config/popp/123601.xml
domoticz/Config/popp/123658.xml
domoticz/Config/popp/700168.xml
domoticz/Config/popp/smoke-detector.xml
domoticz/Config/popp/solar-siren.xml
domoticz/Config/popp/zweather.xml
@ -254,8 +343,10 @@ domoticz/Config/qubino/ZMNHNDx.xml
domoticz/Config/qubino/ZMNHODx.xml
domoticz/Config/qubino/ZMNHSDx.xml
domoticz/Config/qubino/ZMNHTDx.xml
domoticz/Config/qubino/ZMNHTDxS3.xml
domoticz/Config/qubino/ZMNHUD1.xml
domoticz/Config/qubino/ZMNHVDx.xml
domoticz/Config/qubino/ZMNHWD1.xml
domoticz/Config/qubino/ZMNHZDx.xml
domoticz/Config/rcs/em52-zw.xml
domoticz/Config/rcs/pm12-zw.xml
@ -267,10 +358,12 @@ domoticz/Config/remotec/zrc-90.xml
domoticz/Config/remotec/zts-110.xml
domoticz/Config/remotec/zurc.xml
domoticz/Config/remotec/zxt-120.xml
domoticz/Config/schlage/BE469NXCEN.xml
domoticz/Config/schlage/BE468.xml
domoticz/Config/schlage/BE469.xml
domoticz/Config/schlagelink/itemp.xml
domoticz/Config/schlagelink/minikeypad.xml
domoticz/Config/sensative/strips.xml
domoticz/Config/shenzen_neo/nas-ab01z.xml
domoticz/Config/shenzen_neo/nas-ds01z.xml
domoticz/Config/shenzen_neo/nas-pd01z.xml
domoticz/Config/shenzen_neo/nas-wr01z.xml
@ -279,12 +372,15 @@ domoticz/Config/stelpro/stzw402.xml
domoticz/Config/swiid/swiidinter.xml
domoticz/Config/swiid/swiidplug.xml
domoticz/Config/telldus/tzdw100.xml
domoticz/Config/telldus/tzwp100.xml
domoticz/Config/thermofloor/heatit021.xml
domoticz/Config/trane/TZEMT400AB32MAA.xml
domoticz/Config/trane/TZEMT400BB32MAA.xml
domoticz/Config/trane/TZEMT524AA21MA.xml
domoticz/Config/vision/zd2102.xml
domoticz/Config/vision/zd2201.xml
domoticz/Config/vision/zd2301.xml
domoticz/Config/vision/zf5201.xml
domoticz/Config/vision/zg8101.xml
domoticz/Config/vision/zm1601eu.xml
domoticz/Config/vision/zm1601eu5.xml
@ -303,16 +399,26 @@ domoticz/Config/wenzhou/tz65d.xml
domoticz/Config/wenzhou/tz66d.xml
domoticz/Config/wenzhou/tz67.xml
domoticz/Config/wenzhou/tz68.xml
domoticz/Config/wenzhou/tz69.xml
domoticz/Config/wenzhou/tz88.xml
domoticz/Config/widom/UBS104.xml
domoticz/Config/widom/UME304C_S.xml
domoticz/Config/widom/WDS.xml
domoticz/Config/zipato/MiniKeypad.xml
domoticz/Config/zipato/RGBBulb.xml
domoticz/Config/zipato/RGBBulb2.xml
domoticz/Config/zipato/vszd2102.xml
domoticz/Config/zipato/zp3102.xml
domoticz/Config/zooz/zen07.xml
domoticz/Config/zooz/zen20.xml
domoticz/Config/zooz/zen23.xml
domoticz/Config/zooz/zen24.xml
domoticz/Config/zooz/zse08.xml
domoticz/Config/zooz/zse09.xml
domoticz/Config/zooz/zse33.xml
domoticz/Config/zooz/zse40.xml
domoticz/Config/zwave.me/ZME_05431.xml
domoticz/Config/zwave.me/ZME_05461.xml
domoticz/Config/zwave.me/ZME_06433.xml
domoticz/Config/zwave.me/ZME_06436.xml
domoticz/Config/zwave.me/ZME_064381.xml
@ -331,10 +437,169 @@ domoticz/Config/zwscene.xsd
domoticz/History.txt
domoticz/License.txt
domoticz/domoticz
domoticz/plugins/AwoxSMP/%%LUA_LIBDIR%%/__init__.py
domoticz/plugins/AwoxSMP/%%LUA_LIBDIR%%/pySmartPlugSmpB16.py
domoticz/plugins/AwoxSMP/plugin.py
domoticz/plugins/examples/BaseTemplate.py
domoticz/plugins/examples/DenonMarantz.py
domoticz/plugins/examples/Dlink DSP-W215.py
domoticz/plugins/examples/HTTP.py
domoticz/plugins/examples/Kodi.py
domoticz/plugins/examples/RAVEn.py
domoticz/scripts/_domoticz_main
domoticz/scripts/_domoticz_main.bat
domoticz/scripts/buienradar_rain_example.pl
domoticz/scripts/download_update.sh
domoticz/scripts/dzVents/.gitignore
domoticz/scripts/dzVents/data/README.md
domoticz/scripts/dzVents/documentation/README.md
domoticz/scripts/dzVents/documentation/README.wiki
domoticz/scripts/dzVents/documentation/dzvents-smoothing.png
domoticz/scripts/dzVents/documentation/history.md
domoticz/scripts/dzVents/documentation/pandoc.md
domoticz/scripts/dzVents/examples/calc temp delta.lua
domoticz/scripts/dzVents/examples/check battery levels.lua
domoticz/scripts/dzVents/examples/check dead devices by desc.lua
domoticz/scripts/dzVents/examples/check dead devices.lua
domoticz/scripts/dzVents/examples/external_light.lua
domoticz/scripts/dzVents/examples/fake presence.lua
domoticz/scripts/dzVents/examples/garage door.lua
domoticz/scripts/dzVents/examples/get sensor values.lua
domoticz/scripts/dzVents/examples/intruder alert.lua
domoticz/scripts/dzVents/examples/leak_detection.lua
domoticz/scripts/dzVents/examples/notify for dead system-alive check devices.lua
domoticz/scripts/dzVents/examples/only run script when button pressed.lua
domoticz/scripts/dzVents/examples/random night light.lua
domoticz/scripts/dzVents/examples/respond to switch.lua
domoticz/scripts/dzVents/examples/schedule fish pond pump.lua
domoticz/scripts/dzVents/examples/simple room heating with hysteresis control.lua
domoticz/scripts/dzVents/examples/templates/bare.lua
domoticz/scripts/dzVents/examples/templates/complete.lua
domoticz/scripts/dzVents/examples/templates/device.lua
domoticz/scripts/dzVents/examples/templates/global_data.lua
domoticz/scripts/dzVents/examples/templates/security.lua
domoticz/scripts/dzVents/examples/templates/timer.lua
domoticz/scripts/dzVents/examples/templates/variable.lua
domoticz/scripts/dzVents/generated_scripts/README.md
domoticz/scripts/dzVents/runtime/Device.lua
domoticz/scripts/dzVents/runtime/Domoticz.lua
domoticz/scripts/dzVents/runtime/EventHelpers.lua
domoticz/scripts/dzVents/runtime/HistoricalStorage.lua
domoticz/scripts/dzVents/runtime/Time.lua
domoticz/scripts/dzVents/runtime/TimedCommand.lua
domoticz/scripts/dzVents/runtime/Utils.lua
domoticz/scripts/dzVents/runtime/Variable.lua
domoticz/scripts/dzVents/runtime/device-adapters/Adapters.lua
domoticz/scripts/dzVents/runtime/device-adapters/airquality_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/alert_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/ampere_1_phase_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/ampere_3_phase_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/barometer_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/counter_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/custom_sensor_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/distance_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/electric_usage_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/evohome_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/gas_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/generic_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/group_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/humidity_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/kodi_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/kwh_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/leafwetness_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/lux_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/opentherm_gateway_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/p1_smartmeter_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/percentage_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/pressure_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/rain_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/rgbw_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/scaleweight_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/scene_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/security_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/soilmoisture_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/solar_radiation_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/soundlevel_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/switch_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/temperature_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/temperature_humidity_barometer_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/temperature_humidity_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/text_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/thermostat_setpoint_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/uv_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/visibility_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/voltage_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/waterflow_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/wind_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/zone_heating_device.lua
domoticz/scripts/dzVents/runtime/device-adapters/zwave_thermostat_mode_device.lua
domoticz/scripts/dzVents/runtime/dzVents.lua
domoticz/scripts/dzVents/runtime/integration-tests/File.lua
domoticz/scripts/dzVents/runtime/integration-tests/README.md
domoticz/scripts/dzVents/runtime/integration-tests/global_data.lua
domoticz/scripts/dzVents/runtime/integration-tests/secArmedAway.lua
domoticz/scripts/dzVents/runtime/integration-tests/stage1.lua
domoticz/scripts/dzVents/runtime/integration-tests/stage2.lua
domoticz/scripts/dzVents/runtime/integration-tests/testIntegration.lua
domoticz/scripts/dzVents/runtime/integration-tests/varString.lua
domoticz/scripts/dzVents/runtime/integration-tests/vdSwitchDimmer.lua
domoticz/scripts/dzVents/runtime/misc/smoothing.xlsx
domoticz/scripts/dzVents/runtime/persistence.lua
domoticz/scripts/dzVents/runtime/tests/.luacov
domoticz/scripts/dzVents/runtime/tests/README.md
domoticz/scripts/dzVents/runtime/tests/data/README.md
domoticz/scripts/dzVents/runtime/tests/devices.lua
domoticz/scripts/dzVents/runtime/tests/generated_scripts/internal1.lua
domoticz/scripts/dzVents/runtime/tests/generated_scripts/internal2.lua
domoticz/scripts/dzVents/runtime/tests/scandir/.f3.lua
domoticz/scripts/dzVents/runtime/tests/scandir/.f3.lua.swp
domoticz/scripts/dzVents/runtime/tests/scandir/f1.lua
domoticz/scripts/dzVents/runtime/tests/scandir/f1lua
domoticz/scripts/dzVents/runtime/tests/scandir/f2.lua
domoticz/scripts/dzVents/runtime/tests/scandir/f3.lua
domoticz/scripts/dzVents/runtime/tests/scandir/lua.lua
domoticz/scripts/dzVents/runtime/tests/scripts/global_data.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script1.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script2.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script3.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script4.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script5.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script6.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script7.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_combined.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_data.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_error.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_inactive.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_incomplete_missing_execute.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_incomplete_missing_on.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_logging.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_notable.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_security.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_security_grouped.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_timer_classic.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_timer_function.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_timer_single.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_timer_table.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_variable1.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_variable2.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_variable3.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_wildcard1.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_wildcard2.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_with_active_method.lua
domoticz/scripts/dzVents/runtime/tests/scripts/script_with_time-contrained_device.lua
domoticz/scripts/dzVents/runtime/tests/testDevice.lua
domoticz/scripts/dzVents/runtime/tests/testDomoticz.lua
domoticz/scripts/dzVents/runtime/tests/testEventHelpers.lua
domoticz/scripts/dzVents/runtime/tests/testEventHelpersStorage.lua
domoticz/scripts/dzVents/runtime/tests/testScriptdzVentsDispatching.lua
domoticz/scripts/dzVents/runtime/tests/testTime.lua
domoticz/scripts/dzVents/runtime/tests/testTimedCommand.lua
domoticz/scripts/dzVents/runtime/tests/testUtils.lua
domoticz/scripts/dzVents/runtime/tests/testVariable.lua
domoticz/scripts/dzVents/runtime/tests/testfile
domoticz/scripts/dzVents/runtime/tests/tstData.lua
domoticz/scripts/dzVents/runtime/todo.md
domoticz/scripts/dzVents/scripts/README.md
domoticz/scripts/logrotate/domoticz
domoticz/scripts/lua/JSON.lua
domoticz/scripts/lua/script_device_demo.lua
@ -346,15 +611,23 @@ domoticz/scripts/lua_parsers/example_xml.lua
domoticz/scripts/python/domoticz.py
domoticz/scripts/python/googlepubsub.py
domoticz/scripts/python/reloader.py
domoticz/scripts/python/script_device_PIRsmarter.py
domoticz/scripts/python/script_device_demo.py
domoticz/scripts/python/script_time_demo.py
domoticz/scripts/readme.txt
domoticz/scripts/restart_domoticz
domoticz/scripts/templates/All.Lua
domoticz/scripts/templates/All.Python
domoticz/scripts/templates/All.dzVents
domoticz/scripts/templates/Bare.dzVents
domoticz/scripts/templates/Device.Lua
domoticz/scripts/templates/Device.dzVents
domoticz/scripts/templates/Security.Lua
domoticz/scripts/templates/Seurity.dzVents
domoticz/scripts/templates/Time.Lua
domoticz/scripts/templates/Timer.dzvents
domoticz/scripts/templates/UserVariable.Lua
domoticz/scripts/templates/UserVariable.dzVents
domoticz/scripts/templates/global_data.dzVents
domoticz/scripts/update_domoticz
domoticz/server_cert.pem
domoticz/www/app/AboutController.js
@ -363,6 +636,7 @@ domoticz/www/app/CustomIconsController.js
domoticz/www/app/DPFibaroController.js
domoticz/www/app/DPGooglePubSubController.js
domoticz/www/app/DPHttpController.js
domoticz/www/app/DPInfluxController.js
domoticz/www/app/DashboardController.js
domoticz/www/app/DevicesController.js
domoticz/www/app/DummyController.js
@ -377,6 +651,7 @@ domoticz/www/app/LightsController.js
domoticz/www/app/LogController.js
domoticz/www/app/LoginController.js
domoticz/www/app/LogoutController.js
domoticz/www/app/MobileNotificationsController.js
domoticz/www/app/NotificationController.js
domoticz/www/app/OfflineController.js
domoticz/www/app/RFXComFirmwareController.js
@ -388,6 +663,7 @@ domoticz/www/app/TemperatureController.js
domoticz/www/app/TemperatureCustomLogController.js
domoticz/www/app/TemperatureLogController.js
domoticz/www/app/TemperatureNotificationsController.js
domoticz/www/app/TimerplanController.js
domoticz/www/app/UpdateController.js
domoticz/www/app/UserVariablesController.js
domoticz/www/app/UsersController.js
@ -463,6 +739,7 @@ domoticz/www/i18n/domoticz-de.json.gz
domoticz/www/i18n/domoticz-el.json.gz
domoticz/www/i18n/domoticz-en.json.gz
domoticz/www/i18n/domoticz-es.json.gz
domoticz/www/i18n/domoticz-et.json.gz
domoticz/www/i18n/domoticz-fi.json.gz
domoticz/www/i18n/domoticz-fr.json.gz
domoticz/www/i18n/domoticz-he.json.gz
@ -470,6 +747,7 @@ domoticz/www/i18n/domoticz-hu.json.gz
domoticz/www/i18n/domoticz-is.json.gz
domoticz/www/i18n/domoticz-it.json.gz
domoticz/www/i18n/domoticz-lt.json.gz
domoticz/www/i18n/domoticz-lv.json.gz
domoticz/www/i18n/domoticz-mk.json.gz
domoticz/www/i18n/domoticz-nl.json.gz
domoticz/www/i18n/domoticz-no.json.gz
@ -946,6 +1224,7 @@ domoticz/www/media/click.mp3
domoticz/www/media/click.wav
domoticz/www/media/delete.mp3
domoticz/www/media/delete.wav
domoticz/www/media/disconnect.mp3
domoticz/www/media/disconnect.wav
domoticz/www/media/handclosed.cur
domoticz/www/media/handdelete.cur
@ -989,6 +1268,9 @@ domoticz/www/secpanel/media/key.ogg
domoticz/www/secpanel/media/wrongcode.aac
domoticz/www/secpanel/media/wrongcode.mp3
domoticz/www/secpanel/media/wrongcode.ogg
domoticz/www/styles/dark-th3me/custom.css
domoticz/www/styles/dark-th3me/fonts/Ubuntu.ttf
domoticz/www/styles/dark-th3me/images/domoticz.jpg
domoticz/www/styles/default/custom.css
domoticz/www/styles/element-dark/custom.css
domoticz/www/styles/element-dark/fonts/DroidSans.ttf
@ -1016,6 +1298,7 @@ domoticz/www/views/devices.html
domoticz/www/views/dpfibaro.html
domoticz/www/views/dpgooglepubsub.html
domoticz/www/views/dphttp.html
domoticz/www/views/dpinflux.html
domoticz/www/views/events.html
domoticz/www/views/floorplanedit.html
domoticz/www/views/floorplans.html
@ -1028,6 +1311,7 @@ domoticz/www/views/lights.html
domoticz/www/views/log.html
domoticz/www/views/login.html
domoticz/www/views/logout.html
domoticz/www/views/mobile_notifications.html
domoticz/www/views/notification.html
domoticz/www/views/offline.html
domoticz/www/views/restoredatabase.html
@ -1040,6 +1324,7 @@ domoticz/www/views/temperature_custom_temp_log.html
domoticz/www/views/temperature_log.html
domoticz/www/views/temperature_notifications.html
domoticz/www/views/temperatures/temperatureWidget.html
domoticz/www/views/timerplan.html
domoticz/www/views/update.html
domoticz/www/views/users.html
domoticz/www/views/uservariables.html