- Update devel/ucommon to 7.0.0
- Bump PORTREVISION on dependent ports due to shlib bump - Update audio/ccaudio2 to 2.2.0 - Add LICENSE - Fix detection of gsm and speex
This commit is contained in:
parent
2415b92a9f
commit
14200ea79a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=406089
19 changed files with 200 additions and 146 deletions
|
@ -2,24 +2,25 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ccaudio2
|
||||
PORTVERSION= 2.1.3
|
||||
PORTVERSION= 2.2.0
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= GNU/ccaudio
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= C++ class framework for manipulating audio files
|
||||
|
||||
LICENSE= LGPL3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
|
||||
|
||||
LIB_DEPENDS= libccgnu2.so:${PORTSDIR}/devel/commoncpp \
|
||||
libucommon.so:${PORTSDIR}/devel/ucommon \
|
||||
libgsm.so:${PORTSDIR}/audio/gsm \
|
||||
libspeex.so:${PORTSDIR}/audio/speex
|
||||
|
||||
USES= cmake:outsource pkgconfig
|
||||
USES= cmake:outsource pathfix pkgconfig
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CMAKE_ARGS+= -DWITH_INCLUDES:PATH=${LOCALBASE}/include \
|
||||
-DWITH_LIBS:PATH=${LOCALBASE}/lib \
|
||||
-DINSTALL_MANDIR=man \
|
||||
-DSYSCONFDIR=${PREFIX}/etc
|
||||
-DCMAKE_INSTALL_MANDIR:STRING=man
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (ccaudio2-2.1.3.tar.gz) = b94a898c9a2ae55c812bde810fdf89f40bc44b94fb06c4dc3e40a5341eeec301
|
||||
SIZE (ccaudio2-2.1.3.tar.gz) = 443867
|
||||
SHA256 (ccaudio2-2.2.0.tar.gz) = 2756b3c4765f62f69578bbf03b18ccd56baca385a85a1a6679ac6af633b17fb0
|
||||
SIZE (ccaudio2-2.2.0.tar.gz) = 441444
|
||||
|
|
|
@ -1,20 +1,78 @@
|
|||
--- CMakeLists.txt.orig 2014-05-04 01:56:54.000000000 +0200
|
||||
+++ CMakeLists.txt 2014-05-20 10:27:42.000000000 +0200
|
||||
@@ -159,7 +159,7 @@
|
||||
--- CMakeLists.txt.orig 2015-12-13 13:01:59 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -55,10 +55,7 @@ else()
|
||||
endif()
|
||||
|
||||
include_directories(${USES_UCOMMON_INCLUDE_DIRS})
|
||||
-link_directories(${USES_UCOMMON_LIBRARY_DIRS})
|
||||
+link_directories(${USES_UCOMMON_LIBRARY_DIRS} ${WITH_LIBS})
|
||||
add_definitions(${USES_UCOMMON_CFLAGS})
|
||||
check_include_files(sys/soundcard.h HAVE_SYS_SOUNDCARD_H)
|
||||
-check_include_files(speex/speex.h HAVE_SPEEX_SPEEX_H)
|
||||
-check_include_files(gsm.h HAVE_GSM_H)
|
||||
-check_include_files(gsm/gsm.h HAVE_GSM_GSM_H)
|
||||
-check_include_files(endian.h HAVE_ENDIAN_H)
|
||||
+check_include_files(sys/endian.h HAVE_ENDIAN_H)
|
||||
|
||||
# by default we build static libs for windows, shared libs for unix.
|
||||
@@ -243,7 +243,7 @@
|
||||
|
||||
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/ccaudio2.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/ccaudio2.pc)
|
||||
|
||||
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ccaudio2.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig)
|
||||
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ccaudio2.pc DESTINATION libdata/pkgconfig)
|
||||
check_library_exists(ossaudio _oss_ioctl "" OSSAUDIO_LIB)
|
||||
if(OSSAUDIO_LIB)
|
||||
@@ -79,20 +76,39 @@ if(MATH_LIB)
|
||||
set(MATH_LIB m)
|
||||
endif()
|
||||
|
||||
install(FILES ${ccaudio_conf} DESTINATION ${SYSCONFDIR})
|
||||
-if(NOT HAVE_SPEEX_SPEEX_H AND EXISTS ${CMAKE_BINARY_DIR}/Frameworks/Speex)
|
||||
- include_directories(${CMAKE_BINARY_DIR}/Frameworks/Speex/include)
|
||||
- link_directories(${CMAKE_BINARY_DIR}/Frameworks/Speex/lib)
|
||||
- set(HAVE_SPEEX_SPEEX_H 1)
|
||||
-endif()
|
||||
+# Find Speex
|
||||
+find_path(SPEEX_INCLUDE_DIR speex/speex.h)
|
||||
|
||||
-if(HAVE_SPEEX_SPEEX_H)
|
||||
- set(AUDIO_LIBS ${AUDIO_LIBS} speex)
|
||||
+find_library(SPEEX_LIBRARY speex)
|
||||
+
|
||||
+find_package_handle_standard_args(SPEEX DEFAULT_MSG SPEEX_INCLUDE_DIR SPEEX_LIBRARY)
|
||||
+
|
||||
+if(SPEEX_FOUND)
|
||||
+ set(SPEEX_LIBRARIES ${SPEEX_LIBRARY})
|
||||
+ set(AUDIO_LIBS ${AUDIO_LIBS} ${SPEEX_LIBRARIES})
|
||||
+ set(SPEEX_INCLUDE_DIRS ${SPEEX_INCLUDE_DIR})
|
||||
+ set(HAVE_SPEEX_SPEEX_H 1)
|
||||
endif()
|
||||
|
||||
-if(HAVE_GSM_H OR HAVE_GSM_GSM_H)
|
||||
- set(AUDIO_LIBS ${AUDIO_LIBS} gsm)
|
||||
+mark_as_advanced(SPEEX_INCLUDE_DIR SPEEX_LIBRARY)
|
||||
+
|
||||
+# Find GSM
|
||||
+find_path(GSM_INCLUDE_DIR gsm.h)
|
||||
+
|
||||
+find_library(GSM_LIBRARY gsm)
|
||||
+
|
||||
+find_package_handle_standard_args(GSM DEFAULT_MSG GSM_INCLUDE_DIR GSM_LIBRARY)
|
||||
+
|
||||
+if(GSM_FOUND)
|
||||
+ set(GSM_LIBRARIES ${GSM_LIBRARY})
|
||||
+ set(AUDIO_LIBS ${AUDIO_LIBS} ${GSM_LIBRARIES})
|
||||
+ set(GSM_INCLUDE_DIRS ${GSM_INCLUDE_DIR})
|
||||
+ set(HAVE_GSM_H 1)
|
||||
endif()
|
||||
|
||||
+mark_as_advanced(GSM_INCLUDE_DIR GSM_LIBRARY)
|
||||
+######
|
||||
+
|
||||
file(GLOB ccaudio_src src/*.cpp)
|
||||
file(GLOB ccaudio_man1 utils/*.1)
|
||||
file(GLOB ccaudio_conf utils/*.conf)
|
||||
@@ -111,12 +127,12 @@ set_source_dependencies(ccaudio2 ucommon
|
||||
target_link_libraries(ccaudio2 ${USES_UCOMMON_LIBRARIES} ${AUDIO_LIBS} ${WITH_MATH_LIB} ${MATH_LIB})
|
||||
|
||||
add_executable(ccaudio-tonetool utils/tonetool.cpp)
|
||||
-add_dependencies(ccaudio-tonetool ccaudio2 ucommon)
|
||||
+add_dependencies(ccaudio-tonetool ccaudio2)
|
||||
set_target_properties(ccaudio-tonetool PROPERTIES OUTPUT_NAME tonetool)
|
||||
target_link_libraries(ccaudio-tonetool ccaudio2 ucommon ${USES_UCOMMON_LIBRARIES})
|
||||
|
||||
add_executable(ccaudio-audiotool utils/audiotool.cpp)
|
||||
-add_dependencies(ccaudio-audiotool ccaudio2 ucommon)
|
||||
+add_dependencies(ccaudio-audiotool ccaudio2)
|
||||
set_target_properties(ccaudio-audiotool PROPERTIES OUTPUT_NAME audiotool)
|
||||
target_link_libraries(ccaudio-audiotool ccaudio2 ucommon ${USES_UCOMMON_LIBRARIES})
|
||||
|
||||
|
|
14
audio/ccaudio2/files/patch-src_audiofile.cpp
Normal file
14
audio/ccaudio2/files/patch-src_audiofile.cpp
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- src/audiofile.cpp.orig 2015-10-23 22:39:25 UTC
|
||||
+++ src/audiofile.cpp
|
||||
@@ -20,7 +20,10 @@
|
||||
#include <ucommon/ucommon.h>
|
||||
#include <ccaudio2-config.h>
|
||||
#ifdef HAVE_ENDIAN_H
|
||||
-#include <endian.h>
|
||||
+#include <sys/endian.h>
|
||||
+#define __LITTLE_ENDIAN (_BYTE_ORDER == _LITTLE_ENDIAN)
|
||||
+#define __BIG_ENDIAN (_BYTE_ORDER == _BIG_ENDIAN)
|
||||
+#define __BYTE_ORDER _BYTE_ORDER
|
||||
#endif
|
||||
#include <ucommon/export.h>
|
||||
#include <ccaudio2.h>
|
14
audio/ccaudio2/files/patch-src_friends.cpp
Normal file
14
audio/ccaudio2/files/patch-src_friends.cpp
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- src/friends.cpp.orig 2015-11-03 08:30:29 UTC
|
||||
+++ src/friends.cpp
|
||||
@@ -22,7 +22,10 @@
|
||||
#include <math.h>
|
||||
#include <ctype.h>
|
||||
#ifdef HAVE_ENDIAN_H
|
||||
-#include <endian.h>
|
||||
+#include <sys/endian.h>
|
||||
+#define __LITTLE_ENDIAN (_BYTE_ORDER == _LITTLE_ENDIAN)
|
||||
+#define __BIG_ENDIAN (_BYTE_ORDER == _BIG_ENDIAN)
|
||||
+#define __BYTE_ORDER _BYTE_ORDER
|
||||
#endif
|
||||
#include <ucommon/export.h>
|
||||
#include <ccaudio2.h>
|
|
@ -1,16 +1,14 @@
|
|||
--- src/oss.cpp.orig 2014-01-28 20:43:54.000000000 +0100
|
||||
+++ src/oss.cpp 2014-05-20 10:23:04.000000000 +0200
|
||||
@@ -20,6 +20,13 @@
|
||||
#include <ccaudio2-config.h>
|
||||
#include <math.h>
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
--- src/oss.cpp.orig 2015-11-03 08:30:29 UTC
|
||||
+++ src/oss.cpp
|
||||
@@ -31,7 +31,10 @@ int _oss_ccaudio_dummy = 0;
|
||||
#include <unistd.h>
|
||||
#include <sys/soundcard.h>
|
||||
#ifdef HAVE_ENDIAN_H
|
||||
-#include <endian.h>
|
||||
+#include <sys/endian.h>
|
||||
+#define __LITTLE_ENDIAN (_BYTE_ORDER == _LITTLE_ENDIAN)
|
||||
+#define __BIG_ENDIAN (_BYTE_ORDER == _BIG_ENDIAN)
|
||||
+#define __BYTE_ORDER _BYTE_ORDER
|
||||
+#endif
|
||||
+
|
||||
extern int _oss_ccaudio_dummy;
|
||||
int _oss_ccaudio_dummy = 0;
|
||||
#endif
|
||||
|
||||
#include <ucommon/export.h>
|
||||
|
|
11
audio/ccaudio2/files/patch-src_w32.cpp
Normal file
11
audio/ccaudio2/files/patch-src_w32.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/w32.cpp.orig 2015-03-28 15:21:41 UTC
|
||||
+++ src/w32.cpp
|
||||
@@ -21,7 +21,7 @@
|
||||
#include <ccaudio2-config.h>
|
||||
#include <math.h>
|
||||
#ifdef HAVE_ENDIAN_H
|
||||
-#include <endian.h>
|
||||
+#include <sys/endian.h>
|
||||
#endif
|
||||
#define MAX_DEVICES 1
|
||||
|
14
audio/ccaudio2/files/patch-utils_audiotool.cpp
Normal file
14
audio/ccaudio2/files/patch-utils_audiotool.cpp
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- utils/audiotool.cpp.orig 2015-11-03 08:30:29 UTC
|
||||
+++ utils/audiotool.cpp
|
||||
@@ -20,7 +20,10 @@
|
||||
#include <ccaudio2.h>
|
||||
#include <ccaudio2-config.h>
|
||||
#ifdef HAVE_ENDIAN_H
|
||||
-#include <endian.h>
|
||||
+#include <sys/endian.h>
|
||||
+#define __LITTLE_ENDIAN (_BYTE_ORDER == _LITTLE_ENDIAN)
|
||||
+#define __BIG_ENDIAN (_BYTE_ORDER == _BIG_ENDIAN)
|
||||
+#define __BYTE_ORDER _BYTE_ORDER
|
||||
#endif
|
||||
|
||||
#if !defined(__BIG_ENDIAN)
|
|
@ -4,7 +4,7 @@ etc/tones.conf
|
|||
include/ccaudio2.h
|
||||
lib/libccaudio2.so
|
||||
lib/libccaudio2.so.2
|
||||
lib/libccaudio2.so.2.0.3
|
||||
lib/libccaudio2.so.2.0.6
|
||||
libdata/pkgconfig/ccaudio2.pc
|
||||
man/man1/audiotool.1.gz
|
||||
man/man1/tonetool.1.gz
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= ccrtp
|
||||
PORTVERSION= 2.0.9
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= GNU
|
||||
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= libzrtpcpp
|
||||
PORTVERSION= 2.3.4
|
||||
PORTREVISION= 7
|
||||
PORTREVISION= 8
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= GNU/ccrtp
|
||||
|
||||
|
|
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ucommon
|
||||
PORTVERSION= 6.1.11
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 7.0.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= GNU/commoncpp
|
||||
|
||||
|
@ -11,10 +10,12 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= Very lightweight C++ design pattern library
|
||||
|
||||
LICENSE= LGPL3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
|
||||
|
||||
USES= pathfix pkgconfig cmake:outsource
|
||||
USES= cmake:outsource pathfix pkgconfig
|
||||
CMAKE_ARGS+= -DBUILD_TESTING:BOOL=ON \
|
||||
-DINSTALL_BINDIR:STRING=bin/${PORTNAME}
|
||||
-DCMAKE_INSTALL_BINDIR:STRING=bin/${PORTNAME} \
|
||||
-DCMAKE_INSTALL_MANDIR:STRING=man
|
||||
USE_LDCONFIG= yes
|
||||
USE_OPENSSL= yes
|
||||
|
||||
|
@ -22,6 +23,6 @@ post-install:
|
|||
${INSTALL_DATA} ${BUILD_WRKSRC}/ucommon-config.h ${STAGEDIR}${PREFIX}/include/ucommon
|
||||
|
||||
regression-test: build
|
||||
cd ${BUILD_WRKSRC}/test && ${MAKE} test
|
||||
cd ${BUILD_WRKSRC}/test && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} test
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (ucommon-6.1.11.tar.gz) = ef933dd71f0b1e759052ecc169bc473bbcd818497c9ba9e7b778b0d37cecfc42
|
||||
SIZE (ucommon-6.1.11.tar.gz) = 833187
|
||||
SHA256 (ucommon-7.0.0.tar.gz) = 6ac9f76c2af010f97e916e4bae1cece341dc64ca28e3881ff4ddc3bc334060d7
|
||||
SIZE (ucommon-7.0.0.tar.gz) = 837905
|
||||
|
|
|
@ -1,68 +1,15 @@
|
|||
--- CMakeLists.txt.orig 2014-05-05 09:49:48.000000000 +0200
|
||||
+++ CMakeLists.txt 2014-05-05 09:58:30.000000000 +0200
|
||||
@@ -53,6 +55,7 @@
|
||||
set(MODULE_FLAGS "-module -shared -avoid-version")
|
||||
set(SYSCONFDIR "/etc" CACHE PATH "config directory")
|
||||
set(STATEDIR "/var" CACHE PATH "state directory")
|
||||
+ set(INSTALL_MANDIR man)
|
||||
--- CMakeLists.txt.orig 2016-01-14 02:00:17 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -101,7 +101,11 @@ if(CRYPTO_OPENSSL AND NOT OPENSSL_FOUND)
|
||||
endif()
|
||||
if(OPENSSL_FOUND)
|
||||
set(HAVE_OPENSSL TRUE)
|
||||
- check_include_files(openssl/fips.h HAVE_OPENSSL_FIPS_H)
|
||||
+ if(${CMAKE_SYSTEM_NAME} MATCHES "^(FreeBSD|DragonFly)$")
|
||||
+ set(HAVE_OPENSSL_FIPS_H "")
|
||||
+ else()
|
||||
+ check_include_files(openssl/fips.h HAVE_OPENSSL_FIPS_H)
|
||||
+ endif()
|
||||
elseif(PKGCONFIG_FOUND)
|
||||
pkg_check_modules(GNUTLS gnutls>=3.0.0)
|
||||
endif()
|
||||
|
||||
if(NOT INSTALL_SBINDIR)
|
||||
@@ -227,13 +230,15 @@
|
||||
|
||||
|
||||
if(UNIX OR MSYS OR MINGW OR CYGWIN)
|
||||
- check_library_exists(dl dlopen "" HAVE_DL_LIB)
|
||||
- if (HAVE_DL_LIB)
|
||||
- set (UCOMMON_LIBS ${UCOMMON_LIBS} dl)
|
||||
- else()
|
||||
- check_library_exists(compat dlopen "" HAVE_COMPAT_LIB)
|
||||
- if(HAVE_COMPAT_LIB)
|
||||
- set (UCOMMON_LIBS ${UCOMMON_LIBS} compat)
|
||||
+ if(NOT ${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
|
||||
+ check_library_exists(dl dlopen "" HAVE_DL_LIB)
|
||||
+ if (HAVE_DL_LIB)
|
||||
+ set (UCOMMON_LIBS ${UCOMMON_LIBS} dl)
|
||||
+ else()
|
||||
+ check_library_exists(compat dlopen "" HAVE_COMPAT_LIB)
|
||||
+ if(HAVE_COMPAT_LIB)
|
||||
+ set (UCOMMON_LIBS ${UCOMMON_LIBS} compat)
|
||||
+ endif()
|
||||
endif()
|
||||
endif()
|
||||
|
||||
@@ -330,7 +335,11 @@
|
||||
check_include_files(sys/event.h HAVE_SYS_EVENT_H)
|
||||
check_include_files(syslog.h HAVE_SYSLOG_H)
|
||||
check_include_files(openssl/ssl.h HAVE_OPENSSL)
|
||||
-check_include_files(openssl/fips.h HAVE_OPENSSL_FIPS_H)
|
||||
+if(${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
|
||||
+ set(HAVE_OPENSSL_FIPS_H "")
|
||||
+else()
|
||||
+ check_include_files(openssl/fips.h HAVE_OPENSSL_FIPS_H)
|
||||
+endif()
|
||||
check_include_files(libintl.h HAVE_LIBINTL_H)
|
||||
check_include_files(netinet/in.h HAVE_NETINET_IN_H)
|
||||
check_include_files(net/if.h HAVE_NET_IF_H)
|
||||
@@ -434,11 +443,19 @@
|
||||
endforeach()
|
||||
foreach(lib ${UCOMMON_LIBS})
|
||||
STRING(REGEX REPLACE "^[-]l" "" slib ${lib})
|
||||
- set(PACKAGE_LIBS "${PACKAGE_LIBS} -l${slib}")
|
||||
+ if(${lib} STREQUAL "-pthread")
|
||||
+ set(PACKAGE_LIBS "${PACKAGE_LIBS} ${slib}" )
|
||||
+ else()
|
||||
+ set(PACKAGE_LIBS "${PACKAGE_LIBS} -l${slib}")
|
||||
+ endif()
|
||||
endforeach()
|
||||
foreach(lib ${SECURE_LIBS})
|
||||
STRING(REGEX REPLACE "^[-]l" "" slib ${lib})
|
||||
- set(ADDITIONAL_LIBS "${ADDITIONAL_LIBS} -l${slib}")
|
||||
+ if(${lib} STREQUAL "-pthread")
|
||||
+ set(ADDITIONAL_LIBS "${ADDITIONAL_LIBS} ${slib}")
|
||||
+ else()
|
||||
+ set(ADDITIONAL_LIBS "${ADDITIONAL_LIBS} -l${slib}")
|
||||
+ endif()
|
||||
endforeach()
|
||||
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${PROJECT_NAME}.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.pc)
|
||||
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${PROJECT_NAME}-config.cmake ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}-config)
|
||||
|
|
10
devel/ucommon/files/patch-cmake_CapeConfig.cmake
Normal file
10
devel/ucommon/files/patch-cmake_CapeConfig.cmake
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- cmake/CapeConfig.cmake.orig 2016-01-14 02:00:43 UTC
|
||||
+++ cmake/CapeConfig.cmake
|
||||
@@ -163,6 +163,7 @@ endfunction()
|
||||
function(pc_libs _OUTPUT)
|
||||
set(libs)
|
||||
foreach(lib ${ARGN})
|
||||
+ STRING(REGEX REPLACE "pthread" "lpthread" lib ${lib})
|
||||
STRING(REGEX REPLACE "^[-]l" "" slib ${lib})
|
||||
set(libs "${libs} -l${slib}")
|
||||
endforeach()
|
|
@ -1,11 +0,0 @@
|
|||
--- inc/ucommon/socket.h.orig 2014-07-15 09:50:01.000000000 +0200
|
||||
+++ inc/ucommon/socket.h 2014-07-15 09:51:34.000000000 +0200
|
||||
@@ -38,6 +38,8 @@
|
||||
#include <ucommon/string.h>
|
||||
#endif
|
||||
|
||||
+#include <string>
|
||||
+
|
||||
extern "C" {
|
||||
struct addrinfo;
|
||||
}
|
|
@ -1,9 +0,0 @@
|
|||
--- ucommon.pc.in.orig 2014-01-28 20:43:53.000000000 +0100
|
||||
+++ ucommon.pc.in 2014-04-14 16:47:29.000000000 +0200
|
||||
@@ -6,5 +6,5 @@
|
||||
Name: ucommon
|
||||
Description: GNU uCommon C++ class framework
|
||||
Version: @VERSION@
|
||||
-Libs: -lusecure -lucommon @SECURE_LIBS@ @UCOMMON_LINKED@
|
||||
+Libs: -lusecure -lucommon -lpthread @SECURE_LIBS@ @UCOMMON_LINKED@
|
||||
Cflags: @UCOMMON_FLAGS@
|
|
@ -6,4 +6,4 @@ overhead, such as rtti and exception handling, and assumes one will mostly be
|
|||
linking applications with other pure C based libraries rather than using the
|
||||
overhead of the standard C++ library and other similar class frameworks.
|
||||
|
||||
WWW: http://www.gnutelephony.org/index.php/GNU_uCommon_C%2B%2B
|
||||
WWW: https://www.gnu.org/software/commoncpp/
|
||||
|
|
|
@ -7,6 +7,7 @@ bin/ucommon/pdetach
|
|||
bin/ucommon/scrub-files
|
||||
bin/ucommon/sockaddr
|
||||
bin/ucommon/ucommon-config
|
||||
bin/ucommon/urlout
|
||||
bin/ucommon/zerofill
|
||||
include/commoncpp/address.h
|
||||
include/commoncpp/applog.h
|
||||
|
@ -20,6 +21,7 @@ include/commoncpp/mime.h
|
|||
include/commoncpp/misc.h
|
||||
include/commoncpp/numbers.h
|
||||
include/commoncpp/object.h
|
||||
include/commoncpp/persist.h
|
||||
include/commoncpp/pointer.h
|
||||
include/commoncpp/process.h
|
||||
include/commoncpp/serial.h
|
||||
|
@ -30,58 +32,62 @@ include/commoncpp/tcp.h
|
|||
include/commoncpp/thread.h
|
||||
include/commoncpp/tokenizer.h
|
||||
include/commoncpp/udp.h
|
||||
include/commoncpp/xml.h
|
||||
include/ucommon/access.h
|
||||
include/ucommon/arrayref.h
|
||||
include/ucommon/atomic.h
|
||||
include/ucommon/bitmap.h
|
||||
include/ucommon/buffer.h
|
||||
include/ucommon/containers.h
|
||||
include/ucommon/condition.h
|
||||
include/ucommon/counter.h
|
||||
include/ucommon/cpr.h
|
||||
include/ucommon/datetime.h
|
||||
include/ucommon/export.h
|
||||
include/ucommon/file.h
|
||||
include/ucommon/fsys.h
|
||||
include/ucommon/generics.h
|
||||
include/ucommon/keydata.h
|
||||
include/ucommon/linked.h
|
||||
include/ucommon/mapped.h
|
||||
include/ucommon/mapref.h
|
||||
include/ucommon/memory.h
|
||||
include/ucommon/numbers.h
|
||||
include/ucommon/object.h
|
||||
include/ucommon/persist.h
|
||||
include/ucommon/platform.h
|
||||
include/ucommon/protocols.h
|
||||
include/ucommon/reuse.h
|
||||
include/ucommon/secure.h
|
||||
include/ucommon/shared.h
|
||||
include/ucommon/shell.h
|
||||
include/ucommon/socket.h
|
||||
include/ucommon/stl.h
|
||||
include/ucommon/stream.h
|
||||
include/ucommon/string.h
|
||||
include/ucommon/temporary.h
|
||||
include/ucommon/thread.h
|
||||
include/ucommon/timers.h
|
||||
include/ucommon/ucommon.h
|
||||
include/ucommon/typeref.h
|
||||
include/ucommon/ucommon-config.h
|
||||
include/ucommon/ucommon.h
|
||||
include/ucommon/unicode.h
|
||||
include/ucommon/vector.h
|
||||
include/ucommon/xml.h
|
||||
lib/libcommoncpp.so
|
||||
lib/libcommoncpp.so.6
|
||||
lib/libcommoncpp.so.6.0.16
|
||||
lib/libcommoncpp.so.8
|
||||
lib/libcommoncpp.so.8.0.0
|
||||
lib/libucommon.so
|
||||
lib/libucommon.so.6
|
||||
lib/libucommon.so.6.0.16
|
||||
lib/libucommon.so.8
|
||||
lib/libucommon.so.8.0.0
|
||||
lib/libusecure.so
|
||||
lib/libusecure.so.6
|
||||
lib/libusecure.so.6.0.16
|
||||
lib/libusecure.so.8
|
||||
lib/libusecure.so.8.0.0
|
||||
libdata/pkgconfig/commoncpp.pc
|
||||
libdata/pkgconfig/ucommon.pc
|
||||
man/man1/args.1.gz
|
||||
man/man1/car.1.gz
|
||||
man/man1/commoncpp-config.1.gz
|
||||
man/man1/keywait.1.gz
|
||||
man/man1/mdsum.1.gz
|
||||
man/man1/pdetach.1.gz
|
||||
man/man1/scrub-files.1.gz
|
||||
man/man1/sockaddr.1.gz
|
||||
man/man1/ucommon-config.1.gz
|
||||
man/man1/urlout.1.gz
|
||||
man/man1/zerofill.1.gz
|
||||
man/man1/keywait.1.gz
|
||||
%%DATADIR%%/cmake/CapeConfig.cmake
|
||||
%%DATADIR%%/cmake/CapeMakeTargets.cmake
|
||||
|
|
Loading…
Reference in a new issue