Abandonware (1999) no support for modern graphics libraries

This commit is contained in:
Baptiste Daroussin 2014-12-25 14:18:37 +00:00
parent b468905907
commit 144e6f10b6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=375562
9 changed files with 1 additions and 104 deletions

1
MOVED
View file

@ -7332,3 +7332,4 @@ graphics/pornview||2014-12-24|No more upstream, no more public distfile, no prop
misc/gnomehier||2014-12-25|Not needed anymore
graphics/corona||2014-12-25|Abandonware, no proper support for modern png
graphics/libpano12|graphics/libpano13|2014-12-25|No proper support for modern png, newer version available as libpano13
games/hex||2014-12-25|Abandonware, no support for moden graphics libraries

View file

@ -390,7 +390,6 @@
SUBDIR += help_hannahs_horse
SUBDIR += heretic
SUBDIR += heroes
SUBDIR += hex
SUBDIR += hex-a-hop
SUBDIR += hexalate
SUBDIR += hexglass

View file

@ -1,32 +0,0 @@
# Created by: Will Andrews <andrews@technologist.com>
# $FreeBSD$
PORTNAME= hex
PORTVERSION= 0.0.2
PORTREVISION= 11
CATEGORIES= games
MASTER_SITES= http://www.earth.li/projectpurple/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= Clone of "Puzzle Bobble" for X11 that uses GTK/Imlib
USE_GNOME= imlib
MAKE_ENV= GRAPHICPATH="${GRAPHICPATH}" LEVELPATH="${LEVELPATH}"
GRAPHICPATH= ${PREFIX}/share/hex/graphics
LEVELPATH= ${PREFIX}/share/hex/levels
OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hex ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${GRAPHICPATH}
${INSTALL_DATA} ${WRKSRC}/graphics/*.png ${STAGEDIR}${GRAPHICPATH}
@${MKDIR} ${STAGEDIR}${LEVELPATH}
${INSTALL_DATA} ${WRKSRC}/levels/Level1 ${STAGEDIR}${LEVELPATH}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in HISTORY README TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (hex-0.0.2.tar.gz) = f11e88371a211984b756f28859e3b65c50fbc50dfa458644b67e2a0903cdcb4e
SIZE (hex-0.0.2.tar.gz) = 318981

View file

@ -1,26 +0,0 @@
--- Makefile.orig Fri Aug 6 20:56:10 1999
+++ Makefile Wed Aug 9 03:01:56 2000
@@ -1,16 +1,19 @@
-CC = gcc -Wall -O6 -g
+#CC = gcc -Wall -O6 -g
SRCS = main.c levels.c grid.c player.c touching.c gtkstuff.c plot.c graphics.c
OBJS = $(SRCS:.c=.o)
-LIBS = -lm -lgdk_imlib
+CFLAGS += -DGRAPHICPATH=\"${GRAPHICPATH}\" -DLEVELPATH=\"${LEVELPATH}\"
+#LIBS = -lm -lgdk_imlib
+GDK_IMLIB_CFLAGS = `imlib-config --cflags-gdk`
+GDK_IMLIB_LIBS = `imlib-config --libs-gdk`
all: hex
.c.o:
- $(CC) `gtk-config --cflags` -c $*.c -o $*.o
+ $(CC) $(CFLAGS) $(GDK_IMLIB_CFLAGS) -c $*.c -o $*.o
hex: $(OBJS)
- $(CC) $(LIBS) `gtk-config --libs` $(OBJS) -o $@
+ $(CC) $(LIBS) $(GDK_IMLIB_LIBS) $(OBJS) -o $@
clean:
rm -f *~ *.o hex

View file

@ -1,12 +0,0 @@
--- hex.c.orig Thu Aug 5 08:36:00 1999
+++ hex.c Wed Aug 9 02:55:38 2000
@@ -17,7 +17,9 @@
#include <string.h>
#include <ctype.h>
+#ifndef LEVELPATH
#define LEVELPATH "./levels/"
+#endif
#define XSIZE 8
#define YSIZE 12

View file

@ -1,12 +0,0 @@
--- hex.h.orig Sat Aug 7 06:27:05 1999
+++ hex.h Wed Aug 9 02:54:56 2000
@@ -1,5 +1,9 @@
+#ifndef GRAPHICPATH
#define GRAPHICPATH "./graphics/"
+#endif
+#ifndef LEVELPATH
#define LEVELPATH "./levels/"
+#endif
#define XSIZE 8
#define YSIZE 12 // add 1 for the ceiling line

View file

@ -1,5 +0,0 @@
Hex is a clone of "Puzzle Bobble". It is currently in a rather
developmental stage, and needs some bugtesting, so unless you
are a Puzzle Bobble diehard, this game probably isn't for you.
WWW: http://www.earth.li/projectpurple/progs/hex.html

View file

@ -1,14 +0,0 @@
bin/hex
%%PORTDOCS%%%%DOCSDIR%%/HISTORY
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%DATADIR%%/graphics/ball0.png
%%DATADIR%%/graphics/ball1.png
%%DATADIR%%/graphics/ball2.png
%%DATADIR%%/graphics/ball3.png
%%DATADIR%%/graphics/ball4.png
%%DATADIR%%/graphics/ball5.png
%%DATADIR%%/graphics/ball6.png
%%DATADIR%%/graphics/ball7.png
%%DATADIR%%/graphics/ball8.png
%%DATADIR%%/levels/Level1