- Fix build with OpenSSL 0.9.8b in 7-CURRENT
PR: ports/102833 Submitted by: simon Approved by: maintainer timeout (mbr; 2 months) - Modernize usage of USE_RC_SUBR - Fix plist wrt config files
This commit is contained in:
parent
9fd453f7ed
commit
144fb16b91
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=177913
4 changed files with 18 additions and 13 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= pop3proxy
|
||||
PORTVERSION= 1.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://people.freebsd.org/~mbr/distfiles/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}
|
||||
|
@ -17,25 +18,15 @@ COMMENT= POP3 Proxy Server derived from UP IMAP Proxy
|
|||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_AUTOTOOLS= autoconf:213
|
||||
USE_RC_SUBR= YES
|
||||
USE_RC_SUBR= pop3proxyd
|
||||
|
||||
SAMPLE_EXT= sample
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
|
||||
RC_SUBR=${RC_SUBR}
|
||||
|
||||
post-install:
|
||||
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
|
||||
< ${FILESDIR}/pop3proxyd.conf > ${WRKSRC}/pop3proxyd.conf ;
|
||||
if [ ! -f ${PREFIX}/etc/pop3proxyd.conf ]; then \
|
||||
${INSTALL} -c ${WRKSRC}/pop3proxyd.conf ${PREFIX}/etc/pop3proxyd.conf ; \
|
||||
fi
|
||||
${INSTALL} -c ${WRKSRC}/pop3proxyd.conf ${PREFIX}/etc/pop3proxyd.conf.${SAMPLE_EXT} ;
|
||||
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
|
||||
< ${FILESDIR}/pop3proxyd.sh > ${WRKSRC}/pop3proxyd.sh
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/pop3proxyd.sh ${PREFIX}/etc/rc.d/pop3proxyd.sh
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
13
mail/pop3proxy/files/patch-src_imapcommon.c
Normal file
13
mail/pop3proxy/files/patch-src_imapcommon.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/imapcommon.c.orig
|
||||
+++ src/imapcommon.c
|
||||
@@ -121,6 +121,7 @@
|
||||
#include <errno.h>
|
||||
|
||||
#include <openssl/evp.h>
|
||||
+#include <openssl/md5.h>
|
||||
|
||||
#include <pthread.h>
|
||||
#include <sys/types.h>
|
|
@ -1,4 +1,5 @@
|
|||
sbin/pop3proxystat
|
||||
sbin/pop3proxyd
|
||||
etc/rc.d/pop3proxyd.sh
|
||||
@unexec if cmp -s %D/etc/pop3proxyd.conf.sample %D/etc/pop3proxyd.conf; then rm -f %D/etc/pop3proxyd.conf; fi
|
||||
etc/pop3proxyd.conf.sample
|
||||
@exec if [ ! -f %D/etc/pop3proxyd.conf ] ; then cp -p %D/%F %B/pop3proxyd.conf; fi
|
||||
|
|
Loading…
Reference in a new issue