x11-toolkits/libgdiplus: update to 6.1
lots of bugfixed and plugged memory leaks Approved by: maintainer timeout (prj@rootwyrm.com, 2+ weeks)
This commit is contained in:
parent
53dca644f6
commit
147de858be
3 changed files with 43 additions and 4 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= libgdiplus
|
||||
PORTVERSION= 6.0.4
|
||||
PORTVERSION= 6.1
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= http://download.mono-project.com/sources/${PORTNAME}/
|
||||
|
||||
|
@ -10,6 +10,7 @@ WWW= https://www.mono-project.com/docs/gui/libgdiplus/
|
|||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= autoconf>0:devel/autoconf
|
||||
LIB_DEPENDS= libtiff.so:graphics/tiff \
|
||||
libgif.so:graphics/giflib \
|
||||
libpng.so:graphics/png \
|
||||
|
@ -41,4 +42,7 @@ PLIST_FILES= lib/libgdiplus.a \
|
|||
lib/libgdiplus.so.0.0.0 \
|
||||
libdata/pkgconfig/libgdiplus.pc
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && autoconf
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1584469047
|
||||
SHA256 (libgdiplus-6.0.4.tar.gz) = b75c38c9765d5b3e2fb3da4435f169c732983878c0f94b8bf9012137022abf29
|
||||
SIZE (libgdiplus-6.0.4.tar.gz) = 1390998
|
||||
TIMESTAMP = 1666270821
|
||||
SHA256 (libgdiplus-6.1.tar.gz) = 97d5a83d6d6d8f96c27fb7626f4ae11d3b38bc88a1726b4466aeb91451f3255b
|
||||
SIZE (libgdiplus-6.1.tar.gz) = 2336123
|
||||
|
|
35
x11-toolkits/libgdiplus/files/patch-configure.ac
Normal file
35
x11-toolkits/libgdiplus/files/patch-configure.ac
Normal file
|
@ -0,0 +1,35 @@
|
|||
--- configure.ac.orig 2021-11-03 19:53:36 UTC
|
||||
+++ configure.ac
|
||||
@@ -27,7 +27,7 @@ GDIPLUS_LIBS="`$PKG_CONFIG --libs glib-2.0 `"
|
||||
GDIPLUS_INCLUDES="`$PKG_CONFIG --cflags-only-I glib-2.0 `"
|
||||
GDIPLUS_CFLAGS="$GDIPLUS_INCLUDES `$PKG_CONFIG --cflags-only-other glib-2.0 `"
|
||||
|
||||
-AC_PATH_PROG(CMAKE, [cmake], [no], [$PATH:/Applications/CMake.app/Contents/bin:/usr/local/bin])
|
||||
+AC_PATH_PROG(CMAKE, [DISABLEDcmake], [no], [$PATH:/Applications/CMake.app/Contents/bin:/usr/local/bin])
|
||||
if test "x$CMAKE" = "xno"; then
|
||||
AC_MSG_WARN([*** cmake not found, won't build googletest-based tests.])
|
||||
fi
|
||||
@@ -75,8 +75,8 @@ if test $text_v = "default"; then
|
||||
[text_v=pango], [text_v=cairo])
|
||||
fi
|
||||
if test $text_v = "pango"; then
|
||||
- PANGO_LIBS="`$PKG_CONFIG --libs pangocairo `"
|
||||
- PANGO_CFLAGS="`$PKG_CONFIG --cflags pangocairo `"
|
||||
+ PANGO_LIBS="`$PKG_CONFIG --libs pangocairo pangoft2`"
|
||||
+ PANGO_CFLAGS="`$PKG_CONFIG --cflags pangocairo pangoft2`"
|
||||
AC_DEFINE(USE_PANGO_RENDERING,1,[Use Pango to measure and draw text])
|
||||
GDIPLUS_PKG_REQ="$GDIPLUS_PKG_REQ pangocairo-1.0"
|
||||
fi
|
||||
@@ -212,9 +212,10 @@ fi
|
||||
|
||||
# when possible hide stuff we don't want to export
|
||||
AC_MSG_CHECKING(for visibility __attribute__)
|
||||
-AC_TRY_COMPILE([], [
|
||||
+AC_TRY_COMPILE([
|
||||
void __attribute__ ((visibility ("hidden"))) doit (void) {}
|
||||
- void main () { doit (); }
|
||||
+], [
|
||||
+ doit ();
|
||||
], [
|
||||
have_visibility_hidden=yes
|
||||
AC_MSG_RESULT(yes)
|
Loading…
Reference in a new issue