Stop installing an empty headers directory.

A fix has been submitted to https://github.com/FreeRDP/Remmina/pull/428.

While a proper decision is not made there, just patch the code to stop
calling INSTALL(DIRECTORY ...) with a path that does not exist. Until CMake
3.1.0, this would end up creating an empty directory (hence the @dir entry
in the plist). The behavior has changed in 3.1.0, and we were getting build
errors because we were referring to a directory that did not exist in the
plist.
This commit is contained in:
Raphael Kubo da Costa 2014-12-31 16:59:20 +00:00
parent 73ac3bee69
commit 14a14c4a68
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=375903
3 changed files with 3 additions and 4 deletions

View file

@ -3,7 +3,7 @@
PORTNAME= remmina
PORTVERSION= 1.0.0
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= net gnome
MAINTAINER= fluffy@FreeBSD.org

View file

@ -44,7 +44,7 @@ diff -urN CMakeLists.txt CMakeLists.txt
if(NOT BUILD_SHARED_LIBS)
set(BUILD_SHARED_LIBS ON)
endif()
@@ -77,34 +71,35 @@
@@ -77,34 +71,34 @@
include_directories(.)
include_directories(remmina/include)
@ -91,7 +91,7 @@ diff -urN CMakeLists.txt CMakeLists.txt
-
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in ${CMAKE_CURRENT_SOURCE_DIR}/config.h)
install(DIRECTORY include/remmina DESTINATION include/remmina FILES_MATCHING PATTERN "*.h")
-install(DIRECTORY include/remmina DESTINATION include/remmina FILES_MATCHING PATTERN "*.h")
diff -urN COPYING COPYING
--- COPYING 1970-01-01 10:00:00.000000000 +1000
+++ COPYING 2014-01-08 02:31:52.000000000 +1100

View file

@ -44,4 +44,3 @@ share/icons/hicolor/scalable/apps/remmina.svg
%%NLS%%share/locale/tr/LC_MESSAGES/remmina.mo
%%NLS%%share/locale/uk/LC_MESSAGES/remmina.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/remmina.mo
@dir include/remmina