parent
12cf26e278
commit
14ca2b434f
3 changed files with 8 additions and 307 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= yuzu
|
||||
PORTVERSION= s20210409
|
||||
PORTVERSION= s20210414
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES= emulators
|
||||
|
||||
|
@ -43,11 +43,11 @@ LIB_DEPENDS= liblz4.so:archivers/liblz4 \
|
|||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= yuzu-emu
|
||||
GH_TAGNAME= 96d07b494
|
||||
GH_TAGNAME= eedbe8351
|
||||
GH_TUPLE= yuzu-emu:mbedtls:v2.16.9-52-geac2416b8:mbedtls/externals/mbedtls \
|
||||
KhronosGroup:SPIRV-Headers:2c51218:SPIRV_Headers/externals/sirit/externals/SPIRV-Headers \
|
||||
KhronosGroup:Vulkan-Headers:v1.2.145:Vulkan_Headers/externals/Vulkan-Headers \
|
||||
MerryMage:dynarmic:r4-213-gc788bcdf:dynarmic/externals/dynarmic \
|
||||
MerryMage:dynarmic:r4-219-gb2a4da5e:dynarmic/externals/dynarmic \
|
||||
ReinUsesLisp:sirit:eefca56:sirit/externals/sirit \
|
||||
arsenm:sanitizers-cmake:aab6948:sanitizers_cmake/externals/cubeb/cmake/sanitizers-cmake \
|
||||
citra-emu:ext-soundtouch:060181e:soundtouch/externals/soundtouch \
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
TIMESTAMP = 1618009806
|
||||
SHA256 (yuzu-emu-yuzu-s20210409-96d07b494_GH0.tar.gz) = 6d17df4ea6e2737e4b81df2234a165370606a60005df63a2f8789d5c0e9bfabc
|
||||
SIZE (yuzu-emu-yuzu-s20210409-96d07b494_GH0.tar.gz) = 3590138
|
||||
TIMESTAMP = 1618435551
|
||||
SHA256 (yuzu-emu-yuzu-s20210414-eedbe8351_GH0.tar.gz) = be0be285aaaf151ccdc0dc4146fb349ae36a52df486675a94a6723f5f7531ea9
|
||||
SIZE (yuzu-emu-yuzu-s20210414-eedbe8351_GH0.tar.gz) = 3606638
|
||||
SHA256 (yuzu-emu-mbedtls-v2.16.9-52-geac2416b8_GH0.tar.gz) = 8d3b480b4121feaa30f12fdec06de741775465454610202363edaf7564d4f3bb
|
||||
SIZE (yuzu-emu-mbedtls-v2.16.9-52-geac2416b8_GH0.tar.gz) = 2676404
|
||||
SHA256 (KhronosGroup-SPIRV-Headers-2c51218_GH0.tar.gz) = 08f70947b69e17c7e322156adcd471cf02b4b3f63e7baf8ee0f02d32603ac5ff
|
||||
SIZE (KhronosGroup-SPIRV-Headers-2c51218_GH0.tar.gz) = 280829
|
||||
SHA256 (KhronosGroup-Vulkan-Headers-v1.2.145_GH0.tar.gz) = c8656969f0dc33f5f544b9449f02d66b7c9de67e6e58376c1cd4999694ab8517
|
||||
SIZE (KhronosGroup-Vulkan-Headers-v1.2.145_GH0.tar.gz) = 766896
|
||||
SHA256 (MerryMage-dynarmic-r4-213-gc788bcdf_GH0.tar.gz) = 7840d18ac3affa608042755dad23ec39d85db5cb26e73a5695294987af3d9461
|
||||
SIZE (MerryMage-dynarmic-r4-213-gc788bcdf_GH0.tar.gz) = 27453354
|
||||
SHA256 (MerryMage-dynarmic-r4-219-gb2a4da5e_GH0.tar.gz) = 696ae92c3d515faef17b91d2dd0c306e62d89e959a6c802df8955ad5a8a88ffa
|
||||
SIZE (MerryMage-dynarmic-r4-219-gb2a4da5e_GH0.tar.gz) = 27446619
|
||||
SHA256 (ReinUsesLisp-sirit-eefca56_GH0.tar.gz) = cc95e8155e14e596526c378d0a3cc2bb4bfe7da68773a79f224d48f89b20685a
|
||||
SIZE (ReinUsesLisp-sirit-eefca56_GH0.tar.gz) = 22035
|
||||
SHA256 (arsenm-sanitizers-cmake-aab6948_GH0.tar.gz) = d9009e17948aff769a6f6e16b52d4d8752c5cc2cab1e9c381d3a31fd1a680b58
|
||||
|
|
|
@ -1,299 +0,0 @@
|
|||
Revert https://github.com/yuzu-emu/yuzu/commit/d5dfe34c4935
|
||||
|
||||
--- .gitmodules.orig 2020-09-02 16:49:39 UTC
|
||||
+++ .gitmodules
|
||||
@@ -34,6 +34,3 @@
|
||||
[submodule "xbyak"]
|
||||
path = externals/xbyak
|
||||
url = https://github.com/herumi/xbyak.git
|
||||
-[submodule "opus"]
|
||||
- path = externals/opus/opus
|
||||
- url = https://github.com/xiph/opus.git
|
||||
--- CMakeLists.txt.orig 2020-08-10 17:53:43 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -166,6 +166,8 @@ macro(yuzu_find_packages)
|
||||
#"libzip 1.5 libzip/1.5.2@bincrafters/stable"
|
||||
"lz4 1.8 lz4/1.9.2"
|
||||
"nlohmann_json 3.8 nlohmann_json/3.8.0"
|
||||
+ # we need to be careful as the version check might be broken https://github.com/xiph/opus/issues/110
|
||||
+ "opus 1.3 opus/1.3.1"
|
||||
"ZLIB 1.2 zlib/1.2.11"
|
||||
"zstd 1.4 zstd/1.4.5"
|
||||
)
|
||||
--- externals/CMakeLists.txt.orig 2020-10-16 03:59:34 UTC
|
||||
+++ externals/CMakeLists.txt
|
||||
@@ -85,6 +85,3 @@ if (ENABLE_WEB_SERVICE)
|
||||
target_link_libraries(httplib INTERFACE crypt32 cryptui ws2_32)
|
||||
endif()
|
||||
endif()
|
||||
-
|
||||
-# Opus
|
||||
-add_subdirectory(opus)
|
||||
--- externals/opus/CMakeLists.txt.orig 2020-07-07 22:13:55 UTC
|
||||
+++ externals/opus/CMakeLists.txt
|
||||
@@ -1,254 +0,0 @@
|
||||
-cmake_minimum_required(VERSION 3.8)
|
||||
-
|
||||
-project(opus)
|
||||
-
|
||||
-option(OPUS_STACK_PROTECTOR "Use stack protection" OFF)
|
||||
-option(OPUS_USE_ALLOCA "Use alloca for stack arrays (on non-C99 compilers)" OFF)
|
||||
-option(OPUS_CUSTOM_MODES "Enable non-Opus modes, e.g. 44.1 kHz & 2^n frames" OFF)
|
||||
-option(OPUS_FIXED_POINT "Compile as fixed-point (for machines without a fast enough FPU)" OFF)
|
||||
-option(OPUS_ENABLE_FLOAT_API "Compile with the floating point API (for machines with float library" ON)
|
||||
-
|
||||
-include(opus/opus_functions.cmake)
|
||||
-
|
||||
-if(OPUS_STACK_PROTECTOR)
|
||||
- if(NOT MSVC) # GC on by default on MSVC
|
||||
- check_and_set_flag(STACK_PROTECTION_STRONG -fstack-protector-strong)
|
||||
- endif()
|
||||
-else()
|
||||
- if(MSVC)
|
||||
- check_and_set_flag(BUFFER_SECURITY_CHECK /GS-)
|
||||
- endif()
|
||||
-endif()
|
||||
-
|
||||
-add_library(opus STATIC
|
||||
- # CELT sources
|
||||
- opus/celt/bands.c
|
||||
- opus/celt/celt.c
|
||||
- opus/celt/celt_decoder.c
|
||||
- opus/celt/celt_encoder.c
|
||||
- opus/celt/celt_lpc.c
|
||||
- opus/celt/cwrs.c
|
||||
- opus/celt/entcode.c
|
||||
- opus/celt/entdec.c
|
||||
- opus/celt/entenc.c
|
||||
- opus/celt/kiss_fft.c
|
||||
- opus/celt/laplace.c
|
||||
- opus/celt/mathops.c
|
||||
- opus/celt/mdct.c
|
||||
- opus/celt/modes.c
|
||||
- opus/celt/pitch.c
|
||||
- opus/celt/quant_bands.c
|
||||
- opus/celt/rate.c
|
||||
- opus/celt/vq.c
|
||||
-
|
||||
- # SILK sources
|
||||
- opus/silk/A2NLSF.c
|
||||
- opus/silk/CNG.c
|
||||
- opus/silk/HP_variable_cutoff.c
|
||||
- opus/silk/LPC_analysis_filter.c
|
||||
- opus/silk/LPC_fit.c
|
||||
- opus/silk/LPC_inv_pred_gain.c
|
||||
- opus/silk/LP_variable_cutoff.c
|
||||
- opus/silk/NLSF2A.c
|
||||
- opus/silk/NLSF_VQ.c
|
||||
- opus/silk/NLSF_VQ_weights_laroia.c
|
||||
- opus/silk/NLSF_decode.c
|
||||
- opus/silk/NLSF_del_dec_quant.c
|
||||
- opus/silk/NLSF_encode.c
|
||||
- opus/silk/NLSF_stabilize.c
|
||||
- opus/silk/NLSF_unpack.c
|
||||
- opus/silk/NSQ.c
|
||||
- opus/silk/NSQ_del_dec.c
|
||||
- opus/silk/PLC.c
|
||||
- opus/silk/VAD.c
|
||||
- opus/silk/VQ_WMat_EC.c
|
||||
- opus/silk/ana_filt_bank_1.c
|
||||
- opus/silk/biquad_alt.c
|
||||
- opus/silk/bwexpander.c
|
||||
- opus/silk/bwexpander_32.c
|
||||
- opus/silk/check_control_input.c
|
||||
- opus/silk/code_signs.c
|
||||
- opus/silk/control_SNR.c
|
||||
- opus/silk/control_audio_bandwidth.c
|
||||
- opus/silk/control_codec.c
|
||||
- opus/silk/dec_API.c
|
||||
- opus/silk/decode_core.c
|
||||
- opus/silk/decode_frame.c
|
||||
- opus/silk/decode_indices.c
|
||||
- opus/silk/decode_parameters.c
|
||||
- opus/silk/decode_pitch.c
|
||||
- opus/silk/decode_pulses.c
|
||||
- opus/silk/decoder_set_fs.c
|
||||
- opus/silk/enc_API.c
|
||||
- opus/silk/encode_indices.c
|
||||
- opus/silk/encode_pulses.c
|
||||
- opus/silk/gain_quant.c
|
||||
- opus/silk/init_decoder.c
|
||||
- opus/silk/init_encoder.c
|
||||
- opus/silk/inner_prod_aligned.c
|
||||
- opus/silk/interpolate.c
|
||||
- opus/silk/lin2log.c
|
||||
- opus/silk/log2lin.c
|
||||
- opus/silk/pitch_est_tables.c
|
||||
- opus/silk/process_NLSFs.c
|
||||
- opus/silk/quant_LTP_gains.c
|
||||
- opus/silk/resampler.c
|
||||
- opus/silk/resampler_down2.c
|
||||
- opus/silk/resampler_down2_3.c
|
||||
- opus/silk/resampler_private_AR2.c
|
||||
- opus/silk/resampler_private_IIR_FIR.c
|
||||
- opus/silk/resampler_private_down_FIR.c
|
||||
- opus/silk/resampler_private_up2_HQ.c
|
||||
- opus/silk/resampler_rom.c
|
||||
- opus/silk/shell_coder.c
|
||||
- opus/silk/sigm_Q15.c
|
||||
- opus/silk/sort.c
|
||||
- opus/silk/stereo_LR_to_MS.c
|
||||
- opus/silk/stereo_MS_to_LR.c
|
||||
- opus/silk/stereo_decode_pred.c
|
||||
- opus/silk/stereo_encode_pred.c
|
||||
- opus/silk/stereo_find_predictor.c
|
||||
- opus/silk/stereo_quant_pred.c
|
||||
- opus/silk/sum_sqr_shift.c
|
||||
- opus/silk/table_LSF_cos.c
|
||||
- opus/silk/tables_LTP.c
|
||||
- opus/silk/tables_NLSF_CB_NB_MB.c
|
||||
- opus/silk/tables_NLSF_CB_WB.c
|
||||
- opus/silk/tables_gain.c
|
||||
- opus/silk/tables_other.c
|
||||
- opus/silk/tables_pitch_lag.c
|
||||
- opus/silk/tables_pulses_per_block.c
|
||||
-
|
||||
- # Opus sources
|
||||
- opus/src/analysis.c
|
||||
- opus/src/mapping_matrix.c
|
||||
- opus/src/mlp.c
|
||||
- opus/src/mlp_data.c
|
||||
- opus/src/opus.c
|
||||
- opus/src/opus_decoder.c
|
||||
- opus/src/opus_encoder.c
|
||||
- opus/src/opus_multistream.c
|
||||
- opus/src/opus_multistream_decoder.c
|
||||
- opus/src/opus_multistream_encoder.c
|
||||
- opus/src/opus_projection_decoder.c
|
||||
- opus/src/opus_projection_encoder.c
|
||||
- opus/src/repacketizer.c
|
||||
-)
|
||||
-
|
||||
-if (DEBUG)
|
||||
- target_sources(opus PRIVATE opus/silk/debug.c)
|
||||
-endif()
|
||||
-
|
||||
-if (OPUS_FIXED_POINT)
|
||||
- target_sources(opus PRIVATE
|
||||
- opus/silk/fixed/LTP_analysis_filter_FIX.c
|
||||
- opus/silk/fixed/LTP_scale_ctrl_FIX.c
|
||||
- opus/silk/fixed/apply_sine_window_FIX.c
|
||||
- opus/silk/fixed/autocorr_FIX.c
|
||||
- opus/silk/fixed/burg_modified_FIX.c
|
||||
- opus/silk/fixed/corrMatrix_FIX.c
|
||||
- opus/silk/fixed/encode_frame_FIX.c
|
||||
- opus/silk/fixed/find_LPC_FIX.c
|
||||
- opus/silk/fixed/find_LTP_FIX.c
|
||||
- opus/silk/fixed/find_pitch_lags_FIX.c
|
||||
- opus/silk/fixed/find_pred_coefs_FIX.c
|
||||
- opus/silk/fixed/k2a_FIX.c
|
||||
- opus/silk/fixed/k2a_Q16_FIX.c
|
||||
- opus/silk/fixed/noise_shape_analysis_FIX.c
|
||||
- opus/silk/fixed/pitch_analysis_core_FIX.c
|
||||
- opus/silk/fixed/prefilter_FIX.c
|
||||
- opus/silk/fixed/process_gains_FIX.c
|
||||
- opus/silk/fixed/regularize_correlations_FIX.c
|
||||
- opus/silk/fixed/residual_energy16_FIX.c
|
||||
- opus/silk/fixed/residual_energy_FIX.c
|
||||
- opus/silk/fixed/schur64_FIX.c
|
||||
- opus/silk/fixed/schur_FIX.c
|
||||
- opus/silk/fixed/solve_LS_FIX.c
|
||||
- opus/silk/fixed/vector_ops_FIX.c
|
||||
- opus/silk/fixed/warped_autocorrelation_FIX.c
|
||||
- )
|
||||
-else()
|
||||
- target_sources(opus PRIVATE
|
||||
- opus/silk/float/LPC_analysis_filter_FLP.c
|
||||
- opus/silk/float/LPC_inv_pred_gain_FLP.c
|
||||
- opus/silk/float/LTP_analysis_filter_FLP.c
|
||||
- opus/silk/float/LTP_scale_ctrl_FLP.c
|
||||
- opus/silk/float/apply_sine_window_FLP.c
|
||||
- opus/silk/float/autocorrelation_FLP.c
|
||||
- opus/silk/float/burg_modified_FLP.c
|
||||
- opus/silk/float/bwexpander_FLP.c
|
||||
- opus/silk/float/corrMatrix_FLP.c
|
||||
- opus/silk/float/encode_frame_FLP.c
|
||||
- opus/silk/float/energy_FLP.c
|
||||
- opus/silk/float/find_LPC_FLP.c
|
||||
- opus/silk/float/find_LTP_FLP.c
|
||||
- opus/silk/float/find_pitch_lags_FLP.c
|
||||
- opus/silk/float/find_pred_coefs_FLP.c
|
||||
- opus/silk/float/inner_product_FLP.c
|
||||
- opus/silk/float/k2a_FLP.c
|
||||
- opus/silk/float/noise_shape_analysis_FLP.c
|
||||
- opus/silk/float/pitch_analysis_core_FLP.c
|
||||
- opus/silk/float/process_gains_FLP.c
|
||||
- opus/silk/float/regularize_correlations_FLP.c
|
||||
- opus/silk/float/residual_energy_FLP.c
|
||||
- opus/silk/float/scale_copy_vector_FLP.c
|
||||
- opus/silk/float/scale_vector_FLP.c
|
||||
- opus/silk/float/schur_FLP.c
|
||||
- opus/silk/float/sort_FLP.c
|
||||
- opus/silk/float/warped_autocorrelation_FLP.c
|
||||
- opus/silk/float/wrappers_FLP.c
|
||||
- )
|
||||
-endif()
|
||||
-
|
||||
-target_compile_definitions(opus PRIVATE OPUS_BUILD ENABLE_HARDENING)
|
||||
-
|
||||
-if(NOT MSVC)
|
||||
- if(MINGW)
|
||||
- target_compile_definitions(opus PRIVATE _FORTIFY_SOURCE=0)
|
||||
- else()
|
||||
- target_compile_definitions(opus PRIVATE _FORTIFY_SOURCE=2)
|
||||
- endif()
|
||||
-endif()
|
||||
-
|
||||
-# It is strongly recommended to uncomment one of these VAR_ARRAYS: Use C99
|
||||
-# variable-length arrays for stack allocation USE_ALLOCA: Use alloca() for stack
|
||||
-# allocation If none is defined, then the fallback is a non-threadsafe global
|
||||
-# array
|
||||
-if(OPUS_USE_ALLOCA OR MSVC)
|
||||
- target_compile_definitions(opus PRIVATE USE_ALLOCA)
|
||||
-else()
|
||||
- target_compile_definitions(opus PRIVATE VAR_ARRAYS)
|
||||
-endif()
|
||||
-
|
||||
-if(OPUS_CUSTOM_MODES)
|
||||
- target_compile_definitions(opus PRIVATE CUSTOM_MODES)
|
||||
-endif()
|
||||
-
|
||||
-if(NOT OPUS_ENABLE_FLOAT_API)
|
||||
- target_compile_definitions(opus PRIVATE DISABLE_FLOAT_API)
|
||||
-endif()
|
||||
-
|
||||
-target_compile_definitions(opus
|
||||
-PUBLIC
|
||||
- -DOPUS_VERSION="\\"1.3.1\\""
|
||||
-
|
||||
-PRIVATE
|
||||
- # Use C99 intrinsics to speed up float-to-int conversion
|
||||
- HAVE_LRINTF
|
||||
-)
|
||||
-
|
||||
-if (FIXED_POINT)
|
||||
- target_compile_definitions(opus PRIVATE -DFIXED_POINT=1 -DDISABLE_FLOAT_API)
|
||||
-endif()
|
||||
-
|
||||
-target_include_directories(opus
|
||||
-PUBLIC
|
||||
- opus/include
|
||||
-
|
||||
-PRIVATE
|
||||
- opus/celt
|
||||
- opus/silk
|
||||
- opus/silk/fixed
|
||||
- opus/silk/float
|
||||
- opus/src
|
||||
-)
|
||||
--- src/core/CMakeLists.txt.orig 2020-11-07 06:39:05 UTC
|
||||
+++ src/core/CMakeLists.txt
|
||||
@@ -644,7 +644,7 @@ endif()
|
||||
create_target_directory_groups(core)
|
||||
|
||||
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
|
||||
-target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt::fmt nlohmann_json::nlohmann_json mbedtls opus zip)
|
||||
+target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt::fmt nlohmann_json::nlohmann_json mbedtls Opus::Opus zip)
|
||||
|
||||
if (YUZU_ENABLE_BOXCAT)
|
||||
target_compile_definitions(core PRIVATE -DYUZU_ENABLE_BOXCAT)
|
Loading…
Reference in a new issue