net/libcoap: update to 4.3.0

This commit is contained in:
Tobias C. Berner 2021-06-26 21:55:52 +02:00
parent 65673fb381
commit 14f1908038
6 changed files with 249 additions and 49 deletions

View file

@ -1,6 +1,6 @@
PORTNAME= libcoap
DISTVERSIONPREFIX= v
DISTVERSION= 4.2.1
DISTVERSION= 4.3.0
CATEGORIES= net
MAINTAINER= tcberner@FreeBSD.org
@ -9,7 +9,8 @@ COMMENT= C implementation of the Constrained Application Protocol
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= a2x:textproc/asciidoc
BUILD_DEPENDS= a2x:textproc/asciidoc \
gsed:textproc/gsed
LIB_DEPENDS= libgnutls.so:security/gnutls
USES= autoreconf gmake libtool pkgconfig
@ -18,17 +19,19 @@ GH_ACCOUNT= obgm
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
BINARY_ALIAS= sed=gsed
PORTSCOUT= limit:^4\.
PORTDOCS= *
OPTIONS_DEFINE= DOCS DOXYGEN
OPTIONS_DEFAULT= DOXYGEN
PORTDOCS= *
DOXYGEN_IMPLIES= DOCS
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
dot:graphics/graphviz
DOXYGEN_CONFIGURE_ENABLE= doxygen
INSTALL_TARGET= install-strip
PORTSCOUT= limit:^4\.
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1573058250
SHA256 (obgm-libcoap-v4.2.1_GH0.tar.gz) = 29a0394a265d3febee41e5e2dc03d34292a0aede37f5f80334e529ac0dab2321
SIZE (obgm-libcoap-v4.2.1_GH0.tar.gz) = 337438
TIMESTAMP = 1624736788
SHA256 (obgm-libcoap-v4.3.0_GH0.tar.gz) = 1a195adacd6188d3b71c476e7b21706fef7f3663ab1fb138652e8da49a9ec556
SIZE (obgm-libcoap-v4.3.0_GH0.tar.gz) = 495456

View file

@ -1,6 +1,6 @@
--- configure.ac.orig 2019-02-23 16:30:54 UTC
--- configure.ac.orig 2021-06-21 08:39:42 UTC
+++ configure.ac
@@ -616,7 +616,7 @@ case $host in
@@ -826,7 +826,7 @@ case $host in
#AC_SUBST(OS_MACOS)
;;

View file

@ -1,7 +1,7 @@
--- doc/Makefile.am.orig 2019-02-23 16:40:11 UTC
--- doc/Makefile.am.orig 2021-06-21 08:39:42 UTC
+++ doc/Makefile.am
@@ -68,8 +68,8 @@ man-page-build: man-page-start
echo ' <tab type="user" visible="yes" url="@ref deprecated" title="Deprecated Items" intro=""/>' >> $(top_builddir)/doc/insert_file ;\
@@ -112,8 +112,8 @@ man-page-build: upg-page-build man-page-start
echo ' </tab>' >> $(top_builddir)/doc/insert_file ;\
## Create and Update the DoxygenLayout.xml file
$(DOXYGEN) -l ;\
- $(SED) -i 's/<tab type="pages" visible="yes" /<tab type="pages" visible="no" /g' $(top_builddir)/doc/DoxygenLayout.xml ;\
@ -11,7 +11,7 @@
$(RM) $(top_builddir)/doc/insert_file ;\
## Fix up man html files, fixing links, UC Name and Synopsis
for FILE in $${MAN_FILES} ; do \
@@ -77,8 +77,8 @@ man-page-build: man-page-start
@@ -121,8 +121,8 @@ man-page-build: upg-page-build man-page-start
if [ -f $(top_builddir)/man/$${BASE}.html ]; then \
cp -f $(top_builddir)/man/$${BASE}.html $(top_builddir)/doc/man_html/$${BASE}.html ;\
## Correct case sensitive Name and Synopsis
@ -22,7 +22,7 @@
else \
echo "ERROR: $(top_builddir)/man/$${BASE}.html not found!";\
exit 1 ;\
@@ -87,7 +87,7 @@ man-page-build: man-page-start
@@ -131,7 +131,7 @@ man-page-build: upg-page-build man-page-start
EBASE=`basename $${ENTRY} | cut -d . -f1` ;\
MANUAL=`egrep -B 1 "^====" $${ENTRY} | head -1` ;\
SECTION=`echo $${MANUAL} | cut -d\( -f2 | cut -d\) -f1` ;\

View file

@ -0,0 +1,10 @@
--- man/examples-code-check.c.orig 2021-06-26 19:47:52 UTC
+++ man/examples-code-check.c
@@ -16,6 +16,7 @@
#include <stdlib.h>
#include <sys/stat.h>
#include <sys/types.h>
+#include <sys/wait.h>
#include <dirent.h>
#include <errno.h>
#include <string.h>

View file

@ -1,59 +1,246 @@
bin/coap-client
bin/coap-client-gnutls
bin/coap-rd
bin/coap-rd-gnutls
bin/coap-server
include/coap2/address.h
include/coap2/async.h
include/coap2/bits.h
include/coap2/block.h
include/coap2/coap.h
include/coap2/coap_debug.h
include/coap2/coap_dtls.h
include/coap2/coap_event.h
include/coap2/coap_forward_decls.h
include/coap2/coap_hashkey.h
include/coap2/coap_io.h
include/coap2/coap_mutex.h
include/coap2/coap_session.h
include/coap2/coap_time.h
include/coap2/encode.h
include/coap2/libcoap.h
include/coap2/mem.h
include/coap2/net.h
include/coap2/option.h
include/coap2/pdu.h
include/coap2/prng.h
include/coap2/resource.h
include/coap2/str.h
include/coap2/subscribe.h
include/coap2/uri.h
include/coap2/uthash.h
lib/libcoap-2-gnutls.a
lib/libcoap-2-gnutls.so
lib/libcoap-2-gnutls.so.2
lib/libcoap-2-gnutls.so.2.0.1
libdata/pkgconfig/libcoap-2-gnutls.pc
bin/coap-server-gnutls
include/coap3/address.h
include/coap3/async.h
include/coap3/block.h
include/coap3/coap.h
include/coap3/coap_cache.h
include/coap3/coap_debug.h
include/coap3/coap_dtls.h
include/coap3/coap_event.h
include/coap3/coap_forward_decls.h
include/coap3/coap_hashkey.h
include/coap3/coap_io.h
include/coap3/coap_mutex.h
include/coap3/coap_prng.h
include/coap3/coap_session.h
include/coap3/coap_time.h
include/coap3/encode.h
include/coap3/libcoap.h
include/coap3/mem.h
include/coap3/net.h
include/coap3/option.h
include/coap3/pdu.h
include/coap3/resource.h
include/coap3/str.h
include/coap3/subscribe.h
include/coap3/uri.h
lib/libcoap-3-gnutls.a
lib/libcoap-3-gnutls.so
lib/libcoap-3-gnutls.so.3
lib/libcoap-3-gnutls.so.3.0.0
lib/libcoap-3.a
lib/libcoap-3.so
libdata/pkgconfig/libcoap-3-gnutls.pc
libdata/pkgconfig/libcoap-3.pc
man/man3/coap_add_attr.3.gz
man/man3/coap_add_data.3.gz
man/man3/coap_add_data_blocked_response.3.gz
man/man3/coap_add_data_large_request.3.gz
man/man3/coap_add_data_large_response.3.gz
man/man3/coap_add_option.3.gz
man/man3/coap_add_optlist_pdu.3.gz
man/man3/coap_add_resource.3.gz
man/man3/coap_add_token.3.gz
man/man3/coap_async.3.gz
man/man3/coap_async_get_app_data.3.gz
man/man3/coap_async_is_supported.3.gz
man/man3/coap_async_set_app_data.3.gz
man/man3/coap_async_set_delay.3.gz
man/man3/coap_attribute.3.gz
man/man3/coap_binary_equal.3.gz
man/man3/coap_block.3.gz
man/man3/coap_block_build_body.3.gz
man/man3/coap_cache.3.gz
man/man3/coap_cache_delete_key.3.gz
man/man3/coap_cache_derive_key.3.gz
man/man3/coap_cache_derive_key_w_ignore.3.gz
man/man3/coap_cache_get_app_data.3.gz
man/man3/coap_cache_get_by_key.3.gz
man/man3/coap_cache_get_by_pdu.3.gz
man/man3/coap_cache_get_pdu.3.gz
man/man3/coap_cache_ignore_options.3.gz
man/man3/coap_cache_set_app_data.3.gz
man/man3/coap_cancel_observe.3.gz
man/man3/coap_check_option.3.gz
man/man3/coap_context.3.gz
man/man3/coap_context_get_coap_fd.3.gz
man/man3/coap_context_get_csm_timeout.3.gz
man/man3/coap_context_get_max_handshake_sessions.3.gz
man/man3/coap_context_get_max_idle_sessions.3.gz
man/man3/coap_context_get_session_timeout.3.gz
man/man3/coap_context_set_block_mode.3.gz
man/man3/coap_context_set_csm_timeout.3.gz
man/man3/coap_context_set_keepalive.3.gz
man/man3/coap_context_set_max_handshake_sessions.3.gz
man/man3/coap_context_set_max_idle_sessions.3.gz
man/man3/coap_context_set_pki.3.gz
man/man3/coap_context_set_pki_root_cas.3.gz
man/man3/coap_encode_var_bytes.3.gz
man/man3/coap_context_set_psk2.3.gz
man/man3/coap_context_set_session_timeout.3.gz
man/man3/coap_debug_set_packet_loss.3.gz
man/man3/coap_decode_var_bytes.3.gz
man/man3/coap_decode_var_bytes8.3.gz
man/man3/coap_delete_bin_const.3.gz
man/man3/coap_delete_binary.3.gz
man/man3/coap_delete_cache_entry.3.gz
man/man3/coap_delete_optlist.3.gz
man/man3/coap_delete_resource.3.gz
man/man3/coap_delete_str_const.3.gz
man/man3/coap_delete_string.3.gz
man/man3/coap_dtls_cpsk_t.3.gz
man/man3/coap_dtls_is_supported.3.gz
man/man3/coap_dtls_pki_t.3.gz
man/man3/coap_dtls_spsk_t.3.gz
man/man3/coap_encode_var_safe.3.gz
man/man3/coap_encode_var_safe8.3.gz
man/man3/coap_encryption.3.gz
man/man3/coap_endpoint_client.3.gz
man/man3/coap_endpoint_server.3.gz
man/man3/coap_endpoint_set_default_mtu.3.gz
man/man3/coap_endpoint_str.3.gz
man/man3/coap_find_async.3.gz
man/man3/coap_find_attr.3.gz
man/man3/coap_free_async.3.gz
man/man3/coap_free_context.3.gz
man/man3/coap_free_endpoint.3.gz
man/man3/coap_get_data.3.gz
man/man3/coap_get_data_large.3.gz
man/man3/coap_get_log_level.3.gz
man/man3/coap_get_tls_library_version.3.gz
man/man3/coap_handler.3.gz
man/man3/coap_insert_optlist.3.gz
man/man3/coap_io.3.gz
man/man3/coap_io_do_epoll.3.gz
man/man3/coap_io_do_io.3.gz
man/man3/coap_io_prepare_epoll.3.gz
man/man3/coap_io_prepare_io.3.gz
man/man3/coap_io_process.3.gz
man/man3/coap_io_process_with_fds.3.gz
man/man3/coap_join_mcast_group_intf.3.gz
man/man3/coap_keepalive.3.gz
man/man3/coap_log.3.gz
man/man3/coap_logging.3.gz
man/man3/coap_make_str_const.3.gz
man/man3/coap_new_bin_const.3.gz
man/man3/coap_new_binary.3.gz
man/man3/coap_new_cache_entry.3.gz
man/man3/coap_new_client_session.3.gz
man/man3/coap_new_client_session_pki.3.gz
man/man3/coap_new_client_session_psk2.3.gz
man/man3/coap_new_context.3.gz
man/man3/coap_new_endpoint.3.gz
man/man3/coap_new_optlist.3.gz
man/man3/coap_new_pdu.3.gz
man/man3/coap_new_str_const.3.gz
man/man3/coap_new_string.3.gz
man/man3/coap_observe.3.gz
man/man3/coap_opt_length.3.gz
man/man3/coap_opt_value.3.gz
man/man3/coap_option_filter_clear.3.gz
man/man3/coap_option_filter_get.3.gz
man/man3/coap_option_filter_set.3.gz
man/man3/coap_option_filter_unset.3.gz
man/man3/coap_option_iterator_init.3.gz
man/man3/coap_option_next.3.gz
man/man3/coap_package_name.3.gz
man/man3/coap_package_version.3.gz
man/man3/coap_pdu_access.3.gz
man/man3/coap_pdu_get_code.3.gz
man/man3/coap_pdu_get_mid.3.gz
man/man3/coap_pdu_get_token.3.gz
man/man3/coap_pdu_get_type.3.gz
man/man3/coap_pdu_init.3.gz
man/man3/coap_pdu_set_code.3.gz
man/man3/coap_pdu_set_mid.3.gz
man/man3/coap_pdu_set_type.3.gz
man/man3/coap_pdu_setup.3.gz
man/man3/coap_recovery.3.gz
man/man3/coap_register_async.3.gz
man/man3/coap_register_event_handler.3.gz
man/man3/coap_register_handler.3.gz
man/man3/coap_register_nack_handler.3.gz
man/man3/coap_register_ping_handler.3.gz
man/man3/coap_register_pong_handler.3.gz
man/man3/coap_register_response_handler.3.gz
man/man3/coap_resize_binary.3.gz
man/man3/coap_resource.3.gz
man/man3/coap_resource_get_uri_path.3.gz
man/man3/coap_resource_get_userdata.3.gz
man/man3/coap_resource_init.3.gz
man/man3/coap_resource_notify_observers.3.gz
man/man3/coap_resource_proxy_uri_init.3.gz
man/man3/coap_resource_release_userdata_handler.3.gz
man/man3/coap_resource_set_get_observable.3.gz
man/man3/coap_resource_set_mode.3.gz
man/man3/coap_resource_set_userdata.3.gz
man/man3/coap_resource_unknown_init.3.gz
man/man3/coap_send.3.gz
man/man3/coap_session.3.gz
man/man3/coap_session_disconnected.3.gz
man/man3/coap_session_get_ack_random_factor.3.gz
man/man3/coap_session_get_ack_timeout.3.gz
man/man3/coap_session_get_addr_local.3.gz
man/man3/coap_session_get_addr_remote.3.gz
man/man3/coap_session_get_app_data.3.gz
man/man3/coap_session_get_context.3.gz
man/man3/coap_session_get_ifindex.3.gz
man/man3/coap_session_get_max_retransmit.3.gz
man/man3/coap_session_get_proto.3.gz
man/man3/coap_session_get_psk_hint.3.gz
man/man3/coap_session_get_psk_key.3.gz
man/man3/coap_session_get_state.3.gz
man/man3/coap_session_get_tls.3.gz
man/man3/coap_session_get_type.3.gz
man/man3/coap_session_init_token.3.gz
man/man3/coap_session_max_pdu_size.3.gz
man/man3/coap_session_new_token.3.gz
man/man3/coap_session_reference.3.gz
man/man3/coap_session_release.3.gz
man/man3/coap_session_set_ack_random_factor.3.gz
man/man3/coap_session_set_ack_timeout.3.gz
man/man3/coap_session_set_app_data.3.gz
man/man3/coap_session_set_max_retransmit.3.gz
man/man3/coap_session_set_mtu.3.gz
man/man3/coap_session_set_type_client.3.gz
man/man3/coap_session_str.3.gz
man/man3/coap_set_log_handler.3.gz
man/man3/coap_set_log_level.3.gz
man/man3/coap_set_show_pdu_output.3.gz
man/man3/coap_show_pdu.3.gz
man/man3/coap_show_tls_version.3.gz
man/man3/coap_split_path.3.gz
man/man3/coap_split_query.3.gz
man/man3/coap_string.3.gz
man/man3/coap_string_equal.3.gz
man/man3/coap_string_tls_support.3.gz
man/man3/coap_string_tls_version.3.gz
man/man3/coap_tcp_is_supported.3.gz
man/man3/coap_tls_is_supported.3.gz
man/man3/coap_tls_library.3.gz
man/man5/coap-client-gnutls.5.gz
man/man5/coap-client-mbedtls.5.gz
man/man5/coap-client-notls.5.gz
man/man5/coap-client-openssl.5.gz
man/man5/coap-client.5.gz
man/man5/coap-rd-gnutls.5.gz
man/man5/coap-rd-mbedtls.5.gz
man/man5/coap-rd-notls.5.gz
man/man5/coap-rd-openssl.5.gz
man/man5/coap-rd.5.gz
man/man5/coap-server-gnutls.5.gz
man/man5/coap-server-mbedtls.5.gz
man/man5/coap-server-notls.5.gz
man/man5/coap-server-openssl.5.gz
man/man5/coap-server.5.gz
man/man7/coap.7.gz
%%DATADIR%%/examples/COPYING
%%DATADIR%%/examples/LICENSE
%%DATADIR%%/examples/Makefile
%%DATADIR%%/examples/README
%%DATADIR%%/examples/coap-client.c
%%DATADIR%%/examples/coap-server.c