Portlint, deinstall cleanly, and put the .jar files where they belong.

PR:		17835
Submitted by:	Palle Girgensohn <girgen@partitur.se>
This commit is contained in:
Steve Price 2000-04-30 19:41:31 +00:00
parent c25fa1c462
commit 1515c6a207
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=28173
5 changed files with 25 additions and 5 deletions

View file

@ -28,6 +28,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX}\
--libdir=${LOCALBASE}/libexec/apache\
--with-logdir=/var/log\
--sysconfdir=${PREFIX}/etc/apache\
--with-apxs=${LOCALBASE}/sbin/apxs\
--with-jdk-home=${LOCALBASE}/jdk1.1.8\
--with-JSDK=${LOCALBASE}/share/java/classes/jsdk.jar\
--with-java=${LOCALBASE}/jdk1.1.8/bin/java\
@ -36,6 +37,12 @@ CONFIGURE_ARGS= --prefix=${PREFIX}\
--with-gnu-ld\
--enable-compressed-jar\
--enable-EAPI
.if defined (USE_JIKES)
CONFIGURE_ARGS+=--with-javac=${LOCALBASE}/bin/jikes
.endif
pre-install:
${MKDIR} ${PREFIX}/share/java/classes
post-install:
@${CAT} ${PKGDIR}/MESSAGE

View file

@ -1,11 +1,11 @@
--- conf/jserv.properties.in.orig Wed Jan 26 18:26:31 2000
+++ conf/jserv.properties.in Wed Jan 26 18:28:44 2000
--- conf/jserv.properties.in.orig Sat Jan 15 01:58:57 2000
+++ conf/jserv.properties.in Fri Apr 7 01:57:42 2000
@@ -53,8 +53,15 @@
# MUST NOT be in this classpath or the classpath of the shell
# you start the Apache from.
#
-wrapper.classpath=@JSERV_CLASSES@
+wrapper.classpath=@libexecdir@/ApacheJServ.jar
+wrapper.classpath=@prefix@/share/java/classes/ApacheJServ.jar
wrapper.classpath=@JSDK_CLASSES@
+# Uncomment if you use Cocoon.
+#wrapper.classpath=@prefix@/share/java/classes/Cocoon.jar

View file

@ -16,7 +16,7 @@
+ i += size;
+ }
+ stream.close();
+ return new ByteArrayInputStream(data);;
+ return new ByteArrayInputStream(data);
} else {
return null;
}

View file

@ -0,0 +1,11 @@
--- src/java/Makefile.in.orig Fri Apr 7 01:36:25 2000
+++ src/java/Makefile.in Fri Apr 7 01:37:51 2000
@@ -109,7 +109,7 @@
SUBDIRS = org
ARCHIVE = $(PACKAGE).jar
-jardir = ${libexecdir}
+jardir = $(prefix)/share/java/classes
jar_DATA = ${ARCHIVE}
# VT: NOTE: This is not going to be as bad as in ECS because the findstring

View file

@ -1,7 +1,7 @@
etc/apache/jserv/jserv.conf
etc/apache/jserv/jserv.properties
etc/apache/jserv/zone.properties
libexec/apache/ApacheJServ.jar
share/java/classes/ApacheJServ.jar
libexec/apache/mod_jserv.so
share/java/servlets/Hello.class
share/java/servlets/Hello.java
@ -158,3 +158,5 @@ docs/api/overview-frame.html
@dirrm share/doc/mod_jserv/install
@dirrm share/doc/mod_jserv/protocol
@dirrm share/doc/mod_jserv
@unexec rmdir %D/share/java/classes > /dev/null 2>&1 || true
@unexec rmdir %D/share/java > /dev/null 2>&1 || true