Add new port science/ghemical
a computational chemistry software package
This commit is contained in:
parent
ca986960a9
commit
1553328576
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=80095
7 changed files with 225 additions and 0 deletions
|
@ -9,6 +9,7 @@
|
|||
SUBDIR += gchempaint
|
||||
SUBDIR += gchemutils
|
||||
SUBDIR += gdis
|
||||
SUBDIR += ghemical
|
||||
SUBDIR += glens
|
||||
SUBDIR += libctl
|
||||
SUBDIR += libsvm
|
||||
|
|
41
science/ghemical/Makefile
Normal file
41
science/ghemical/Makefile
Normal file
|
@ -0,0 +1,41 @@
|
|||
# New ports collection makefile for: ghemical
|
||||
# Date created: May 4, 2003
|
||||
# Whom: Nakata Maho <maho@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ghemical
|
||||
PORTVERSION= 1.00
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= http://www.uku.fi/~thassine/ghemical/download/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= maho@FreeBSD.org
|
||||
COMMENT= Ghemical is a computational chemistry software package
|
||||
|
||||
BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
|
||||
${LOCALBASE}/lib/libmpqc.a:${PORTSDIR}/science/mpqc
|
||||
LIB_DEPENDS= gtkgl:${PORTSDIR}/x11-toolkits/gtkglarea \
|
||||
glade-gnome:${PORTSDIR}/devel/libglade
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GTK= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-mpqc
|
||||
|
||||
USE_AUTOCONF= yes
|
||||
USE_AUTOCONF_VER= 253
|
||||
|
||||
pre-configure:
|
||||
@cd ${WRKDIR}/${DISTNAME} ; ${AUTOCONF}
|
||||
|
||||
pre-patch:
|
||||
@${REINPLACE_CMD} -e 's|gtk-config|${GTK_CONFIG}|g;' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|gtk-config|${GTK_CONFIG}|g; s|-lgtk|-lgtk12|g;' \
|
||||
${WRKSRC}/Makefile.in
|
||||
pre-build:
|
||||
@${REINPLACE_CMD} -e 's|f2c.h|g2c.h|g;' ${WRKSRC}/miniMOPAC/*.c
|
||||
@${REINPLACE_CMD} -e 's|f2c.h|g2c.h|g;' ${WRKSRC}/src/common/qm1e_mopac.cpp
|
||||
.include <bsd.port.mk>
|
1
science/ghemical/distinfo
Normal file
1
science/ghemical/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (ghemical-1.00.tgz) = bbc177c1433f5fec9ee8c10468561564
|
15
science/ghemical/files/patch-configure.in
Normal file
15
science/ghemical/files/patch-configure.in
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- configure.in.orig Wed Jun 5 21:10:50 2002
|
||||
+++ configure.in Wed Jul 17 21:08:10 2002
|
||||
@@ -104,7 +104,12 @@
|
||||
#AC_CHECK_LIB([ibs], [main])
|
||||
|
||||
# Checks for header files.
|
||||
+saved_CFLAGS="$CFLAGS"
|
||||
+LIBS="$LIBS $GTKGL_LIBS $GTK_LIBS"
|
||||
+CFLAGS="$CFLAGS $GTKGL_CFLAGS $GTK_CFLAGS"
|
||||
AC_CHECK_HEADERS(GL/glut.h)
|
||||
+LIBS="$LIBS $saved_LIBS"
|
||||
+CFLAGS="$saved_CFLAGS"
|
||||
|
||||
# Checks for typedefs, structures, and compiler characteristics.
|
||||
AC_PROG_CC_STDC
|
15
science/ghemical/files/patch-src:common:Makefile.in
Normal file
15
science/ghemical/files/patch-src:common:Makefile.in
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- src/common/Makefile.in~ Thu Jun 20 06:19:02 2002
|
||||
+++ src/common/Makefile.in Wed Jul 17 21:39:28 2002
|
||||
@@ -24,7 +24,11 @@
|
||||
-I$(top_srcdir)/src/common \
|
||||
-I$(top_srcdir)/openbabel \
|
||||
-I$(top_builddir)/src \
|
||||
- @SC_CPPFLAGS@
|
||||
+ @SC_CPPFLAGS@ \
|
||||
+ @GTK_CFLAGS@ \
|
||||
+ @GNOME_INCLUDEDIR@ \
|
||||
+ @GTKGL_CFLAGS@ \
|
||||
+ @LIBGLADE_INCLUDES@
|
||||
LIBS= @LIBS@
|
||||
|
||||
CFLAGS= @CFLAGS@
|
8
science/ghemical/pkg-descr
Normal file
8
science/ghemical/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
Ghemical is a computational chemistry software package,
|
||||
|
||||
Ghemical relies on external code to provide the quantum-mechanical calculations.
|
||||
Semi-empirical methods MNDO, MINDO/3, AM1 and PM3 come from the MOPAC7 package,
|
||||
and are included in the source distribution. The
|
||||
MPQC package (GNU GPL) is used to provide ab initio methods.
|
||||
|
||||
WWW: http://www.uku.fi/~thassine/ghemical/
|
144
science/ghemical/pkg-plist
Normal file
144
science/ghemical/pkg-plist
Normal file
|
@ -0,0 +1,144 @@
|
|||
bin/ghemical
|
||||
share/ghemical/1.00/aromatic.txt
|
||||
share/ghemical/1.00/atomtyp.txt
|
||||
share/ghemical/1.00/element.txt
|
||||
share/ghemical/1.00/extable.txt
|
||||
share/ghemical/1.00/glade/file_export_dialog.glade
|
||||
share/ghemical/1.00/glade/file_import_dialog.glade
|
||||
share/ghemical/1.00/glade/geomopt_dialog.glade
|
||||
share/ghemical/1.00/glade/moldyn_dialog.glade
|
||||
share/ghemical/1.00/glade/setup_mm1_dialog.glade
|
||||
share/ghemical/1.00/glade/setup_qm1_dialog.glade
|
||||
share/ghemical/1.00/glade/trajview_dialog.glade
|
||||
share/ghemical/1.00/parameters/builder/amino.txt
|
||||
share/ghemical/1.00/parameters/builder/nucleic.txt
|
||||
share/ghemical/1.00/parameters/mm1param/stable/atomtypes.txt
|
||||
share/ghemical/1.00/parameters/mm1param/stable/parameters1.txt
|
||||
share/ghemical/1.00/parameters/mm1param/stable/parameters2.txt
|
||||
share/ghemical/1.00/parameters/mm1param/stable/parameters3.txt
|
||||
share/ghemical/1.00/parameters/mm1param/stable/parameters4.txt
|
||||
share/ghemical/1.00/parameters/mm1param/stable/parameters5.txt
|
||||
share/ghemical/1.00/parameters/mm1param/unstable/atomtypes.txt
|
||||
share/ghemical/1.00/parameters/mm1param/unstable/parameters1.txt
|
||||
share/ghemical/1.00/parameters/mm1param/unstable/parameters2.txt
|
||||
share/ghemical/1.00/parameters/mm1param/unstable/parameters3.txt
|
||||
share/ghemical/1.00/parameters/mm1param/unstable/parameters4.txt
|
||||
share/ghemical/1.00/parameters/mm1param/unstable/parameters5.txt
|
||||
share/ghemical/1.00/parameters/mm2param/loopdip.txt
|
||||
share/ghemical/1.00/parameters/mm2param/looptor.txt
|
||||
share/ghemical/1.00/parameters/mm2param/nonbonded.txt
|
||||
share/ghemical/1.00/phmodel.txt
|
||||
share/ghemical/1.00/resdata.txt
|
||||
share/ghemical/1.00/types.txt
|
||||
share/ghemical/examples/1gar.mm2gp
|
||||
share/ghemical/examples/1hcl.mm2gp
|
||||
share/ghemical/examples/2-chlorobutane.gpr
|
||||
share/ghemical/examples/2-chlorobutane.mm1gp
|
||||
share/ghemical/examples/3-phenylpropanal.gpr
|
||||
share/ghemical/examples/3-phenylpropanal.mm1gp
|
||||
share/ghemical/examples/4rhn.mm2gp
|
||||
share/ghemical/examples/PeriodicTable.gpr
|
||||
share/ghemical/examples/PeriodicTable.mm1gp
|
||||
share/ghemical/examples/acetylsalicylic_acid.gpr
|
||||
share/ghemical/examples/acetylsalicylic_acid.mm1gp
|
||||
share/ghemical/examples/alpha-pinene.gpr
|
||||
share/ghemical/examples/alpha-pinene.mm1gp
|
||||
share/ghemical/examples/bromobenzene.gpr
|
||||
share/ghemical/examples/bromobenzene.mm1gp
|
||||
share/ghemical/examples/camphor.gpr
|
||||
share/ghemical/examples/camphor.mm1gp
|
||||
share/ghemical/examples/cinnamaldehyde.gpr
|
||||
share/ghemical/examples/cinnamaldehyde.mm1gp
|
||||
share/ghemical/examples/cis-2-pentene.gpr
|
||||
share/ghemical/examples/cis-2-pentene.mm1gp
|
||||
share/ghemical/examples/cyclohexane.gpr
|
||||
share/ghemical/examples/cyclohexane.mm1gp
|
||||
share/ghemical/examples/naphtalene.gpr
|
||||
share/ghemical/examples/naphtalene.mm1gp
|
||||
share/gnome/help/ghemical/C/MD.html
|
||||
share/gnome/help/ghemical/C/MD_viewer.html
|
||||
share/gnome/help/ghemical/C/aa_table.html
|
||||
share/gnome/help/ghemical/C/add_hydrogens.html
|
||||
share/gnome/help/ghemical/C/conf_search_tools.html
|
||||
share/gnome/help/ghemical/C/energy_vs_torsion.html
|
||||
share/gnome/help/ghemical/C/filetypes.html
|
||||
share/gnome/help/ghemical/C/formula.html
|
||||
share/gnome/help/ghemical/C/geometry_optimization.html
|
||||
share/gnome/help/ghemical/C/images/2atoms_bond.png
|
||||
share/gnome/help/ghemical/C/images/2atoms_unbonded.png
|
||||
share/gnome/help/ghemical/C/images/aa_builder_ci.png
|
||||
share/gnome/help/ghemical/C/images/aa_builder_menu.png
|
||||
share/gnome/help/ghemical/C/images/aa_builder_note.png
|
||||
share/gnome/help/ghemical/C/images/aa_builder_w_h.png
|
||||
share/gnome/help/ghemical/C/images/aa_builder_wo_h.png
|
||||
share/gnome/help/ghemical/C/images/add_hydrogens.png
|
||||
share/gnome/help/ghemical/C/images/add_hydrogens_select.png
|
||||
share/gnome/help/ghemical/C/images/change_bond_dialog.png
|
||||
share/gnome/help/ghemical/C/images/change_bond_select.png
|
||||
share/gnome/help/ghemical/C/images/ci_plane.png
|
||||
share/gnome/help/ghemical/C/images/cyclohexane1.png
|
||||
share/gnome/help/ghemical/C/images/cyclohexane2.png
|
||||
share/gnome/help/ghemical/C/images/cyclohexane_optimized.png
|
||||
share/gnome/help/ghemical/C/images/cyclohexane_unoptimized.png
|
||||
share/gnome/help/ghemical/C/images/draw_button.png
|
||||
share/gnome/help/ghemical/C/images/draw_hydrogens.png
|
||||
share/gnome/help/ghemical/C/images/energy_vs_torsion1.png
|
||||
share/gnome/help/ghemical/C/images/energy_vs_torsion2.png
|
||||
share/gnome/help/ghemical/C/images/energy_vs_torsion3.png
|
||||
share/gnome/help/ghemical/C/images/energy_vs_torsion4.png
|
||||
share/gnome/help/ghemical/C/images/enlevdiag.png
|
||||
share/gnome/help/ghemical/C/images/esp-plane_mm.png
|
||||
share/gnome/help/ghemical/C/images/esp-plane_qm.png
|
||||
share/gnome/help/ghemical/C/images/esp-plane_select.png
|
||||
share/gnome/help/ghemical/C/images/esp-plane_select_obj.png
|
||||
share/gnome/help/ghemical/C/images/first_atom.png
|
||||
share/gnome/help/ghemical/C/images/formula.png
|
||||
share/gnome/help/ghemical/C/images/formula_select.png
|
||||
share/gnome/help/ghemical/C/images/geometry_op_dialog.png
|
||||
share/gnome/help/ghemical/C/images/geometry_optimization_select.png
|
||||
share/gnome/help/ghemical/C/images/labels_menu.png
|
||||
share/gnome/help/ghemical/C/images/mainmenu.png
|
||||
share/gnome/help/ghemical/C/images/maintools.png
|
||||
share/gnome/help/ghemical/C/images/md_dialog.png
|
||||
share/gnome/help/ghemical/C/images/modal.png
|
||||
share/gnome/help/ghemical/C/images/new_mm.png
|
||||
share/gnome/help/ghemical/C/images/notebook.png
|
||||
share/gnome/help/ghemical/C/images/optimized_ethane.png
|
||||
share/gnome/help/ghemical/C/images/periodic_button.png
|
||||
share/gnome/help/ghemical/C/images/periodic_table.png
|
||||
share/gnome/help/ghemical/C/images/remove_hydrogens.png
|
||||
share/gnome/help/ghemical/C/images/ribbon.png
|
||||
share/gnome/help/ghemical/C/images/sequence_builder.png
|
||||
share/gnome/help/ghemical/C/images/toplevel.png
|
||||
share/gnome/help/ghemical/C/images/traj_dialog.png
|
||||
share/gnome/help/ghemical/C/images/window.png
|
||||
share/gnome/help/ghemical/C/import_types.html
|
||||
share/gnome/help/ghemical/C/index.html
|
||||
share/gnome/help/ghemical/C/introduction.html
|
||||
share/gnome/help/ghemical/C/labels.html
|
||||
share/gnome/help/ghemical/C/mdi_mode.html
|
||||
share/gnome/help/ghemical/C/measure.html
|
||||
share/gnome/help/ghemical/C/perspective.html
|
||||
share/gnome/help/ghemical/C/references.html
|
||||
share/gnome/help/ghemical/C/ribbon.html
|
||||
share/gnome/help/ghemical/C/sequence_builder.html
|
||||
share/gnome/help/ghemical/C/using_mm.html
|
||||
share/gnome/help/ghemical/C/using_qm.html
|
||||
share/gnome/help/ghemical/C/using_sf.html
|
||||
share/gnome/help/ghemical/C/visualization.html
|
||||
@dirrm share/gnome/help/ghemical/C/images
|
||||
@dirrm share/gnome/help/ghemical/C
|
||||
@dirrm share/gnome/help/ghemical
|
||||
@dirrm share/gnome/help
|
||||
@dirrm share/gnome
|
||||
@dirrm share/ghemical/examples
|
||||
@dirrm share/ghemical/1.00/parameters/mm2param
|
||||
@dirrm share/ghemical/1.00/parameters/mm1param/unstable
|
||||
@dirrm share/ghemical/1.00/parameters/mm1param/stable
|
||||
@dirrm share/ghemical/1.00/parameters/mm1param
|
||||
@dirrm share/ghemical/1.00/parameters/builder
|
||||
@dirrm share/ghemical/1.00/parameters
|
||||
@dirrm share/ghemical/1.00/glade
|
||||
@dirrm share/ghemical/1.00
|
||||
@dirrm share/ghemical
|
||||
|
Loading…
Reference in a new issue