Update to nmh-1.0.2:

Documentation update providing current support channels.
	No show-stopping bugs fixed, just lots of nits.

Changes to the actual port:

	Simplify handling of PREFIX.
	Use autoconf.
	Use DOT_LOCKING, not FLOCK_LOCKING. (IMPORTANT)
	Tweak DESCR to make it more obvious that this is an MUA.

PR:		15423
Submitted by:	maintainer
This commit is contained in:
Sheldon Hearn 1999-12-22 17:32:04 +00:00
parent 39e0ff9ee1
commit 157e05f118
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=23818
6 changed files with 73 additions and 200 deletions

View file

@ -1 +1 @@
MD5 (nmh-1.0.tar.gz) = 712f93d485ab77a7b28e5abaa7341034
MD5 (nmh-1.0.2.tar.gz) = eb0ab031b13bf9d10406661c7ad86e50

View file

@ -1,46 +1,35 @@
--- ../nmh-0.19.ORIG/acconfig.h Mon Dec 1 07:52:31 1997
+++ acconfig.h Mon Jan 5 20:03:43 1998
@@ -36,9 +36,9 @@
* OpenBSD 2.x
* BSD/OS 2.x
*/
-/* #define BIND 1 */
-/* #define BSD42 1 */
-/* #define BSD44 1 */
+#define BIND 1
+#define BSD42 1
+#define BSD44 1
/*
* SCO 4.x
@@ -58,7 +58,7 @@
* group and add the setgid bit to `inc' manually after
* installation.
*/
-/* #define MAILGROUP 1 */
+#define MAILGROUP 1
/*
* Turn on locale (setlocale) support
@@ -71,10 +71,10 @@
* other programs which may modify your maildrops.
* Currently you can only use one type.
*/
-#define DOT_LOCKING 1
+/* #define DOT_LOCKING 1 */
/* #define FCNTL_LOCKING 1 */
/* #define LOCKF_LOCKING 1 */
-/* #define FLOCK_LOCKING 1 */
+#define FLOCK_LOCKING 1
/*
* If you have defined DOT_LOCKING, then the default is to
@@ -154,7 +154,7 @@
/*
* The prefix to use when messages are "removed" by rmm.
diff -ur ../../nmh-1.0.2-DIST/acconfig.h ./acconfig.h
--- ../../nmh-1.0.2-DIST/acconfig.h Thu Oct 21 11:58:09 1999
+++ ./acconfig.h Sat Dec 11 11:54:28 1999
@@ -104,7 +104,7 @@
* The prefix which is prepended to the name of messages when they
* are "removed" by rmm. This should typically be `,' or `#'
*/
-#define BACKUP_PREFIX ","
+#define BACKUP_PREFIX "#"
/*
* Name of link to file to which you are replying.
@@ -128,11 +128,11 @@
/* Defined for Solaris 2.x, Irix, OSF/1, HP-UX, AIX */
#undef SVR4
/* Defined for SunOS 4, FreeBSD, NetBSD, OpenBSD, BSD/OS, Mac OS X/Rhapsody */
-#undef BSD44
+#define BSD44
/* Defined for SunOS 4, FreeBSD, NetBSD, OpenBSD, BSD/OS, Mac OS X/Rhapsody
* -- does PicoBSD have uname? :) */
-#undef BSD42
+#define BSD42
/* Defined for SCO5 */
#undef SCO_5_STDIO
@@ -231,7 +231,7 @@
* not world writable. There are no guarantees as to the safety of doing this,
* but this #define will add some extra security checks.
*/
-#undef MAILGROUP
+#define MAILGROUP
/* Define ruserpass as _ruserpass if your libraries have a bug *
* such that it can't find ruserpass, but can find _ruserpass. */

View file

@ -1,23 +1,7 @@
diff -udr ../nmh-0.19.ORIG/Makefile.in ./Makefile.in
--- ../nmh-0.19.ORIG/Makefile.in Sat Jul 26 06:38:35 1997
+++ ./Makefile.in Mon Jan 5 20:29:42 1998
@@ -26,7 +26,7 @@
bindir = @bindir@
# location of support binaries and scripts
-libdir = @libdir@
+libexecdir = @libexecdir@
# location of nmh configuration and formats files
etcdir = @sysconfdir@
@@ -59,12 +59,13 @@
MAKEDEFS = CC='$(CC)' CPPFLAGS='$(CPPFLAGS)' DEFS='$(DEFS)' \
CFLAGS='$(CFLAGS)' LDFLAGS='$(LDFLAGS)' LIBS='$(LIBS)' \
prefix='$(prefix)' exec_prefix='$(exec_prefix)' bindir='$(bindir)' \
-etcdir='$(etcdir)' libdir='$(libdir)' mandir='$(mandir)' \
+etcdir='$(etcdir)' libexecdir='$(libexecdir)' mandir='$(mandir)' \
mailspool='$(mailspool)' sendmailpath='$(sendmailpath)' \
default_editor='$(default_editor)' default_pager='$(default_pager)'
diff -ur ../../nmh-1.0.2-DIST/Makefile.in ./Makefile.in
--- ../../nmh-1.0.2-DIST/Makefile.in Sun Sep 26 12:43:15 1999
+++ ./Makefile.in Sat Dec 11 11:54:28 1999
@@ -65,6 +65,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
@ -25,117 +9,38 @@ diff -udr ../nmh-0.19.ORIG/Makefile.in ./Makefile.in
INSTALL_DATA = @INSTALL_DATA@
.SUFFIXES:
diff -udr ../nmh-0.19.ORIG/configure.in ./configure.in
--- ../nmh-0.19.ORIG/configure.in Wed Dec 17 01:18:12 1997
+++ ./configure.in Mon Jan 5 20:20:08 1998
@@ -400,7 +400,7 @@
eval "nmhbin=${bindir}"; eval "nmhbin2=${nmhbin}"
eval "nmhsysconf=${sysconfdir}"; eval "nmhsysconf2=${nmhsysconf}"
-eval "nmhlib=${libdir}"; eval "nmhlib2=${nmhlib}"
+eval "nmhlib=${libexecdir}"; eval "nmhlib2=${nmhlib}"
eval "nmhman=${mandir}"
echo "
@@ -413,7 +413,7 @@
linker flags : ${LDFLAGS}
source code location : ${srcdir}
binary install path : ${nmhbin2}
-libary install path : ${nmhlib2}
+libexec install path : ${nmhlib2}
config files install path : ${nmhsysconf2}
man page install path : ${nmhman}"
echo ""
diff -udr ../nmh-0.26.ORIG/etc/Makefile.in ./etc/Makefile.in
--- ../nmh-0.26.ORIG/etc/Makefile.in Sat May 16 21:05:03 1998
+++ ./etc/Makefile.in Mon Jun 1 21:05:45 1998
@@ -13,13 +13,14 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
bindir = @bindir@
-libdir = @libdir@
+libexecdir = @libexecdir@
etcdir = @sysconfdir@
mailspool = @mailspool@
diff -ur ../../nmh-1.0.2-DIST/etc/Makefile.in ./etc/Makefile.in
--- ../../nmh-1.0.2-DIST/etc/Makefile.in Thu Jul 15 17:43:04 1999
+++ ./etc/Makefile.in Sat Dec 11 12:12:53 1999
@@ -20,6 +20,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_DATA = @INSTALL_DATA@
# Path to search for programs to display content
@@ -86,9 +87,9 @@
done
# Path to search for programs to handle MIME
@@ -89,7 +90,7 @@
install-scripts:
- $(top_srcdir)/mkinstalldirs $(libdir)
+ $(top_srcdir)/mkinstalldirs $(libexecdir)
$(top_srcdir)/mkinstalldirs $(libdir)
for script in $(SCRIPTS); do \
- $(INSTALL_PROGRAM) $(srcdir)/$$script $(libdir)/$$script; \
+ $(INSTALL_SCRIPT) $(srcdir)/$$script $(libexecdir)/$$script; \
+ $(INSTALL_SCRIPT) $(srcdir)/$$script $(libdir)/$$script; \
done
uninstall: uninstall-files uninstall-scripts
@@ -100,7 +101,7 @@
uninstall-scripts:
for script in $(SCRIPTS); do \
- rm -f $(libdir)/$$script; \
+ rm -f $(libexecdir)/$$script; \
diff -ur ../../nmh-1.0.2-DIST/man/Makefile.in ./man/Makefile.in
--- ../../nmh-1.0.2-DIST/man/Makefile.in Wed Oct 13 07:56:41 1999
+++ ./man/Makefile.in Sat Dec 11 11:52:33 1999
@@ -146,8 +146,9 @@
$(INSTALL_DATA) $$file $(mandir)/man$(manext5) ; \
done
if [ ! -f mh_profile.$(manext5) ] ; then \
- ( cd $(mandir)/man$(manext5) ; ln mh-profile.$(manext5) \
- mh_profile.$(manext5) ) \
+ ( cd $(mandir)/man$(manext5) ; \
+ rm -f mh_profile.$(manext5) ; \
+ ln mh-profile.$(manext5) mh_profile.$(manext5) ) \
fi
# ========== DEPENDENCIES FOR CLEANUP ==========
diff -udr ../nmh-0.19.ORIG/uip/Makefile.in ./uip/Makefile.in
--- ../nmh-0.19.ORIG/uip/Makefile.in Thu Dec 4 02:16:04 1997
+++ ./uip/Makefile.in Mon Jan 5 20:29:16 1998
@@ -13,7 +13,7 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
bindir = @bindir@
-libdir = @libdir@
+libexecdir = @libexecdir@
etcdir = @sysconfdir@
CC = @CC@
@@ -235,9 +235,9 @@
# install misc support binaries
install-misc:
- $(top_srcdir)/mkinstalldirs $(libdir)
+ $(top_srcdir)/mkinstalldirs $(libexecdir)
for misc in $(MISC); do \
- $(INSTALL_PROGRAM) $$misc $(libdir)/$$misc; \
+ $(INSTALL_PROGRAM) $$misc $(libexecdir)/$$misc; \
done
uninstall:
@@ -248,7 +248,7 @@
rm -f $(bindir)/$$lcmd; \
done
for misc in $(MISC); do \
- rm -f $(libdir)/$$misc; \
+ rm -f $(libexecdir)/$$misc; \
done
# ========== DEPENDENCIES FOR CLEANUP ==========
diff -udr ../nmh-0.19.ORIG/config/Makefile.in ./config/Makefile.in
--- ../nmh-0.19.ORIG/config/Makefile.in Sat Jul 26 06:38:57 1997
+++ ./config/Makefile.in Mon Jan 5 22:02:45 1998
@@ -17,6 +17,7 @@
exec_prefix = @exec_prefix@
bindir = @bindir@
libdir = @libdir@
+libexecdir = @libexecdir@
etcdir = @sysconfdir@
default_editor = @vipath@
@@ -26,7 +27,7 @@
CFLAGS = @CFLAGS@
DEFS = @DEFS@
INCLUDES = -I.. -I$(top_srcdir)
-CONFIGDEFS = -DNMHBINDIR='"$(bindir)"' -DNMHETCDIR='"$(etcdir)"' -DNMHLIBDIR='"$(libdir)"' \
+CONFIGDEFS = -DNMHBINDIR='"$(bindir)"' -DNMHETCDIR='"$(etcdir)"' -DNMHLIBDIR='"$(libdir)"' -DNMHLIBEXECDIR='"$(libexecdir)"' \
-DDEFAULT_EDITOR='"$(default_editor)"' -DDEFAULT_PAGER='"$(default_pager)"'
COMPILE = $(CC) -c $(DEFS) $(INCLUDES) $(CFLAGS)
# install the man pages in man8

View file

@ -1,37 +1,14 @@
--- ../nmh-0.19.ORIG/configure Sun Dec 28 12:19:27 1997
+++ configure Mon Jan 5 20:34:08 1998
@@ -967,6 +967,8 @@
# It thinks the first close brace ends the variable substitution.
test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
--- ../../nmh-1.0.2-DIST/configure.in Tue Oct 26 14:12:37 1999
+++ ./configure.in Sat Dec 11 11:54:28 1999
@@ -160,6 +160,11 @@
dnl ------------------
AC_PROG_MAKE_SET dnl Does make define $MAKE
AC_PROG_INSTALL dnl Check for BSD compatible `install'
+
+test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL} -m 755'
+
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
# Extract the first word of "ranlib", so it can be a program name with args.
set dummy ranlib; ac_word=$2
@@ -3449,6 +3451,7 @@
s%@CC@%$CC%g
s%@SET_MAKE@%$SET_MAKE%g
s%@INSTALL_PROGRAM@%$INSTALL_PROGRAM%g
+s%@INSTALL_SCRIPT@%$INSTALL_SCRIPT%g
s%@INSTALL_DATA@%$INSTALL_DATA%g
s%@RANLIB@%$RANLIB%g
s%@AWK@%$AWK%g
@@ -3692,7 +3695,7 @@
eval "nmhbin=${bindir}"; eval "nmhbin2=${nmhbin}"
eval "nmhsysconf=${sysconfdir}"; eval "nmhsysconf2=${nmhsysconf}"
-eval "nmhlib=${libdir}"; eval "nmhlib2=${nmhlib}"
+eval "nmhlib=${libexecdir}"; eval "nmhlib2=${nmhlib}"
eval "nmhman=${mandir}"
echo "
@@ -3705,7 +3708,7 @@
linker flags : ${LDFLAGS}
source code location : ${srcdir}
binary install path : ${nmhbin2}
-libary install path : ${nmhlib2}
+libexec install path : ${nmhlib2}
config files install path : ${nmhsysconf2}
man page install path : ${nmhman}"
echo ""
+AC_SUBST(INSTALL_SCRIPT)
+
AC_PROG_RANLIB dnl Check for `ranlib'
AC_PROG_AWK dnl Check for mawk,gawk,nawk, then awk
AC_PROG_LEX dnl Check for lex/flex

View file

@ -1,9 +1,10 @@
-----------
what is it?
What is it?
-----------
nmh (new MH) is an electronic mail handling system. It was originally
based on the package MH-6.8.3, and is intended to be a (mostly)
compatible drop-in replacement for MH.
nmh (new MH) is an electronic mail handling system - a MUA (Mail
User Agent) package for end-users to handle their e-mail. It was
originally based on the package MH-6.8.3, and is intended to be a
(mostly) compatible drop-in replacement for MH.
nmh consists of a collection of fairly simple single-purpose programs
to send, receive, save, retrieve, and manipulate e-mail messages. Since

View file

@ -51,6 +51,7 @@ etc/nmh/mhl.reply
etc/nmh/mhn.defaults
etc/nmh/mts.conf
etc/nmh/rcvdistcomps
etc/nmh/rcvdistcomps.outbox
etc/nmh/replcomps
etc/nmh/replgroupcomps
etc/nmh/scan.default