PR: ports/14303

Submitted by:Ade Lovett <ade@lovett.com>
Initial import.
a library for the GNOME component architecture.
This commit is contained in:
Yukihiro Nakai 1999-10-14 05:03:17 +00:00
parent 6d7f4a4423
commit 157fbd1bbc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=22422
7 changed files with 316 additions and 0 deletions

33
devel/bonobo/Makefile Normal file
View file

@ -0,0 +1,33 @@
# New ports collection makefile for: bonobo
# Version required: 0.4
# Date created: 8th October 1999
# Whom: Ade Lovett <ade@lovett.com>
#
# $FreeBSD$
#
DISTNAME= bonobo-0.4
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/bonobo
MAINTAINER= ade@lovett.com
LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs \
gdk_pixbuf.0:${PORTSDIR}/graphics/gdk-pixbuf
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_PERL5= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
LIBTOOLFILES= configure libefs/configure
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GLIB_CONFIG="${GLIB_CONFIG}" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>

1
devel/bonobo/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (bonobo-0.4.tar.gz) = 108b835663269416b100a0dfd7207c72

View file

@ -0,0 +1,19 @@
--- configure.orig Fri Oct 8 12:58:58 1999
+++ configure Fri Oct 8 13:06:30 1999
@@ -4454,6 +4454,8 @@
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
+ ac_save_LIBS="$LIBS"
+LIBS="-lintl $LIBS"
cat > conftest.$ac_ext <<EOF
#line 4459 "configure"
#include "confdefs.h"
@@ -4488,6 +4490,7 @@
eval "ac_cv_func_$ac_func=no"
fi
rm -f conftest*
+LIBS="$ac_save_LIBS"
fi
if eval "test \"`echo '$ac_cv_func_'$ac_func`\" = yes"; then

173
devel/bonobo/files/patch-ab Normal file
View file

@ -0,0 +1,173 @@
--- Makefile.in.orig Mon Sep 27 16:21:48 1999
+++ Makefile.in Fri Oct 8 13:45:53 1999
@@ -126,7 +126,7 @@
SUBDIRS = po intl idl libefs bonobo storage-modules components samples
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = bonoboConf.sh
EXTRA_DIST = bonoboConf.sh.in bonobo.spec.in
--- bonobo/Makefile.in.orig Mon Sep 27 16:22:01 1999
+++ bonobo/Makefile.in Fri Oct 8 13:46:36 1999
@@ -128,7 +128,7 @@
corba_DATA = sample.gnorba item.gnorba
-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -DSTORAGE_LIB=\""$(libdir)"\" -DG_LOG_DOMAIN=\"Bonobo\" -I$(srcdir) -I$(top_srcdir) -I. -I$(top_builddir) -I$(includedir) $(GNOME_INCLUDEDIR)
+INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DSTORAGE_LIB=\""$(libdir)"\" -DG_LOG_DOMAIN=\"Bonobo\" -I$(srcdir) -I$(top_srcdir) -I. -I$(top_builddir) -I$(includedir) $(GNOME_INCLUDEDIR)
gnome_libs = $(GNOME_LIBDIR) $(GNOMEUI_LIBS) $(GNOMEGNORBA_LIBS) $(INTLLIBS)
--- components/application-x-gnomine/Makefile.in.orig Mon Sep 27 16:22:05 1999
+++ components/application-x-gnomine/Makefile.in Fri Oct 8 13:47:29 1999
@@ -125,9 +125,9 @@
l = @l@
scoredir = $(localstatedir)/games
-Gamesdir = $(datadir)/gnome/apps/Games
+Gamesdir = $(datadir)/apps/Games
-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(includedir) $(GNOME_INCLUDEDIR)
+INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(includedir) $(GNOME_INCLUDEDIR)
#bin_PROGRAMS = gnomine bonobo-application-x-mines
@@ -146,7 +146,7 @@
bonobo_application_x_mines_SOURCES = minefield.h minefield.c bonobo-application-x-mines.c
-bonobo_application_x_mines_LDADD = $(GNOME_LIBDIR) -lbonobo $(GNOMEGNORBA_LIBS)
+bonobo_application_x_mines_LDADD = $(GNOME_LIBDIR) $(top_builddir)/bonobo/libbonobo.la $(GNOMEGNORBA_LIBS)
gnorbadir = $(sysconfdir)/CORBA/servers
--- components/audio-ulaw/Makefile.in.orig Mon Sep 27 16:22:12 1999
+++ components/audio-ulaw/Makefile.in Fri Oct 8 13:48:17 1999
@@ -124,14 +124,14 @@
cxxflags_set = @cxxflags_set@
l = @l@
-SUBDIRS = doc
+SUBDIRS = # doc
bin_PROGRAMS = bonobo-audio-ulaw
bonobo_audio_ulaw_SOURCES = bonobo-audio-ulaw.c bonobo-audio-ulaw.h item-audio.c item-audio.h color.c color.h
-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
+INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
bonobo_audio_ulaw_LDADD = $(top_builddir)/bonobo/libbonobo.la $(GTK_LIBS) $(GNOME_LIBDIR) $(GNOMEGNORBA_LIBS) $(INTLLIBS)
--- components/audio-ulaw/doc/C/Makefile.in.orig Mon Sep 27 16:22:14 1999
+++ components/audio-ulaw/doc/C/Makefile.in Fri Oct 8 13:49:03 1999
@@ -128,7 +128,7 @@
cxxflags_set = @cxxflags_set@
l = @l@
-audio_ulaw_helpdir = $(datadir)/gnome/bonobo/docs/audio_ulaw/C
+audio_ulaw_helpdir = $(datadir)/bonobo/docs/audio_ulaw/C
#
# Module configuration information
--- components/image-generic/Makefile.in.orig Mon Sep 27 16:22:06 1999
+++ components/image-generic/Makefile.in Fri Oct 8 13:49:51 1999
@@ -129,7 +129,7 @@
bonobo_image_generic_SOURCES = bonobo-image-generic.c
-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
+INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
bonobo_image_generic_LDADD = $(top_builddir)/bonobo/libbonobo.la $(GTK_LIBS) $(GNOME_LIBDIR) $(GNOMEGNORBA_LIBS) $(INTLLIBS) -lgdk_pixbuf
--- components/image-x-png/Makefile.in.orig Mon Sep 27 16:22:07 1999
+++ components/image-x-png/Makefile.in Fri Oct 8 13:50:29 1999
@@ -124,14 +124,14 @@
cxxflags_set = @cxxflags_set@
l = @l@
-SUBDIRS = doc
+SUBDIRS = # doc
bin_PROGRAMS = bonobo-image-x-png
bonobo_image_x_png_SOURCES = bonobo-image-x-png.c
-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
+INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
bonobo_image_x_png_LDADD = $(top_builddir)/bonobo/libbonobo.la $(GTK_LIBS) $(GNOME_LIBDIR) $(GNOMEGNORBA_LIBS) $(INTLLIBS) -lpng
--- components/image-x-png/doc/C/Makefile.in.orig Mon Sep 27 16:22:09 1999
+++ components/image-x-png/doc/C/Makefile.in Fri Oct 8 13:51:01 1999
@@ -128,7 +128,7 @@
cxxflags_set = @cxxflags_set@
l = @l@
-image_x_png_helpdir = $(datadir)/gnome/bonobo/docs/image_x_png/C
+image_x_png_helpdir = $(datadir)/bonobo/docs/image_x_png/C
#
# Module configuration information
--- components/text-plain/Makefile.in.orig Mon Sep 27 16:22:11 1999
+++ components/text-plain/Makefile.in Fri Oct 8 13:51:48 1999
@@ -129,7 +129,7 @@
bonobo_text_plain_SOURCES = bonobo-text-plain.c
-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
+INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
bonobo_text_plain_LDADD = $(top_builddir)/bonobo/libbonobo.la $(GTK_LIBS) $(GNOME_LIBDIR) $(GNOMEGNORBA_LIBS) $(INTLLIBS)
--- samples/Makefile.in.orig Mon Sep 27 16:22:16 1999
+++ samples/Makefile.in Fri Oct 8 13:53:54 1999
@@ -126,7 +126,7 @@
bin_PROGRAMS = paint-component-simple sample-container
-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
+INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I. -I$(includedir) $(GNOME_INCLUDEDIR) $(GTK_CFLAGS)
paint_component_simple_SOURCES = paint-component-simple.c
--- storage-modules/Makefile.in.orig Mon Sep 27 16:22:03 1999
+++ storage-modules/Makefile.in Fri Oct 8 13:54:29 1999
@@ -124,7 +124,7 @@
cxxflags_set = @cxxflags_set@
l = @l@
-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -I$(srcdir) -I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/libefs/src -I$(includedir) $(GNOME_INCLUDEDIR)
+INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -I$(srcdir) -I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/libefs/src -I$(includedir) $(GNOME_INCLUDEDIR)
common_ldflags = -avoid-version
--- po/Makefile.in.in.orig Mon Sep 27 15:26:21 1999
+++ po/Makefile.in.in Fri Oct 8 14:08:03 1999
@@ -18,8 +18,8 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
-datadir = $(prefix)/@DATADIRNAME@
-localedir = $(datadir)/locale
+datadir = $(prefix)/share/locale
+localedir = $(prefix)/share/locale
gnulocaledir = $(prefix)/share/locale
gettextsrcdir = $(prefix)/share/gettext/po
subdir = po
--- libefs/Makefile.in.orig Mon Sep 27 16:21:53 1999
+++ libefs/Makefile.in Fri Oct 8 14:18:17 1999
@@ -78,7 +78,7 @@
USE_SYMBOL_UNDERSCORE = @USE_SYMBOL_UNDERSCORE@
VERSION = @VERSION@
-SUBDIRS = src doc
+SUBDIRS = src # doc
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/../mkinstalldirs
CONFIG_HEADER = config.h

1
devel/bonobo/pkg-comment Normal file
View file

@ -0,0 +1 @@
The component and compound document system for GNOME

9
devel/bonobo/pkg-descr Normal file
View file

@ -0,0 +1,9 @@
Bonobo is a set of language and system independant CORBA
interfaces for creating reusable components and creating compound
documents.
The Bonobo distribution includes a Gtk+ based implementation of the
Bonobo interfaces, enabling developers to create reusable components
and applications that can be used to form more complex documents.
WWW: http://www.gnome.org/

80
devel/bonobo/pkg-plist Normal file
View file

@ -0,0 +1,80 @@
bin/bonobo-application-x-mines
bin/bonobo-audio-ulaw
bin/bonobo-image-generic
bin/bonobo-image-x-png
bin/bonobo-text-plain
bin/efstool
bin/paint-component-simple
bin/sample-container
etc/CORBA/servers/application-x-mines.gnorba
etc/CORBA/servers/audio-ulaw.gnorba
etc/CORBA/servers/image-generic.gnorba
etc/CORBA/servers/image-x-png.gnorba
etc/CORBA/servers/item.gnorba
etc/CORBA/servers/paint-component-simple.gnorba
etc/CORBA/servers/sample.gnorba
etc/CORBA/servers/text-plain.gnorba
etc/bonoboConf.sh
include/bonobo/bonobo.h
include/bonobo/gnome-bonobo-item.h
include/bonobo/gnome-bonobo-selector.h
include/bonobo/gnome-bonobo-widget.h
include/bonobo/gnome-bonobo.h
include/bonobo/gnome-canvas-component.h
include/bonobo/gnome-client-site.h
include/bonobo/gnome-component-io.h
include/bonobo/gnome-container.h
include/bonobo/gnome-embeddable-factory.h
include/bonobo/gnome-embeddable.h
include/bonobo/gnome-main.h
include/bonobo/gnome-moniker-client.h
include/bonobo/gnome-moniker.h
include/bonobo/gnome-object-client.h
include/bonobo/gnome-object-io.h
include/bonobo/gnome-object.h
include/bonobo/gnome-persist-file.h
include/bonobo/gnome-persist-stream.h
include/bonobo/gnome-persist.h
include/bonobo/gnome-progressive.h
include/bonobo/gnome-storage.h
include/bonobo/gnome-stream-client.h
include/bonobo/gnome-stream-fs.h
include/bonobo/gnome-stream-memory.h
include/bonobo/gnome-stream.h
include/bonobo/gnome-ui-handler.h
include/bonobo/gnome-view-frame.h
include/bonobo/gnome-view.h
include/bonobo/gnome-wrapper.h
include/efs.h
lib/libbonobo.a
lib/libbonobo.so.0
lib/libbonobo.so
lib/libefs.a
lib/libstorage_efs.so
lib/libstorage_fs.so
share/gnome/apps/Games/gnomine.desktop
share/gnome/idl/bonobo.idl
share/gnome/idl/gnome-advise.idl
share/gnome/idl/gnome-canvas.idl
share/gnome/idl/gnome-client-site.idl
share/gnome/idl/gnome-container.idl
share/gnome/idl/gnome-embeddable.idl
share/gnome/idl/gnome-persist.idl
share/gnome/idl/gnome-progressive.idl
share/gnome/idl/gnome-storage.idl
share/gnome/idl/gnome-ui-handler.idl
share/gnome/mime-info/bonobo.keys
share/locale/da/LC_MESSAGES/bonobo.mo
share/locale/de/LC_MESSAGES/bonobo.mo
share/locale/el/LC_MESSAGES/bonobo.mo
share/locale/es/LC_MESSAGES/bonobo.mo
share/locale/fr/LC_MESSAGES/bonobo.mo
share/locale/it/LC_MESSAGES/bonobo.mo
share/locale/no/LC_MESSAGES/bonobo.mo
share/locale/pl/LC_MESSAGES/bonobo.mo
share/locale/ru/LC_MESSAGES/bonobo.mo
share/locale/sv/LC_MESSAGES/bonobo.mo
share/locale/wa/LC_MESSAGES/bonobo.mo
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@dirrm include/bonobo