- Update to 1.0.3

PR:		92536
Submitted by:	triosoft@triosoft.com.ua (maintainer)
This commit is contained in:
Tim Bishop 2006-02-06 13:50:33 +00:00
parent 20bfef583b
commit 162e7e23a5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=155329
28 changed files with 40 additions and 378 deletions

View file

@ -5,17 +5,18 @@
# $FreeBSD$
PORTNAME= k9copy
PORTVERSION= 1.0.2
PORTVERSION= 1.0.3
CATEGORIES= multimedia kde
MASTER_SITES= http://k9copy.free.fr/
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= triosoft@triosoft.com.ua
COMMENT= A DVD-9 to DVD-5 shrinking application for KDE
LIB_DEPENDS= dvdread.3:${PORTSDIR}/multimedia/libdvdread
RUN_DEPENDS= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
vamps:${PORTSDIR}/multimedia/vamps
dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
vamps:${PORTSDIR}/multimedia/vamps
USE_KDELIBS_VER=3
USE_REINPLACE= yes

View file

@ -1,3 +1,3 @@
MD5 (k9copy-1.0.2.tar.gz) = 9037dfa804a6f758c5df7e641c67127d
SHA256 (k9copy-1.0.2.tar.gz) = 1432c327ea38aeaffcfe34c99637ec90b09e31552c132a947a0a0f9e36dfa9e2
SIZE (k9copy-1.0.2.tar.gz) = 1154768
MD5 (k9copy-1.0.3.tar.gz) = 4ba308eb696c2b3c66df65e341e84ee5
SHA256 (k9copy-1.0.3.tar.gz) = 50f8a52fbc767e3bc8f25841eba87135854459c3eae118a96d12e184f955da0d
SIZE (k9copy-1.0.3.tar.gz) = 1048825

View file

@ -1,15 +0,0 @@
--- libk9copy/k9backupdlg.cpp.orig Thu Jan 5 06:08:21 2006
+++ libk9copy/k9backupdlg.cpp Thu Jan 5 06:08:38 2006
@@ -18,7 +18,11 @@
* 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
***************************************************************************/
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include <qtimer.h>
#include <qdatetime.h>
#include <qapplication.h>

View file

@ -1,15 +0,0 @@
--- libk9copy/k9cell.h.orig Thu Jan 5 06:09:52 2006
+++ libk9copy/k9cell.h Thu Jan 5 06:10:12 2006
@@ -22,7 +22,11 @@
#include <qobject.h>
#include <qobjectlist.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include "k9dvdtitle.h"
enum streamType_t {stAudio,stVideo,stSubpicture,stOther};
/**

View file

@ -1,15 +0,0 @@
--- libk9copy/k9cellcopylist.h.orig Thu Jan 5 06:10:57 2006
+++ libk9copy/k9cellcopylist.h Thu Jan 5 06:11:13 2006
@@ -24,7 +24,11 @@
#include "k9dvd.h"
#include "k9cell.h"
#include <dvdread/ifo_types.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
class k9CellCopyVTS {
private:

View file

@ -1,28 +1,15 @@
--- libk9copy/k9dvd.cpp.orig Fri Dec 9 19:18:03 2005
+++ libk9copy/k9dvd.cpp Thu Jan 5 06:12:30 2006
@@ -27,7 +27,11 @@
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include "k9dvd.h"
#include "k9dvdtitle.h"
@@ -196,7 +200,7 @@
--- libk9copy/k9dvd.cpp.orig Mon Jan 16 10:40:01 2006
+++ libk9copy/k9dvd.cpp Mon Jan 16 10:40:33 2006
@@ -199,7 +199,7 @@
return -1;
}
- if ( fseek(filehandle, 32808, SEEK_SET )) {
+ if ( fseek(filehandle, 32768, SEEK_SET )) {
fclose(filehandle);
c.sprintf(tr2i18n("Couldn't seek in %s for title\n"), dvd_device);
c=i18n("Couldn't seek in %1 for title\n").arg( dvd_device);
setError(c);
@@ -204,12 +208,18 @@
@@ -207,12 +207,19 @@
return -1;
}
@ -39,6 +26,7 @@
+ }
+ snprintf( title, 32, "%s", tempBuf + 40 );
+ i=32;
+
}
fclose (filehandle);

View file

@ -1,15 +0,0 @@
--- libk9copy/k9dvd.h.orig Thu Jan 5 06:13:32 2006
+++ libk9copy/k9dvd.h Thu Jan 5 06:13:58 2006
@@ -25,7 +25,11 @@
#include <qobjectlist.h>
#include <qdatetime.h>
#include <qvaluelist.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include <dvdread/ifo_types.h>

View file

@ -1,15 +0,0 @@
--- libk9copy/k9dvdbackup.h.orig Thu Jan 5 06:16:05 2006
+++ libk9copy/k9dvdbackup.h Thu Jan 5 06:16:20 2006
@@ -26,7 +26,11 @@
#include <qobjectlist.h>
#include "k9cell.h"
#include <dvdread/ifo_types.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include "k9cellcopylist.h"
/**
@author Jean-Michel Petit

View file

@ -1,15 +0,0 @@
--- libk9copy/k9dvdtitle.cpp.orig Thu Jan 5 06:16:57 2006
+++ libk9copy/k9dvdtitle.cpp Thu Jan 5 06:17:14 2006
@@ -31,7 +31,11 @@
#include <stdlib.h>
#include <unistd.h>
#include <qvaluelist.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
//*******************k9DVDAudioStream**************

View file

@ -1,12 +0,0 @@
--- libk9copy/k9ifo.cpp.orig Sun Dec 18 23:40:34 2005
+++ libk9copy/k9ifo.cpp Sun Dec 18 23:40:52 2005
@@ -21,6 +21,9 @@
#include <dvdread/dvd_reader.h>
#include <dvdread/ifo_read.h>
#include <dvdread/ifo_print.h>
+#ifdef __FreeBSD__
+#include <osreldate.h>
+#endif
#include "bswap.h"
#ifndef DVD_BLOCK_LEN

View file

@ -1,11 +0,0 @@
--- src/Makefile.in.orig Tue Jan 3 04:57:30 2006
+++ src/Makefile.in Tue Jan 3 04:57:42 2006
@@ -439,7 +439,7 @@
shellrcdir = $(kde_datadir)/k9copy
shellrc_DATA = k9copyui.rc
applnkApplication_DATA = K9copy.desktop
-applnkApplicationdir = $(kde_appsdir)/Application
+applnkApplicationdir = $(kde_appsdir)/Multimedia
AM_CXXFLAGS = -O2 -g3
#>- all: all-am
#>+ 1

View file

@ -1,15 +0,0 @@
--- src/kburndvd.cpp.orig Thu Jan 5 06:04:49 2006
+++ src/kburndvd.cpp Thu Jan 5 06:05:18 2006
@@ -24,7 +24,11 @@
#include <qdir.h>
#include <kmessagebox.h>
#include <kprocess.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include <kfiledialog.h>
kBurnDVD::kBurnDVD()

View file

@ -1,34 +0,0 @@
--- src/kcddrive.cpp.orig Sun Dec 18 18:36:56 2005
+++ src/kcddrive.cpp Fri Jan 6 18:01:33 2006
@@ -21,6 +21,7 @@
#include "kcddrive.h"
#include <kprocess.h>
+#include <sys/param.h>
#include <sys/mount.h>
kCDDrive::kCDDrive() {
canReadDVD=false;
@@ -55,7 +56,7 @@
if (process->isRunning()) process->wait(-1);
delete process;
*/
- umount(device.latin1());
+ unmount(device.latin1(),0);
dev->eject();
}
}
@@ -99,6 +100,7 @@
void kCDDrives::scanDrives() {
int i;
drives.clear();
+ dm->clear();
dm->scanBus();
dm->scanFstab();
@@ -128,4 +130,4 @@
/** No descriptions */
kCDDrive * kCDDrives::getDrive(int num) {
return (kCDDrive *)drives.at(num);
-}
\ No newline at end of file
+}

View file

@ -2,16 +2,18 @@ bin/k9copy
include/k9backupdlg.h
include/k9cell.h
include/k9cellcopylist.h
include/k9common.h
include/k9dvd.h
include/k9dvdauthor.h
include/k9dvdbackup.h
include/k9dvdprogress.h
include/k9dvdsize.h
include/k9dvdtitle.h
include/k9ifo.h
lib/libk9copy.la
lib/libk9copy.so
lib/libk9copy.so.0
share/applnk/Multimedia/K9copy.desktop
share/applnk/Multimedia/k9copy.desktop
share/apps/k9copy/k9copyui.rc
%%PORTDOCS%%%%DOCSDIR%%/index.cache.bz2
%%PORTDOCS%%%%DOCSDIR%%/index.docbook
@ -20,11 +22,13 @@ share/icons/hicolor/16x16/apps/k9copy.png
share/icons/hicolor/32x32/apps/k9copy.png
share/icons/hicolor/48x48/apps/k9copy.png
share/locale/cs/LC_MESSAGES/k9copy.mo
share/locale/de/LC_MESSAGES/k9copy.mo
share/locale/el/LC_MESSAGES/k9copy.mo
share/locale/en_GB/LC_MESSAGES/k9copy.mo
share/locale/es/LC_MESSAGES/k9copy.mo
share/locale/fr/LC_MESSAGES/k9copy.mo
share/locale/hu/LC_MESSAGES/k9copy.mo
share/locale/it/LC_MESSAGES/k9copy.mo
share/locale/pt_BR/LC_MESSAGES/k9copy.mo
share/locale/ru/LC_MESSAGES/k9copy.mo
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/apps/k9copy

View file

@ -5,17 +5,18 @@
# $FreeBSD$
PORTNAME= k9copy
PORTVERSION= 1.0.2
PORTVERSION= 1.0.3
CATEGORIES= multimedia kde
MASTER_SITES= http://k9copy.free.fr/
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= triosoft@triosoft.com.ua
COMMENT= A DVD-9 to DVD-5 shrinking application for KDE
LIB_DEPENDS= dvdread.3:${PORTSDIR}/multimedia/libdvdread
RUN_DEPENDS= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
vamps:${PORTSDIR}/multimedia/vamps
dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
vamps:${PORTSDIR}/multimedia/vamps
USE_KDELIBS_VER=3
USE_REINPLACE= yes

View file

@ -1,3 +1,3 @@
MD5 (k9copy-1.0.2.tar.gz) = 9037dfa804a6f758c5df7e641c67127d
SHA256 (k9copy-1.0.2.tar.gz) = 1432c327ea38aeaffcfe34c99637ec90b09e31552c132a947a0a0f9e36dfa9e2
SIZE (k9copy-1.0.2.tar.gz) = 1154768
MD5 (k9copy-1.0.3.tar.gz) = 4ba308eb696c2b3c66df65e341e84ee5
SHA256 (k9copy-1.0.3.tar.gz) = 50f8a52fbc767e3bc8f25841eba87135854459c3eae118a96d12e184f955da0d
SIZE (k9copy-1.0.3.tar.gz) = 1048825

View file

@ -1,15 +0,0 @@
--- libk9copy/k9backupdlg.cpp.orig Thu Jan 5 06:08:21 2006
+++ libk9copy/k9backupdlg.cpp Thu Jan 5 06:08:38 2006
@@ -18,7 +18,11 @@
* 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
***************************************************************************/
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include <qtimer.h>
#include <qdatetime.h>
#include <qapplication.h>

View file

@ -1,15 +0,0 @@
--- libk9copy/k9cell.h.orig Thu Jan 5 06:09:52 2006
+++ libk9copy/k9cell.h Thu Jan 5 06:10:12 2006
@@ -22,7 +22,11 @@
#include <qobject.h>
#include <qobjectlist.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include "k9dvdtitle.h"
enum streamType_t {stAudio,stVideo,stSubpicture,stOther};
/**

View file

@ -1,15 +0,0 @@
--- libk9copy/k9cellcopylist.h.orig Thu Jan 5 06:10:57 2006
+++ libk9copy/k9cellcopylist.h Thu Jan 5 06:11:13 2006
@@ -24,7 +24,11 @@
#include "k9dvd.h"
#include "k9cell.h"
#include <dvdread/ifo_types.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
class k9CellCopyVTS {
private:

View file

@ -1,28 +1,15 @@
--- libk9copy/k9dvd.cpp.orig Fri Dec 9 19:18:03 2005
+++ libk9copy/k9dvd.cpp Thu Jan 5 06:12:30 2006
@@ -27,7 +27,11 @@
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include "k9dvd.h"
#include "k9dvdtitle.h"
@@ -196,7 +200,7 @@
--- libk9copy/k9dvd.cpp.orig Mon Jan 16 10:40:01 2006
+++ libk9copy/k9dvd.cpp Mon Jan 16 10:40:33 2006
@@ -199,7 +199,7 @@
return -1;
}
- if ( fseek(filehandle, 32808, SEEK_SET )) {
+ if ( fseek(filehandle, 32768, SEEK_SET )) {
fclose(filehandle);
c.sprintf(tr2i18n("Couldn't seek in %s for title\n"), dvd_device);
c=i18n("Couldn't seek in %1 for title\n").arg( dvd_device);
setError(c);
@@ -204,12 +208,18 @@
@@ -207,12 +207,19 @@
return -1;
}
@ -39,6 +26,7 @@
+ }
+ snprintf( title, 32, "%s", tempBuf + 40 );
+ i=32;
+
}
fclose (filehandle);

View file

@ -1,15 +0,0 @@
--- libk9copy/k9dvd.h.orig Thu Jan 5 06:13:32 2006
+++ libk9copy/k9dvd.h Thu Jan 5 06:13:58 2006
@@ -25,7 +25,11 @@
#include <qobjectlist.h>
#include <qdatetime.h>
#include <qvaluelist.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include <dvdread/ifo_types.h>

View file

@ -1,15 +0,0 @@
--- libk9copy/k9dvdbackup.h.orig Thu Jan 5 06:16:05 2006
+++ libk9copy/k9dvdbackup.h Thu Jan 5 06:16:20 2006
@@ -26,7 +26,11 @@
#include <qobjectlist.h>
#include "k9cell.h"
#include <dvdread/ifo_types.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include "k9cellcopylist.h"
/**
@author Jean-Michel Petit

View file

@ -1,15 +0,0 @@
--- libk9copy/k9dvdtitle.cpp.orig Thu Jan 5 06:16:57 2006
+++ libk9copy/k9dvdtitle.cpp Thu Jan 5 06:17:14 2006
@@ -31,7 +31,11 @@
#include <stdlib.h>
#include <unistd.h>
#include <qvaluelist.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
//*******************k9DVDAudioStream**************

View file

@ -1,12 +0,0 @@
--- libk9copy/k9ifo.cpp.orig Sun Dec 18 23:40:34 2005
+++ libk9copy/k9ifo.cpp Sun Dec 18 23:40:52 2005
@@ -21,6 +21,9 @@
#include <dvdread/dvd_reader.h>
#include <dvdread/ifo_read.h>
#include <dvdread/ifo_print.h>
+#ifdef __FreeBSD__
+#include <osreldate.h>
+#endif
#include "bswap.h"
#ifndef DVD_BLOCK_LEN

View file

@ -1,11 +0,0 @@
--- src/Makefile.in.orig Tue Jan 3 04:57:30 2006
+++ src/Makefile.in Tue Jan 3 04:57:42 2006
@@ -439,7 +439,7 @@
shellrcdir = $(kde_datadir)/k9copy
shellrc_DATA = k9copyui.rc
applnkApplication_DATA = K9copy.desktop
-applnkApplicationdir = $(kde_appsdir)/Application
+applnkApplicationdir = $(kde_appsdir)/Multimedia
AM_CXXFLAGS = -O2 -g3
#>- all: all-am
#>+ 1

View file

@ -1,15 +0,0 @@
--- src/kburndvd.cpp.orig Thu Jan 5 06:04:49 2006
+++ src/kburndvd.cpp Thu Jan 5 06:05:18 2006
@@ -24,7 +24,11 @@
#include <qdir.h>
#include <kmessagebox.h>
#include <kprocess.h>
-#include <stdint.h>
+#ifdef HAVE_STDINT_H
+ #include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+ #include <inttypes.h>
+#endif
#include <kfiledialog.h>
kBurnDVD::kBurnDVD()

View file

@ -1,34 +0,0 @@
--- src/kcddrive.cpp.orig Sun Dec 18 18:36:56 2005
+++ src/kcddrive.cpp Fri Jan 6 18:01:33 2006
@@ -21,6 +21,7 @@
#include "kcddrive.h"
#include <kprocess.h>
+#include <sys/param.h>
#include <sys/mount.h>
kCDDrive::kCDDrive() {
canReadDVD=false;
@@ -55,7 +56,7 @@
if (process->isRunning()) process->wait(-1);
delete process;
*/
- umount(device.latin1());
+ unmount(device.latin1(),0);
dev->eject();
}
}
@@ -99,6 +100,7 @@
void kCDDrives::scanDrives() {
int i;
drives.clear();
+ dm->clear();
dm->scanBus();
dm->scanFstab();
@@ -128,4 +130,4 @@
/** No descriptions */
kCDDrive * kCDDrives::getDrive(int num) {
return (kCDDrive *)drives.at(num);
-}
\ No newline at end of file
+}

View file

@ -2,16 +2,18 @@ bin/k9copy
include/k9backupdlg.h
include/k9cell.h
include/k9cellcopylist.h
include/k9common.h
include/k9dvd.h
include/k9dvdauthor.h
include/k9dvdbackup.h
include/k9dvdprogress.h
include/k9dvdsize.h
include/k9dvdtitle.h
include/k9ifo.h
lib/libk9copy.la
lib/libk9copy.so
lib/libk9copy.so.0
share/applnk/Multimedia/K9copy.desktop
share/applnk/Multimedia/k9copy.desktop
share/apps/k9copy/k9copyui.rc
%%PORTDOCS%%%%DOCSDIR%%/index.cache.bz2
%%PORTDOCS%%%%DOCSDIR%%/index.docbook
@ -20,11 +22,13 @@ share/icons/hicolor/16x16/apps/k9copy.png
share/icons/hicolor/32x32/apps/k9copy.png
share/icons/hicolor/48x48/apps/k9copy.png
share/locale/cs/LC_MESSAGES/k9copy.mo
share/locale/de/LC_MESSAGES/k9copy.mo
share/locale/el/LC_MESSAGES/k9copy.mo
share/locale/en_GB/LC_MESSAGES/k9copy.mo
share/locale/es/LC_MESSAGES/k9copy.mo
share/locale/fr/LC_MESSAGES/k9copy.mo
share/locale/hu/LC_MESSAGES/k9copy.mo
share/locale/it/LC_MESSAGES/k9copy.mo
share/locale/pt_BR/LC_MESSAGES/k9copy.mo
share/locale/ru/LC_MESSAGES/k9copy.mo
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/apps/k9copy