The Machine Emulator provides a general-purpose framework

for computer emulation.  Right now it can emulate Sun 2/120 and
3/150.

WWW:	http://theory.lcs.mit.edu/~fredette/tme/

PR:		ports/106839
Submitted by:	trasz <trasz at pin.if.uz.zgora.pl>
This commit is contained in:
Martin Wilke 2006-12-21 20:20:43 +00:00
parent e60947bbed
commit 165ff1ee24
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=180383
6 changed files with 152 additions and 0 deletions

View file

@ -119,6 +119,7 @@
SUBDIR += tiemu2
SUBDIR += tilem
SUBDIR += tkhfs
SUBDIR += tme
SUBDIR += tuxnes
SUBDIR += twin
SUBDIR += uae

25
emulators/tme/Makefile Normal file
View file

@ -0,0 +1,25 @@
# New ports collection makefile for: tme
# Date created: 2006-12-14
# Whom: trasz <trasz@pin.if.uz.zgora.pl>
#
# $FreeBSD$
#
PORTNAME= tme
PORTVERSION= 0.4
CATEGORIES= emulators
MASTER_SITES= http://theory.lcs.mit.edu/~fredette/tme/
MAINTAINER= trasz@pin.if.uz.zgora.pl
COMMENT= Emulator for Sun 2/120 and Sun 3/150 machines
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk12 gnometarget
CONFIGURE_ARGS+= --disable-shared
MAKE_ENV= LANG=C
post-patch:
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/libtme/module.c
.include <bsd.port.mk>

3
emulators/tme/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (tme-0.4.tar.gz) = 70673e07c3bd6bf2bd5abd2f7678f4e2
SHA256 (tme-0.4.tar.gz) = edb148558e923ae25f11c4bba7dca1fe601c20e106aa0ada208a48ed305c7b47
SIZE (tme-0.4.tar.gz) = 1448981

View file

@ -0,0 +1,18 @@
--- libtme/module.c.orig Wed Jan 26 13:59:24 2005
+++ libtme/module.c Sun Dec 17 19:11:37 2006
@@ -107,13 +107,14 @@
FILE *modules_index;
/* pass over the search path environment variables: */
- for (pass = 0; ++pass < 2; ) {
+ for (pass = 0; ++pass <= 3; ) {
/* get the next search path environment variable value: */
search_path = NULL;
switch (pass) {
case 1: search_path = getenv("LTDL_LIBRARY_PATH"); break;
case 2: search_path = getenv(LTDL_SHLIBPATH_VAR); break;
+ case 3: search_path = "%%PREFIX%%/lib"; break;
default: assert(FALSE);
}
if (search_path == NULL) {

5
emulators/tme/pkg-descr Normal file
View file

@ -0,0 +1,5 @@
The Machine Emulator provides a general-purpose framework
for computer emulation. Right now it can emulate Sun 2/120 and
3/150.
WWW: http://theory.lcs.mit.edu/~fredette/tme/

100
emulators/tme/pkg-plist Normal file
View file

@ -0,0 +1,100 @@
bin/tme-sun-idprom
bin/tme-sun-eeprom
bin/tmesh
include/tme/generic/bus-device.h
include/tme/generic/bus.h
include/tme/generic/ic.h
include/tme/generic/serial.h
include/tme/generic/ethernet.h
include/tme/generic/fb.h
include/tme/generic/scsi.h
include/tme/generic/disk.h
include/tme/generic/tape.h
include/tme/generic/mouse.h
include/tme/generic/float.h
include/tme/generic/keyboard.h
include/tme/ic/m68k.h
include/tme/ic/am9513.h
include/tme/ic/z8530.h
include/tme/ic/mm58167.h
include/tme/ic/isil7170.h
include/tme/ic/i825x6.h
include/tme/ic/ieee754.h
include/tme/ic/ieee754-auto.h
include/tme/ic/ieee754-ops-auto.h
include/tme/machine/sun.h
include/tme/scsi/scsi-disk.h
include/tme/scsi/scsi-tape.h
include/tme/scsi/scsi-msg.h
include/tme/scsi/scsi-cdb.h
include/tme/scsi/scsi-device.h
include/tme/atomics.h
include/tme/common.h
include/tme/connection.h
include/tme/element.h
include/tme/threads.h
include/tme/module.h
include/tme/log.h
include/tme/tme.h
include/tme/misc.h
include/tme/hash.h
include/tme/tmesh.h
include/ltdl.h
lib/tme/tme-plugins.txt
lib/tme/tme_generic.la
lib/tme/tme_generic.a
lib/tme/tme_ic_m68k.la
lib/tme/tme_ic_m68k.a
lib/tme/tme_ic_am9513.la
lib/tme/tme_ic_am9513.a
lib/tme/tme_ic_mm58167.la
lib/tme/tme_ic_mm58167.a
lib/tme/tme_ic_z8530.la
lib/tme/tme_ic_z8530.a
lib/tme/tme_ic_i825x6.la
lib/tme/tme_ic_i825x6.a
lib/tme/tme_ic_isil7170.la
lib/tme/tme_ic_isil7170.a
lib/tme/tme_ic_ncr5380.la
lib/tme/tme_ic_ncr5380.a
lib/tme/libtme-machine-sun.la
lib/tme/libtme-machine-sun.a
lib/tme/tme_machine_sun2.la
lib/tme/tme_machine_sun2.a
lib/tme/tme_machine_sun3.la
lib/tme/tme_machine_sun3.a
lib/tme/tme_host_posix.la
lib/tme/tme_host_posix.a
lib/tme/tme_host_bsd.la
lib/tme/tme_host_bsd.a
lib/tme/tme_host_gtk.la
lib/tme/tme_host_gtk.a
lib/tme/tme_bus_multibus.la
lib/tme/tme_bus_multibus.a
lib/tme/tme_serial_kb.la
lib/tme/tme_serial_kb.a
lib/tme/tme_scsi.la
lib/tme/tme_scsi.a
lib/tme/tmeconfig.h
lib/libltdl.la
lib/libltdl.a
lib/libtme.la
lib/libtme.a
lib/libtme-generic.la
lib/libtme-generic.a
lib/libtme-ieee754.la
lib/libtme-ieee754.a
lib/libtmesh.la
lib/libtmesh.a
%%EXAMPLESDIR%%/sun-keyboards.txt
%%EXAMPLESDIR%%/my-sun-macros.txt
%%EXAMPLESDIR%%/SUN2-MULTIBUS
%%EXAMPLESDIR%%/SUN3-CARRERA
%%EXAMPLESDIR%%/sun3-carrera-eeprom.txt
@dirrmtry %%EXAMPLESDIR%%
@dirrmtry lib/tme
@dirrmtry include/tme/scsi
@dirrmtry include/tme/machine
@dirrmtry include/tme/ic
@dirrmtry include/tme/generic
@dirrmtry include/tme