net/freeradius-client: unbreak fetch, update to 1.1.7 release

Maintainer didn't unbreak the port over 3 months since it was marked unfetchable,
version 1.1.7 was released 26.05.2017

Approved by:	maintainer (timeout)
MFH:		2020Q1
This commit is contained in:
Dima Panov 2020-02-24 15:12:22 +00:00
parent 2cded8bae8
commit 16b08b0223
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=526973
8 changed files with 35 additions and 60 deletions

View file

@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= freeradius-client
PORTVERSION= 1.1.6
PORTREVISION= 1
PORTVERSION= 1.1.7
PORTREVISION= 0
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/freeradius/ \
ftp://ftp.suntel.com.tr/pub/freeradius/
@ -11,11 +11,9 @@ MASTER_SITES= ftp://ftp.freeradius.org/pub/freeradius/ \
MAINTAINER= netch@portaone.com
COMMENT= Client library and basic utilities for RADIUS AAA
BROKEN= unfetchable
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= gmake libtool tar:bzip2
USES= gmake libtool
USE_LDCONFIG= yes
CONFLICTS= radiusclient-ng-[0-9]*

View file

@ -1,2 +1,3 @@
SHA256 (freeradius-client-1.1.6.tar.bz2) = a3c9522ed6d9bc795794595a8f3eebada868ea11a0c046637500faf257f9688f
SIZE (freeradius-client-1.1.6.tar.bz2) = 297916
TIMESTAMP = 1582553895
SHA256 (freeradius-client-1.1.7.tar.gz) = eada2861b8f4928e3ac6b5bbfe11e92cd6cdcacfce40cae1085e77c1b6add0e9
SIZE (freeradius-client-1.1.7.tar.gz) = 433141

View file

@ -1,26 +1,22 @@
--- configure
--- configure.orig 2015-01-19 16:18:26 UTC
+++ configure
@@ -19728,23 +19728,6 @@
@@ -12503,19 +12503,6 @@ fi
gethostbyaddrrstyle=""
echo "$as_me:$LINENO: checking gethostbyaddr_r() syntax" >&5
echo $ECHO_N "checking gethostbyaddr_r() syntax... $ECHO_C" >&6
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking gethostbyaddr_r() syntax" >&5
$as_echo_n "checking gethostbyaddr_r() syntax... " >&6; }
-case "$host" in
-*-freebsd*)
-
-cat >>confdefs.h <<\_ACEOF
-#define GETHOSTBYADDR_R
-_ACEOF
-$as_echo "#define GETHOSTBYADDR_R /**/" >>confdefs.h
-
-
-cat >>confdefs.h <<\_ACEOF
-#define GETHOSTBYADDRRSTYLE_BSD
-_ACEOF
-$as_echo "#define GETHOSTBYADDRRSTYLE_BSD /**/" >>confdefs.h
-
- gethostbyaddrrstyle=BSD
- { echo "$as_me:$LINENO: WARNING: FreeBSD overridden to BSD-style" >&5
-echo "$as_me: WARNING: FreeBSD overridden to BSD-style" >&2;}
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: FreeBSD overridden to BSD-style" >&5
-$as_echo "$as_me: WARNING: FreeBSD overridden to BSD-style" >&2;}
- ;;
-esac
if test "x$gethostbyaddrrstyle" = "x"; then
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */

View file

@ -1,6 +1,6 @@
--- configure.in
--- configure.in.orig 2015-01-19 16:18:26 UTC
+++ configure.in
@@ -66,14 +66,6 @@
@@ -66,14 +66,6 @@ dnl http://h30097.www3.hp.com/docs/base_doc/DOCUME
dnl We need #stdio.h to define NULL on FreeBSD (at least)
gethostbyaddrrstyle=""
AC_MSG_CHECKING([gethostbyaddr_r() syntax])

View file

@ -1,6 +1,6 @@
--- lib/config.c
--- lib/config.c.orig 2015-01-19 16:18:26 UTC
+++ lib/config.c
@@ -106,7 +106,7 @@
@@ -106,7 +106,7 @@ static int set_option_srv(char const *filename, int li
serv = (SERVER *) option->val;
if (serv == NULL) {
DEBUG(LOG_ERR, "option->val / server is NULL, allocating memory");
@ -9,10 +9,10 @@
if (serv == NULL) {
rc_log(LOG_CRIT, "read_config: out of memory");
free(p_dupe);
@@ -313,8 +313,8 @@
@@ -319,8 +319,8 @@ rc_config_init(rc_handle *rh)
authservers = rc_conf_srv(rh, "authserver");
acctservers = rc_conf_srv(rh, "acctserver");
acct = find_option(rh, "acctserver", OT_ANY);
auth = find_option(rh, "authserver", OT_ANY);
- authservers = malloc(sizeof(SERVER));
- acctservers = malloc(sizeof(SERVER));
+ authservers = calloc(1, sizeof(SERVER));
@ -20,16 +20,16 @@
if(authservers == NULL || acctservers == NULL)
{
@@ -491,7 +491,7 @@
option = find_option(rh, optname, OT_INT|OT_AUO);
@@ -504,7 +504,7 @@ int rc_conf_int(rc_handle const *rh, char const *optna
if (option != NULL) {
- return *((int *)option->val);
+ return option->val ? *((int *)option->val) : 0;
} else {
rc_log(LOG_CRIT, "rc_conf_int: unkown config option requested: %s", optname);
abort();
@@ -528,17 +528,21 @@
if (option->val) {
- return *((int *)option->val);
+ return option->val ? *((int *)option->val) : 0;
} else {
rc_log(LOG_ERR, "rc_conf_int: config option %s was not set", optname);
return 0;
@@ -545,17 +545,21 @@ int test_config(rc_handle const *rh, char const *filen
struct stat st;
char *file;
#endif

View file

@ -1,6 +1,6 @@
--- lib/ip_util.c
--- lib/ip_util.c.orig 2015-01-19 16:18:26 UTC
+++ lib/ip_util.c
@@ -350,6 +350,36 @@
@@ -348,6 +348,36 @@ uint32_t rc_own_bind_ipaddress(rc_handle *rh)
}
/*

View file

@ -1,6 +1,6 @@
--- lib/options.h
--- lib/options.h.orig 2015-01-19 16:18:26 UTC
+++ lib/options.h
@@ -50,6 +50,7 @@
@@ -50,6 +50,7 @@ static OPTION config_options_default[] = {
{"radius_retries", OT_INT, ST_UNDEF, NULL},
{"radius_deadtime", OT_INT, ST_UNDEF, NULL},
{"bindaddr", OT_STR, ST_UNDEF, NULL},

View file

@ -1,20 +0,0 @@
--- lib/sendserver.c
+++ lib/sendserver.c
@@ -196,6 +196,7 @@
char send_buffer[BUFFER_LEN];
int retries;
VALUE_PAIR *vp;
+ unsigned long nasaddr;
server_name = data->server;
if (server_name == NULL || server_name[0] == '\0')
@@ -259,6 +262,9 @@
/*
* Fill in NAS-IP-Address
*/
+ nas_ipaddr = rc_nasaddress(rh);
+ if (nas_ipaddr != 0)
+ sinlocal.sin_addr.s_addr = htonl(nas_ipaddr);
if (sinlocal.sin_addr.s_addr == htonl(INADDR_ANY)) {
if (rc_get_srcaddr(SA(&sinlocal), SA(&sinremote)) != 0) {
close (sockfd);