net-mgmt/nrpe3: Remove expired port

2023-06-03 net-mgmt/nrpe3: Fails to build with recent OpenSSL so use net-mgmt/nrpe
This commit is contained in:
Rene Ladan 2023-06-03 13:17:04 +02:00
parent 9f1633b483
commit 16c38f9952
11 changed files with 1 additions and 207 deletions

1
MOVED
View file

@ -7617,3 +7617,4 @@ net-mgmt/send||2023-06-03|Has expired: Implementation is based on older obsolete
dns/validns||2023-06-03|Has expired: Last upstream release was 10 years ago and last upstream activity in 2017
sysutils/cfengine319||2023-06-03|Has expired: Upstream EOL reached on 2022-06-30
sysutils/cfengine-masterfiles319||2023-06-03|Removed, part of expired sysutils/cfengine319
net-mgmt/nrpe3|net-mgmt/nrpe|2023-06-03|Has expired: Fails to build with recent OpenSSL so use net-mgmt/nrpe

View file

@ -205,7 +205,6 @@
SUBDIR += ng_ipacct
SUBDIR += nitpicker
SUBDIR += nrpe
SUBDIR += nrpe3
SUBDIR += nsca
SUBDIR += nsca-client
SUBDIR += nsca-ng

View file

@ -1,88 +0,0 @@
PORTNAME= nrpe
PORTVERSION= 3.2.1
DISTVERSIONPREFIX= nrpe-
PORTREVISION?= 1
CATEGORIES= net-mgmt
PKGNAMESUFFIX= 3
MAINTAINER= ports@FreeBSD.org
COMMENT?= Nagios Remote Plugin Executor
WWW= https://www.nagios.org/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.md
DEPRECATED= Fails to build with recent OpenSSL so use net-mgmt/nrpe
EXPIRATION_DATE= 2023-06-03
USE_GITHUB= yes
GH_ACCOUNT= NagiosEnterprises
USES= perl5
USE_PERL5= build
USE_RC_SUBR= nrpe3
GNU_CONFIGURE= yes
OPTIONS_DEFINE= SSL ARGS
OPTIONS_RADIO= PLUGINS
OPTIONS_RADIO_PLUGINS= MONPLUGINS NAGPLUGINS
OPTIONS_DEFAULT=NAGPLUGINS SSL
SSL_DESC= Enable SSL support (disables plain-text server)
ARGS_DESC= Enable command argument processing
NAGPLUGINS_DESC=Use net-mgmt/nagios-plugins
MONPLUGINS_DESC=Use net-mgmt/monitoring-plugins
SSL_USES= ssl
SSL_CONFIGURE_ENABLE= ssl
SSL_CONFIGURE_WITH= ssl=${OPENSSLBASE} ssl-inc=${OPENSSLINC} ssl-lib=${OPENSSLLIB}
SSL_CFLAGS= -I${OPENSSLINC}
SSL_VARS= BROKEN_SSL="openssl30 openssl31" \
BROKEN_SSL_REASON="error: undefined symbol: get_dh2048"
ARGS_CONFIGURE_ON= --enable-command-args
ARGS_CONFIGURE_OFF= --disable-command-args
MONPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:net-mgmt/monitoring-plugins
NAGPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:net-mgmt/nagios-plugins
NAGIOSUSER?= nagios
NAGIOSGROUP?= nagios
USERS= ${NAGIOSUSER}
GROUPS= ${NAGIOSGROUP}
NRPE_PIDDIR?= /var/run/nrpe3
CONFIGURE_ARGS+=--bindir=${PREFIX}/sbin \
--libexecdir=${PREFIX}/libexec/nagios \
--sysconfdir=${PREFIX}/etc \
--with-nrpe-user=${NAGIOSUSER} \
--with-nrpe-group=${NAGIOSGROUP}
PLIST_SUB= NAGIOSUSER=${NAGIOSUSER} \
NAGIOSGROUP=${NAGIOSGROUP} \
NRPE_PIDDIR=${NRPE_PIDDIR}
SUB_LIST+= PIDDIR=${NRPE_PIDDIR}
SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/var/run/nrpe.pid|${NRPE_PIDDIR}/nrpe3.pid|g' \
-e 's|/usr/lib/nagios/plugins/|${LOCALBASE}/libexec/nagios/|g' \
-e 's|/usr/bin/sudo|${LOCALBASE}/bin/sudo|g' \
${WRKSRC}/sample-config/nrpe.cfg.in
do-install:
${INSTALL} -d ${STAGEDIR}${NRPE_PIDDIR}
${INSTALL_PROGRAM} ${WRKSRC}/src/nrpe ${STAGEDIR}${PREFIX}/sbin/nrpe3
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/nagios
${INSTALL_PROGRAM} ${WRKSRC}/src/check_nrpe ${STAGEDIR}${PREFIX}/libexec/nagios/check_nrpe3
${INSTALL_DATA} ${WRKSRC}/sample-config/nrpe.cfg ${STAGEDIR}${PREFIX}/etc/nrpe.cfg.sample
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
TIMESTAMP = 1507746408
SHA256 (NagiosEnterprises-nrpe-nrpe-3.2.1_GH0.tar.gz) = b1bb0a0cbbd0f6c438ce7260db600cd45612c61ae7e3bd59a309262dc4d70b81
SIZE (NagiosEnterprises-nrpe-nrpe-3.2.1_GH0.tar.gz) = 518035

View file

@ -1,51 +0,0 @@
#!/bin/sh
# PROVIDE: nrpe3
# REQUIRE: LOGIN
# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf to enable nrpe3:
# nrpe3_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable nrpe3.
# nrpe3_flags (str): Not set by default.
# nrpe3_configfile (str): Set to "%%PREFIX%%/etc/nrpe.cfg" by default.
. /etc/rc.subr
name=nrpe3
rcvar=nrpe3_enable
load_rc_config "${name}"
: ${nrpe3_enable:=NO}
: ${nrpe3_configfile:=%%PREFIX%%/etc/nrpe.cfg}
required_files="${nrpe3_configfile}"
command="%%PREFIX%%/sbin/nrpe3"
command_args="-c ${nrpe3_configfile} -d"
extra_commands=reload
sig_reload=HUP
start_precmd=nrpe3_prestart
stop_precmd=find_pidfile
find_pidfile()
{
[ -n "$nrpe3_pidfile" ] &&
warn "No longer necessary to set nrpe3_pidfile in rc.conf[.local]"
if get_pidfile_from_conf pid_file ${nrpe3_configfile}; then
pidfile="$_pidfile_from_conf"
else
pidfile='%%PIDDIR%%/nrpe3.pid'
fi
}
nrpe3_prestart()
{
find_pidfile
install -d -o ${nrpe_user:-nagios} ${pidfile%/*}
}
run_rc_command "$1"

View file

@ -1,19 +0,0 @@
--- include/common.h.in.orig 2017-12-08 11:11:28 UTC
+++ include/common.h.in
@@ -30,11 +30,16 @@
#ifdef HAVE_SSL
#include <@SSL_INC_PREFIX@@SSL_HDR@>
+#include <@SSL_INC_PREFIX@crypto.h>
# ifdef SSL_TYPE_openssl
# include <@SSL_INC_PREFIX@err.h>
# include <@SSL_INC_PREFIX@rand.h>
# include <@SSL_INC_PREFIX@engine.h>
+# include <@SSL_INC_PREFIX@crypto.h>
+# if defined (LIBRESSL_VERSION_NUMBER)
+# include <@SSL_INC_PREFIX@opensslfeatures.h>
+# endif
# endif
#endif
#define PROGRAM_VERSION "3.2.1"

View file

@ -1,11 +0,0 @@
--- src/check_nrpe.c.orig 2017-04-17 14:21:54 UTC
+++ src/check_nrpe.c
@@ -839,7 +839,7 @@ void setup_ssl()
exit(STATE_CRITICAL);
}
-#if OPENSSL_VERSION_NUMBER >= 0x10100000
+#if OPENSSL_VERSION_NUMBER >= 0x10100000 && !defined(LIBRESSL_VERSION_NUMBER)
SSL_CTX_set_max_proto_version(ctx, 0);

View file

@ -1,11 +0,0 @@
--- src/nrpe.c.orig 2017-04-28 10:29:47 UTC
+++ src/nrpe.c
@@ -320,7 +320,7 @@ void init_ssl(void)
exit(STATE_CRITICAL);
}
-#if OPENSSL_VERSION_NUMBER >= 0x10100000
+#if OPENSSL_VERSION_NUMBER >= 0x10100000 && !defined(LIBRESSL_VERSION_NUMBER)
SSL_CTX_set_max_proto_version(ctx, 0);

View file

@ -1,12 +0,0 @@
[
{ type: install
message: <<EOM
Enable NRPE in /etc/rc.conf with the following line:
nrpe3_enable="YES"
A sample configuration is available in %%PREFIX%%/etc/nrpe.cfg.sample.
Copy to nrpe.cfg where required and edit to suit your needs.
EOM
}
]

View file

@ -1,7 +0,0 @@
nrpe is used to execute Nagios plugins on remote hosts and report the results
to the main Nagios server. From the Nagios homepage:
Allows you to execute "local" plugins (like check_disk, check_procs, etc.) on
remote hosts. The check_nrpe plugin is called from Nagios and actually makes
the plugin requests to the remote host. Requires that nrpe be running on the
remote host (either as a standalone daemon or as a service under inetd).

View file

@ -1,4 +0,0 @@
@sample etc/nrpe.cfg.sample
libexec/nagios/check_nrpe3
sbin/nrpe3
@dir(%%NAGIOSUSER%%,%%NAGIOSGROUP%%,755) %%NRPE_PIDDIR%%