- Fix build on AMD64

- Pet portlint
This commit is contained in:
Kirill Ponomarev 2004-02-01 19:04:25 +00:00
parent 258de68afc
commit 16f9b1e8c9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99734
3 changed files with 25 additions and 5 deletions

View file

@ -8,11 +8,11 @@
PORTNAME= dtv
PORTVERSION= 0.50
CATEGORIES= multimedia
MASTER_SITES= http://apollo.backplane.com/FreeBSDPorts/
MASTER_SITES= http://apollo.backplane.com/FreeBSDPorts/
MAINTAINER= ports@FreeBSD.org
COMMENT= A client/server based TV capture/display program
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
.include <bsd.port.mk>

View file

@ -1,10 +1,20 @@
--- defs.h.orig Sat Sep 7 16:44:57 2002
+++ defs.h Sat Sep 7 16:45:03 2002
@@ -12,7 +12,7 @@
--- defs.h.orig Mon Feb 11 04:14:17 2002
+++ defs.h Sun Feb 1 20:01:30 2004
@@ -10,9 +10,17 @@
#include <sys/mman.h>
#include <sys/ipc.h>
#include <sys/shm.h>
+#ifdef __FreeBSD__
+#include <osreldate.h>
+#if __FreeBSD_version > 500000
+#include <dev/bktr/ioctl_bt848.h>
+#include <dev/bktr/ioctl_meteor.h>
+#else
#include <machine/ioctl_bt848.h>
#include <machine/ioctl_meteor.h>
-#include <machine/soundcard.h>
+#endif
+#endif
+#include <sys/soundcard.h>
#include <stdio.h>
#include <stdlib.h>

View file

@ -0,0 +1,10 @@
--- main.c.orig Sun Feb 1 19:51:55 2004
+++ main.c Sun Feb 1 19:52:11 2004
@@ -11,6 +11,7 @@
#include <netinet/in.h>
#include <arpa/inet.h>
#include <netdb.h>
+#include <sys/time.h>
Prototype int VerboseOpt;