graphics/pencil2d: Update 0.6.4 -> 0.6.5
Reported by: portscout
This commit is contained in:
parent
3abcdfe88a
commit
16ffafa18d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=544011
6 changed files with 39 additions and 35 deletions
|
@ -2,8 +2,7 @@
|
|||
|
||||
PORTNAME= pencil2d
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.6.4
|
||||
PORTREVISION= 2
|
||||
DISTVERSION= 0.6.5
|
||||
CATEGORIES= graphics math
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -12,22 +11,21 @@ COMMENT= Easy and intuitive tool to make 2D hand-drawn animations
|
|||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
|
||||
|
||||
BROKEN= Project ERROR: Unknown module(s) in QT: xmlpatterns
|
||||
|
||||
RUN_DEPENDS= ffmpeg:multimedia/ffmpeg
|
||||
|
||||
USES= compiler:c++11-lang desktop-file-utils gl gmake qmake qt:5 \
|
||||
shared-mime-info
|
||||
USE_GITHUB= yes
|
||||
USE_QT= core gui multimedia network svg widgets xml buildtools_build
|
||||
USE_QT= core gui multimedia svg widgets xml xmlpatterns buildtools_build
|
||||
USE_GL= gl
|
||||
GH_PROJECT= pencil
|
||||
|
||||
PLIST_FILES= bin/pencil2d \
|
||||
share/applications/pencil2d.desktop \
|
||||
share/applications/org.pencil2d.Pencil2D.desktop \
|
||||
share/bash-completion/completions/pencil2d \
|
||||
share/icons/hicolor/256x256/apps/pencil2d.png \
|
||||
share/mime/packages/pencil2d.xml \
|
||||
share/icons/hicolor/256x256/apps/org.pencil2d.Pencil2D.png \
|
||||
share/metainfo/org.pencil2d.Pencil2D.metainfo.xml \
|
||||
share/mime/packages/org.pencil2d.Pencil2D.xml \
|
||||
share/zsh/site-functions/_pencil2d
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1559551254
|
||||
SHA256 (pencil2d-pencil-v0.6.4_GH0.tar.gz) = 9be6d699cb5a960af89a10ee77dce33ddfe050eb3f0327a055e13f395d92afe6
|
||||
SIZE (pencil2d-pencil-v0.6.4_GH0.tar.gz) = 3397891
|
||||
TIMESTAMP = 1596418829
|
||||
SHA256 (pencil2d-pencil-v0.6.5_GH0.tar.gz) = 31903c54c8f0a79385cc5f519b380d26524219984e619204820b946c96fc2482
|
||||
SIZE (pencil2d-pencil-v0.6.5_GH0.tar.gz) = 3714951
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- app/app.pro.orig 2018-11-21 09:01:18 UTC
|
||||
+++ app/app.pro
|
||||
@@ -135,7 +135,7 @@ win32 {
|
||||
RC_FILE = data/pencil2d.rc
|
||||
}
|
||||
|
||||
-linux {
|
||||
+freebsd {
|
||||
target.path = $${PREFIX}/bin
|
||||
|
||||
bashcompletion.files = data/pencil2d
|
|
@ -1,10 +0,0 @@
|
|||
--- core_lib/src/graphics/vector/beziercurve.cpp.orig 2020-05-21 12:20:43 UTC
|
||||
+++ core_lib/src/graphics/vector/beziercurve.cpp
|
||||
@@ -19,6 +19,7 @@ GNU General Public License for more details.
|
||||
|
||||
#include <cmath>
|
||||
#include <QList>
|
||||
+#include <QPainterPath>
|
||||
#include "object.h"
|
||||
#include "pencilerror.h"
|
||||
|
|
@ -1,8 +1,8 @@
|
|||
--- core_lib/src/graphics/vector/beziercurve.h.orig 2020-05-21 12:23:34 UTC
|
||||
--- core_lib/src/graphics/vector/beziercurve.h.orig 2020-07-31 15:32:15 UTC
|
||||
+++ core_lib/src/graphics/vector/beziercurve.h
|
||||
@@ -18,6 +18,7 @@ GNU General Public License for more details.
|
||||
@@ -17,6 +17,7 @@ GNU General Public License for more details.
|
||||
#define BEZIERCURVE_H
|
||||
|
||||
#include <QtXml>
|
||||
#include <QPainter>
|
||||
+#include <QPainterPath>
|
||||
|
||||
|
|
27
graphics/pencil2d/files/patch-pencil2d.pro
Normal file
27
graphics/pencil2d/files/patch-pencil2d.pro
Normal file
|
@ -0,0 +1,27 @@
|
|||
--- pencil2d.pro.orig 2020-08-03 02:00:25 UTC
|
||||
+++ pencil2d.pro
|
||||
@@ -6,8 +6,8 @@ TEMPLATE = subdirs
|
||||
|
||||
SUBDIRS = \ # sub-project names
|
||||
core_lib \
|
||||
- app \
|
||||
- tests
|
||||
+ app
|
||||
+# tests
|
||||
|
||||
# build the project sequentially as listed in SUBDIRS !
|
||||
CONFIG += ordered
|
||||
@@ -15,11 +15,11 @@ CONFIG += ordered
|
||||
# where to find the sub projects - give the folders
|
||||
core_lib.subdir = core_lib
|
||||
app.subdir = app
|
||||
-tests.subdir = tests
|
||||
+#tests.subdir = tests
|
||||
|
||||
# what subproject depends on others
|
||||
app.depends = core_lib
|
||||
-tests.depends = core_lib
|
||||
+#tests.depends = core_lib
|
||||
|
||||
TRANSLATIONS += translations/pencil.ts \
|
||||
translations/pencil_ar.ts \
|
Loading…
Reference in a new issue