Update to 10.3

PR:		40245
Submitted by:	KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
Patrick Li 2002-07-06 01:17:43 +00:00
parent b700a20278
commit 1710ed6ad1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62495
6 changed files with 20 additions and 53 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= netpbm
PORTVERSION= 10.2
PORTVERSION= 10.3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -19,6 +19,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
png.5:${PORTSDIR}/graphics/png \
jbig.1:${PORTSDIR}/graphics/jbigkit
USE_PERL5= yes
USE_REINPLACE= yes
USE_GMAKE= yes
MAKE_ENV= LN="${LN}" RANLIB="${RANLIB}"

View file

@ -1 +1 @@
MD5 (netpbm-10.2.tgz) = 871cf2c42f101fcd57c51ad415160819
MD5 (netpbm-10.3.tgz) = 73ffe1962788d585e041684260dfadae

View file

@ -1,16 +1,16 @@
--- converter/other/pnmtopng.c.orig Thu Apr 25 09:37:11 2002
+++ converter/other/pnmtopng.c Tue Jun 18 00:00:00 2002
@@ -1857,8 +1857,13 @@
fprintf(stderr,"pnmtopng version %s.\n", VERSION);
fprintf(stderr, " Compiled with libpng %s; using libpng %s.\n",
PNG_LIBPNG_VER_STRING, png_libpng_ver);
--- converter/other/pnmtopng.c.orig Sun Jun 23 12:51:37 2002
+++ converter/other/pnmtopng.c Sat Jul 6 00:00:00 2002
@@ -1903,8 +1903,13 @@
*/
fprintf(stderr, " Compiled with libpng %s.\n",
PNG_LIBPNG_VER_STRING);
+#ifdef zlib_version
fprintf(stderr, " Compiled with zlib %s; using zlib %s.\n",
ZLIB_VERSION, zlib_version);
fprintf(stderr, " Compiled with zlib %s; using zlib %s.\n",
ZLIB_VERSION, zlib_version);
+#else
+ fprintf(stderr, " Compiled with zlib %s.\n",
+ ZLIB_VERSION);
+ fprintf(stderr, " Compiled with zlib %s.\n",
+ ZLIB_VERSION);
+#endif
fprintf(stderr,
" Compiled with %d-bit netpbm support (PPM_OVERALLMAXVAL = %d).\n",
pm_maxvaltobits (PPM_OVERALLMAXVAL), PPM_OVERALLMAXVAL);
fprintf(stderr,
" Compiled with %d-bit netpbm support "
"(PPM_OVERALLMAXVAL = %d).\n",

View file

@ -1,23 +0,0 @@
--- converter/ppm/ppmtompeg/Makefile.orig Mon Jun 10 13:35:38 2002
+++ converter/ppm/ppmtompeg/Makefile Tue Jun 18 00:00:00 2002
@@ -8,18 +8,12 @@
include $(BUILDDIR)/Makefile.config
JPEGLD =
-ifeq ($(JPEGLIB_DIR),NONE)
+ifeq ($(JPEGLIB),NONE)
# 'nojpeg' is a module that implements all the jpeg access routines as
# error messages that tell you we don't have jpeg capability
JPEG_MODULE = nojpeg
else
- ifneq ($(JPEGLIB_DIR)x,x)
- JPEGLD += -L$(JPEGLIB_DIR)
- ifeq ($(NEED_RUNTIME_PATH),Y)
- JPEGLD += -R$(JPEGLIB_DIR)
- endif
- endif
- JPEGLD += -ljpeg
+ JPEGLD += `$(LIBOPT) $(LIBOPTOPT) $(JPEGLIB)`
# 'jpeg' is a module that accesses J-movies via the JPEG library.
JPEG_MODULE = jpeg
endif

View file

@ -1,15 +0,0 @@
--- other/pnmarith.c.orig Sun Aug 13 13:08:04 1995
+++ other/pnmarith.c Tue Jun 18 00:00:00 2002
@@ -147,9 +147,9 @@
break;
case '*':
- r1 = r1 * r2 / maxval3;
- g1 = g1 * g2 / maxval3;
- b1 = b1 * b2 / maxval3;
+ r1 = (unsigned) r1 * r2 / maxval3;
+ g1 = (unsigned) g1 * g2 / maxval3;
+ b1 = (unsigned) b1 * b2 / maxval3;
break;
case 'D':

View file

@ -33,14 +33,17 @@ bin/mgrtopbm
bin/mtvtoppm
bin/neotoppm
bin/palmtopnm
bin/pamarith
bin/pamchannel
bin/pamcut
bin/pamdeinterlace
bin/pamdice
bin/pamendian
bin/pamfile
bin/pamfunc
bin/pamoil
bin/pamseq
bin/pamslice
bin/pamstack
bin/pamstretch
bin/pamstretch-gen
@ -90,6 +93,7 @@ bin/pbmtozinc
bin/pbmupc
bin/pcdovtoppm
bin/pcxtoppm
bin/pgmabel
bin/pgmbentley
bin/pgmcrater
bin/pgmedge