- Update devel/hwlock to version 1.7.1 [1]
- Bump net/openmpi PR: ports/178882 [1] Submitted by: Eijiro Shibusawa <phd_kimberlite@yahoo.co.jp> (maintainer)
This commit is contained in:
parent
20e2d683f0
commit
17124e4aa2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=319015
6 changed files with 41 additions and 14 deletions
|
@ -1,10 +1,10 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= hwloc
|
||||
PORTVERSION= 1.6.2
|
||||
PORTVERSION= 1.7.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.open-mpi.org/software/hwloc/v1.6/downloads/ \
|
||||
http://icl.cs.utk.edu/open-mpi/software/hwloc/v1.6/downloads/
|
||||
MASTER_SITES= http://www.open-mpi.org/software/hwloc/v${PORTVERSION:R}/downloads/ \
|
||||
http://icl.cs.utk.edu/open-mpi/software/hwloc/v${PORTVERSION:R}/downloads/
|
||||
|
||||
MAINTAINER= phd_kimberlite@yahoo.co.jp
|
||||
COMMENT= The Portable Hardware Locality software package
|
||||
|
@ -16,7 +16,8 @@ LIB_DEPENDS= pciaccess:${PORTSDIR}/devel/libpciaccess
|
|||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --enable-static \
|
||||
--enable-libxml2
|
||||
--enable-libxml2 \
|
||||
--disable-gl
|
||||
USES= pkgconfig pathfix iconv
|
||||
USE_BZIP2= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
|
|
@ -40,6 +40,7 @@ MAN3= HWLOC_API_VERSION.3 \
|
|||
HWLOC_OBJ_MISC.3 \
|
||||
HWLOC_OBJ_NODE.3 \
|
||||
HWLOC_OBJ_OSDEV_BLOCK.3 \
|
||||
HWLOC_OBJ_OSDEV_COPROC.3 \
|
||||
HWLOC_OBJ_OSDEV_DMA.3 \
|
||||
HWLOC_OBJ_OSDEV_GPU.3 \
|
||||
HWLOC_OBJ_OSDEV_NETWORK.3 \
|
||||
|
@ -137,9 +138,12 @@ MAN3= HWLOC_API_VERSION.3 \
|
|||
hwloc_cpuset_to_nodeset.3 \
|
||||
hwloc_cpuset_to_nodeset_strict.3 \
|
||||
hwloc_cuda_get_device_cpuset.3 \
|
||||
hwloc_cuda_get_device_osdev.3 \
|
||||
hwloc_cuda_get_device_osdev_by_index.3 \
|
||||
hwloc_cuda_get_device_pci_ids.3 \
|
||||
hwloc_cuda_get_device_pcidev.3 \
|
||||
hwloc_cudart_get_device_cpuset.3 \
|
||||
hwloc_cudart_get_device_osdev_by_index.3 \
|
||||
hwloc_cudart_get_device_pci_ids.3 \
|
||||
hwloc_cudart_get_device_pcidev.3 \
|
||||
hwloc_custom_insert_group_object_by_parent.3 \
|
||||
|
@ -210,8 +214,14 @@ MAN3= HWLOC_API_VERSION.3 \
|
|||
hwloc_get_type_or_below_depth.3 \
|
||||
hwloc_get_whole_distance_matrix_by_depth.3 \
|
||||
hwloc_get_whole_distance_matrix_by_type.3 \
|
||||
hwloc_gl_get_display_by_osdev.3 \
|
||||
hwloc_gl_get_display_osdev_by_name.3 \
|
||||
hwloc_gl_get_display_osdev_by_port_device.3 \
|
||||
hwloc_ibv_get_device_cpuset.3 \
|
||||
hwloc_ibv_get_device_osdev.3 \
|
||||
hwloc_ibv_get_device_osdev_by_name.3 \
|
||||
hwloc_intel_mic_get_device_cpuset.3 \
|
||||
hwloc_intel_mic_get_device_osdev_by_index.3 \
|
||||
hwloc_linux_get_tid_cpubind.3 \
|
||||
hwloc_linux_parse_cpumap_file.3 \
|
||||
hwloc_linux_set_tid_cpubind.3 \
|
||||
|
@ -224,6 +234,9 @@ MAN3= HWLOC_API_VERSION.3 \
|
|||
hwloc_nodeset_t.3 \
|
||||
hwloc_nodeset_to_linux_libnuma_bitmask.3 \
|
||||
hwloc_nodeset_to_linux_libnuma_ulongs.3 \
|
||||
hwloc_nvml_get_device_cpuset.3 \
|
||||
hwloc_nvml_get_device_osdev.3 \
|
||||
hwloc_nvml_get_device_osdev_by_index.3 \
|
||||
hwloc_obj.3 \
|
||||
hwloc_obj_add_info.3 \
|
||||
hwloc_obj_attr_snprintf.3 \
|
||||
|
@ -251,6 +264,9 @@ MAN3= HWLOC_API_VERSION.3 \
|
|||
hwloc_obj_type_snprintf.3 \
|
||||
hwloc_obj_type_string.3 \
|
||||
hwloc_obj_type_t.3 \
|
||||
hwloc_opencl_get_device_cpuset.3 \
|
||||
hwloc_opencl_get_device_osdev.3 \
|
||||
hwloc_opencl_get_device_osdev_by_index.3 \
|
||||
hwloc_restrict_flags_e.3 \
|
||||
hwloc_set_area_membind.3 \
|
||||
hwloc_set_area_membind_nodeset.3 \
|
||||
|
@ -273,6 +289,7 @@ MAN3= HWLOC_API_VERSION.3 \
|
|||
hwloc_topology_get_complete_cpuset.3 \
|
||||
hwloc_topology_get_complete_nodeset.3 \
|
||||
hwloc_topology_get_depth.3 \
|
||||
hwloc_topology_get_flags.3 \
|
||||
hwloc_topology_get_online_cpuset.3 \
|
||||
hwloc_topology_get_support.3 \
|
||||
hwloc_topology_get_topology_cpuset.3 \
|
||||
|
@ -310,6 +327,7 @@ MAN3= HWLOC_API_VERSION.3 \
|
|||
hwlocality_cudart.3 \
|
||||
hwlocality_custom.3 \
|
||||
hwlocality_distances.3 \
|
||||
hwlocality_gl.3 \
|
||||
hwlocality_glibc_sched.3 \
|
||||
hwlocality_helper_binding.3 \
|
||||
hwlocality_helper_cpuset.3 \
|
||||
|
@ -323,12 +341,15 @@ MAN3= HWLOC_API_VERSION.3 \
|
|||
hwlocality_helper_traversal_basic.3 \
|
||||
hwlocality_helper_types.3 \
|
||||
hwlocality_information.3 \
|
||||
hwlocality_intel_mic.3 \
|
||||
hwlocality_linux.3 \
|
||||
hwlocality_linux_libnuma_bitmask.3 \
|
||||
hwlocality_linux_libnuma_ulongs.3 \
|
||||
hwlocality_membinding.3 \
|
||||
hwlocality_myriexpress.3 \
|
||||
hwlocality_nvml.3 \
|
||||
hwlocality_objects.3 \
|
||||
hwlocality_opencl.3 \
|
||||
hwlocality_openfabrics.3 \
|
||||
hwlocality_sets.3 \
|
||||
hwlocality_tinker.3 \
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (hwloc-1.6.2.tar.bz2) = fd4d47738afc9c5f60d2c35f0963f82feb78bb57f2bc239e84e93ad376169df1
|
||||
SIZE (hwloc-1.6.2.tar.bz2) = 3066020
|
||||
SHA256 (hwloc-1.7.1.tar.bz2) = 96a3c34f7237205448a99d1a16daac6c052f81abc2e2ddfbacc154a31a8c0d01
|
||||
SIZE (hwloc-1.7.1.tar.bz2) = 3214808
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
--- utils/Makefile.in.orig 2012-12-04 00:27:15.000000000 +0900
|
||||
+++ utils/Makefile.in 2012-12-04 00:27:30.000000000 +0900
|
||||
@@ -1505,9 +1505,7 @@
|
||||
--- utils/Makefile.in.orig 2013-04-03 22:42:37.000000000 +0900
|
||||
+++ utils/Makefile.in 2013-04-03 22:43:41.000000000 +0900
|
||||
@@ -1816,9 +1816,7 @@
|
||||
@HWLOC_HAVE_CAIRO_FALSE@@HWLOC_HAVE_WINDOWS_FALSE@ rm -f $(DESTDIR)$(bindir)/lstopo
|
||||
@HWLOC_HAVE_CAIRO_FALSE@@HWLOC_HAVE_WINDOWS_FALSE@ cd $(DESTDIR)$(bindir) && $(LN_S) lstopo-no-graphics$(EXEEXT) lstopo$(EXEEXT) || true
|
||||
rm -f $(DESTDIR)$(man1dir)/hwloc-ls.1 $(DESTDIR)$(man1dir)/hwloc-info.1
|
||||
- cd $(DESTDIR)$(man1dir) && $(LN_S) lstopo.1 hwloc-ls.1 && $(LN_S) lstopo.1 hwloc-info.1
|
||||
rm -f $(DESTDIR)$(man1dir)/hwloc-ls.1
|
||||
- cd $(DESTDIR)$(man1dir) && $(LN_S) lstopo.1 hwloc-ls.1
|
||||
rm -f $(DESTDIR)$(man1dir)/lstopo-no-graphics.1
|
||||
- cd $(DESTDIR)$(man1dir) && $(LN_S) lstopo.1 lstopo-no-graphics.1
|
||||
$(SED) -e 's/abs_top_builddir\/utils/bindir/' -e '/abs_top_builddir/d' $(DESTDIR)$(bindir)/hwloc-assembler-remote > $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp && mv -f $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp $(DESTDIR)$(bindir)/hwloc-assembler-remote
|
||||
$(SED) -e 's/HWLOC_top_builddir\/utils/bindir/' -e '/HWLOC_top_builddir/d' $(DESTDIR)$(bindir)/hwloc-assembler-remote > $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp && mv -f $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp $(DESTDIR)$(bindir)/hwloc-assembler-remote
|
||||
chmod +x $(DESTDIR)$(bindir)/hwloc-assembler-remote
|
||||
|
||||
|
|
|
@ -15,14 +15,19 @@ include/hwloc/autogen/config.h
|
|||
include/hwloc/bitmap.h
|
||||
include/hwloc/cuda.h
|
||||
include/hwloc/cudart.h
|
||||
include/hwloc/gl.h
|
||||
include/hwloc/helper.h
|
||||
include/hwloc/intel-mic.h
|
||||
include/hwloc/myriexpress.h
|
||||
include/hwloc/nvml.h
|
||||
include/hwloc/opencl.h
|
||||
include/hwloc/openfabrics-verbs.h
|
||||
include/hwloc/plugins.h
|
||||
include/hwloc/rename.h
|
||||
lib/libhwloc.a
|
||||
lib/libhwloc.la
|
||||
lib/libhwloc.so
|
||||
lib/libhwloc.so.7
|
||||
lib/libhwloc.so.8
|
||||
libdata/pkgconfig/hwloc.pc
|
||||
share/hwloc/hwloc-valgrind.supp
|
||||
share/hwloc/hwloc.dtd
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
|
||||
PORTNAME= openmpi
|
||||
DISTVERSION= 1.6.1
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= net parallel
|
||||
MASTER_SITES= http://www.open-mpi.org/software/ompi/v1.6/downloads/
|
||||
|
||||
|
|
Loading…
Reference in a new issue