- Update to 0.7.0

PR:		108886
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Martin Wilke 2007-02-08 22:33:28 +00:00
parent 84b9c4a750
commit 179e3757c3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=184617
8 changed files with 111 additions and 42 deletions

View file

@ -5,27 +5,26 @@
# $FreeBSD$
#
PORTNAME= qtella
PORTVERSION= 0.6.4
PORTREVISION= 4
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= qtella
PORTNAME= qtella
PORTVERSION= 0.7.0
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Gnutella client using Qt
MAINTAINER= ports@FreeBSD.org
COMMENT= A Gnutella client using Qt
HAS_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS+= --with-qt-dir=${X11BASE} --with-qt-moc=${X11BASE}/bin
CONFIGURE_ENV+= LDFLAGS=-pthread CXXFLAGS="${CXXFLAGS} -pthread"
LIB_DEPENDS= id3-3.8.3:${PORTSDIR}/audio/id3lib \
vorbis.3:${PORTSDIR}/audio/libvorbis
USE_KDELIBS_VER=3
USE_KDELIBS_VER= 3
USE_GNOME= gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ogg-dir=${LOCALBASE} \
--with-id3-dir=${LOCALBASE}
.include <bsd.port.pre.mk>
QTCPPFLAGS+= ${PTHREAD_CFLAGS}
QTCFGLIBS+= ${PTHREAD_LIBS}
.if ${OSVERSION} < 500000
BROKEN= "Does not compile on FreeBSD 4.x"
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (qtella-0.6.4.tar.gz) = 64504b71f8aa73e0f868f092d0656fdc
SHA256 (qtella-0.6.4.tar.gz) = 9b9974569f6ce0bb5bd05b1ac24059cd6755a5469de4ce9ee209706ddc7032ba
SIZE (qtella-0.6.4.tar.gz) = 512207
MD5 (qtella-0.7.0.tar.gz) = 43f59fcf6366db64f8b6b3fc3d6b0fa3
SHA256 (qtella-0.7.0.tar.gz) = d985e3ee9749016c3bbc8bd90c4c01af6533bff5c88407068b25fbe3107d597c
SIZE (qtella-0.7.0.tar.gz) = 672916

View file

@ -0,0 +1,14 @@
--- include/SHA1Storage.h.orig Fri May 21 01:14:16 2004
+++ include/SHA1Storage.h Mon Jan 29 22:00:47 2007
@@ -7,7 +7,11 @@
#include <qobject.h>
#include <qstring.h>
#include <qtimer.h>
+#ifdef HAVE_STDINT_H
#include <stdint.h>
+#else
+#include <inttypes.h>
+#endif
#include "SharedFile.h"

View file

@ -0,0 +1,15 @@
--- include/sha1.h.orig Fri May 21 01:14:16 2004
+++ include/sha1.h Mon Jan 29 22:02:09 2007
@@ -5,7 +5,12 @@
extern "C" {
#endif
+#ifdef HAVE_STDINT_H
#include <stdint.h>
+#else
+#include <inttypes.h>
+#define int_least16_t int16_t
+#endif
/*
* If you do not have the ISO standard stdint.h header file, then you
* must typdef the following:

View file

@ -0,0 +1,11 @@
--- libyahoo/Makefile.in.orig Fri May 28 04:47:01 2004
+++ libyahoo/Makefile.in Tue Jan 30 01:44:43 2007
@@ -403,7 +403,7 @@
install-data-am:
-install-exec-am: install-libLIBRARIES
+install-exec-am:
install-info: install-info-am

View file

@ -0,0 +1,15 @@
--- src/Interface.cpp.orig Fri May 21 01:14:12 2004
+++ src/Interface.cpp Mon Jan 29 20:24:53 2007
@@ -1,9 +1,11 @@
#include "Interface.h"
#if !defined(_WIN32)
+#include <sys/types.h>
#include <sys/socket.h>
-#include <sys/ioctl.h>
#include <netinet/in.h>
+#include <arpa/inet.h>
+#include <sys/ioctl.h>
#endif
#if !defined(_WIN32)

View file

@ -0,0 +1,14 @@
--- src/MessengerThread.cpp.orig Fri May 28 05:02:18 2004
+++ src/MessengerThread.cpp Mon Jan 29 21:58:13 2007
@@ -2,8 +2,10 @@
#include "MessengerContacts.h"
#include <iostream>
#include <netdb.h>
-#include <sys/time.h>
+#include <errno.h>
#include <sys/types.h>
+#include <sys/time.h>
+#include <unistd.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>

View file

@ -1,21 +1,22 @@
bin/qtella
share/qtella/pixmaps/p2p.xpm
share/qtella/pixmaps/down_icon.png
share/qtella/pixmaps/flash_icon.png
share/qtella/pixmaps/help_icon.png
share/qtella/pixmaps/interrupt_icon.png
share/qtella/pixmaps/lens_icon.png
share/qtella/pixmaps/shared_icon.png
share/qtella/pixmaps/stats_icon.png
share/qtella/pixmaps/up_icon.png
share/qtella/pixmaps/ball_d.xpm
share/qtella/pixmaps/ball_g.xpm
share/qtella/pixmaps/ball_r.xpm
share/qtella/pixmaps/ball_y.xpm
share/qtella/pixmaps/gsmile.xpm
share/qtella/pixmaps/remove.xpm
share/qtella/pixmaps/removeresearch.xpm
share/qtella/pixmaps/research.xpm
share/qtella/pixmaps/smile.xpm
@dirrm share/qtella/pixmaps
@dirrm share/qtella
%%DATADIR%%/pixmaps/ball_d.xpm
%%DATADIR%%/pixmaps/ball_g.xpm
%%DATADIR%%/pixmaps/ball_r.xpm
%%DATADIR%%/pixmaps/ball_y.xpm
%%DATADIR%%/pixmaps/down_icon.png
%%DATADIR%%/pixmaps/flash_icon.png
%%DATADIR%%/pixmaps/gsmile.xpm
%%DATADIR%%/pixmaps/help_icon.png
%%DATADIR%%/pixmaps/interrupt_icon.png
%%DATADIR%%/pixmaps/lens_icon.png
%%DATADIR%%/pixmaps/messeng_icon.png
%%DATADIR%%/pixmaps/p2p.xpm
%%DATADIR%%/pixmaps/remove.xpm
%%DATADIR%%/pixmaps/removeresearch.xpm
%%DATADIR%%/pixmaps/research.xpm
%%DATADIR%%/pixmaps/shared_icon.png
%%DATADIR%%/pixmaps/smile.xpm
%%DATADIR%%/pixmaps/stats_icon.png
%%DATADIR%%/pixmaps/up_icon.png
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%