Upgrade to version 1.81.6.

This commit is contained in:
David E. O'Brien 2008-06-15 18:45:04 +00:00
parent 4973efd41f
commit 181ef26622
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=214910
10 changed files with 69 additions and 222 deletions

View file

@ -6,10 +6,11 @@
#
PORTNAME= nvi
PORTVERSION= 1.81.5
PORTREVISION= 4
PORTVERSION= 1.81.6
PORTREVISION= 0
CATEGORIES= editors
MASTER_SITES= http://193.190.253.81/~skimo/nvi/devel/ \
MASTER_SITES= http://www.kotnet.org/~skimo/nvi/devel/ \
http://193.190.253.81/~skimo/nvi/devel/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= dd
@ -23,26 +24,16 @@ USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/build.unix
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
CONFIGURE_ARGS+= --with-db3=${LOCALBASE}
CONFIGURE_ARGS+= --with-db-prefix=${LOCALBASE}
CONFIGURE_SCRIPT= ../dist/configure
MAN1= ex.1 vi.1 view.1
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
EXTRA_PATCHES+= \
files/extra-patch-cl-cl.h \
files/extra-patch-cl-cl_funcs.c \
files/extra-patch-cl-cl_screen.c \
files/extra-patch-common-db.c \
files/extra-patch-common-key.c \
files/extra-patch-common-mem.h \
files/extra-patch-vi-v_txt.c
.endif
# XXX: nvi doesn't really need sys/select.h, but I don't think the
# build should break when it includes it (this happens on RELENG_4;
# sys/select.h is effectively empty on -current).
pre-configure:
@${CHMOD} +rwx ${WRKSRC}/${CONFIGURE_SCRIPT}
post-configure:
${ECHO_CMD} "#undef HAVE_SYS_SELECT_H" >> ${WRKSRC}/config.h
@ -52,4 +43,4 @@ post-install:
${RM} ${PREFIX}/man/cat1/${__p}.0
.endfor
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (nvi-1.81.5.tar.bz2) = 82262d08803b364033dd7ab38190305a
SHA256 (nvi-1.81.5.tar.bz2) = e40e1810e5aa39ebcea4c99b4cabd385dd5c8c817d4f7eb74741939623d97eaf
SIZE (nvi-1.81.5.tar.bz2) = 1274353
MD5 (nvi-1.81.6.tar.bz2) = 88d1e23115ee9f2961186b62e55f5704
SHA256 (nvi-1.81.6.tar.bz2) = 3441b8e3247b2b6dd19b5fd38355fe6593b2a92e960ecb3dd00d676f63d06b59
SIZE (nvi-1.81.6.tar.bz2) = 1758309

View file

@ -1,10 +0,0 @@
--- ../cl/cl.h.orig 2001-07-08 09:06:11.000000000 -0400
+++ ../cl/cl.h 2007-11-15 14:19:16.000000000 -0500
@@ -80,6 +80,7 @@
#define CLP(sp) ((CL_PRIVATE *)((sp)->gp->cl_private))
#define GCLP(gp) ((CL_PRIVATE *)gp->cl_private)
#define CLSP(sp) ((WINDOW *)((sp)->cl_private))
+#define LCLSP(sp) ((sp)->cl_private)
/* Return possibilities from the keyboard read routine. */
typedef enum { INP_OK=0, INP_EOF, INP_ERR, INP_INTR, INP_TIMEOUT } input_t;

View file

@ -1,32 +0,0 @@
--- ../cl/cl_funcs.c.orig 2001-06-25 11:19:05.000000000 -0400
+++ ../cl/cl_funcs.c 2007-11-15 14:18:45.000000000 -0500
@@ -381,7 +381,7 @@
if (CLSP(discardp)) {
delwin(CLSP(discardp));
- CLSP(discardp) = NULL;
+ LCLSP(discardp) = NULL;
}
}
@@ -395,7 +395,7 @@
if (CLSP(tsp))
delwin(CLSP(tsp));
- CLSP(tsp) = subwin(stdscr, tsp->rows, tsp->cols,
+ LCLSP(tsp) = subwin(stdscr, tsp->rows, tsp->cols,
tsp->roff, tsp->coff);
}
@@ -716,9 +716,9 @@
if (CLSP(origp))
delwin(CLSP(origp));
- CLSP(origp) = subwin(stdscr, origp->rows, origp->cols,
+ LCLSP(origp) = subwin(stdscr, origp->rows, origp->cols,
origp->roff, origp->coff);
- CLSP(newp) = subwin(stdscr, newp->rows, newp->cols,
+ LCLSP(newp) = subwin(stdscr, newp->rows, newp->cols,
newp->roff, newp->coff);
/* origp is the original screen, giving up space to newp. */

View file

@ -1,11 +0,0 @@
--- ../cl/cl_screen.c.orig 2001-06-25 11:19:06.000000000 -0400
+++ ../cl/cl_screen.c 2007-11-15 14:19:50.000000000 -0500
@@ -56,7 +56,7 @@
if (F_ISSET(gp, G_SRESTART)) {
if (CLSP(sp)) {
delwin(CLSP(sp));
- CLSP(sp) = NULL;
+ LCLSP(sp) = NULL;
}
if (cl_quit(gp))
return (1);

View file

@ -1,11 +0,0 @@
--- ../common/db.c.orig 2001-08-18 17:52:00.000000000 -0400
+++ ../common/db.c 2007-11-15 13:56:15.000000000 -0500
@@ -164,7 +164,7 @@
nlen = 1024;
retry:
/* data.size contains length in bytes */
- BINC_GOTO(sp, (char *)ep->c_lp, ep->c_blen, nlen);
+ BINC_GOTO(sp, ep->c_lp, ep->c_blen, nlen);
/* Get the line from the underlying database. */
memset(&key, 0, sizeof(key));

View file

@ -1,11 +0,0 @@
--- ../common/key.c.orig 2001-06-25 11:19:10.000000000 -0400
+++ ../common/key.c 2007-11-15 13:50:47.000000000 -0500
@@ -833,7 +833,7 @@
wp = sp->wp;
new_nelem = wp->i_nelem + add;
olen = wp->i_nelem * sizeof(wp->i_event[0]);
- BINC_RET(sp, (char *)wp->i_event, olen, new_nelem * sizeof(wp->i_event[0]));
+ BINC_RET(sp, wp->i_event, olen, new_nelem * sizeof(wp->i_event[0]));
wp->i_nelem = olen / sizeof(wp->i_event[0]);
return (0);
}

View file

@ -1,81 +0,0 @@
--- ../common/mem.h.orig 2000-08-20 05:12:59.000000000 -0400
+++ ../common/mem.h 2007-11-15 13:55:35.000000000 -0500
@@ -13,7 +13,7 @@
* returns, one that jumps to an error label.
*/
#define BINC_GOTO(sp, lp, llen, nlen) { \
- char *L__p = lp; \
+ CHAR_T *L__p = lp; \
void *L__bincp; \
if ((nlen) > llen) { \
if ((L__bincp = binc(sp, lp, &(llen), nlen)) == NULL) \
@@ -25,12 +25,12 @@
lp = L__bincp; \
} \
}
-#define BINC_GOTOW(sp, lp, llen, nlen) { \
+#define BINC_GOTOW(sp, lp, llen, nlen) { \
CHAR_T *L__bp = lp; \
- BINC_GOTO(sp, (char *)lp, llen, (nlen) * sizeof(CHAR_T)) \
+ BINC_GOTO(sp, lp, llen, (nlen) * sizeof(CHAR_T)) \
}
#define BINC_RET(sp, lp, llen, nlen) { \
- char *L__p = lp; \
+ CHAR_T *L__p = lp; \
void *L__bincp; \
if ((nlen) > llen) { \
if ((L__bincp = binc(sp, lp, &(llen), nlen)) == NULL) \
@@ -44,7 +44,7 @@
}
#define BINC_RETW(sp, lp, llen, nlen) { \
CHAR_T *L__bp = lp; \
- BINC_RET(sp, (char *)lp, llen, (nlen) * sizeof(CHAR_T)) \
+ BINC_RET(sp, lp, llen, (nlen) * sizeof(CHAR_T)) \
}
/*
@@ -67,7 +67,7 @@
}
#define GET_SPACE_GOTOW(sp, bp, blen, nlen) { \
CHAR_T *L__bp = bp; \
- GET_SPACE_GOTO(sp, (char *)bp, blen, (nlen) * sizeof(CHAR_T)) \
+ GET_SPACE_GOTO(sp, bp, blen, (nlen) * sizeof(CHAR_T)) \
}
#define GET_SPACE_RET(sp, bp, blen, nlen) { \
WIN *L__wp = (sp) == NULL ? NULL : (sp)->wp; \
@@ -84,7 +84,7 @@
}
#define GET_SPACE_RETW(sp, bp, blen, nlen) { \
CHAR_T *L__bp = bp; \
- GET_SPACE_RET(sp, (char *)bp, blen, (nlen) * sizeof(CHAR_T)) \
+ GET_SPACE_RET(sp, bp, blen, (nlen) * sizeof(CHAR_T)) \
}
/*
@@ -104,7 +104,7 @@
}
#define ADD_SPACE_GOTOW(sp, bp, blen, nlen) { \
CHAR_T *L__bp = bp; \
- ADD_SPACE_GOTO(sp, (char *)bp, blen, (nlen) * sizeof(CHAR_T)) \
+ ADD_SPACE_GOTO(sp, bp, blen, (nlen) * sizeof(CHAR_T)) \
}
#define ADD_SPACE_RET(sp, bp, blen, nlen) { \
WIN *L__wp = (sp) == NULL ? NULL : (sp)->wp; \
@@ -119,7 +119,7 @@
}
#define ADD_SPACE_RETW(sp, bp, blen, nlen) { \
CHAR_T *L__bp = bp; \
- ADD_SPACE_RET(sp, (char *)bp, blen, (nlen) * sizeof(CHAR_T)) \
+ ADD_SPACE_RET(sp, bp, blen, (nlen) * sizeof(CHAR_T)) \
}
/* Free a GET_SPACE returned buffer. */
@@ -132,7 +132,7 @@
}
#define FREE_SPACEW(sp, bp, blen) { \
CHAR_T *L__bp = bp; \
- FREE_SPACE(sp, (char *)bp, blen); \
+ FREE_SPACE(sp, bp, blen); \
}
/*

View file

@ -1,11 +0,0 @@
--- ../vi/v_txt.c.orig 2001-07-26 13:15:53.000000000 -0400
+++ ../vi/v_txt.c 2007-11-15 13:57:33.000000000 -0500
@@ -589,7 +589,7 @@
/* Check to see if the character fits into the replay buffers. */
if (LF_ISSET(TXT_RECORD)) {
- BINC_GOTO(sp, (char *)vip->rep,
+ BINC_GOTO(sp, vip->rep,
vip->rep_len, (rcol + 1) * sizeof(EVENT));
vip->rep[rcol++] = *evp;
}

View file

@ -1,41 +1,64 @@
# This patch makes the following changes:
#
# - -ldb -> -ldb3
# - db3 include files in include/db3, not include
#
# As far as I can tell, both of these are FreeBSDisms, so this patch
# should not be submitted to the vendor.
--- ../dist/configure~ Sun Feb 10 23:08:14 2002
+++ ../dist/configure Sun Feb 10 23:08:11 2002
@@ -10676,17 +10676,17 @@
saveLDFLAGS="$LDFLAGS"
if test "x$with_db3" != "x"; then
LDFLAGS="-L$with_db3/lib $LDFLAGS"
- CFLAGS="-I$with_db3/include $CFLAGS"
+ CFLAGS="-I$with_db3/include/db3 $CFLAGS"
fi;
--- ../dist/configure.orig 2007-11-18 08:43:54.000000000 -0800
+++ ../dist/configure 2008-06-15 11:35:32.000000000 -0700
@@ -19433,10 +19433,10 @@ fi
-echo $ac_n "checking for db_create in -ldb""... $ac_c" 1>&6
-echo "configure:10684: checking for db_create in -ldb" >&5
+echo $ac_n "checking for db_create in -ldb3""... $ac_c" 1>&6
+echo "configure:10684: checking for db_create in -ldb3" >&5
ac_lib_var=`echo db'_'db_create | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-ldb $LIBS"
+LIBS="-ldb3 $LIBS"
cat > conftest.$ac_ext <<EOF
#line 10692 "configure"
#include "confdefs.h"
@@ -10835,7 +10835,7 @@
# This can be used to rebuild libtool when needed
-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+LIBTOOL_DEPS=" /usr/local/share/libtool/ltmain.sh"
# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+LIBTOOL='$(SHELL) /usr/local/bin/libtool'
# Prevent multiple expansion
@@ -27631,6 +27631,8 @@ _ACEOF
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
+#include <stdlib.h>
+#include <stdio.h>
main(){char buf[20]; exit(sprintf(buf, "XXX") != 3);}
_ACEOF
rm -f conftest$ac_exeext
@@ -28624,7 +28626,7 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
#include <stdio.h>
-int fprintf ();
+/*int fprintf ();*/
int
main ()
@@ -28755,18 +28757,19 @@ fi
SAVELDFLAGS="$LDFLAGS"
if test "x$with_db_prefix" != "x"; then
LDFLAGS="-L$with_db_prefix/lib $LDFLAGS"
- CPPFLAGS="-I$with_db_prefix/include $CPPFLAGS"
+ CPPFLAGS="-I$with_db_prefix/include/db3 $CPPFLAGS"
fi
if test "$with_db_type" != db1; then
SAVELIBS="$LIBS"
- LIBS="$LIBS -ldb"
+ LIBS="$LIBS -ldb3"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
+#include <sys/stddef.h>
#include <db.h>
int
main ()
@@ -28958,7 +28961,7 @@ _ACEOF
dl_src=../common/dldb.c
LIBS="-ldl $LIBS"
else
- LIBS="-ldb $LIBS"
+ LIBS="-ldb3 $LIBS"
if test "X$with_db3" != "X"; then
LDFLAGS="`echo $with_db3/lib | sed "$LRscript"` $LDFLAGS"
if test "X$with_db_prefix" != "X"; then
LDFLAGS="`echo $with_db_prefix/lib | sed "$LRscript"` $LDFLAGS"
fi