A BSD licensed Bignum library

WWW: https://github.com/wbhart/bsdnt/
This commit is contained in:
Steve Wills 2014-01-03 21:37:23 +00:00
parent e936740ebe
commit 18326009be
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=338583
7 changed files with 79 additions and 0 deletions

View file

@ -71,6 +71,7 @@
SUBDIR += blas
SUBDIR += blitz++
SUBDIR += blocksolve95
SUBDIR += bsdnt
SUBDIR += calc
SUBDIR += calcoo
SUBDIR += calctool

31
math/bsdnt/Makefile Normal file
View file

@ -0,0 +1,31 @@
# $FreeBSD$
PORTNAME= bsdnt
PORTVERSION= 1.0
CATEGORIES= math
MASTER_SITES= GH
MAINTAINER= swills@FreeBSD.org
COMMENT= Bignum Library
LICENSE= BSD3CLAUSE
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= wbhart
GH_PROJECT= ${PORTNAME}
GH_TAGNAME= 72e20a7
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/wbhart-${PORTNAME}-${GH_TAGNAME}
pre-configure:
@${REINPLACE_CMD} -e "s,#!/bin/bash,#!${LOCALBASE}/bin/bash," ${WRKSRC}/configure
do-configure:
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ./configure --prefix=${STAGEDIR}${PREFIX} CC=cc CXX=c++ AS=cc
.include <bsd.port.mk>

2
math/bsdnt/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (bsdnt-1.0.tar.gz) = fe7a6b9692dd5d9a51abf8be352f386af3b8ac650dd7ee210e42d9e6009d701a
SIZE (bsdnt-1.0.tar.gz) = 58899

View file

@ -0,0 +1,10 @@
--- nn.h.orig 2014-01-03 20:28:26.000000000 +0000
+++ nn.h 2014-01-03 20:29:08.000000000 +0000
@@ -31,7 +31,6 @@
#include <stdint.h>
#include <stdlib.h>
#include <limits.h>
-#include <malloc.h>
#include "helper.h"
#include "rand.h"

View file

@ -0,0 +1,10 @@
--- rand/internal_rand.h.orig 2014-01-03 20:32:30.000000000 +0000
+++ rand/internal_rand.h 2014-01-03 20:32:40.000000000 +0000
@@ -30,7 +30,6 @@
#include <stdint.h>
#include <stdlib.h>
-#include <malloc.h>
#include "helper.h"
#include "rand.h"

3
math/bsdnt/pkg-descr Normal file
View file

@ -0,0 +1,3 @@
A BSD licensed Bignum library
WWW: https://github.com/wbhart/bsdnt/

22
math/bsdnt/pkg-plist Normal file
View file

@ -0,0 +1,22 @@
lib/libbsdnt.a
lib/libbsdnt.so
include/bsdnt/arch/inline/nn_linear_x86_64_core2.h
include/bsdnt/arch/inline/nn_linear_x86_64_k8.h
include/bsdnt/config.h
include/bsdnt/helper.h
include/bsdnt/helper_arch.h
include/bsdnt/nn.h
include/bsdnt/nn_arch.h
include/bsdnt/nn_linear_arch.h
include/bsdnt/nn_quadratic_arch.h
include/bsdnt/nn_subquadratic_arch.h
include/bsdnt/rand.h
include/bsdnt/sha1.h
include/bsdnt/test.h
include/bsdnt/tuning.h
include/bsdnt/types_arch.h
include/bsdnt/zz.h
include/bsdnt/zz0.h
@dirrm include/bsdnt/arch/inline
@dirrm include/bsdnt/arch
@dirrm include/bsdnt