Upgrade from 3.2.9 to 3.2.10. Fix a couple of warnings and an actual

error introduced in the new version by the developers.

Remove the library's .la file in post-install (no other way to suppress
the junk, apparently). Turn on parallel-building (MAKE_JOBS_SAFE).

Notified by: portscout
This commit is contained in:
Mikhail Teterin 2013-01-14 17:55:58 +00:00
parent 66e7731c7a
commit 18492fd79a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=310397
5 changed files with 37 additions and 5 deletions

View file

@ -7,8 +7,7 @@
#
PORTNAME= cgicc
PORTVERSION= 3.2.9
PORTREVISION= 2
PORTVERSION= 3.2.10
CATEGORIES= www devel
MASTER_SITES= GNU
@ -22,6 +21,8 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
USE_LDCONFIG= yes
PORTDOCS= *
CXXFLAGS+= -Wno-unknown-pragmas
MAKE_JOBS_SAFE= yes
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
@ -42,5 +43,6 @@ post-install:
@${MKDIR} ${DOCSDIR}
@(cd ${WRKSRC}/doc/html && ${COPYTREE_SHARE} . ${DOCSDIR})
.endif
${RM} -f ${PREFIX}/lib/libcgicc.la
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (cgicc-3.2.9.tar.gz) = 7bf392da75787e848ddf04395a5ed08fc472411deaa07cbae2c3edbea8fbeed4
SIZE (cgicc-3.2.9.tar.gz) = 2087796
SHA256 (cgicc-3.2.10.tar.gz) = 87680cb303e65bee2816b9f0e3d0a3c3258efc4f908ec3cad620d01f0b597ce0
SIZE (cgicc-3.2.10.tar.gz) = 2385130

View file

@ -0,0 +1,9 @@
--- cgicc/Cgicc.cpp 2013-01-12 06:48:13.000000000 -0500
+++ cgicc/Cgicc.cpp 2013-01-14 12:33:56.000000000 -0500
@@ -388,5 +388,5 @@
// Find the '&' or ';' separating subsequent name/value pairs
- pos = data.find_first_of(';&', oldPos);
+ pos = data.find_first_of(";&", oldPos);
// Even if an '&' wasn't found the rest of the string is a value

View file

@ -0,0 +1,21 @@
--- demo/cardgame.cpp 2013-01-12 06:48:14.000000000 -0500
+++ demo/cardgame.cpp 2013-01-14 12:48:50.000000000 -0500
@@ -350,5 +350,5 @@
string actualCard;
bool isPlaying=false;
- int points;
+ int points = -1;
int vNBCardsQueue1=0;
@@ -1483,8 +1483,8 @@
Cgicc cgi;
- // Get the name and value of the cookie to set
- const_form_iterator name = cgi.getElement("name");
+ // Get the name and value of the cookie to set XXX unused
+ // const_form_iterator name = cgi.getElement("name");
- const_form_iterator value = cgi.getElement("value");
+ // const_form_iterator value = cgi.getElement("value");
const_form_iterator actionIn = cgi.getElement("actionner");

View file

@ -28,8 +28,8 @@ include/cgicc/XHTMLDoctype.h
include/cgicc/XMLDeclaration.h
include/cgicc/XMLPI.h
lib/libcgicc.a
lib/libcgicc.la
lib/libcgicc.so
lib/libcgicc.so.5
lib/pkgconfig/cgicc.pc
share/aclocal/cgicc.m4
@dirrm include/cgicc